Vista is not showing up in grub2

Bug #430141 reported by Dave Morley on 2009-09-15
72
This bug affects 9 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Colin Watson
Karmic
High
Colin Watson

Bug Description

Binary package hint: grub2

I have a default pre installed vista config of:
Rescue partition
System partition (contains boot stuff)
Vista Partition (everything else)

This is not showing up in the side by side install so I can't access the vista partition at boot time.

Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :
David Murphy (schwuk) wrote :

Also visible in a Virtualbox VM (Windows 7 + Karmic 20090917.1).

Jonathan Riddell (jr) wrote :

I had this problem with Ubiquity and Windows XP. Installs from d-i do show Windows in the grub menu.

Steve Langasek (vorlon) on 2009-09-17
Changed in grub2 (Ubuntu Karmic):
importance: Undecided → High
Stefan Hammer (j-4) wrote :

Also affects installing Karmic beside a Jaunty Installation. Can only boot Karmic then. There is no grub entry for Jaunty!

summary: - Vista is not showing up in grub2
+ No second OS is shown up in grub2

It seems that /usr/bin/os-prober is not installed or fails to run before the call to update-grub from the installer.
Running it manually and then update-grub will add the missing entries, for both windows and linux partitions.

DBF (fasnacht) wrote :

For me, after upgrading to grub2 (package "grub-pc" instead of "grub"),
the package "os-prober" was not installed, and thus /etc/grub.d/30_os-prober
immediately aborted instead of detecting the other operating systems.

# apt-get install os-prober
# update-grub

should solve this (at least did it for me).

In case you have no grub menu at all, edit
/etc/default/grub, comment out the line GRUB_HIDDEN_TIMEOUT=0
and run update-grub ...

DBF (fasnacht) wrote :

maybe i should add that os-prober then correctly created
menu entries for other Ubuntu installations, and Windows XP
(which I only use as a gaming platform ;-)

Colin Watson (cjwatson) wrote :

Guys, could you please file a separate bug about os-prober being missing - it's not at all obvious that you have the same problem as Dave.

In general, I find it's much better to file a new bug and risk it being a duplicate, than to jump into an existing bug.

Colin Watson (cjwatson) wrote :

In particular, DBF, you're talking about upgrades which isn't the case for Dave. os-prober is only a Recommends - recommends are installed by default, but perhaps you ignored the recommendation intentionally. (Don't do that. :-) )

Colin Watson (cjwatson) on 2009-09-18
summary: - No second OS is shown up in grub2
+ Vista is not showing up in grub2
Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :

tester@tester-desktop:~$ sudo update-grub
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-2.6.31-10-generic
Found initrd image: /boot/initrd.img-2.6.31-10-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Windows Vista (loader) on /dev/sda2
Found Windows Vista (loader) on /dev/sda3
done

Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :
Colin Watson (cjwatson) wrote :

I think os-prober is failing somehow when run from ubiquity, but unfortunately grub2 throws away errors from it so I can't see what's going wrong. I've uploaded this to try to make the error visible:

grub2 (1.97~beta3-1ubuntu5) karmic; urgency=low

  * debian/patches/957_savedefault.diff: Quote the value assigned to
    'default', in case it contains spaces (LP: #431179).
  * debian/patches/964_os-prober_errors.diff: Don't throw away errors from
    os-prober; it makes things hard to debug.

 -- Colin Watson <email address hidden> Fri, 18 Sep 2009 18:47:06 +0100

Josema (jmvalbuenap) on 2009-09-19
Changed in grub2 (Ubuntu Karmic):
status: New → Confirmed
Gulle (gullenster) on 2009-09-20
Changed in grub2 (Ubuntu Karmic):
status: Confirmed → Fix Released
status: Fix Released → Confirmed
Gulle (gullenster) wrote :

Excuse me if I'm stupid!
(Needless subscription)

Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :
Colin Watson (cjwatson) wrote :

This is thoroughly baffling. It appears to be falling over at 'chmod 400 ${grub_cfg.new}' in grub-mkconfig. Since that has an || guard, I can't think of any reason that might happen short of the shell crashing. I'm wondering at this point if the syslog is lying to me!

Colin Watson (cjwatson) on 2009-09-23
affects: grub2 (Ubuntu Karmic) → ubiquity (Ubuntu Karmic)
Changed in ubiquity (Ubuntu Karmic):
assignee: nobody → Colin Watson (cjwatson)
status: Confirmed → Fix Committed
Alejandro Vidal (mancvso) wrote :

how can I reconfigure GRUB2 to boot from my past Jaunty or XP??

If you update Karmic, and reboot, you should be able to, from the grub2
menu, access Karmic, Jaunty or XP.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.99.22

---------------
ubiquity (1.99.22) karmic; urgency=low

  [ Michael Terry ]
  * gtk: Don't assume there will be a country shortlist for the selected
    language. Fixes the lack of a default zone for Polish. LP: #425011
  * kde: Let back/forward/quit buttons activate when highlighted and the
    user presses Enter. Part of bug #46600

  [ Evan Dandrea ]
  * Suppress Pango warning about not being able to open /root/.pangorc.
  * Use the page name instead of the new step name when considering both
    partitioning pages.
  * Fix broken conditional statement that prevented
    process_autopartitioning and info_loop from being called.
  * Disable the forward button for the usersetup page when coming from
    both the automatic and manual partitioning pages, rather than just
    the latter.
  * Open a browser window when links are clicked on in the slideshow
    (LP: #432145).
  * Automatic update of included source packages: base-installer
    1.102ubuntu1, flash-kernel 2.13ubuntu11, grub-installer 1.43ubuntu3,
    partman-partitioning 72ubuntu1.

  [ Roman Shtylman ]
  * Fixed vertical spacer on keyboard page
  * Removed underline from keyboard buttons
  * Added ability to view shifted keys on keyboard display

  [ Colin Watson ]
  * Mount /sys while running grub-installer, since os-prober needs to look
    in /sys/block (LP: #430141).
  * Install new dmi-available-memory program from base-installer
    1.101ubuntu5.
  * Don't respawn Upstart jobs on exit status 1.

 -- Evan Dandrea <email address hidden> Thu, 24 Sep 2009 09:40:12 -0700

Changed in ubiquity (Ubuntu Karmic):
status: Fix Committed → Fix Released
Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :
Juan Manuel (lukather35) wrote :

With the latest daily updates, that problem has been solved, at least on my system.

http://cdimage.ubuntu.com/daily-live/current/

ratatuia (ratatuiamail) wrote :

Vista is stil not showing up in grub2.karnic.beta

os-prober installed ad runned

update-grub executed

Dave Morley (davmor2) wrote :

This is fixed for me on 2 machines runing vista, and 3 running xp

mark (mark-voidzero) wrote :

Not fixed for me; Windows 7 on sdc1 shows up, but Windows Vista on sdb1 does not.

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers