Partitioning page shows strings like "20some_device_____regular", then crashes.

Bug #318564 reported by Bernd Schlapsi on 2009-01-18
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Evan

Bug Description

Description: Ubuntu jaunty (development branch)
Release: 9.04
-------------------------------------------------------------------------
Package: ubiquity
State: installed
Automatically installed: no
Version: 1.11.3

I tried to install the latest development version of Ubuntu 9.04 Alpha 3 (language: german) in Virtualbox but the Installation failed (partman crashed)

The second problem is that there are some problems with the translation on the partition page.

The installation process works fine, if I choose English as language at the beginning.

I attached the following files:
- a screenshot of the partion page with wrong translation
- a scrennshot of the partman error
- /var/log/syslog
- /var/log/partman

Bernd Schlapsi (bernd-sch) wrote :
Evan (ev) wrote :

Confirmed. This bug only occurs if you start the CD in English, then switch to another language when you start ubiquity.

Changed in ubiquity:
assignee: nobody → evand
importance: Undecided → High
milestone: none → jaunty-alpha-4
status: New → Confirmed
Evan (ev) wrote :

Running locale-gen before starting ubiquity fixes the bug, but this should not be necessary.

Bernd Schlapsi (bernd-sch) wrote :

@Evan Dandrea
In my case the bug also occurs if I choose german in the first menu (directly after the boot up) and don't change the language later

karlrt (karlrt) wrote :

it's somehow weared, i think not every language is affected:

i started jaunty alpha3 amd64 with de_DE locale, but somehow it also generated the english locales: so at the install, it was no problem for german nor english. But for polish, it was:

i had to generate the locale pl_PL with a simple "sudo locale-gen pl" then everything worked fine, even the polish install. I think this is the case with all other languages other than english and your default loaded language, ubiquity should reconfigure with locale-gen after another language is chosen!

i also think bug 318140 is a duplicate of this one, but he has a nice screenshot

karlrt (karlrt) wrote :

well starting the disk with polish and then installing with ubiquity in polish works fine, just tried it, i think then the locale is allready generated...

Bernd Schlapsi (bernd-sch) wrote :

I installed the latest iso (http://cdimage.ubuntu.com/cdimage/daily-live/current/jaunty-desktop-i386.iso) and partman doesn't crash anymore if I choose German as language.

Evan (ev) wrote :

I can confirm that this no longer happens with German for me on the latest daily live CDs (20090223 tested).

Evan (ev) wrote :

Is anyone able to reproduce this using the latest daily live CD: http://cdimage.ubuntu.com/daily-live/current/ ?

Please include the version of ubiquity that you used (ubiquity --version) in your reply.

Thanks!

Changed in ubiquity:
status: Confirmed → Incomplete
Simon Strandman (nejsimon) wrote :

I'm getting this with a kubuntu daily CD as of today and ubiquity 1.11.14. It might be a different bug though because choosing english or running locale-gen doesn't help but partman always crashes with exit code 141 after the keyboard layout section.

loddi (loddili) wrote :

i'm getting the same bug with alpha5. after selecting the keyboard layout, partman crashes. it only happens if a sd-card is plugged in. without a sd-card the installer works.

loddi (loddili) wrote :

i've just tested the daily built from today. still the same bug occurs.
here is my syslog:

i hope somebody can fix this soon.

Evan (ev) wrote :

loddi, nxsty,

Are you seeing strings on the partitioning page like "20some_device_____regular"?

Simon Strandman (nejsimon) wrote :

@Evan

No, I never got that far. It crashed right before the partitioning page.

Btw, I installed an ubuntu snapshot today and it worked so perhaps my problem is already fixed. I'm going to try kubuntu also like last time.

Evan (ev) wrote :

nxsty,
Ok, if you don't see those strings, then you have a different bug, if you have one at all, since you mentioned that the latest snapshot worked for you.

If you can reproduce your bug, please open a new bug report for it.

I would still very much appreciate if anyone can confirm they're still seeing strings like "20some_device____regular" on the partitioning page.

Thanks!

Evan (ev) wrote :

I'm marking this as fixed as I believe this bug no longer exists. However, if anyone is still experiencing this, please feel free to reopen the bug.

Changed in ubiquity (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers