partman exited with code 141 (attempted manual partitioning)

Bug #282756 reported by Tomasz Dominikowski on 2008-10-13
48
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Wishlist
Unassigned
partman-partitioning (Ubuntu)
Medium
Colin Watson
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

I'm trying to do manual partitioning using a daily livecd of intrepid from today. It fails with partman exited with status cod 141

I'm using a USB media to install, not a CDROM, this is a MSI Wind netbook. Syslog seems to indicate that partman doesn't detect sda3, even after adding the partitions sda1 (former /) and sda3 (former /home) manually to fstab and test-mounting them (without adding manually they won't show up), the installer just gets confused and shows an empty page of manual partitioning automatically. Unmounting them, but leaving in fstab again crashes partman. This is really irritating, I just cannot install intrepid, I need to wipe my / partition, but leave /home intact.

Steve Beattie (sbeattie) wrote :

I also had this occur with the daily iso image build 20081015. Ubiquity debug log is attached. The disk is currently partitioned with the following layout (fdisk -l output):

  Disk /dev/sda: 10.7 GB, 10737418240 bytes
  255 heads, 63 sectors/track, 1305 cylinders
  Units = cylinders of 16065 * 512 = 8225280 bytes
  Disk identifier: 0x000cd2d7

     Device Boot Start End Blocks Id System
  /dev/sda1 * 1 564 4530298+ 83 Linux
  /dev/sda2 852 913 498015 82 Linux swap / Solaris
  /dev/sda3 914 1305 3148740 83 Linux
  /dev/sda4 565 851 2305327+ 5 Extended
  /dev/sda5 565 830 2136613+ 83 Linux
  /dev/sda6 831 851 168651 82 Linux swap / Solaris

  Partition table entries are not in disk order

(The goofiness of the layout is due to previous partman guided resizes.)

Changed in ubiquity:
status: New → Confirmed
Steve Beattie (sbeattie) wrote :

This problem is fixed in ubiquity 1.10.6, which did not make it in time to be on the daily snapshot for 20081015, but should be in tomorrow's snapshots.

For those wishing to test it out before the next snapshot is built, boot the live cd, and then run:

  sudo apt-get update
  sudo apt-get install ubiquity

apt-cache policy should show that you now have ubiquity 1.10.6 installed. Running "sudo ubiquity" should now let a manual partition-based install complete. Please reopen this bug if it does not.

Thanks!

Changed in ubiquity:
status: Confirmed → Fix Released
Emilio (turl) wrote :

I am experiencing the same problem, using Alpha 3 CD and installed the latest ubiquity as you said. I attach my syslog.

ubuntu@ubuntu:~$ sudo fdisk -l /dev/sda

Disk /dev/sda: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000af8fe

   Device Boot Start End Blocks Id System
/dev/sda1 1 1 0 27 Unknown
Partition 1 does not end on cylinder boundary.
/dev/sda2 * 1 10949 87947811 7 HPFS/NTFS
/dev/sda3 10950 11690 5952082+ 83 Linux

Emilio (turl) wrote :

Reopening the bug

Changed in ubiquity:
status: Fix Released → Confirmed
Emilio (turl) wrote :

I attach a screenshot for you to see. Also, it it normal for the options to have such an strange text?

I'm seeing this error on the kubuntu/i386 version of Jaunty Alpha 5 with an HP dl380g5. I have a single array on a SmartArray P400 (/dev/cciss/c0d0), and this message shows up every time I've tried so far. It happens right after hitting the 'Forward' button on the 'Keyboard layout' step.

Here's the md5sum of the CD ISO I used:

3be21b44ffa441bd6d1e25e3343870ea jaunty-desktop-i386.iso

Evan (ev) wrote :

Bryan (or anyone else still experiencing this bug),

I just tried to reproduce this bug in KVM (so I'm using just a single disk, but that shouldn't matter given previous investigation of this) using the CD you reference, as well as the Ubuntu alpha-5 i386 desktop CD. Unfortunately, it's working fine for me.

I'll need a few log files to debug this further. Can you please run the install in debug mode (`ubiquity -d` from a terminal window) and attach /var/log/syslog, /var/log/installer/debug, and /var/log/partman when you get to the error?

Thanks a bunch!

Evan (ev) wrote :

Correction. Please use the latest daily-live CD, if possible, from http://cdimage.ubuntu.com or http://cdimage.ubuntu.com/kubuntu .

Thanks!

I tested this with the 2009-03-04 release of the kubuntu CD install image:

f921f32a81315dec9e4c78812ef10f96 jaunty-desktop-i386.iso

This appears to be the problem (from /var/log/installer/debug):

Exception caught in process_line:
Traceback (most recent call last):
  File "/usr/lib/ubiquity/ubiquity/filteredcommand.py", line 112, in process_line
    return self.dbfilter.process_line()
  File "/usr/lib/ubiquity/ubiquity/debconffilter.py", line 261, in process_line
    if not input_widgets[0].run(priority, question):
  File "/usr/lib/ubiquity/ubiquity/components/partman.py", line 461, in run
    self.resize_desc, self.manual_desc)
  File "/usr/lib/ubiquity/ubiquity/frontend/kde_ui.py", line 1373, in set_autopartition_choices
    bFrame.removeWidget(before_bar)
AttributeError: removeWidget

Correction, it wasn't the kubuntu CD install image, but the regular one from here:

http://cdimage.ubuntu.com/kubuntu/daily-live/20090304/jaunty-desktop-i386.iso

Changed in ubiquity:
assignee: nobody → canonical-qa
Steve Beattie (sbeattie) wrote :

I have been unable to reproduce this with either the ubuntu live cd (20090305.1) or the kubuntu live cd installer (20090305) both in a virtual machine and on live hardware (two scsi disks).

Bryan: I do note that, in addition to the traceback there, there was also some errors generated by tune2fs in your /var/log/messages.

Kevin|Jerone: is the OEM team seeing this as well? Can you reproduce it, particularly with debugging enabled? See https://wiki.ubuntu.com/DebuggingCasper

Evan" can you take a look at this again?

Thanks.

Changed in ubiquity:
assignee: canonical-qa → nobody
Jerone Young (jerone) wrote :

@Steve.
            This is being seen on server hardware at the moment. I think you do not have the proper test hardware to trip up on the issue.

 @Bryan
             Are you still seeing this issue now with the 20090305 daily builds or later?

Yes, I'm still seeing this problem with the 20090306 daily build.

Jerone Young (jerone) wrote :

I'm thinking this has something to do with the "cciss" driver being used.

Linux is detecting the drive fine. But as Steve mentions, in the syslog you can see where you see:

Mar 4 20:58:53 ubuntu ubiquity: tune2fs: Bad magic number in super-block while trying to open /dev/cciss/c0d0^M
Mar 4 20:58:53 ubuntu ubiquity: Couldn't find valid filesystem superblock.
Mar 4 20:58:53 ubuntu partman: Error running 'tune2fs -l /dev/cciss/c0d0'
Mar 4 20:58:53 ubuntu ubiquity: tune2fs
Mar 4 20:58:53 ubuntu ubiquity: :
Mar 4 20:58:53 ubuntu ubiquity: Bad magic number in super-block
Mar 4 20:58:53 ubuntu ubiquity:
Mar 4 20:58:53 ubuntu ubiquity: while trying to open /dev/cciss/c0d0
Mar 4 20:58:53 ubuntu ubiquity: ^M
Mar 4 20:58:53 ubuntu ubiquity: Couldn't find valid filesystem superblock.
Mar 4 20:58:54 ubuntu partman: Error running 'tune2fs -l /dev/cciss/c0d0'
Mar 4 20:58:54 ubuntu ubiquity[5609]: debconffilter_done: Partman (current: Partman)
Mar 4 20:58:54 ubuntu ubiquity[5609]: dbfilter_handle_status: ('Partman', 141)

@Bryan
    Do you have other machines that use the "cciss" driver for the disk controller? Can you attempt to try an install with the latested dated build on one of those?

Jerone Young (jerone) wrote :

Ok it looks like it is. It should be doing /dev/cciss/c0d0p1 ..c0d0p2 .. and so on. We had somewhat of a similar issue with the debian installer here:
https://bugs.launchpad.net/ubuntu/+source/hw-detect/+bug/325947

So it does look to that this issue may be an issue with partman and drives attached to a controller using the cciss driver.

@Bryan
    Any help on your part to try another machine using the cciss driver to confirm this theory would be great!

There is a problem with the Kubuntu 030809 installer (live-cd) with my hardware too. I've got an nForce 650i as well as following hardware and syslog is attached with partman and debug logs following in a moment.

Drive setup:
>Drive 0
>>NTFS Vista 465GiB/500GB
>Drive 1
>>Extended partition
>>>ext3 partition (with previous (failed) attempt at installation with "alternate cd") 239GB
>>>swap partition (same failed attempt) 10GB
>>>NTFS XP 249GB
>>2GB emergency backup partition

Also, attached is syslog

Changed in oem-priority:
assignee: nobody → canonical-qa

Jerone,

Yes, it appears like partman is trying to run tune2fs on a drive and not a partition. Running tune2fs manually on /dev/cciss/c0d0p1 returns the proper results.

BTW, the installer appears to try and run tune2fs even if there aren't any partitions on the disk too. The hardy installer handles this situation just fine.

Also, the original bug report was on a netbook. So while the fix to my problem on proliants might be because of cciss devices, it's not the fix for everyone who has run into it.

Bryan

This is interesting... The kubuntu live cd has packages from a few weeks ago instead of current ones:

ubiquity 1.11.14
ubiquity-casper 1.157

The kernel is also old:

# uname -a
Linux ubuntu 2.6.28-8-generic #26-Ubuntu SMP Wed Feb 25 04:28:54 UTC 2009 i686 GNU/Linux

I tried installing with the today's regular ubuntu live cd which has these packages/kernel and everything worked great:

ubiquity 1.11.14
ubiquity-casper 1.157

# uname -a
Linux ubuntu 2.6.28-8-generic #28-Ubuntu SMP Fri Mar 6 00:09:20 UTC 2009 x86_64 GNU/Linux

Joey Stanford (joey) wrote :

oem-priority changed to wishlist with agreement from krafty

Changed in oem-priority:
importance: Undecided → Wishlist

So the latest ones work?

Jerone, Joey:

Is there a bug filed against kubuntu for the builds having old versions of key packages that prevent testing on some hardware?

epicharikaky:

I believe the kubuntu images are still broken. Try the regular ubuntu images and see if they work for you.

Jerone Young (jerone) wrote :

@Bryan
         To confirm things are working in Ubuntu but not in Kubuntu. Mainly because the package versions are behind and Kbuntu needs to catch up. I will try to find outside this but what is going on with Kubuntu.

          Probably wait till Friday to test out Kubuntu again if there is this lag. This will of course not be the case in the release version.

           I'm going to close this bug since you confirmed it's fixed in the latest Ubuntu build. But if this prersists in Kubuntu, please file a separate bug against Kubuntu.

           If any does still see this issue with the latest builds as of March 10th please reopen the bug.

           Thanks for your help testing this!

Changed in oem-priority:
status: New → Fix Released
Changed in ubiquity:
status: Confirmed → Fix Released
Colin Watson (cjwatson) wrote :

The Kubuntu CD images failed to build for a while due to a broken package, but are up to date now.

Colin Watson (cjwatson) wrote :

This bug has now had five different reports and contains at least three different causes. Although I'm not sure what the original report was about, and can't find any record of it being fixed, it probably has gone away. There are at least two distinct remaining problems here, though.

The first problem is this tune2fs/cciss thing. I don't think it can be the same as bug 325947, because all the fixes applied as a result of that bug were in ubiquity as of version 1.11.14 where this was reported. Furthermore there are some suspicious ^M characters in the log, and of course there's the business of running tune2fs -l on the disk device rather than on the partition.

The second problem is the Kubuntu-specific crash on bFrame.removeWidget. This code does look wrong to me - I think it should be before_frame.layout().removeWidget(before_bar) etc. - but that code was contributed by Roman Shtylman so I'm checking with him before Just Fixing It.

Changed in ubiquity:
status: Fix Released → Triaged

On Wed, Mar 11, 2009 at 01:49:11PM -0000, Colin Watson wrote:
> The Kubuntu CD images failed to build for a while due to a broken
> package, but are up to date now.

FYI, the status of current development builds can be found at
http://qa.ubuntu.com/reports/ogasawara/weatherreport.html

This will show if a build is out of date.

--
 - mdz

I'm still seeing this error message in the 20090313 kubuntu/amd64 image. However, I don't see it with the 20090313 ubuntu/amd64 image. Both images have the tune2fs problem.

vi-max (vi-max) wrote :

Kubuntu 9.04 alpha6. Live-Flash. Rus.
....partman crashed code 141....(before partitioning window)
Then i try this: (in live CD mode)
sudo apt-get update
sudo apt-get install ubiquity (1.11.17) ~ 11 Mb
sudo ubiquity
i saw different (gnome-style) window.

After that partition master OK:
"/" - ext4, format
"swap" format
"/var" ext4, format
"/home", ext3, no format. (home dir after kubuntu 8.10).

 but my setup crashed after downloading and installing language modules (97%).

I tested the 20090316 release of kubuntu and I'm still seeing this problem.

Based off comment #37 from mvirus, I tried upgrading ubiquity* to version 1.11.18 and that didn't help. I then tried removing ubiquity-frontend-kde/1.11.18 and replacing it with ubiquity-frontend-gtk/1.11.18 (this required installing other packages like the gtk version of apport). When using the gtk-based ubiquity I was able to complete an install (and the timezone selection screened rendered properly too!)

Colin Watson (cjwatson) wrote :

mvirus: This bug has got confusing enough as it is, and if any more people weigh in with separate reports it will become completely unmanageable. Unless you have a patch for one of the specific issues I identified in https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/282756/comments/34, please file a new bug.

Colin Watson (cjwatson) on 2009-03-17
Changed in partman-partitioning (Ubuntu):
assignee: nobody → cjwatson
importance: Undecided → Medium
status: New → Fix Committed

Colin,

I see that you marked the bug affecting 'partman-partitioning' as 'Fix Committed' today. Which bug from comment #34 was fixed? Also, which release of 'partman-partitioning' has this fix so I can keep an eye out for it?

Thanks,
Bryan

Colin Watson (cjwatson) wrote :

The bit I've fixed (or believe I've fixed, anyway; I don't have the necessary hardware) is the tune2fs/cciss problem. This is in partman-partitioning 64ubuntu6 which I'm going to upload shortly. Note, though, that ubiquity embeds its own copy of partman-partitioning's source code for technical reasons, although these embedded copies are refreshed as a matter of routine before every upload, so in practice the version you need to keep an eye out for is ubiquity 1.11.19.

I discussed the KDE bug on IRC, and I think Roman is working on it, but I haven't seen a patch come in yet.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-partitioning - 64ubuntu6

---------------
partman-partitioning (64ubuntu6) jaunty; urgency=low

  * get_real_device: Add support for /dev/vd*, /dev/xvd*, /dev/cciss/*,
    /dev/ida/*, and /dev/mmcblk* (LP: #282756).

 -- Colin Watson <email address hidden> Wed, 18 Mar 2009 10:28:55 +0000

Changed in partman-partitioning:
status: Fix Committed → Fix Released

I just tested the 20090319 desktop/i386 build of kubuntu and didn't see the tune2fs problem in the logs anymore. Thanks Colin!

Any word from Roman on the ubiquity-frontend-kde problem?

This appears to be fixed in the 20090406 desktop/amd64 build of kubuntu. Thanks!

Colin Watson (cjwatson) wrote :

Indeed, it looks like Roman fixed this a little while ago, on a branch which was merged on 27 March. Here's the log of the original revision (which didn't get a proper changelog entry, so this bug wasn't closed):

revno: 3083.1.4
committer: Roman Shtylman <email address hidden>
branch nick: ubiquity.kdeui
timestamp: Wed 2009-03-11 11:13:09 -0400
message:
  update from accidental bug fix for 337181 undo, removed some timezone debug, fixed removeWidget problem

Thanks for following up!

Changed in ubiquity (Ubuntu):
status: Triaged → Fix Released
SPU (spbamdclub) wrote :

Image: Kubuntu Desktop amd64 (20090415) = RC1
Bug is still here... (during installation process and running partman from "live" mode)

...
Apr 15 20:18:17 ubuntu ubiquity[5345]: debconffilter_done: Partman (current: Partman)
Apr 15 20:18:17 ubuntu ubiquity[5345]: dbfilter_handle_status: ('Partman', 141)
...

Colin Watson (cjwatson) wrote :

SPU, it's probably not actually the same bug, but a different bug with similar symptoms. (Translated into English, this symptom is a complaint from the partitioning backend saying "help, the installer frontend I was talking to seems to have stopped wanting to talk to me for some reason".) Could you please file a new bug report for this? I need you to attach /var/log/installer/debug as well as /var/log/syslog to that bug; in fact, if you could just run 'ubuntu-bug ubiquity' from a terminal on the live CD after the installer has crashed, that should give me all the information I need.

SPU (spbamdclub) wrote :

I've reported it as a new bug:
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/362466

In addition debug file from the install session in my previous comment is in the attachment.

Omer Akram (om26er) wrote :

i am facing the same error in today's lucid live cd 20100105 when install on my acer aspire one

Changed in ubiquity (Ubuntu):
status: Fix Released → Confirmed
Colin Watson (cjwatson) wrote :

om26er: I'd really appreciate it if you could file a new bug rather than reopening this one. Please see my previous comment:

  https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/282756/comments/47

Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released
benste (benste) wrote :

om26er did you file a new bug - I'm experiencing the same bug in daily today

Colin Watson (cjwatson) wrote :

benste, please could *you* file a new bug. This is a very generic error message and the cause for you is probably not the same as for anyone else, particularly not for anyone else months ago. Make sure to include the syslog and partman logs - use 'ubuntu-bug ubiquity' from a terminal after the crash and it'll do it all for you.

Alessandro Losavio (alo21) wrote :

i had the same problem with Kubuntu-alternate i386 Maverick Meerkat 10.10 Alpha 1.
But i don't know what's the problem, in fact the installation stopped at 83% during configuration kernel

tags: added: iso-testing
Changed in oem-priority:
assignee: Canonical Ubuntu QA Team (canonical-qa) → nobody
To post a comment you must log in.