xubuntu groovy install - bootloader install failure

Bug #1897991 reported by Chris Guiver on 2020-10-01
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)

Bug Description

Xubuntu groovy (daily) QA-test install on
dell [optiplex] 990 (i7-2600, 16gb, nvidia geforce gt 6600 gt)

Error writing boot loader, asked for my to select device, but I was unable to select SDA device

Bootloader install failed -
Bootloader install failed selections -

-- iso.qa.ubuntu.com details
box had internet cable disconnected, install was as expected until error box appeared that it was unable to write boot loader to device & select box asking me to select device was offered, I kept trying to use sda (ssd) but it'd reject & ask again. I tried a few times before clicking continue

install completed, on reboot I get no OS found error

** Expected Results
I'd expect the SSD selected to be acceptable, not repeating errors & then fail to boot on selecting continue.

ProblemType: Bug
DistroRelease: Ubuntu 20.10
Package: ubiquity 20.10.10
ProcVersionSignature: Ubuntu 5.8.0-20.21-generic 5.8.10
Uname: Linux 5.8.0-20-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu48
Architecture: amd64
CasperMD5CheckResult: pass
CasperVersion: 1.452
Date: Thu Oct 1 11:29:32 2020
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/xubuntu.seed maybe-ubiquity quiet splash ---
LiveMediaBuild: Xubuntu 20.10 "Groovy Gorilla" - Beta amd64 (20200930)
 PATH=(custom, no user)
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Chris Guiver (guiverc) wrote :
Changed in ubiquity (Ubuntu):
status: New → Incomplete
Chris Guiver (guiverc) wrote :

This issue has been noted before, but it was occuring after the error reported in the bug


the error message that is mentioned in that bug however no longer appears, thus the separate filing

description: updated
Changed in ubiquity (Ubuntu):
status: Incomplete → New
Chris Guiver (guiverc) on 2020-10-01
description: updated
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:

tags: added: iso-testing
Chris Guiver (guiverc) on 2020-10-01
summary: - xubuntu groovy install suspected install failure (bootloader?)
+ xubuntu groovy install - bootloader install failure
Chris Guiver (guiverc) wrote :

FYI. This box isn't mine, so it's not used very often in my QA

Lubuntu & main Ubuntu have installed to it in recent day(s) though.

(I've been trying to re-install windows 7 for it's owner, and it's been failing to install for unknown reason.. When that's resolved I'll lose access to the box again)

Chris Guiver (guiverc) wrote :

kubuntu groovy (daily) installed cleanly to this box
(minor unrelated graphic glitches after reboot)

Łukasz Zemczak (sil2100) wrote :

Is this issue reproducible on that machine? This feels machine-specific - but also weird that Kubuntu and other flavors did not surface this problem. I think there's not much we can do for beta, but I poked the Xubuntu flavor maintainers to take a look.

Chris Guiver (guiverc) wrote :

(repeat of comments made earlier on #ubuntu-flavors)

I had the issue with prior ISOs as mentioned comment #3

Yes I performed test again (same box) & got same result (photos were from 2nd attempt; box turned off between re-try.

I did NOT re-create this issue using the Ubuntu daily (2020-09-30) on same d990 box.

I tried using the Xubuntu daily on
sony vaio svp112a1cw (i5-9400u, 4gb, intel haswell-ULT)
and it did NOT have this issue either.

This install however had what I considered a different issue "System Bootloader not found. Initializing defaults\n..."
which is filed as https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1898041 right/wrongly

(I also clouded issue by including two issues; filing against linux as I couldn't decide on package; & kernel sure is wrong. If the bootloader is related to this, it should be removed from other bug & package changed to xubuntu-desktop|meta on 1898041)

Sean Davis (bluesabre) wrote :

I'm also seeing the same with Vmware Workstation on Xubuntu 200930.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Chris Guiver (guiverc) wrote :

I tried to QA-test installs on

- hp dc7700 (c2d-e6320, 5gb, nvidia quadro nvs 290)

error installing bootloader, as per this bug report; couldn't select sda to write to, eventually continued. on reboot, it fails to load, last BIOS message was

"Attempting Boot from Hard Drive" & just sits there.

- dell [optiplex] 755 (c2d-e8300, 8gb, amd/ati radeon rv610/radeon hd2400 pro/xt)

error on bootloader appeared as per this bug report, where it wouldn't accept sda as device to install bootloader to... after numerous tries I hit continue via skip..

on reboot, I get only a blinking cursor top left

ajgreeny (ajg-charlbury) wrote :

I also have this problem.
Today's Xubuntu iso (Sun Oct 11 2020) boots well in KVM/QEMU virt-manager and appears to install until it bets to grub installation where it says it can ot install grub to /dev/sda and offers alternatives which are the partitions.

I tried creating a new partition gpt table and adding EFI and small grub-boot partition (can't remember exactly what it's called) but still no success.

ajgreeny (ajg-charlbury) wrote :

Adding to my report at #10, I replaced my daily current iso with daily pending and tried again using KVM/QUEMU and virt-manager.
This time I noticed for the first time, an option to boot using UEFI firmware and at last the installation was a success.

It looks as if the iso boots in UEFI mode by default if installed in KVM virt-manager, and this is the first and only time that I have seen this behaviour.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers