20.10 Installer crashes with partitions being written but unable to inform kernel of the change

Bug #1897173 reported by Bill (franksmcb) on 2020-09-24
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
parted (Ubuntu)
Undecided
Unassigned
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu MATE currently daily 20.10 20200924 using QEMU.

Expected outcome:
Boot daily iso
Choose Erase disk and install Ubuntu MATE
Complete installation.

Actual outcome:
Boot daily iso
Choose Erase disk and install Ubuntu MATE
Install crashes with ERROR!!! (as superuser) Partition(s) on /dev/vda have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use. As a result, the old partition(s) will remain in use. You should reboot now before making further changes.

ProblemType: Bug
DistroRelease: Ubuntu 20.10
Package: ubiquity 20.10.10
ProcVersionSignature: Ubuntu 5.8.0-19.20-generic 5.8.8
Uname: Linux 5.8.0-19-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu47
Architecture: amd64
CasperMD5CheckMismatches: ./casper/filesystem.squashfs
CasperMD5CheckResult: skip
CasperVersion: 1.452
CurrentDesktop: MATE
Date: Thu Sep 24 19:29:19 2020
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/ubuntu-mate.seed maybe-ubiquity quiet splash ---
LiveMediaBuild: Ubuntu-MATE 20.10 "Groovy Gorilla" - Alpha amd64 (20200924)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Bill (franksmcb) (franksmcb) wrote :
Bill (franksmcb) (franksmcb) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1897173

tags: added: iso-testing
Leó Kolbeinsson (leok) wrote :

This bug also occurred on daily xubuntu daily iso 20.10 20200924
on my Dell [Optiplex] 7010 ( i5-3470 , 16 GB, Intel Graphics 2500, Intel 82579LM GB Ethernet ,1TB hd) box and crashed my hard disk which became unbootable. The machine was set to boot in UEFI with secure boot mode.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Norbert (nrbrtx) wrote :

Confirmed.

Log mentions partman:parted_server.

I think that `partprobe` is the real reason, it is a part of `parted` package. Mark it as affected package.

Changed in parted (Ubuntu):
status: New → Confirmed
Bill (franksmcb) (franksmcb) wrote :

Issue still occurring on 20200925 Ubuntu MATE daily.

Leó Kolbeinsson (leok) wrote :

And I can confirm the issue still occurring on 20200925 Xubuntu daily as well.

Chris Guiver (guiverc) wrote :

Xubuntu daily install on (setup for BIOS/legacy boot)
dell [optiplex] 990 (i7-2600, 16gb, nvidia geforce gt 6600 gt)

error reflected in pictures of comment #2 or #6 occurred
I continued installation, it stopped unable to write boot loader.
My attempts to select ssd repeatedly failed, I accepted it may not boot and completed installation.

On reboot "No boot device found. Press any key to reboot"

Norbert (nrbrtx) wrote :

Currently all testcases about UM installation fail with symptoms:

GUI:

```
ERROR!!! (as superuser)

Partition(s) 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 31, 32, 33, 34, 35, 36, 37, 38, 39, 40, 41, 42, 43, 44, 45, 46, 47, 48, 49, 50, 51, 52, 53, 54, 55, 56, 57, 58, 59, 60, 61, 62, 63, 64, 65, 66, 67, 68, 69, 70, 71, 72, 73, 74, 75, 76, 77, 78, 79, 80, 81, 82, 83, 84, 85, 86, 87, 88, 89, 90, 91, 92, 93, 94, 95, 96, 97, 98, 99, 100, 101, 102, 103, 104, 105, 106, 107, 108, 109, 110, 111, 112, 113, 114, 115, 116, 117, 118, 119, 120, 121, 122, 123, 124, 125, 126, 127, 128 on /dev/vda have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use. As a result, the old partition(s) will remain in use. You should reboot now before making further changes.

[Ignore] [Cancel]
```

/var/log/partman , using QuickEMU

```
artman:parted_server: OUT: yes
partman:parted_server: Closing infifo and outfifo
partman:parted_server: main_loop: iteration 146
partman:parted_server: Opening infifo
partman:/lib/partman/commit.d/30parted: IN: COMMIT =dev=vda
partman:parted_server: Read command: COMMIT
partman:parted_server: command_commit()
partman:parted_server: Opening outfifo
partman:parted_server: command_commit: wiping superblocks from /dev/vda
partman:parted_server: do_wipe open(/dev/vda), 6
partman:parted_server: wiping superblocks from /dev/vda succeeded
partman:parted_server: OUT: Error
partman:/lib/partman/commit.d/30parted: error_handler: exception with type Error
partman:/lib/partman/commit.d/30parted: error_handler: reading message
partman:parted_server: OUT: Partition(s) 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 31, 32, 33, 34, 35, 36, 37, 38, 39, 40, 41, 42, 43, 44, 45, 46, 47, 48, 49, 50, 51, 52, 53, 54, 55, 56, 57, 58, 59, 60, 61, 62, 63, 64, 65, 66, 67, 68, 69, 70, 71, 72, 73, 74, 75, 76, 77, 78, 79, 80, 81, 82, 83, 84, 85, 86, 87, 88, 89, 90, 91, 92, 93, 94, 95, 96, 97, 98, 99, 100, 101, 102, 103, 104, 105, 106, 107, 108, 109, 110, 111, 112, 113, 114, 115, 116, 117, 118, 119, 120, 121, 122, 123, 124, 125, 126, 127, 128 on /dev/vda have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use. As a result, the old partition(s) will remain in use. You should reboot now before making further changes.
partman:parted_server: OUT:
partman:parted_server: OUT: Ignore
partman:parted_server: OUT: Cancel
partman:parted_server: OUT:

```

Using VirtualBox changes `/dev/vda` to `/dev/sda` and fails in the same way.

Chris Guiver (guiverc) wrote :

Just had this issue on Ubuntu daily with a "Install alongside" on
hp dc7700 (c2d-e6320, 5gb, nvidia quadro nvs 290)

Leó Kolbeinsson (leok) wrote :

The issue occurred on Xubuntu daily/beta iso 20.10 20200926

on 2 machines
1. Acer [Aspire] E3-111-P60S UEFI+secure boot
2. Dell [Optiplex] 7010 UEFI+secure boot

Bill (franksmcb) (franksmcb) wrote :

Still occurring on Ubuntu MATE 20200928 daily.

Chris Guiver (guiverc) wrote :

I just re-tried Xubuntu groovy daily (20200928); full disk install

uEFI failure on
- dell [optiplex] 990 (i7-2600, 16gb, nvidia geforce gt 6600 gt)

BIOS failure on
- hp dc7700 (c2d-e6320, 5gb, nvidia quadro nvs 290)

Chris Guiver (guiverc) wrote :

Attempt to install Ubuntu groovy daily (20200928); full disk install on two boxes I tried Xubuntu with, it's unusable on d990 due different (graphics) issue, however

It won't let me CANCEL or IGNORE the "ERROR!!! Partition(s) 4, 5, 6, 7 ...." message; it just remains locked at that window on either IGNORE or CANCEL. Whichever button I click is briefly COLORED/shaded as if click is recognized, but nothing else occurs; it remains stuck at the ERROR!!! popup.

Chris Guiver (guiverc) wrote :

Comment #15 was attempted install on
hp dc7700 (c2d-e6320, 5gb, nvidia quadro nvs 290)

Chris Guiver (guiverc) wrote :

I completed (comment #15, safe graphics, 20200929) Erase disk & install of Ubuntu (groovy) desktop on
- dell [optiplex] 990 (i7-2600, 16gb, nvidia geforce gt 6600 gt)

and despite getting the "ERROR! Partition(s) 4, 5, 6, 7, ...." message the install did complete & install booted.

Bill (franksmcb) (franksmcb) wrote :

Ubuntu Budgie Beta is affected by this issue.

tags: added: rls-gg-incoming
Changed in ubiquity (Ubuntu):
milestone: none → ubuntu-20.10-beta
Norbert (nrbrtx) wrote :

Ubuntu MATE 20200930 beta is surprisingly no more affected by this bug.
Tested on QuickEMU legacy and EFI; and also on VirtualBox - both legacy and EFI.

@Bill (franksmcb), can you please confirm?

Bill (franksmcb) (franksmcb) wrote :

Latest iso spin 20200930 resolves this on Ubuntu MATE 20.10

Chris Guiver (guiverc) wrote :

xubuntu daily still fails to install on
dell [optiplex] 990 (i7-2600, 16gb, nvidia geforce gt 6600 gt)

but no appearance of the error message key to this bug. It's a bootloader issue I mentioned in comment #9 so I've started a new bug
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1897991

kubuntu daily however succeeded on
dell [optiplex] 990 (i7-2600, 16gb, nvidia geforce gt 6600 gt)

Dimitri John Ledkov (xnox) wrote :

fixed in beta

Changed in parted (Ubuntu):
status: Confirmed → Fix Released
Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers