You can't enable the Orca screen reader until after you click "Try Ubuntu" on Ubuntu bionic

Bug #1741690 reported by jokinglove on 2018-01-06
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
Critical
Jean-Baptiste Lallement
Bionic
Critical
Jean-Baptiste Lallement
ubiquity (Ubuntu)
Critical
Jean-Baptiste Lallement
Bionic
Critical
Jean-Baptiste Lallement

Bug Description

When doing manual tests for Ubuntu Bionic. I am trying to enable screenreader after initially booting up ubuntu to its "Try" & "Install" Ubuntu options. When trying to enable screen reader (Alt+Super+S), nothing happens. Alt+Super+S only works after you click "Try Ubuntu".

I am running Ubuntu Bionic amd64 on Virtualbox

Related branches

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1741690

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Alex ARNAUD (alexarnaud) on 2018-03-02
summary: - You can't enable screen reader until after you click "Try Ubuntu" on
- Ubuntu bionic
+ You can't enable the Orca screen reader until after you click "Try
+ Ubuntu" on Ubuntu bionic
Daniel van Vugt (vanvugt) wrote :

Isn't the "Try Ubuntu" icon (and anything to click on at all) only after you've booted up in install mode?

Can you boot in "Try Ubuntu without installing" mode (from the grub menu) as a workaround?

tags: added: a11y
Changed in ubiquity (Ubuntu):
importance: Undecided → Critical
tags: added: rls-bb-incoming
Jean-Baptiste Lallement (jibel) wrote :

could be due to bug 1749546.

Changed in ubiquity (Ubuntu):
assignee: nobody → Jean-Baptiste Lallement (jibel)
status: Confirmed → In Progress
Changed in casper (Ubuntu):
importance: Undecided → Critical
status: New → In Progress
assignee: nobody → Jean-Baptiste Lallement (jibel)
tags: removed: rls-bb-incoming
Jean-Baptiste Lallement (jibel) wrote :

This is caused by this commit:
https://github.com/GNOME/gnome-shell/commit/01d88119132f277196fa39c05b733dd1b4c5e951#diff-27bd3da1798473ae0fa876e6712c08a4

gdm: Remove separate greeter universal access icon

The idea behind always showing the icon on the login screen is that
the users' needs aren't known at that point. However we can achieve
the same behavior by including the 'always-show-universal-access-status'
key in GDM's presets, so drop the special-case.

https://bugzilla.gnome.org/show_bug.cgi?id=788943

Jean-Baptiste Lallement (jibel) wrote :

I pushed a first branch that fixes the display of the a11y icon when the shortcut is pressed.
Now we still need to fix Orca startup.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 18.04.11

---------------
ubiquity (18.04.11) bionic; urgency=medium

  [ Sebastien Bacher]
  * Don't deactivate the screen-reader desktop keybinding, that was needed
    when ubiquity was handling the key press events but now gsd-media-keys is
    doing that. Listen to the corresponding key to start orca under
    ubiquity-dm since gnome-session isn't there to do it.
    (lp: #1741690)

  [ Iain Lane ]
  * misc.py: Fall back to SUDO_UID if PKEXEC_UID is not set.
  * ubiquity.desktop.in, misc.py: Pass through the ubuntu user's D-Bus session
    bus, if set, so that we can communicate with it.

  [ Jean-Baptiste Lallement ]
  * data/ubiquity.json: The separate greeter universal icon has been removed
    and the gnome-shell mode updated accordingly.

 -- Iain Lane <email address hidden> Tue, 24 Apr 2018 16:29:35 +0100

Changed in ubiquity (Ubuntu Bionic):
status: In Progress → Fix Released
Changed in casper (Ubuntu Bionic):
status: In Progress → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.