Screen reader does not read Ubiquity windows

Bug #1719995 reported by Jean-Baptiste Lallement on 2017-09-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
ubiquity (Ubuntu)
High
Unassigned

Bug Description

artful desktop 20170926

Test Case
1. Boot to the live session
2. Enable the screen reader (alt+super+s)
3. Start ubiquity and proceed with the installation using the screen reader

Expected result
The screen reader reads ubiquity windows

Actual result
It is speachless

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 4.13.0-11.12-generic 4.13.1
Uname: Linux 4.13.0-11-generic x86_64
ApportVersion: 2.20.7-0ubuntu1
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Wed Sep 27 16:06:02 2017
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/ubuntu.seed boot=casper --
InstallationDate: Installed on 2013-09-03 (1484 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130902)
ProcEnviron:
 TERM=screen-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1719995

tags: added: iso-testing
Will Cooke (willcooke) on 2017-09-27
tags: added: rls-bb-incoming
removed: rls-aa-incoming
tags: added: rls-aa-incoming
removed: rls-bb-incoming
Changed in ubiquity (Ubuntu):
importance: Undecided → High
Sebastien Bacher (seb128) wrote :

Having another look to that bug, is it specific to the install only mode or also in the real session?

One issue is in that in install-only nothing starts orca, the indicator is from gnome-shell but that's only settings a gsettings key. In a normal session gnome-session is handling to activation/desactivation of orca when the key is changing

I'm adding a patch that watches the gsetting key and active orca when it's set to true. I didn't test it but it should work. Note that it should probably be stopped when the key is to False then.

There might be other changes needed, calls like this used to be made
" subprocess.call(
            ['log-output', '-t', 'ubiquity', '--pass-stdout',
             'casper-a11y-enable', 'onscreen-keyboard'],"

But they got deleted when the installed was transitioned by Luke to the "a11y-profile-manager", which has been deprecated&removed since Luke left, so there might be custom code that needs to be added back, see http://bazaar.launchpad.net/~ubuntu-installer/ubiquity/trunk/revision/6373

tags: added: patch
Jean-Baptiste Lallement (jibel) wrote :

It works fine from a live session but not from "Install Ubuntu"

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Changed in ubuntu-release-notes:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers