UI freeze exception for ubiquity-slideshow-ubuntu 9 (Ubuntu One and FF 3.5)

Bug #447383 reported by Evan on 2009-10-09
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Translations
High
Aron Xu
ubiquity-slideshow-ubuntu (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity-slideshow-ubuntu

We need a UI freeze exception for ubiquity-slideshow-ubuntu 9, as it corrects the Firefox version shipped with 9.10 to be 3.5, not 3.0, and adds a slide for Ubuntu One, as requested.

Evan (ev) wrote :
Changed in ubiquity-slideshow-ubuntu (Ubuntu):
milestone: none → ubuntu-9.10
Evan (ev) wrote :
Timo Jyrinki (timo-jyrinki) wrote :

If the exception gets granted, and deadline is on Thursday, shall the translations be done in https://translations.launchpad.net/ubiquity-slideshow-ubuntu or https://translations.launchpad.net/ubuntu/karmic/+source/ubiquity-slideshow-ubuntu ? If the latter, it's only updated _after_ a new upload in the normal case, which would mean two uploads - first to update the templates and second to pick up new translations after the template update.

Matthew East (mdke) wrote :

No problem for ubuntu-docs

Evan (ev) wrote :

I've since changed the debian/copyright to account for bug 451263.

Steve Langasek (vorlon) wrote :

Freeze exception granted.

Would it be possible to manually un-fuzzy the translations of "firefox 3.5" before upload, so that translators don't have to go through individually and s/3/3.5/?

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity-slideshow-ubuntu - 9

---------------
ubiquity-slideshow-ubuntu (9) karmic; urgency=low

  [ Evan Dandrea ]
  * The version of Firefox shipped with Ubuntu 9.10 is 3.5, not 3.0
    (LP: #442832).
  * Add an Ubuntu One slide.
  * Freeze exception (LP: #447383).
  * Updated Ubuntu and Ubuntu One logo license (LP: #451263).
  * Updated translations from Launchpad (source package).

  [ Dylan McCall ]
  * Merged middle-tweaks branch. Freeze exception (LP: #445102)
  * New strings for firefox.html, fspot.html, rhythmbox-totem.html,
    evolution.html, empathy.html, openoffice.html, accessibility.html,
    installing-software.html.
  * Changed order of slideshow; multimedia stuff slide appears first,
    accessibility near the end, before Installing Software.
  * Breathe icons have been replaced with icons from the Humanity icon theme:
    accessibility.svg, evolution.svg, fspot.svg, help.svg, openoffice.svg
    (LP: #428169)
  * Breathe icon fspot.svg has been replaced with its counterpart from the
    fspot source package.
  * Removed banshee.svg from source tree and removed mention of nonexistent
    icons from debian/copyright.
  * Updated translation templates for new slides.

  [ Daniel Holbert ]
  * Made images in slideshow non-draggable to work around pywebkitgtk crash
    (LP: #448703).

 -- Evan Dandrea <email address hidden> Thu, 15 Oct 2009 11:50:19 +0100

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: Confirmed → Fix Released
Adi Roiban (adiroiban) wrote :

According to https://wiki.ubuntu.com/KarmicReleaseSchedule this freeze break was granted after the non-language pack translation freeze (15th Oct, 00:00UTC).

I don't know how we are going to translate the new strings.

Do we also have an exception for non-language pack translation deadline?

Aron Xu (happyaron) wrote :

According to Adi's consideration, I think it's necessary for UTC team to have an eye on this.

Changed in ubuntu-translations:
assignee: nobody → Aron Xu (happyaron)
importance: Undecided → High
status: New → Triaged
Steve Langasek (vorlon) wrote :

The requested freeze exception was granted for the FF version number change and the new UbuntuOne slide; but I see that there are other string changes that were not mentioned in the request. :/

However, the worst-case consequence of not having up-to-date translations is that users will see a slide during the install that they may not understand, which I don't think is terrible... and also not worse than omitting the new slide entirely or shipping with unclear/inaccurate information in some of the slides. The slideshow is effectively eye candy while the install is running, after all; while I look forward to having this slideshow more completely translated and more accessible for Lucid, I don't think this is anything translation teams should be distracted by, given that there are much more important things to get translated for release (i.e., all the bits that users *need* to understand to be able to use their system).

As for the earlier idea to unfuzzy translations by updating the version number, I see now that more than just the version number was changed, so this isn't an option.

If the Ubuntu translators feel strongly about this, we can still consider reverting the string changes for release.

Dylan McCall (dylanmccall) wrote :

Ah, sorry Steve. We actually ended up with two overlapping freeze exceptions on the FF 3.5 change, where the other one (also granted) involved a rather major rewrite. That's what you are seeing here.

I am prepared to rewire this (and actually have a branch standing by in that event) based on where things go, but the awesome translation work that was done in the last day tells me that probably won't be necessary, and would in fact be rather detrimental. I'll just have to owe a lot of people some time :)

Steve Langasek (vorlon) wrote :

Dylan, what other freeze exception was granted here? I don't recall seeing another freeze exception bug about this.

Timo Jyrinki (timo-jyrinki) wrote :

Whatever the case, now that the new strings are in, please make sure you will do a new upload of ubiquity-slideshow-ubuntu with all the new translations from Rosetta in a couple of days, or 21st the latest. I see that https://translations.launchpad.net/ubiquity-slideshow-ubuntu was removed, which is good that there is only one place the translations are in, namely https://translations.launchpad.net/ubuntu/karmic/+source/ubiquity-slideshow-ubuntu

2009/10/16 Timo Jyrinki <email address hidden>:
> Whatever the case, now that the new strings are in, please make sure you
> will do a new upload of ubiquity-slideshow-ubuntu with all the new
> translations from Rosetta in a couple of days, or 21st the latest. I see
> that https://translations.launchpad.net/ubiquity-slideshow-ubuntu was
> removed, which is good that there is only one place the translations are
> in, namely https://translations.launchpad.net/ubuntu/karmic/+source
> /ubiquity-slideshow-ubuntu

I agree with Timo, whatever the decision at this point, please make an
update export of all translations.
I asked on the mailing list how much time we were granted for this
exception, since in that way we could have known how to deal with
this: if it was best to keep on translating, or if it was best to
revert back to the old templates.

These translations will be see by a big audience, and probably not
English speaking: having half strings translated would be a real bad
experience for them (and probably give them a bad image of Ubuntu).

Thanks.

--
Milo Casagrande <email address hidden>

Evan (ev) wrote :

Will do.

Evan (ev) wrote :

Steve,
The other freeze exception was bug 445102.

David Planella (dpm) wrote :

After talking with pitti, I've filed bug 452889 to formally request an exception to NonLanguagePackTranslationDeadline.

Dylan, Evan, could you please comment on that bug and tell us when you could do the last translation export, so that I can communicate it to translators?

Aron Xu (happyaron) on 2009-10-25
Changed in ubuntu-translations:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers