Ubuntu

Argentina does not change to DST this (2009-10-18) sunday

Reported by Alberto Bertogli on 2009-10-16
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
tzdata (Debian)
Fix Released
Unknown
tzdata (Ubuntu)
Undecided
Unassigned
Dapper
Undecided
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Undecided
Unassigned
Jaunty
High
Martin Pitt
Karmic
Undecided
Unassigned

Bug Description

Binary package hint: tzdata

It was decided today that Argentina will not change to DST this sunday 2009-10-18,
so tzdata requires an update.

News reports about it (in spanish):
  http://www.pagina12.com.ar/diario/ultimas/20-133580-2009-10-16.html
  http://www.lanacion.com.ar/nota.asp?nota_id=1186963&pid=7542694&toi=6275
  http://www.clarin.com/diario/2009/10/16/um/m-02020173.htm

There's a bug in Debian about this, which includes patches and packages:
  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=551195

Thanks,
    Alberto

Changed in tzdata (Debian):
status: Unknown → New
MarianoAbsatz (el-baby) wrote :

Hi,

Margarita Manterola (the debian maintainer who posted the debian patches) kindly posted the complete .deb packages for tzdata and tzdata-java:

    * Etch: http://www.marga.com.ar/~marga/debian/tzdata/tzdata_2009g-0etch1.1_all.deb

    * Lenny: http://www.marga.com.ar/~marga/debian/tzdata/tzdata_2009l-0lenny1.1_all.deb
y http://www.marga.com.ar/~marga/debian/tzdata/tzdata-java_2009l-0lenny1.1_all.deb

    * Squeeze/Sid/Karmik:
http://www.marga.com.ar/~marga/debian/tzdata/tzdata_2009n-1.1_all.deb
y http://www.marga.com.ar/~marga/debian/tzdata/tzdata-java_2009n-1.1_all.deb

My guess is that the Squeeze/Sid/Karmik packages are good for Jaunty too.

MarianoAbsatz (el-baby) wrote :

Just dpkg -i'd the Squeeze/Sid/Karmic on my Jaunty and it works OK...

They should be just fine in Hardy and Intrepid too (the packages are simply data, not code).

On Fri, Oct 16, 2009 at 03:31:53PM -0000, MarianoAbsatz wrote:
> My guess is that the Squeeze/Sid/Karmik packages are good for Jaunty
> too.

I tested it a moment ago, and it works fine.

Thanks,
  Alberto

MarianoAbsatz (el-baby) wrote :

Anyway... stay tuned if you live in San Luis, 'cause tzdata is wrong about it...

I just posted to the mailing list about that: http://thread.gmane.org/gmane.comp.time.tz/2936

Martin Pitt (pitti) wrote :

Karmic fixed by syncing 2009n-2 from Debian sid:

tzdata (2009n-2) unstable; urgency=low

  [ Christian Perrier ]
  * Brazilian Portuguese translation (Flamarion Jorge). Closes: #550846

  [ Clint Adams ]
  * debian/patches/argentinas-dst-2009.diff: patch from Margarita
    Manterola to fix Argentina DST again. closes: #551195.

Changed in tzdata (Ubuntu Karmic):
status: New → Fix Released
Martin Pitt (pitti) wrote :

Test case:

Current situation:

$ LANG= TZ=America/Argentina/Buenos_Aires date
Sat Oct 17 09:14:43 ART 2009
$ LANG= TZ=America/Argentina/Buenos_Aires date -d tomorrow
Sun Oct 18 10:14:46 ARST 2009

-> Argentina would switch to DST, which has just been changed. I'm using Magerita's patch which is straightforward:

+# Margarita Manterola:
+# Same as always, Argentina's government just decided to change its mind
+# regarding DST, 2 days in advance.
+# http://www.lanacion.com.ar/nota.asp?nota_id=1186963&pid=7542694&toi=6275
+
 Rule Arg 2007 only - Dec 30 0:00 1:00 S
-Rule Arg 2008 max - Mar Sun>=15 0:00 0 -
-Rule Arg 2008 max - Oct Sun>=15 0:00 1:00 S
+Rule Arg 2008 2009 - Mar Sun>=15 0:00 0 -
+Rule Arg 2008 only - Oct Sun>=15 0:00 1:00 S

Changed in tzdata (Ubuntu Jaunty):
status: New → In Progress
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → High
Martin Pitt (pitti) wrote :

With the patch, DST is not enabled:

$ LANG= TZ=America/Argentina/Buenos_Aires date
Sat Oct 17 09:19:02 ART 2009
$ LANG= TZ=America/Argentina/Buenos_Aires date -d tomorrow
Sun Oct 18 09:19:08 ART 2009

Martin Pitt (pitti) wrote :

Accepted tzdata into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in tzdata (Ubuntu Jaunty):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in tzdata (Ubuntu Intrepid):
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Accepted tzdata into intrepid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

Accepted tzdata into hardy-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in tzdata (Ubuntu Hardy):
status: New → Fix Committed
Changed in tzdata (Ubuntu Dapper):
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Accepted into dapper-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

The San Louis special case is not quite clear to me yet, but let's fix it for the other provinces now at least.

Changed in tzdata (Debian):
status: New → Fix Released
Martin Pitt (pitti) wrote :

I tested the .debs in *-proposed and confirmed that they install/upgrade cleanly and that they fix Argentina DST with the test above.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tzdata - 2009n-0ubuntu0.8.04.1

---------------
tzdata (2009n-0ubuntu0.8.04.1) hardy-proposed; urgency=low

  * Add argentinas-dst-2009.diff: Disable DST switch for Argentina tomorrow,
    as the Argentina government decided yesterday. Careful planning is boring.
    Thanks to Margarita Manterola for the patch! (LP: #453165)

 -- Martin Pitt <email address hidden> Sat, 17 Oct 2009 14:34:53 +0200

Changed in tzdata (Ubuntu Hardy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tzdata - 2009n-0ubuntu0.8.10.1

---------------
tzdata (2009n-0ubuntu0.8.10.1) intrepid-proposed; urgency=low

  * Add argentinas-dst-2009.diff: Disable DST switch for Argentina tomorrow,
    as the Argentina government decided yesterday. Careful planning is boring.
    Thanks to Margarita Manterola for the patch! (LP: #453165)

 -- Martin Pitt <email address hidden> Sat, 17 Oct 2009 14:31:58 +0200

Changed in tzdata (Ubuntu Intrepid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tzdata - 2009n-0ubuntu0.9.04.1

---------------
tzdata (2009n-0ubuntu0.9.04.1) jaunty-proposed; urgency=low

  * Add argentinas-dst-2009.diff: Disable DST switch for Argentina tomorrow,
    as the Argentina government decided yesterday. Careful planning is boring.
    Thanks to Margarita Manterola for the patch! (LP: #453165)

 -- Martin Pitt <email address hidden> Sat, 17 Oct 2009 14:22:39 +0200

Changed in tzdata (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2009-10-17
Changed in tzdata (Ubuntu Dapper):
status: Fix Committed → Fix Released
almafuerte (almafuerte) wrote :

Thank you very much for the patch guys!

Now all we need is to apt-get remove kirchner (Cristina Kirchner being the bitch responsible for all this mess).

As always, The GNU/Linux community is better informed than the rest of the world (Yes, nobody here is sure about what time to set tomorrow, not even the media. Specially the media).

Thanks again,
Almafuerte

almafuerte (almafuerte) wrote :

sed -i s/guys/girls/g

Gracias Marga!

Almafuerte

On Sun, Oct 18, 2009 at 04:00:30AM -0000, almafuerte wrote:
> Now all we need is to apt-get remove kirchner

Launchpad isn't really the right place to agitate for regime change :), but
given that this is a chronic issue for Argentina, I do strongly encourage
Argentines to communicate to their government that last minute changes to
daylight savings rules are irresponsible and cost businesses a lot of time
and money due to the confusion. Martin does a wonderful job of making
tzdata updates available as quickly as possible, but it's not enough for the
updates to be available if the information isn't disseminated in a manner
that gives *people* time to plan appropriately...

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

mama21mama (mama21mama2000) wrote :

che! ptm :s por que estando manual me sincronizo a otro uso orario?
miren mi configuracion estaba en manual :s http://img39.imageshack.us/img39/1849/pantallazoajustesdehora.png

MarianoAbsatz (el-baby) wrote :

(English below)

mama21mama,

lo que pasa es que el "manual" lo que le dice es que no sincronice la hora con servidores de hora de internet (NTP). Sin embargo, el ajuste de huso horario SIEMPRE se hace (en base a las reglas que se llaman "America/Argentina/Buenos_Aires" que tenés seteadas según la imagen).

Esas reglas, hasta ayer en que Martin Pitt publicó los paquetes en base a un patch que armó Margarita Manterola para Debian (aun ANTES de que salga publicado en el paquete "upstream" ftp://elsie.nci.nih.gov/pub/, que todavía no salió), decían que hoy a las 0:00 se atrasaba una hora.

En Unix/Linux, normalmente, la "hora del sistema" se la considera como la hora UTC (Greenwich) y lo que se mantiene es una tabla de conversiones entre esa hora y la hora local en cada lugar. En Windows, por el contrario, la "hora del sistema" es la hora local, lo cual hace difícil manejar equipos que se utilizan desde distintos lugares, y los cambios son bastante más traumáticos (tanto más si se los hace "hacia atrás" como vas a tener que hacer vos ahora).

Si actualizás el paquete tzdata ahora, seguramente vas a ver la hora bien (posiblemente tengas que "desloguearte y volver a loguearte" para que se te arregle el relojito del escritorio).

ENGLISH VERSION:
mama21mama complains in https://bugs.launchpad.net/ubuntu/+source/tzdata/+bug/453165/comments/20 that even when he/she has configured manual handling of the time, his/her clock changed to DST at 0:00 today.

To which I answered:

the problem is that "manual" here refers to "not syncing time to internet time servers" (NTP). However, the timezone adjustment is ALWAYS done (based on the rules called "America/Argentina/Buenos_Aires" you have configured according to the image).

Those rules, until yesterday, when Martin Pitt published the new packages based on a patch for Margarita Manterola for Debian (even BEFORE that is acutally published upstream at ftp://elsie.nci.nih.gov/pub/), said that today at 0:00 we had to go one hour back.

In Unix/Linux, normally "system time" is kept in UTC (Greenwich) and a conversion table between UTC and every place's localtime is maintained. On the contrary, in Windows, "system time" is the local time, which makes dificult to handle computers used from different places, and changes are rather traumatic (especially if you have to do it "backwards", after the fact, as you will have to do now).

If you update the tzdata package now, you will surely see the right time (you will have to logout/login back for your desktop clock to read the right time).

MarianoAbsatz (el-baby) wrote :

To whoever has the disgrace to administer different windows versions, have fun with this instructions: http://www.microsoft.com/argentina/dst/

Obviously, the instructions to fix (even manually) Ubuntu 9.10, 9.04, 8.10 and 8.04 are identical.. in fact, they are the same as with any other unix-like system (including Sun Solaris, FreeBSD and a bunch others)....

MarianoAbsatz (el-baby) wrote :

Hi Martin,

tzdata2009p is out today so argentinas-dst-2009.diff will no longer be necessary.

Other fix regarding Argentina is included for the special case of the Provincia de San Luis.

Regards.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.