Error OAFIID:GNOME_TSClientApplet while adding the applet onto panel

Bug #399436 reported by Michal Matyska on 2009-07-14
400
This bug affects 86 people
Affects Status Importance Assigned to Milestone
tsclient (Debian)
Fix Released
Unknown
tsclient (Ubuntu)
Critical
Unassigned
Nominated for Dapper by r12056
Nominated for Hardy by r12056
Nominated for Intrepid by r12056
Nominated for Jaunty by r12056
Nominated for Karmic by MaxNegro
Nominated for Lucid by Richard Lee

Bug Description

Binary package hint: tsclient

The same error shows up when starting Gnome with the applet been previously (before today's update) installed onto panel.

tsclient: 0.150-2ubuntu1
libc6: 2.9-9ubuntu2
libglib2.0-0: 2.21.3-0ubuntu1
libgtk2.0-0: 2.17.4-0ubuntu2
rdesktop: 1.6.0-2ubuntu2

If you need more info, I'm able to provide it.

Martin Emrich (emme) wrote :

Same here on current karmic amd64. The message appears on every logon if I choose not to remove from panel. It also appears when attempting to re-add the applet to the panel.

Changed in tsclient (Ubuntu):
status: New → Confirmed
Ulf Rompe (rompe) wrote :

According to the related Debian bug at http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=538035 this is already fixed, but a new package has not been released yet.

Ulf Rompe (rompe) wrote :

May be interesting for other users waiting for this bug to get fixed: I switched to "grdc-gnome" a week ago and find it does everything that tsclient did for me, just in a nicer fashion.

This is indeed fixed in version 0.150-3. As of now, this version has not yet made it into the karmic repositories.

LosD (d-hp23c) wrote :

Ulf, thanks for the hint, grdc-gnome indeed seems like a very nice rdesktop frontend!

Nikolaus Filus (nfilus) wrote :

I can confirm, that using the debian package 0.150-3 instead of karmics 0.150-2 fixes the problem. As the Author confirms, it was a typo in a patch, this should be simple enough to even allow a bugfix before karmic final.

Please update the included 01_configure_check_libgnomeui.patch

Noel (b-launchpad-lolith-net) wrote :

This bug still exists in Karmic as of 23/10/09.

Noel (b-launchpad-lolith-net) wrote :

Blast - meant to say "This bug still exists in Karmic as of 28/10/09."

Martin Emrich (emme) wrote :

Yes, I just upgraded my work laptop to 9.10, and it's still there, making the tsclient applet basically useless. As it seems to be only a typo in a patch, and AFAIK no packages depend on tsclient, would't this be a candidate for a SRU?

wgacquer (wgacquer) wrote :

Huge bug :(

smileboot (smileboot) wrote :

I am curious as to why the new version with the minor revision has not been put in the repositories yet over a month since it has been available for over a month now???????

smileboot (smileboot) wrote :

That will teach me to post at 4:30am.

David Brewer (david-brewer) wrote :

Confirmed as of November 3, 2009 on Karmic amd64, fresh install from desktop CD + latest updates.

omriasta (omri) wrote :

Confirmed x86 Karmic fresh install...Nov. 3.

Jamin W. Collins (jcollins) wrote :

Don't believe this bug needs any further confirmation. It has already been confirmed more than enough. The fix is known, and trivial at that. The question is why an updated package for Karmic hasn't been made and pushed into the repository. I'll see about getting a fixed version submitted to my PPA.

Craig Barnes (cjbarnes18) wrote :

I have installed 0.150-3 for i386 and can confirm its working.

You can download the deb from http://packages.debian.org/sid/tsclient

yayo (jaganz) wrote :

it's not true for me... i have installed this package with "--force-architecture" after killall gnome-panel/logoff/reboot problem is the same... rollback to previous version.

tsclient crash:
ii tsclient 0.150-2ubuntu2
on amd64 distro

TK (tkrishan) wrote :

I don't believe you should have had to use the --force architecture switch.

Did you use the correct binary?

i386
http://packages.debian.org/sid/i386/tsclient/download

AMD64
http://packages.debian.org/sid/amd64/tsclient/download

Craig Barnes (cjbarnes18) wrote :

Audio in 0.150-3 is not as good as 0.150-2ubuntu2 for me.

Craig Barnes (cjbarnes18) wrote :

are there any patches in 0.150-2ubuntu2 that are not upstream yet?

yayo (jaganz) wrote :

thanks TK and sorry Craig Barnes for my mistake... it works great! I need to pin this deb against upgrade? thank you!

I had the same problem on AMD64 after upgrade to Karmic. Installed new tsclient debian package - problem solved.

Alroger Filho (alroger-filho) wrote :

I am thankfull for this bug... it went on for so long that I had to search for another option, and I found it... great rdp/vnc/sftp/xdmcp manager: Remmina! http://remmina.sourceforge.net

Mathieu Charron (elwillow) wrote :

to add on Alorger message: Grdc was renamed to remmina (http://grdc.sourceforge.net)
Since Remmina is *not yet* in the repos, the packages are grdc-gnome and grdc (until name change) or check the download page.

Jonh Wendell (wendell) on 2010-01-28
Changed in tsclient (Ubuntu):
importance: Undecided → Critical
Jakob Reiter (jakommo) wrote :

If you are interested in remmina there is a ppa on launchpad.
https://launchpad.net/~llyzs/+archive/ppa

Jamin W. Collins (jcollins) wrote :

Sorry it took so long, got side tracked, but I have uploaded a rebuild of the Debian package to my ppa:

https://launchpad.net/~jcollins/+archive/jaminppa/

Chris Johnston (cjohnston) wrote :

The nominations may not be appropriate. Please investigate and fix as appropriate.

David Baucum (maxolasersquad) wrote :

This bug was reported before 9.10 was released, and upstream has fixed it. Why has this fix still not been released for Ubuntu users?

Jamin W. Collins (jcollins) wrote :

While not in the actual archive, Ubuntu users do have several options. It's in my PPA, they can download the proper .deb files from Debian, or they can use the superior Remmina. I'll admit I was reluctant to move to Remmina, but since having packaged the corrected tsclient version for my PPA, I have done so. I do wish that Remmina had an import/migration option for tsclient files though.

David Baucum (maxolasersquad) wrote :

I have installed the .deb from Debian and it works great. However, having the app crash is enough to make most users give up on trying at all. Keeping something broken because Googling and finding a fix that is beyond what users should be expected to do is not really the kind of quality people expect from a world class OS.

Brian Murray (brian-murray) wrote :

This is fixed in Lucid Lynx with version 0.150-3 of tsclient.

tsclient (0.150-3) unstable; urgency=low

  [ Emilio Pozuelo Monfort ]
  * debian/patches/01_configure_check_libgnomeui.patch:
    + Fix typo (yes instead of xyes) that caused libpanelapplet and libgnomeui
      to not be checked, missing -l flags. This caused tsclient-applet to not
      link against those libs, failing to load in the panel. Closes: #538035.

Changed in tsclient (Ubuntu):
status: Confirmed → Fix Released
gumpish (launchpad-5-gumpish) wrote :

Wow. Really? "Well, we've fixed it in the next release WHICH IS STILL ALPHA. Why don't you just upgrade now?"

This bug was identified and fixed upstream two months before Karmic was released. No packages depend on it... it was caused by a typo in a patch... and yet all the brainpower behind Ubuntu can't get the fixed package into karmic?

WTF?

Ryan Daly (daly-ctcnet) wrote :

I must agree... It seems to take too long for simple bugs like this to be fixed.

IF Ubuntu is to challenge Windows/MAC/<whatever>, more speedy fixes will need to occur. The average user cannot be expected to go in search of fixes that should already be released.

If there are other issues with releasing the fix, make them known.

cboese (boese) wrote :

Still not fixed. WTF?
Two lines of code. Every possible help from the community right here.
Panel-Applet that's used by a lot of people.
Using the app itself ist NOT a workaround.
Please enlighten me, what the problem here is?

zadir (jzadir) wrote :

2010-03-17
Still not fixed?
I really want to know what is the problem ?

TK (tkrishan) wrote :

The Ubuntu team has been busy reworking the brand identity of Ubuntu. Important changes are being made to the desktop, changing the primary color from brown to lavender. The Window control buttons are being moved from the right to the left. A new logo and font is being created that better symbolizes: Precision, Reliability, Collaboration, and Freedom.

See:
https://wiki.ubuntu.com/Brand
and
http://www.jonobacon.org/2010/03/03/refreshing-the-ubuntu-brand/

Thomas Jagoditsch (tja) wrote :

thx TK for the morning laugh. although its a bit sad laugh...
anyway - its strange that this bug is critical and has heat 4 - but if u go to the package's bugs u will not see it listed there ... is this because #31 listed is as "fix released" ?!?
or - as u may ask - is this launchpads bug or launchpads feature ...

TK (tkrishan) wrote :

With reference to the Ubuntu brand identity, Precision, Reliability, Collaboration, and Freedom:

Für das Können gibt es nur einen Beweis: das Tun. - Marie von Ebner-Eschenbach,

approximate English translation: The proof of the ability is in the doing.

Dnia 2010-03-19, pią o godzinie 13:50 +0000, TK pisze:
> With reference to the Ubuntu brand identity, Precision, Reliability,
> Collaboration, and Freedom:
>
> Für das Können gibt es nur einen Beweis: das Tun. - Marie von Ebner-
> Eschenbach,
>
> approximate English translation: The proof of the ability is in the
> doing.
Well said :)

--
Patryk "LeadMan" Benderz
Linux Registered User #377521
() ascii ribbon campaign - against html e-mail
/\ www.asciiribbon.org - against proprietary attachments

Email secured by Check Point

beaon (filc03) wrote :

mcdjork wrote on 2009-11-23:
I downloaded and installed the updated version of tsclient, and adding the applet worked great.

http://packages.debian.org/sid/tsclient

See full activity log
beaon wrote 3 seconds ago: #18
Uninstalling and reinstalling it from mcdjork's link fixed the problem. The only downside is the applet on the panel is not movable, but at least it works.

Changed in tsclient (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.