Ubuntu

Tomboy causing delay on logout or shutdown

Reported by Colin Law on 2011-10-23
310
This bug affects 56 people
Affects Status Importance Assigned to Milestone
tomboy
Fix Released
Medium
tomboy (Ubuntu)
High
Unassigned
Oneiric
High
Dariel
Precise
High
Unassigned

Bug Description

SRU TESTCASE

1. start tomboy
2. logout from the session menu
3. it take almost 30 secs to kill the session
4. now install tomboy from oneiric-proposed
5. repeat step 1 and 2
6. note the logout happens instantly as it should

If Tomboy is running (on screen or in the background) when a logout or shutdown is requested then about 30 seconds is added to the logout time.
Note that this is not a duplicate of bug #816950 (though may be related to it) as there is no Not Responding message shown.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: tomboy 1.8.0-1ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
ApportVersion: 1.23-0ubuntu3
Architecture: i386
Date: Sun Oct 23 12:06:02 2011
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: tomboy
UpgradeStatus: Upgraded to oneiric on 2011-10-14 (8 days ago)

Colin Law (colin-law) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in tomboy (Ubuntu):
status: New → Confirmed
Kirill Kabardin (kkabardin) wrote :

Can confirm this for x86_64 architecture too.

The problem might be more noticeable when one uses Ubuntu One synchronisation.

Colin Law (colin-law) wrote :

Not using Ubuntu One sync here and the problem is perfectly repeatable. Leave Tomboy running and logout takes around 30 seconds longer to logout.

Guilherme Salgado (salgado) wrote :

I can reproduce this even with a freshly created user. After starting tomboy, logging out takes almost 30 seconds

I can confirm this using latest Oneiric Ocelot and Unity. I've searched for bugs upstream but could not find anything. Anybody can try if it is reproducible in Unity 2D or gnome-shell?

Colin Law (colin-law) wrote :

It is reproducible in Unity 2D. I doubt it is anything to do with the window manager.

@colin-law, it is strange it is not reported upstream, it looks like something related to Unity to me.

Colin Law (colin-law) wrote :

@Walter, apparently not as it is also seen with Unity2d

Valezan (ssuzan) wrote :

It is also reproducible in “Gnome” and “Gnome classic”. As supposed by Colin Law, seems to have no relationship with the window manager.

OK, thanks I filed a bug upstram, Gnome bugzilla 880299.

Sorry, I meant Gnome Bugzilla 663422.

Changed in tomboy:
importance: Unknown → Medium
status: Unknown → Invalid
Changed in tomboy:
importance: Medium → Unknown
status: Invalid → Unknown
Changed in tomboy:
importance: Unknown → Medium
status: Unknown → New
Changed in tomboy (Ubuntu):
importance: Undecided → High
Rene Horn (the-rhorn) wrote :

The upstream bug noted above was marked as a duplicate of this:

https://bugzilla.gnome.org/show_bug.cgi?id=650029

Rene

Thanks Rene, I've updated the link to the upstream bug.

no longer affects: tomboy
Changed in tomboy:
importance: Unknown → Medium
status: Unknown → New
Sam Lin (itrs-lin) wrote :

I checked dbus messages of gnome session manager and it seems tomboy doesn't take action in response to Stop signal of session manager.

I add Stop signal callback in Tomboy and it solve the issue.

The attachment "exit on Stop signal of session manager" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Iain Lane (laney) wrote :

I unsubscribed sponsors as the patch is being discussed on bugzilla. When something gets committed we'll get it in Ubuntu then. Thanks for the work so far!

Changed in tomboy (Ubuntu Precise):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tomboy - 1.8.0-1ubuntu1.2

---------------
tomboy (1.8.0-1ubuntu1.2) precise; urgency=low

  * debian/patches/git_logout_delay.patch: upstream fix, should fix the issue
    where tomboy is delaying the session logout (lp: #880299)
 -- Sebastien Bacher <email address hidden> Mon, 16 Jan 2012 18:39:47 +0100

Changed in tomboy (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in tomboy:
status: New → Fix Released
pablomme (pablomme) wrote :

May I suggest backporting the fix as an SRU to Oneiric, where tomboy is installed by default?

Jesse Johnson (holocronweaver) wrote :

I second the suggestion of backporting the fix. There is no version difference between Oneiric and Precise packages for Tomboy except for this patch. Thus there is no reason not to backport.

SRU request for Ubuntu 11.10:

Impact: the bug affects all users using tomboy which is a default application in 11.10.

Development fix: This bug was fixed in the package tomboy - 1.8.0-1ubuntu1.2 according to the upstream bug.

Stable fix: It shouls be easy to apply the patch as the version number of Tomboy is the current one in 11.10.

Test Case: open Tomboy and log out or quit the desktop session (Unity or Gnome Shell). The logout is delayed by about 30 seconds.

Regression Potential: none predicted.

Omer Akram (om26er) on 2012-01-17
Changed in tomboy (Ubuntu Oneiric):
importance: Undecided → High
description: updated

Hello Colin, or anyone else affected,

Accepted tomboy into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in tomboy (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
Helmut (debesh) wrote :

Updated as suggested to tomboy version 1.8.0 -> fixed. No adverse side effects so far. Thanks a lot.

tags: added: verification-done
removed: verification-needed
Rémi Rérolle (remi.rerolle) wrote :

I've updated Tomboy to version 1.8.0-1ubuntu1.1.1 from oneiric-proposed as well. The delay when logging out is gone. Everything works like expected!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tomboy - 1.8.0-1ubuntu1.1.1

---------------
tomboy (1.8.0-1ubuntu1.1.1) oneiric-proposed; urgency=low

  * debian/patches/32_logout_delay.patch:
    - Fix the issue where tomboy is delaying the session logout.
      (LP: #880299)

  [ Stéphane Graber ]
  * Change version number to 1.8.0-1ubuntu1.1.1 to avoid conflicting
    with Precise's 1.8.0-1ubuntu1.2 (which should have been -1ubuntu2)
 -- Omer Akram <email address hidden> Tue, 17 Jan 2012 22:51:08 +0500

Changed in tomboy (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Dariel (ikki026) on 2012-03-16
Changed in tomboy (Ubuntu Oneiric):
assignee: nobody → Dariel (ikki026)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.