Thunderbird will not launch due to a recursive symlink

Bug #563893 reported by Christopher on 2010-04-15
164
This bug affects 29 people
Affects Status Importance Assigned to Milestone
thunderbird (Ubuntu)
Critical
Micah Gersten
Lucid
Critical
Micah Gersten

Bug Description

NOTE: In 3.0.4+nobinonly-0ubuntu2, a recursive symlink might have been created. If Thunderbird will not start once you upgrade to 3.0.4+nobinonly-0ubuntu3, then run 'ls -ld ~/.*thunderbird*' from a terminal. If you see .thunderbird in your home directory linked to itself, remove the .thunderbird link to itself and move .thunderbird.upstream to .thunderbird

WORKAROUND for 3.0.4+nobinonly-0ubuntu2: Remove the .thunderbird (not .mozilla-thunderbird) symlink in your home directory and move .thunderbird.upstream to .thunderbird Then create an empty .thunderbird.upstream directory. Thunderbird should launch after that.

Binary package hint: thunderbird

After an update involving a GB language pack, Thunderbird will not launch at all. I've tried the terminal, Alt+F2 and directly from usr/bin with no success. The System Monitor doesn't show any instance of Thunderbird running.

DistroRelease: Ubuntu 10.04

Christopher (soft-kristal) wrote :
Christopher (soft-kristal) wrote :

I also see that in my Home folder, the .thunderbird folder is now named .thunderbird.upstream. The shortcuts can't find the files.

Micah Gersten (micahg) wrote :

Thank you for reporting this to Ubuntu. Do you have a symlink from .mozilla-thunderbird to .thunderbird now in your home dir? Can you try launching from a terminal and post the output?

Changed in thunderbird (Ubuntu):
status: New → Incomplete
Micah Gersten (micahg) wrote :

We actually found the problem and it seems to be a symlink loop. This should be fixed in the next upload.

Changed in thunderbird (Ubuntu):
assignee: nobody → Micah Gersten (micahg)
importance: Undecided → High
status: Incomplete → Triaged
summary: - Thunderbird will not launch
+ Thunderbird will not launch do to a recursive symlink

The links .mozilla.thunderbird and .thunderbird return an alert box with the message 'This link cannot be used, because its target "/home/chris/.thunderbird" doesn't exist.'

Thunderbird is crucial to my work. Should I back up my folder and do a complete removal and reinstallation? The renaming of the folder .thunderbird to .thunderbird.upstream is weird.

I don't see .thunderbird anymore in my home directory, and when I copied the folder .thundebird.upstream to an external USB drive, renamed it .thunderbird and tried to copy it back to my home directory I received the message that .thunderbird was already there, even though I can't see it, even with the hidden folders displayed.

Changed in thunderbird (Ubuntu):
importance: High → Critical
affects: thunderbird (Ubuntu) → ubuntu
affects: Ubuntu Lucid → thunderbird (Ubuntu Lucid)
Micah Gersten (micahg) on 2010-04-15
description: updated
Christopher (soft-kristal) wrote :

Thanks for the workaround. Thunderbird is working again and I was able to use my old profile without incident. As I have over 6000 messages and 16 email addresses, losing that would have an inconvenience, although most everything is backed up on my Karmic partition.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunderbird - 3.0.4+nobinonly-0ubuntu3

---------------
thunderbird (3.0.4+nobinonly-0ubuntu3) lucid; urgency=high

  * fix LP: #563893 - Thunderbird will not launch do to a recursive symlink;
    Test if old profile directory is a symlink before migration
    - update debian/thunderbird.sh.in
  * Add NEWS file regarding problem with last version
    - add debian/thunderbird.NEWS
 -- Micah Gersten <email address hidden> Thu, 15 Apr 2010 12:19:31 -0500

Changed in thunderbird (Ubuntu Lucid):
status: Triaged → Fix Released
summary: - Thunderbird will not launch do to a recursive symlink
+ Thunderbird will not launch due to a recursive symlink

Even after upgrading to version 3.0.4+nobinonly-0ubuntu3, I had to do the workaround for thunderbird to work again. I Removed the .thunderbird symlink in my home directory and mv .thunderbird.upstream to .thunderbird.

Is it alright? Everything works fine now. Thank you very much.

That's the correct procedure. You should have been notified during
package install of that.

On 04/15/2010 04:14 PM, JSGosselin wrote:
> Even after upgrading to version 3.0.4+nobinonly-0ubuntu3, I had to do
> the workaround for thunderbird to work again. I Removed the .thunderbird
> symlink in my home directory and mv .thunderbird.upstream to
> .thunderbird.
>
> Is it alright? Everything works fine now. Thank you very much.
>

Jmadero (jmadero) wrote :

I had to use the workaround as well, updating Thunderbird did not fix it

Micah Gersten (micahg) on 2010-04-16
description: updated
Micah Gersten (micahg) on 2010-04-16
description: updated
Mossroy (mossroy) wrote :

Had to use the workaround too (even after updating to 3.0.4+nobinonly-0ubuntu3) , but now it's fine

Micah Gersten (micahg) on 2010-04-16
description: updated
igi (igor-cali) wrote :

The bad thing is that my profile folder was cancelled during the update, this would have caused big inconvenience, If I had no backup.

Micah Gersten (micahg) wrote :

The profile wasn't deleted, just moved. See NOTE in the Description
for this bug.

On 04/16/2010 06:14 PM, igi wrote:
> The bad thing is that my profile folder was cancelled during the update,
> this would have caused big inconvenience, If I had no backup.
>

igi (igor-cali) wrote :

The note describes what happened for the simlink.
But inside the .thunderbird folder, my original abcdefgh.default folder
(the one with prefs, account settings, extension, etc) was not existing
anymore.
A fresh new one was created instead.
For instance, I have lost latest calendar event for the Lightning
extension (in the storage.sdb file).

Il 17/04/2010 01:47, Micah Gersten ha scritto:
> The profile wasn't deleted, just moved. See NOTE in the Description
> for this bug.
>
> On 04/16/2010 06:14 PM, igi wrote:
>
>> The bad thing is that my profile folder was cancelled during the update,
>> this would have caused big inconvenience, If I had no backup.
>>
>>
>

rschlitz (rschlitz) wrote :

As others my configuration files were completely wiped out in the amd64 version. Also symlink is created each time Thunderbird is started: .mozilla-thunderbird -> /home/user/.thunderbird

A .thunderbird.upstream sub-directory never appeared in the home directory.

This is quite bad form, even if it is a beta, since recovery seems almost impossible. Perhaps Thunderbird needs an auto-backup for the configuration files.

Micah Gersten (micahg) wrote :

It says the the old profile folder was moved to .thunderbird.upstream
when the symlink was created.

On 04/17/2010 01:27 AM, igi wrote:
> The note describes what happened for the simlink.
> But inside the .thunderbird folder, my original abcdefgh.default folder
> (the one with prefs, account settings, extension, etc) was not existing
> anymore.
> A fresh new one was created instead.
> For instance, I have lost latest calendar event for the Lightning
> extension (in the storage.sdb file).
>
> Il 17/04/2010 01:47, Micah Gersten ha scritto:
>> The profile wasn't deleted, just moved. See NOTE in the Description
>> for this bug.
>>
>> On 04/16/2010 06:14 PM, igi wrote:
>>
>>> The bad thing is that my profile folder was cancelled during the update,
>>> this would have caused big inconvenience, If I had no backup.
>>>
>>>
>>
>

Micah Gersten (micahg) wrote :

We added the symlink because others we having issues with extensions
that still tried to use the old profile folder. Your old profile
should still be in .thunderbird if .thunderbird.upstream was never
created.

On 04/18/2010 12:31 PM, rschlitz wrote:
> As others my configuration files were completely wiped out in the
> amd64 version. Also symlink is created each time Thunderbird is
> started: .mozilla-thunderbird -> /home/user/.thunderbird
>
> A .thunderbird.upstream sub-directory never appeared in the home
> directory.
>
> This is quite bad form, even if it is a beta, since recovery seems
> almost impossible. Perhaps Thunderbird needs an auto-backup for
> the configuration files.
>

igi (igor-cali) wrote :

Hello Micah,
Really, even after I renamed the .thunderbird.upstream folder, the original profile folder was not inside.

Micah Gersten (micahg) wrote :

Were you a Thunderbird 3.0 beta user before upgrade? You might want
to join me in #ubuntu-mozillateam on freenode to work this out.

On 04/18/2010 01:21 PM, igi wrote:
> Hello Micah, Really, even after I renamed the .thunderbird.upstream
> folder, the original profile folder was not inside.
>

Micah Gersten (micahg) on 2010-04-22
description: updated
description: updated

Running Lucid here, upgraded via Upgrade Manager from Karmic. I had been running Thunderbird 2 in Karmic.
Confirming the installed Thunderbird package is 3.0.4+nobinonly-0ubuntu4

I understand - from reading this bug - that Lucid is working around some extensions that are still using "mozilla-thunderbird" calls by having a sym link directory titled ".mozilla-thunderbird" as well as the ".thunderbird" profile directory in ~/home. It also seems to be retaining the "Mozilla-Thunderbird" titles for menus and so forth.
I use either Gnome Do (which calls the Gnome menu link "Mozilla Thunderbird") or Gnome Terminal command "thunderbird" to open Thunderbird 3 and all runs fine.

However, in my home directory, the sym link folder ".mozilla-thunderbird" is echoing the ".thunderbird" folder in a slightly unsettling way:
The profile in "thunderbird" is completely duplicated in ".mozilla-thunderbird". All changes in ".thunderbird" directory are echoed in ".mozilla-thunderbird"; it's not just an empty sym link.
Thus, If I delete the profile in either directory, then simply using manipulating the directories in Nautilus returns the echoing between both directories.

I've not seen this kind of behaviour before and would like to know:
1. Is this expected behaviour for what seems to be a sort of temporary workaround?
2. If not, what sort of approach can I take to troubleshoot the setup?

Gzip doesn't handle archiving this structure - - it turns the ".mozilla-thunderbird" sym link directory into a plain directory and creates a sym link file with no value.
I'm concerned that I may not be able to restore the right structure if it becomes necessary.
Your help would be appreciated.

Micah Gersten (micahg) wrote :

Please file a new bug. Thanks.

On 06/02/2010 04:20 PM, Nan M wrote:
> Running Lucid here, upgraded via Upgrade Manager from Karmic. I had
been running Thunderbird 2 in Karmic.
> Confirming the installed Thunderbird package is 3.0.4+nobinonly-0ubuntu4
><snip />

arturpio (arturpio-cyberkit) wrote :

In my Lucid 10.4, "fresh" installed from distribution CD, now Thunderbird ver. 3.0.4, installed via Ubuntu apps library, is running well.

I was even able to restore my previous Thunderbird records (emails etc.) just removing the initial content of .thunderbird directory and putting there my old Thunderbird profiles.ini file and data folder.

Rumpeltux (rumpeltux) wrote :

Today, the lucid thunderbird update helper asked if I wanted to reimport thunderbird-2 profile settings or keep the thunderbird-3-beta ones. I selected the latter, thunderbird did not start.
I then found the self-referencing symlink .thunderbird and deleted it.
Thunderbird seems to have created a new profile in .thunderbird-3.0.
My normal thunderbird profile is now in .thunderbird-2.0-replaced.
thunderbird starts with an empty profile.
Thunderbird seems to have created a new profile in .thunderbird.
I removed .thunderbird-3 and put a copy of .thunderbird-2.0-replaced there.
thunderbird-3.0 does start and opens my profile, however this is pre3 shredder.
I got it fixed then by putting a symlink to .thunderbird-3.0 at .thunderbird, don’t know though why that had to happen.

Micah Gersten (micahg) wrote :

@Rumpeltux
Please file a new bug as this might be a new issue.

On 06/14/2010 12:42 PM, Rumpeltux wrote:
> Today, the lucid thunderbird update helper asked if I wanted to
> reimport thunderbird-2 profile settings or keep the
> thunderbird-3-beta ones. I selected the latter, thunderbird did not
> start. I then found the self-referencing symlink .thunderbird and
> deleted it. Thunderbird seems to have created a new profile in
> .thunderbird-3.0. My normal thunderbird profile is now in
> .thunderbird-2.0-replaced. thunderbird starts with an empty
> profile. Thunderbird seems to have created a new profile in
> .thunderbird. I removed .thunderbird-3 and put a copy of
> .thunderbird-2.0-replaced there. thunderbird-3.0 does start and
> opens my profile, however this is pre3 shredder. I got it fixed
> then by putting a symlink to .thunderbird-3.0 at .thunderbird,
> don’t know though why that had to happen.
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers