Drag & Drop needs extra selection in Detailed List View in Thunar

Bug #1425700 reported by Viktor Pal on 2015-02-25
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
thunar
Fix Released
High
thunar (Ubuntu)
Undecided
Unassigned

Bug Description

To reproduce:
1.) Open Thunar.
2.) Select the "View" menu from the menu bar.
3.) Select "View as Detailed List".
4.) Go to a folder with at least one file.
5.) Unselect all files by clicking into the white area after the file list.
6.) Move the mouse over one of the files and click the left mouse button and keep it pressed and try to drag the file.

What happens.
- A selection box is activated but the file is not moved.

What should happen.
- The file should start moving into the direction where the mouse is moved.

The drag and drop works otherwise but to get it working you have to first select the file with clicking on it.
Then when the file is selected you can do the drag and drop, but this means clicking twice unnecessarily.

Why I consider this a bug?:
- Because the extra selection is not needed in any other file browser I ever met in my live.
- Because it works as expected in all other listing modes like "View as Icons" without needing the extra selection.
- Because it does not work as expected by the user.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: thunar 1.6.3-1ubuntu5
ProcVersionSignature: Ubuntu 3.13.0-45.74-generic 3.13.11-ckt13
Uname: Linux 3.13.0-45-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.7
Architecture: amd64
CurrentDesktop: XFCE
Date: Wed Feb 25 22:05:00 2015
SourcePackage: thunar
UpgradeStatus: No upgrade log present (probably fresh install)

Viktor Pal (deere) wrote :

To reproduce:
1.) Open Thunar.
2.) Select the "View" menu from the menu bar.
3.) Select "View as Detailed List".
4.) Go to a folder with at least one file.
5.) Unselect all files by clicking into the white area after the file list.
6.) Move the mouse over one of the files and click the left mouse button and keep it pressed and try to drag the file.

What happens.
- A selection box is activated but the file is not moved.

What should happen.
- The file should start moving into the direction where the mouse is moved.

The drag and drop works otherwise but to get it working you have to first select the file with clicking on it.
Then when the file is selected you can do the drag and drop, but this means clicking twice unnecessarily.

Why I consider this a bug?:
- Because the extra selection is not needed in any other file browser I ever met in my live.
- Because it works as expected in all other listing modes like "View as Icons" without needing the extra selection.
- Because it does not work as expected.

Tchnical details:

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: thunar 1.6.3-1ubuntu5
ProcVersionSignature: Ubuntu 3.13.0-45.74-generic 3.13.11-ckt13
Uname: Linux 3.13.0-45-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.7
Architecture: amd64
CurrentDesktop: XFCE
Date: Wed Feb 25 22:05:00 2015
SourcePackage: thunar
UpgradeStatus: No upgrade log present (probably fresh install)

Viktor Pal (deere) wrote :

I have also submitted this bug here: https://bugzilla.xfce.org/show_bug.cgi?id=11605

I belive that this bug is related to
https://bugzilla.xfce.org/show_bug.cgi?id=8852

The selection is also something that only works differently in the "Detailed List View" according to my tests.

I think that all views should behave the same if possible.

Changed in thunar:
importance: Unknown → High
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunar (Ubuntu):
status: New → Confirmed

*** Bug 8852 has been marked as a duplicate of this bug. ***

*** Bug 5232 has been marked as a duplicate of this bug. ***

*** Bug 11218 has been marked as a duplicate of this bug. ***

*** Bug 8875 has been marked as a duplicate of this bug. ***

*** Bug 11219 has been marked as a duplicate of this bug. ***

*** Bug 10585 has been marked as a duplicate of this bug. ***

*** Bug 3386 has been marked as a duplicate of this bug. ***

I have pushed the change and documented it on the wiki (still work-in-progress): http://docs.xfce.org/xfce/thunar/working-with-files-and-folders

This should improve things a bit, though unfortunately fixing every aspect and making the view behave exactly as the other views is not a trivial task. This fix will be included in the next thunar release 1.6.7. Should too many people complain about the changed behaviour, I will revert it, and a proper, more thorough patch will need to be written. Maybe this will (have to) be completely rewritten with the gtk3 port anyway, who knows...

If something in the duplicates has not been fixed, please feel free to reopen the duplicates, but please do not report new issues in this bug.

Pushed to master: http://git.xfce.org/xfce/thunar/commit/?id=bb9fe8ad3e2202be52fa5c987cb1a7744d20a0a6

Changed in thunar:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.