revtex4-1 should be upgraded to bugfix release on 3/15/2010

Bug #575812 reported by Alfredo Braunstein on 2010-05-05
84
This bug affects 16 people
Affects Status Importance Assigned to Milestone
texlive-extra (Debian)
Fix Released
Unknown
texlive-extra (Ubuntu)
Undecided
Unassigned

Bug Description

in particular, a serious bug in \affiliation in previous versions is corrected. See http://authors.aps.org/revtex4/revtex4_faq.html

uellue (dieter-uellue) on 2010-05-28
Changed in texlive-extra (Ubuntu):
status: New → Confirmed
tags: added: revtex texlive texlive-extra texlive-publishers
Andrew Punnett (andrew-punnett) wrote :

revtex needs to be upgraded to at least version 4.1p which can be downloaded here:

http://authors.aps.org/revtex4/revtex4-1.zip or http://ctan.org/tex-archive/macros/latex/contrib/revtex/doc/latex/revtex/

Currently 'texlive-publishers (2009-8)' in Debian Sid (unstable) uses version 4.1g of revtex and will also have this bug.

This bug affects a lot of my users so I would like to fix this is someone can give me some pointers.

Andy

Robert Schroll (rschroll) wrote :

In case it helps anyone else, here's a .deb I made by updating 2009-7ubuntu3 (current version in Lucid) to include REVTeX 4.1r. I can confirm that this fixes the affiliation bug. Some obsure debuild bug kept me from including the updated PDF files in this. But the .tex files have been updated, so you can generate the up-to-date PDFs if you really care.

Robert Schroll (rschroll) wrote :

And here's a .debdiff with those changes. Again, it's missing the updated PDFs.

tags: added: patch
crasic (trueurssian) wrote :

Thank you Robert for the deb, this fixed my problem in the short term.

There was a bug fix in revtex that fixed some notorious issues (like author affiliations not working properly). The package needs to reflect the latest version of revtex.

der_vegi (m-may) wrote :

Still there in Natty. Installation of the deb mentioned above works for me as well, but causes an error with natbib.sty. Maybe this bug should be forwarded to Debian?

Robert Schroll (rschroll) wrote :

> but causes an error with natbib.sty.

The RevTeX4.1 release notes say that it "requires the latest version of natbib, developed in
conjunction with REVTEX 4.1." This is not provided by the deb I produced. For whatever reason, I haven't had problems with natbib, but I'm not surprised to hear that they exist. Here's a forum post about upgrading natbib: http://ubuntuforums.org/showpost.php?p=9097651&postcount=4

> Maybe this bug should be forwarded to Debian?

Probably should be, but I doubt I'll get around to it. If you do so, let us know and I'll try to pay attention to it.

Robert Schroll (rschroll) wrote :

BTW, the natbib problem is bug #578693.

And it looks like Debian already knows and has decided not to fix it yet.

Changed in texlive-extra (Debian):
status: Unknown → Confirmed
der_vegi (m-may) wrote :

The natbib problem I had was not related to bug 578693. Natbib in Natty works together with the Revtex-version that comes with Natty. But when I install the .deb file and use natbib, it requests a newer version of natbib as mentioned in the Debian bug. Manually installing the newest natbib solved my problem.

Btw: Shouldn't this bug be related to texlive-publishers instead of texlive-extra?

Robert Schroll (rschroll) wrote :

> Shouldn't this bug be related to texlive-publishers instead of texlive-extra?

As I understand it, bugs are filed against source packages, not binary packages.

Juan M Lopez (lopez-s) wrote :

I spent quite a long time today trying to compile my paper and being unable to get the affiliations properly. It took me quite a while to google thru and get here to learn that I might have an old and buggy version of revtex4-1. I am surprised this bug seems to have not been taken seriously despite the amount of users in debian/ubuntu that use latex/revtex4-1 daily. Thank you all for the work. Updating revtex4-1 *AND* natbib fixed all my problems, but it isn't just right that one has to do this manually. Specially since this bug is already one full year old!

der_vegi (m-may) wrote :

This bug is now almost 2 years old. Shouln't it be considered to be fixed at least in 12.04, which will be an LTS-release?

der_vegi (m-may) wrote :

A version of texlive-publishers fixing this bug is now in Debian unstable.

Changed in texlive-extra (Debian):
status: Confirmed → Fix Released

This bus is still here in 12.04.
Any fix? Any workaround?

uellue (dieter-uellue) wrote :

A PPA with a backport of the current version (texlive 2012) from 12.10 is available here: https://launchpad.net/~texlive-backports/+archive/ppa

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.