lyx: missing TeX class "aa"

Bug #3080 reported by Thomas Hood
38
This bug affects 2 people
Affects Status Importance Assigned to Milestone
texlive-base (Debian)
Fix Released
Unknown
texlive-extra (Ubuntu)
Medium
Unassigned

Bug Description

$ lyx-qt /usr/share/lyx/examples/aa_sample.lyx

result in a dialog reporting:

    Textclass error

    The document uses a missing TeX class "aa".
    LyX will not be able to produce output.

The user gets the same message when he starts lyx and selects
File|New_from_template|aa.lyx

The same problem afflicts IEEEtran, aastex, docbook, and so on.

Running "dpkg-reconfigure lyx-common" does not help.

Running Edit|Reconfigure does not help.

$ dpkg -l \*lyx\*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii lyx 1.3.6-1ubuntu4 High Level Word Processor
ii lyx-common 1.3.6-1ubuntu4 High Level Word Processor - common files
ii lyx-qt 1.3.6-1ubuntu4 High Level Word Processor - Qt frontend
un lyx-xforms <none> (no description available)

In Help|Extended_Features section 4.4 "A&A paper" it points out
that the .cls file has to be downloaded from an ftp site. The same
goes for the other missing classes, presumably.

Given that aa.lyx is a template shipped in the -common package, I would
expect all the required classes to be included in that package or in
one of the packages upon which it Depends. It turns out that the
required classes aren't packaged at all! It would be much better if
they were. (Please consider this a wish to that effect.)

Finding out why the basic templates don't work requires reading many
long winded help files.

In order to use the basic templates the user has to learn how to
install new classes into LaTeX. This is far from easy for a newbie.

Changed in lyx:
assignee: nobody → motumedia
Revision history for this message
Edjard Mota (edjard-mota) wrote :

Your're right. IMHO, the examples should be changed from the LyX to use the correct classes which comes in
/usr/share/texmf/tex/latex/.

This seems more a problem of the examples directory being packaged rather than the classes. As far as I know from being a latex user,
such classes (old .sty files) never came with specific classes/styles from .org like IEEE por ACM. We always had to dowwnload them
and set environment variables such as TEXINPUTS.

If one changes the example (aa_example.lyx) from
\textclass aa
to
\textclass article

the example works fine, showing that the template where not based on standard LaTeX classes.

Revision history for this message
Edjard Mota (edjard-mota) wrote :

To be more specific, edit the file aa_example.lyx and make the change suggested and you will see that it works.
I have downloaed the latest texmf and have found no such classes. I have also send an emal do lyx-devel list
asking them to try to put only standard LaTeX classes as default templates and teach how to include new ones.

Changed in lyx:
assignee: motumedia → motu
Revision history for this message
Edjard Mota (edjard-mota) wrote :

Hi again,

I have an answer from lyx-devel ML, and it seems the problem is really about making LyX templates
associated to TeX classes as I had thought. You can read the dialog below dashed line. I'll try
to help the LyX side and see how it goes.

br

Edjard

------------------------------------------------------------------------------------------------
Edjard> IMHO there could be two options. First, each Linux distro
Edjard> could take care of checking whether the files needed for a
Edjard> given application are there or not, and collect where they can
Edjard> be found during the mounting of the packages. Second, and
Edjard> perhaps the "easiest one" (at least for the distro guys :) ),
Edjard> is to divide templates into standard TeX and those by LyX.

JMarc > It depends what you call 'standard'... Those who are in
 JMarc > teTeX? In TeXLive? In the LaTeX distribution of some
 JMarc > University?

 I meant the teTex. But if we have to consider other standards then
you're right, that might be confusing.

Edjard> At least, this would give a clear message, when loading a
Edjard> template, which ones will generate output and which ones may
Edjard> not.

JMarc > Note first that you have this message right when you JMarc >
load the template. It is not as if you lost two hour writing
 JMarc > a document.

 Yes, but this has been reported as a bug in some Linux distro, which I
don't agree.

JMarc > What we should do is have a better support for template
 JMarc > by associating rigourously a template to a class. Since
 JMarc > we do know inside LyX which classes are available, it
 JMarc > would allow us to show this information at the template JMarc
> level. I am not sure when this is going to happen though.

JMarc

 Could you, or someone, give the directions? I feel like coding and
would be more than pleased to help.

 br

 Edjard

Revision history for this message
Thomas Hood (jdthood) wrote :

Thanks for working on this.

Revision history for this message
Edjard Mota (edjard-mota) wrote : Re: [Bug 3080] lyx: missing TeX class "aa"

My pleasure ;)

On 11/17/05, Thomas Hood <email address hidden> wrote:
>
> Public bug report changed:
> https://launchpad.net/malone/bugs/3080
>
> Comment:
> Thanks for working on this.
>

--
"In a world without fences who needs Gates"

Changed in lyx:
status: Unconfirmed → Confirmed
Revision history for this message
Alexandre Otto Strube (surak) wrote :

How's dapper on this matter? Does someone have updated information?

Revision history for this message
Edjard Mota (edjard-mota) wrote : Re: [Bug 3080] Re: lyx: missing TeX class "aa"

Sorry,

I haven't found much time to tacke it as it was suggested from LyX-devel
mailing list
that the best solution would be to re-redisign the way LyX links classes and
templates
to TeX standard classes.

On 4/5/06, Alexandre Otto Strube <email address hidden> wrote:
>
> How's dapper on this matter? Does someone have updated information?
> --
> lyx: missing TeX class "aa"
> https://launchpad.net/malone/bugs/3080
>

--
"In a world without fences who needs Gates"

Revision history for this message
Eric Lake (ericlake) wrote :

I have installed the LyX package on Dapper and I get the same things described here. I am new to LyX so I thought that it was just me until I saw this post. Thanks for working to resolve this.

Revision history for this message
Edjard Mota (edjard-mota) wrote :

Hi Eric,

Yeah, I'm still working on it. But my time is really tight these days.
One thing I think we should have is to separate, in bug track, bugs
which are inherently from Ubuntu development (libraries, etc) from
bugs which are associated to applications. This bug is one example.
This error also raises in any other LyX version for other distros, unless
user set things manualy as I pointed as partialk solution.

br,
Edjard

On 5/22/06, elake <email address hidden> wrote:
>
> I have installed the LyX package on Dapper and I get the same things
> described here. I am new to LyX so I thought that it was just me until I
> saw this post. Thanks for working to resolve this.
>
> --
> lyx: missing TeX class "aa"
> https://launchpad.net/bugs/3080
>

--
"In a world without fences who needs Gates"

Revision history for this message
ruchirsaraswat (ruchir-saraswat) wrote :

Hi

I am a newbie to lyx. Just downloaded the same. I get the error as mentioned above when i try to

File|New_from_template|aa.lyx

 Textclass error

    The document uses a missing TeX class "aa".
    LyX will not be able to produce output.

Could somebody please guide me as to how to resolve the same.

Going through the above comments, i saw that i need to install some classes but i could not find how to.

Kindly help out.

Best Regards
Ruchir

Revision history for this message
Edjard Mota (edjard-mota) wrote :

Hi,

If you track the messages at https://launchpad.net/malone/bugs/3080 you will
find a solution I proposed to partially solve your problem.
It is not a bug of Ubuntu, but rather a bug of LyX TeX class compatibility.
Try the (manual solution) I proposed and see if it works for you.

As I wrote some time ago, I am trying to find a room im my spare time to
write
a general solution for LyX-devel to which I got some ideas oin how to solve
it.

Hope it helps.

br
Edjard

On 6/8/06, ruchirsaraswat <email address hidden> wrote:
>
> Hi
>
> I am a newbie to lyx. Just downloaded the same. I get the error as
> mentioned above when i try to
>
> File|New_from_template|aa.lyx
>
> Textclass error
>
> The document uses a missing TeX class "aa".
> LyX will not be able to produce output.
>
> Could somebody please guide me as to how to resolve the same.
>
> Going through the above comments, i saw that i need to install some
> classes but i could not find how to.
>
> Kindly help out.
>
> Best Regards
> Ruchir
>
> --
> lyx: missing TeX class "aa"
> https://launchpad.net/bugs/3080
>

--
"In a world without fences who needs Gates"

Revision history for this message
William Grant (wgrant) wrote :

It has been 9 months since the last comment. Has there been any change in LyX's behaviour?

Changed in lyx:
assignee: motu → nobody
status: Confirmed → Needs Info
Revision history for this message
Edjard Mota (edjard-mota) wrote :

Unfortunately, no.

The LyX community hasn't done a bit to change this. I tried myself to create
a project
in LyX.org to change that but my time has been very tight since then.

On 3/15/07, William Grant <email address hidden> wrote:
>
> It has been 9 months since the last comment. Has there been any change
> in LyX's behaviour?
>
> ** Changed in: lyx (Ubuntu)
> Assignee: MOTU => (unassigned)
> Status: Confirmed => Needs Info
>
> --
> lyx: missing TeX class "aa"
> https://launchpad.net/bugs/3080
>

--
"In a world without fences who needs Gates"

William Grant (wgrant)
Changed in lyx:
status: Needs Info → Confirmed
Revision history for this message
Fuat Geleri (fuatgeleri) wrote :

Friends,

I think i found a solution in this site
http://www.ece.iit.edu/~jgrad/lyx/

1. Download the cls file you need.
2.
cd /usr/share/texmf/tex/latex/lyx
cp ~/IEEEtran.cls .
mktexlsr .

That is all.
Then open lyx and tools>reconfigure

It fixed the same error that i was getting when i open the IEEEtran template, saying no class found.

Good luck,
Fuat Geleri

Revision history for this message
Edjard Mota (edjard-mota) wrote :

Yeah,

This is the same solution I pointed out some time ago. I think LyX guys
have changed the deafult class directory the $HOME or something like that.

We still need to copy a new class template every time it is needed. Thanks
for the site you sent it is really helpful.

br,
Edjard

On 7/28/07, Fuat Geleri <email address hidden> wrote:
>
> Friends,
>
> I think i found a solution in this site
> http://www.ece.iit.edu/~jgrad/lyx/
>
> 1. Download the cls file you need.
> 2.
> cd /usr/share/texmf/tex/latex/lyx
> cp ~/IEEEtran.cls .
> mktexlsr .
>
> That is all.
> Then open lyx and tools>reconfigure
>
> It fixed the same error that i was getting when i open the IEEEtran
> template, saying no class found.
>
> Good luck,
> Fuat Geleri
>
> --
> lyx: missing TeX class "aa"
> https://bugs.launchpad.net/bugs/3080
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
"In a world without fences who needs Gates"

Revision history for this message
Thomas Hood (jdthood) wrote :

On ubuntu I installed the texlive-publishers package and ran LyX | Tools | Reconfigure.
Now when I File | New from Template | IEEEtran.lyx, I don't get the warning message
I got before.

$ dpkg -L texlive-publishers | grep IEEEtran.cls
/usr/share/texmf-texlive/tex/latex/IEEEtran/IEEEtran.cls

Revision history for this message
Vincenzo Ciancia (vincenzo-ml) wrote :

The point seems to be, lyx installs by default templates for classes that are not available, is this correct? If so, shouldn't the bug be solved by providing separate packages for groups of templates, depending on the appropriate texlive packages (maybe only texlive-publishers)?

Revision history for this message
Edjard Mota (edjard-mota) wrote :

Yeah,

That's correct.
It seems a possible solution.

On 9/27/07, Vincenzo Ciancia <email address hidden> wrote:
>
> The point seems to be, lyx installs by default templates for classes
> that are not available, is this correct? If so, shouldn't the bug be
> solved by providing separate packages for groups of templates, depending
> on the appropriate texlive packages (maybe only texlive-publishers)?
>
> --
> lyx: missing TeX class "aa"
> https://bugs.launchpad.net/bugs/3080
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
"In a world without fences who needs Gates"

Revision history for this message
Se6 (se6astien) wrote :

Hi,

Is there any news on that one?
I tried to update the cv I wrote a few months ago and I encountered the same problem!

Try opening /usr/share/lyx/examples/fr/simplecv.lyx
and you will get the "Document class not available".

This seems to be link to this bug (?): http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=449983

I found the tex class posing the problem with simplecv.layout here:http://www.ctan.org/tex-archive/help/Catalogue/entries/simplecv.html
But I don't even know how to install it!

Any help would be greatly appreciated as I need to update and send my cv soon!!

Thanks,

Seb.

Revision history for this message
Vincenzo Ciancia (vincenzo-ml) wrote :

Il giorno mer, 23/04/2008 alle 15.23 +0000, Seb ha scritto:
> Hi,
>
> Is there any news on that one?
> I tried to update the cv I wrote a few months ago and I encountered the same problem!
>
> Try opening /usr/share/lyx/examples/fr/simplecv.lyx
> and you will get the "Document class not available".
>
> This seems to be link to this bug (?): http://bugs.debian.org/cgi-
> bin/bugreport.cgi?bug=449983
>
> I found the tex class posing the problem with simplecv.layout here:http://www.ctan.org/tex-archive/help/Catalogue/entries/simplecv.html
> But I don't even know how to install it!
>
> Any help would be greatly appreciated as I need to update and send my cv
> soon!!
>
> Thanks,
>
> Seb.
>

Sebastien: try to install the appropriate texlive package. I can't
access launchpad at the moment (probably due to hardy coming out soon)
but I recall that installing e.g. texlive-publishers solved the issue.
Recall to reconfigure and restart lyx after installation. Alternatively
try to change the document class to "article" in the document's
preferences.

Vincenzo

Revision history for this message
Se6 (se6astien) wrote :

Thanks for your answer Vincenzo.
I looked at many texlive packages, none seems to contain the one I am after: simplecv.
Changing the class to "article" is not really a solution, isn't it!
A fix would be to know how to install the CTAN package simplecv.

Seb.

Revision history for this message
Vincenzo Ciancia (vincenzo-ml) wrote :

Copy the files in one of the latex directories, e.g. /usr/share/texmf/tex/latex/lyx/, then run texhash, then reconfigure lyx. The first two steps have to be done as root.

Revision history for this message
Se6 (se6astien) wrote :

Thanks so much Vincenzo for your help.

I just tried what you said, restarted lyx.. but the document class it is still missing.
In the simplecv.zip from CTAN, there are only: simplecv.dtx simplecv.ins (and testcv.pdf testcv.tex)

Seb.

Revision history for this message
Se6 (se6astien) wrote :

For those having the same problem with simplecv.layout, find below a tempory solution to make it work (Thanks to Sven for his help)

1) Download the simplecv package at CTAN (http://www.ctan.org/tex-archive/help/Catalogue/entries/simplecv.html)
2) Extract it and run "tex simplecv.ins". That should produce a simplecv.cls
3) Copy it to somewhere that texhash will find. (I copied it to /usr/share/texmf-texlive/tex/latex/simplecv/)
4) sudo texhash
5) In Lyx, Tools/reconfigure. Close and restart Lyx.

The simplecv class should be available now.

Seb.

Revision history for this message
Se6 (se6astien) wrote :

Apparently, the simplecv problem has been addressed a few days ago in the Debian package texlive-extra
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=449983
Any chance that will make it to the Ubuntu repo?

Thanks,

Seb.

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

Assigning to texlive-extra

For those with the simplecv issue, this is fixed in Intrepid, please install texlive-latex-extra.
For those with the aa issue, it doesn't seem to be fixed.

Revision history for this message
fuck you (dave-dtaviation) wrote :

I've never seen as big a pile of shit as this. No wonder people just stick with MS Word.

Revision history for this message
Norbert Preining (preining) wrote :

On Di, 17 Nov 2009, fuck you wrote:
> I've never seen as big a pile of shit as this. No wonder people just
> stick with MS Word.

Very intelligent remark, about as intelligent as a small chick talking
about general relativity theory.

Thanks a lot for your useful contribution, and please remove Ubuntu from
your computer and be happy henceforth with Windows.

Best wishes

Norbert

-------------------------------------------------------------------------------
Dr. Norbert Preining Associate Professor
JAIST Japan Advanced Institute of Science and Technology <email address hidden>
Vienna University of Technology <email address hidden>
Debian Developer (Debian TeX Task Force) <email address hidden>
gpg DSA: 0x09C5B094 fp: 14DF 2E6C 0307 BE6D AD76 A9C0 D2BF 4AA3 09C5 B094
-------------------------------------------------------------------------------
ALDCLUNE (n.)
One who collects ten-year-old telephone directories.
   --- Douglas Adams, The Meaning of Liff

Revision history for this message
fuck you (dave-dtaviation) wrote :

Dr. Preining,

I will not use MSWin; my OS of choice is Solaris, but that's irrelevant, and it's my fault that you misundestand my comment, so I'll be more clear:

I've struggled with the issue discussed here, with no success. Some posts such as the one by Se6 were somewhat helpful, but simplecv still does not work for me and I don't see any evidence that the posters here are doing anymore than random rituals without any understanding of the underlying mechanics.

I'm dissapointed that I will have to find another tool.

LyX SuX.

Revision history for this message
zephirum (zephirum) wrote :

I have a similar problem and it's pretty amazing to find that the bug has lived on for 4 years now.
I'm about to write my thesis and thought Lyx might be the intelligent way of getting to do it; however, if I can't even start the process without getting bogged down my numerous error messages, it's somewhat off-putting.

Revision history for this message
Anzenketh (anzenketh) wrote :

Found bug on missing upstream link QA report. Bug for lyx is fixed upstream. Fixed in Intrepid. Added Link to tracker as issue also talks about Issue fixed upstream.

Revision history for this message
rusivi2 (rusivi2-deactivatedaccount) wrote :

Thank you for posting this bug.

Does this issue occur in Lucid?

Changed in texlive-extra (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Thomas Hood (jdthood) wrote :

$ sudo aptitude install lyx
File | New from Template | aa.lyx results in this dialog:

------------------------
The layout file requested by this document,
aa.layout,
is not usable. This is probably because a LaTeX
class or style file required by it is not
available. See the Customization documentation
for more information.
LyX will not be able to produce output.
--------------------------

$ sudo aptitude install texlive-publishers
Tools | Reconfigure
Restart LyX
File | New from Template | aa.lyx still produces the above message.

So there is still a problem.

Changed in lyx (Debian):
status: Unknown → Fix Released
affects: texlive-extra (Ubuntu) → texlive-base (Ubuntu)
affects: lyx (Debian) → texlive-base (Debian)
affects: texlive-base (Ubuntu) → texlive-extra (Ubuntu)
Revision history for this message
Thomas Hood (jdthood) wrote :

I have the latest packages from oneiric

ii lyx 2.0.0-1~natty1
ii texlive-publishers 2009-10ubuntu1

but the problem (as described in #33) still exists.

Revision history for this message
Thomas Hood (jdthood) wrote :

Updated to lyx 2.0.0-1.

"Setting up lyx-common" and "Processing triggers for tex-common" both fail with:

    /usr/sbin/update-language-def: line 779: printf: missing unicode digit for \u

Then starting lyx from an interactive shell produces many instances of

    ../../../../src/frontends/qt4/GuiToolbar.cpp(339): Session settings could not be found!. Defaults are used instead

on the console, which it didn't before; and the faulty behavior as described above (#33) still occurs.

Revision history for this message
Thomas Hood (jdthood) wrote :

On a new Ubuntu 12.04 system I did

    sudo apt-get install lyx
    lyx

I clicked File | New_from_template | aa.lyx and Open and once again got an error dialog. The contents of the dialog are a bit different now.

LyX: Document class not available
------------------------------------------------------------
The selected document class
 article (A&A)
requires external files that are not available.
The document class can still be used, but the
document cannot be compiled until the following
prerequisites are installed:
 aa.cls
See section 3.1.2.2 (Class Availability) of the
User's Guide for more information.

Installing texlive-publishers doesn't help. Also, with reference to comment #16, installing texlive-publishers doesn't eliminate the message in the case of IEEEtran.lyx.

Changed in texlive-extra (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
dmbortz (dmbortz-gmail) wrote :

On a new Linux mint 14 system, just starting lyx from the command line gives this error:

../../../../src/frontends/qt4/GuiToolbar.cpp(339): Session settings could not be found!. Defaults are used instead

repeated a large number of times. In googling around, this seems to be an issue with the accessibility extensions in QT. If one removes the qt-at-spi package, this error disappears.

So, whatever the issue is with the A&A class, the GuiToolbar.cpp error seems unrelated.

best,
David

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.