Empathy indicator chat messages build up in the message menu & we are not be able to clear it.

Bug #921168 reported by Dario Bertini on 2012-01-24
32
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Telepathy Indicator
Medium
Ken VanDine
telepathy-indicator (Ubuntu)
Medium
Ken VanDine

Bug Description

Just look at the screenshot
afaik, this is a regression: I don't remember this ever happening on ubuntu11.10
this happened with a facebook contact

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: empathy 3.3.4-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-10.17-generic 3.2.1
Uname: Linux 3.2.0-10-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
Date: Tue Jan 24 21:09:06 2012
InstallationMedia: Kubuntu 11.10 "Oneiric Ocelot" - Release amd64+mac (20111012)
SourcePackage: empathy
UpgradeStatus: Upgraded to precise on 2012-01-20 (4 days ago)

Dario Bertini (berdario) wrote :
Bilal Shahid (s9iper1) wrote :

its not a empathy bug its telepathy-indicator bug moving it to there.thanks

affects: empathy (Ubuntu) → telepathy-indicator (Ubuntu)
Bilal Shahid (s9iper1) wrote :

confirmed as per many duplicates and i have faced it also.

Changed in telepathy-indicator (Ubuntu):
status: New → Confirmed
summary: - Empathy doesn't reuse the same indicator notification
+ Empathy indicator chat messages build up in the message menu & we are
+ not be able to clear it.
Bilal Shahid (s9iper1) wrote :

@Dario
are you using unity 2d?

Bilal Shahid (s9iper1) wrote :

so as "ken vandine " said me in xchat irc to assignin him.i have said hggdh to assign him..
thanks hggdh

C de-Avillez (hggdh2) wrote :

Assigned to Ken, following chat with Muhammad Bilal.

Changed in telepathy-indicator (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
Ken VanDine (ken-vandine) wrote :

I couldn't reproduce the duplicate indicators for messages, however I did notice indicators for facebook messages shows the receiver's name not the sender's name. Which could be causing the havoc, it looks like telepathy is giving us the wrong alias tp_contact_get_alias or perhaps the list of contacts is longer and we shouldn't be looking for the first one.

Changed in telepathy-indicator:
status: New → Confirmed
assignee: nobody → Ken VanDine (ken-vandine)
importance: Undecided → Medium
Changed in telepathy-indicator (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package telepathy-indicator - 0.1.2-0ubuntu1

---------------
telepathy-indicator (0.1.2-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Fix to make sure we don't get duplicate indicators (LP: #921168)
 -- Ken VanDine <email address hidden> Wed, 25 Jan 2012 15:29:06 -0500

Changed in telepathy-indicator (Ubuntu):
status: Confirmed → Fix Released
Changed in telepathy-indicator:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers