Enable auto-install of packages in recommends field by default, like in aptitude

Bug #8896 reported by Henrik Nilsen Omma on 2004-10-08
36
Affects Status Importance Assigned to Milestone
gnome-app-install (Ubuntu)
Undecided
Unassigned
synaptic (Baltix)
Undecided
Unassigned
synaptic (Debian)
Fix Released
Unknown
synaptic (Ubuntu)
Medium
Michael Vogt

Bug Description

Synaptic must automatically install packages, listed in Recommends field on install *and* upgrades in the default configuration, like aptitude.
Currently setting "Consider recommended packages as dependancies" is not enabled as default in synaptic, because of this synaptic does make Recommends field useless, since the users can't look at the dependencies of every depended package manually and see which recommendations may be missing...

It would be nice to have is an improved "Mark additional required changes window, coming up saying:
- "those dependes must be installed" (Depends)
- "those dependencies should be install" (Recommends) with a toggle-box, on by default
- "those can be installed" (Suggests) with a toggle box, off by default

What we have right now is just the window coming up with no selection feature for the user that marks the recommends just like depends. The user can't unmark (some) of them, etc. :(

There is very user-friendly implementation of installation recommended and suggested packages in stormpkg and deity package managers (which were orphaned for few years):
when user pressed "Install" button and "mark additional changes" dialog with list of packages (to be marked for installation) is displayed in stormpkg, this list contains not only depends, but also recommends and suggests and there is the ability to mark/unmark wanted ones. "Marked changes" list has 2 additional columns - one with checkbox and second with dependency type (depend, recommend or suggest).

Matt Zimmerman (mdz) wrote :

gnopernicus Recommends gnome-mag, which means that it should be installed by
default when gnopernicus is installed, but it may be removed (because
gnopernicus is still useful without it).

Theoretically, it is a bug in synaptic that it does not install Recommends by
default, but that is not a simple thing

Henrik Nilsen Omma (henrik) wrote :

OK, well the problem would at least be reduced with better documentation. If the
user was able to install gnopernicus itself, she would also be able to install
gnome-mag, provided the knowledge that it was required. But it's not that easy
to know; I found out about gnome-mag after reading some well-hidden stuff on the
web. The gnoperniucus documentation itself is very thin.

Looks like the Ubunbtu Accessibility Team should start gluing together some
general documentation on all the relevant apps for our web pages, and then we
can feed that back upstream.

Michael Vogt (mvo) wrote :

My current development version of synaptic contains the feature to auto-install
recommended packages.
But I don't think this should be put into warty as it got too little testing.

Michael Vogt (mvo) wrote :

Do we want to enable "auto-install-recommends" feature by default for hoary?
it's the default for aptitude already and it would love this bug too.

Matt Zimmerman (mdz) wrote :

(In reply to comment #4)
> Do we want to enable "auto-install-recommends" feature by default for hoary?
> it's the default for aptitude already and it would love this bug too.

I think the effects are too far-reaching for this point in the release process;
let's defer it to hoary+1

Daniel Robitaille (robitaille) wrote :

*** Bug 13822 has been marked as a duplicate of this bug. ***

(In reply to comment #5)
> (In reply to comment #4)
> > Do we want to enable "auto-install-recommends" feature by default for hoary?
> > it's the default for aptitude already and it would love this bug too.
>
> I think the effects are too far-reaching for this point in the release process;
> let's defer it to hoary+1

So is it going to happen for breezy???

Michael Vogt (mvo) wrote :

(In reply to comment #7)
> (In reply to comment #5)
> > (In reply to comment #4)
> > > Do we want to enable "auto-install-recommends" feature by default for hoary?
> > > it's the default for aptitude already and it would love this bug too.
> >
> > I think the effects are too far-reaching for this point in the release process;
> > let's defer it to hoary+1
>
> So is it going to happen for breezy???

No, it's too late at this stage and it was not really discussed at the last
developers submit. We should set it onto the agenda for the next submit though,
it's a change that should be done very early in the release cycle.

Cheers,
 Michael

Mantas Kriaučiūnas (mantas) wrote :

Comment #8 From Michael Vogt:
> No, it's too late at this stage and it was not really discussed at the last
> developers submit. We should set it onto the agenda for the next submit though,
> it's a change that should be done very early in the release cycle.

There is no need for discuss about instaling recommended packages by default -
all needed info about recommends field is in Debian policy:
( http://www.debian.org/doc/debian-policy/ch-relationships.html#s-binarydeps ):

The Recommends field should list packages that would be found together with this
one in all but unusual installations.

aptitude follows Debian policy, so, why synaptic shouldn't follow ?

Florian Boucault (fboucault) wrote :

I totally agree with Mantas. It is not even an option not to follow this policy. I would even say that it is a critical bug since a lot of software will not work properly without it (k3b will not burn).

Florian Boucault (fboucault) wrote :

Sorry, k3b will eventually burn but important features are missing without the recommended packages.
Just a reminder : this behaviour is still present in Dapper.

Michael Vogt (mvo) wrote :

I have a new http://people.ubuntu.com/~mvo/bzr/apt/apt--install-recommends/

branch that will hopefully make it for dapper+1. With it, recommends will be installed by default.

Phillip Susi (psusi) wrote :

Seems that this did not make it into edgy. What is the current status? Can we get synaptic and the add programs applet to prompt to install the recommended and suggested packages? Rather than silently install Recommended packages, I think it should prompt the user for Recommended and Suggested packages, informing them that the former are strongly recommended, and the latter that they might find interesting, with default action being to install the former, but not the latter.

This bit me the other day when I installed grip from the add applications applet and it failed to run properly out of the box because to encode, it requires vorbis-tools.

eppy 1 (choppy121212) wrote :

I agree with this, recommends should install by default by gnome-app-installer and Synaptic, or at least tell us if there are recommends; don't just be silent.

I tried to install the beryl metapackage in Feisty Fawn's beta universe, and beryl-manager didn't install because it was only recommended. So I could not even figure out how to turn Beryl on.

Henrik Nilsen Omma (henrik) wrote :

The original problem of magnification not working has been fixed with Orca and gnome-mag. The debate auto-install of recommends is more of a policy issue than a bug. Marking Fixed.

Changed in synaptic:
status: Confirmed → Fix Released
Mantas Kriaučiūnas (mantas) wrote :

Henrik Nilsen Omma said on 2007-04-03: (permalink)
> The debate auto-install of recommends is more of a policy issue than a bug.

It's not a policy issue - why main debian/ubuntu package manager, aptitude, installs recommended packages as default, but synaptic doesn't ? Please don't close this bug until it will be really fixed in synaptic.

There is no need for discuss about instaling recommended packages by default - all needed info about recommends field is in Debian policy:
( http://www.debian.org/doc/debian-policy/ch-relationships.html#s-binarydeps ):

The Recommends field should list packages that would be found together with this
one in *all* but unusual installations.

Changed in synaptic:
status: Fix Released → Confirmed
description: updated
Phillip Susi (psusi) wrote :

My original problem has NOT been fixed - installing grip by default produces an install that fails with a cryptic error message instead of being able to rip to ogg or mp3, because those recommended packages have not been installed.

If this were a policy issue there would be a config file somewhere that could be set to isntruct synaptic and add-applications to auto install recommends. As previously noted in this bug report, work to add such an option was under way, but what is its current status?

Sebastian Heinlein (glatzor) wrote :

In progress.

Bradly Wilson (mocoloco) wrote :

My mom was confused as to why if GRAMPS lacked some chart printing functionality until I installed graphviz for her. Seemed a little odd after I had talked up the fact that the package manager takes care of those things for you.
As the Debian policy lists: "The Recommends field should list packages that would be found together with this one in all but unusual installations."
I say just set it enabled by default in Synaptic, that takes care of it for gnome-app-install, and anyone who doesn't want it that way (bandwidth concerns, HD space, etc) can disable it. I really don't think additional dialogs or hoopla is necessary.

Sebastian Heinlein (glatzor) wrote :

Thanks for your feedback, mocoloco. As stated before this known and worked on. It implicates a lot more than just switching a handler. The package archive needs to be tested before to avoid not well chosen recommends.

Phillip Susi (psusi) wrote :

Sebastian, has the support for this been implemented yet and just not switched on because we are unsure of the quality of the recommends and suggests in the archive? If so how could I turn it on and begin testing?

Florian Boucault (fboucault) wrote :

Any update on the issue? What can we do to help?

Michael Vogt (mvo) wrote :

Please have a look at this mailing list post:

http://lists.debian.org/debian-devel-announce/2007/08/msg00000.html

and the subsequent discussion for some background information. We will turn on recommends fairly soon too (but not for gutsy anymore).

Cheers,
 Michael

Saivann Carignan (oxmosys) wrote :

Michael Vogt : It was planned that this bug would be fixed for Hardy but it is not yet. Can you tell us the status of this bug? Is enabling installation of "recommands" still planned for debian?

Michael Vogt (mvo) wrote :

This is done in intrepid now.

Changed in synaptic:
status: Confirmed → Fix Released
Changed in gnome-app-install:
status: New → Fix Released
Saivann Carignan (oxmosys) wrote :

Thank you very much for you work :)

Felipe Figueiredo (philsf) wrote :

Out of curiosity, are there any plans on backporting the patch to Hardy?

Changed in synaptic:
status: New → Fix Released

@Felipe:
You can do this quite easy by adding an entry in the /etc/apt/apt.conf.d/ directory.

Make a new file in there, e.g. sudo gedit 99recommends

And paste
APT::Install-Recommends “true";

into it.

Go to Synaptic in Preference and just check if "consider recommendations as dependencies" is active, if not, check the box active.

Then go >Synaptic >Settings >Filters,
Make a new one e.g. "Missing recommends"
Uncheck all boxes, only check the line "broken policy" (which means the apt policy in the config files)

Reload package information (I guess it is not explicitly necessary).

And with "Search filters" you have the Filter Missing Recommends.

E.g., if you select abiword-gnome, it will automatically set abiword-gnome-plugins for install, which is only a recommend not a dependency.

Ok, that all did not answer your questions if this configurations gets automatically backported for hardy. ;-)

Regards,

@ Felipe:
though be aware of it, that some recommended packages are not in the main respository, considering support. At least in hardy.

ami_nakata (ami-nakata) wrote :

Christian's very helpful fix appears to include a small error that causes Synaptic to fail on attempted startup. He writes,

> And paste
> APT::Install-Recommends “true";

I think users will have better success if they instead copy and paste the following line into the 99recommends file that Christian suggests users create in the /etc/apt/apt.conf.d/ directory:

APT::Install-Recommends "true";

The two lines look the identical, but they're not. In the version that Christian typed, the first of the two quotation marks is some kind of non-standard character, presumably a "smart" or (same) "opening" quotation mark. When I tried to use Christian's exact line on my Hardy system I received this fatal error the next time I tried to start Synaptic:

E: Syntax error /etc/apt/apt.conf.d/99recommends:2: Extra junk at end of file

Replacing the non-standard quotation mark with a normal one, as was done to create the corrected APT line immediately above, solves the problem, and lets Synaptic start normally.

@Ami:

Thanks, this was indeed a keyboard layout typo error.

APT::Install-Recommends "true";
is correct like you said

Kelly (kellyjeanross) on 2009-11-26
Changed in gnome-app-install (Ubuntu):
status: Fix Released → Incomplete
Changed in synaptic (Baltix):
status: Fix Released → New
Changed in synaptic (Ubuntu):
status: Fix Released → New

@Kelly, why did you change the status of this report ?
This one is fixed for a while now. If you're facing some bug, then please open a new report and we can easily mark it as duplicate if it happens to be the same issue.
Thanks for your understanding.

Changed in gnome-app-install (Ubuntu):
status: Incomplete → Fix Released
Changed in synaptic (Baltix):
status: New → Fix Released
Changed in synaptic (Ubuntu):
status: New → Fix Released
Changed in synaptic (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.