Synaptic crashes in vfprintf() with Norwegian locale

Bug #880493 reported by Stian Skjelstad on 2011-10-23
168
This bug affects 27 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Low
Ubuntu Norwegian Translators
synaptic (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned
Quantal
Medium
Unassigned
Raring
Medium
Unassigned

Bug Description

== Test case ==
Quoted from https://bugs.launchpad.net/ubuntu/+source/synaptic/+bug/830750/comments/5:

1. Open "Language Support"
2. Install Norwegian Bokmål if not installed already, then drag "Norsk, bokmål (Norge)" to the top of the list.
3. Apply system-wide (I don't know if this is necessary)
4. Log out and log in again
5. Open "Synaptic pakkebehandler", type in password as usual
6. Shortly after its window appears, it will crash

== Impact ==
Makes the package unusable for Norwegian users on Precise LTS
Attaching screenshot (ubuntu 11.10, synaptic 0.75.2ubuntu8)

== Development Fix ==
Fix merged into lp:synaptic at revision 2126. Only three strings in po/nb.po are changed.

== Regression Potential ==
I've verified that the singatures of the translated strings match the signatures of the original English one.

Related branches

Stian Skjelstad (mywave) wrote :
Hans Joachim Desserud (hjd) wrote :
Changed in ubuntu-translations:
assignee: nobody → Ubuntu Norwegian Translators (ubuntu-l10n-no)
tags: added: i18n oneiric
Gabor Kelemen (kelemeng) on 2011-10-27
Changed in ubuntu-translations:
status: New → Fix Committed
importance: Undecided → Low
Hans Joachim Desserud (hjd) wrote :

Thanks mabynke.

I think the strings used in the status bar at the bottom are the following:
https://translations.launchpad.net/synaptic/main/+pots/synaptic/nb/341/+translate
https://translations.launchpad.net/synaptic/main/+pots/synaptic/nb/342/+translate
https://translations.launchpad.net/synaptic/main/+pots/synaptic/nb/343/+translate

Though I am not sure if we should replace them with the suggestion offered or something else. If someone has some spare time, it might be a good idea to review the translations in this package since there might be more issues like this.

Marius B. Kotsbak (mariusko) wrote :

Because of bug #839219, it is not even possible to start synaptic in Norwegian language to verify if this bug is fixed.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in synaptic (Ubuntu):
status: New → Confirmed
Robert Roth (evfool) on 2012-11-19
tags: added: precise quantal
Robert Roth (evfool) wrote :

I have marked some other bugs reporting crashes as duplicates of this bug, as the translation problems outlined here (in the status text and in the summary window) seem to be causing crashes for people (only using the nb_NO locale).

Marius B. Kotsbak (mariusko) wrote :

Well, given those issues are merged into this bug report, I must then change the status of the "upstream" version as the latest issues are not solved.

Translation team, please also fix the issues outlined in bug #839219. See comment https://bugs.launchpad.net/ubuntu-translations/+bug/839219/comments/42

Changed in ubuntu-translations:
status: Fix Committed → Confirmed
Dave Chiluk (chiluk) wrote :

This has since been fixed by bug #839219.

Please have the customer update to the latest synaptic, and retest.

Thanks

#wosup

Changed in synaptic (Ubuntu):
status: Confirmed → Fix Released
Dave Chiluk (chiluk) wrote :

Woops wrong bug, but I guess it applies here as well. Please try the newest synaptic.

Hans Joachim Desserud (hjd) wrote :

Last time I checked synaptic would still crash with Norwegian Bokmål locale. However, I went through the Norwegian translations, fixed a lot with mismatch in number of parameters, replaced some and added a couple. My hope is that this will improve the situation once we get a new synaptic release with the updated translations included.

Ante Karamatić (ivoks) wrote :

@Hans looks like your changes have solved the problem. With new synaptic.mo attached, I can no longer reproduce the problem. Could you please confirm by downloading this .mo and placing it into /usr/share/locale/nb/LC_MESSAGES/. Make sure to backup /usr/share/locale/nb/LC_MESSAGES/synaptic.mo before doing this, so you can restore if new version is not good.

This file is generated using export mechanics in Launchpad:

https://translations.launchpad.net/synaptic/main/+export

Changed in ubuntu-translations:
status: Confirmed → Fix Committed
Ante Karamatić (ivoks) wrote :

Reopening the bug on synaptic since the fix is *not* pushed into the package - package needs to be rebuilt to pick up new translation. 'Broken' file is /usr/share/locale/nb/LC_MESSAGES/synaptic.mo, which belongs to synaptic package, therefore, bug is valid in synaptic.

Changed in synaptic (Ubuntu):
status: Fix Released → Confirmed
importance: Undecided → Medium
Ante Karamatić (ivoks) on 2013-03-14
Changed in synaptic (Ubuntu Precise):
status: New → Confirmed
Changed in synaptic (Ubuntu Quantal):
status: New → Confirmed
Changed in synaptic (Ubuntu):
status: Confirmed → Fix Released
Changed in synaptic (Ubuntu Precise):
importance: Undecided → Medium
Changed in synaptic (Ubuntu Quantal):
importance: Undecided → Medium
Hans Joachim Desserud (hjd) wrote :

Ante: Thanks for following up on this issue. :) After replacing synaptic.mo I'm no longer able to trigger a crash. I haven't done an exhaustive testing of functionality in Synaptic with this, but installing/removing/etc packages works fine. Looks like rebuilding with the latest translations would indeed resolve this.

PS. Raring is also affected, so you might want to add a milestone for that release too.

Joachim Hansen (sn3ipen) wrote :

I can confirm that the fix are working.

Ante Karamatić (ivoks) wrote :

Still broken in 13.04.

Changed in synaptic (Ubuntu):
status: Fix Released → Confirmed
Ante Karamatić (ivoks) on 2013-04-29
Changed in synaptic (Ubuntu Raring):
status: New → Confirmed
importance: Undecided → Medium
summary: - Norwegian translation has some issues
+ Synaptic crashes in vfprintf() with Norwegian locale
description: updated
tags: added: raring sru
removed: oneiric
David Planella (dpm) wrote :

I'm wondering (and worrying) why gettext did not notice and display an error for the wrongly formatted translation. Is there anything particular about the original format string?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package synaptic - 0.80

---------------
synaptic (0.80) unstable; urgency=low

  * update translations from launchpad

 -- Michael Vogt <email address hidden> Wed, 08 May 2013 21:11:11 +0200

Changed in synaptic (Ubuntu):
status: Confirmed → Fix Released

Aligning ubuntu-translations status on synaptic status

synaptic (0.80) unstable; urgency=low

  * update translations from launchpad

 -- Michael Vogt <email address hidden> Wed, 08 May 2013 21:11:11 +0200

Changed in ubuntu-translations:
status: Fix Committed → Fix Released
Marius B. Kotsbak (mariusko) wrote :

David, I think it is performance reasons for it doing it like that.

Hello Stian, or anyone else affected,

Accepted synaptic into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/synaptic/0.80~exp2raring1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in synaptic (Ubuntu Raring):
status: Confirmed → Fix Committed
tags: added: verification-needed
Adolfo Jayme (fitojb) wrote :

Can someone test the package in raring-proposed?

Thorben Dahl (thorbendahl) wrote :

I tried the package (version 0.80~exp2raring1), and I encountered no problems, so the bug seems to be fixed (and I can confirm the bug affected the version of Synaptic I had on my computer, before updating). I'm a newbeginner when it comes to testing, though, so it would be nice with confirmation from someone else.

Marius B. Kotsbak (mariusko) wrote :

Seems to work fine for me too.

Marius B. Kotsbak (mariusko) wrote :

Version tested is 0.80~exp2raring1.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package synaptic - 0.80~exp2raring1

---------------
synaptic (0.80~exp2raring1) raring-proposed; urgency=low

  * po/nb.po: cherry-pick some strings from Launchpad to fix crash
    (LP: #880493)
 -- Dmitry Shachnev <email address hidden> Mon, 29 Apr 2013 18:46:32 +0400

Changed in synaptic (Ubuntu Raring):
status: Fix Committed → Fix Released

I tried this on my norwegian Lubuntu machine today, with all updates
installed, and synaptic worked as it should, so seems to be fixed!

Thanks.

Kjetil

On Mon, Jun 17, 2013 at 1:04 PM, Marius B. Kotsbak
<email address hidden> wrote:
> Seems to work fine for me too.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/880493
>
> Title:
> Synaptic crashes in vfprintf() with Norwegian locale
>
> Status in Ubuntu Translations:
> Fix Released
> Status in “synaptic” package in Ubuntu:
> Fix Released
> Status in “synaptic” source package in Precise:
> Confirmed
> Status in “synaptic” source package in Quantal:
> Confirmed
> Status in “synaptic” source package in Raring:
> Fix Committed
>
> Bug description:
> == Test case ==
> Quoted from https://bugs.launchpad.net/ubuntu/+source/synaptic/+bug/830750/comments/5:
>
> 1. Open "Language Support"
> 2. Install Norwegian Bokmål if not installed already, then drag "Norsk, bokmål (Norge)" to the top of the list.
> 3. Apply system-wide (I don't know if this is necessary)
> 4. Log out and log in again
> 5. Open "Synaptic pakkebehandler", type in password as usual
> 6. Shortly after its window appears, it will crash
>
> == Impact ==
> Makes the package unusable for Norwegian users.
>
> == Development Fix ==
> Fix merged into lp:synaptic at revision 2126. Only three strings in po/nb.po are changed.
>
> == Regression Potential ==
> I've verified that the singatures of the translated strings match the signatures of the original English one.
>
> == Original Description ==
> Attaching screenshot (ubuntu 11.10, synaptic 0.75.2ubuntu8)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu-translations/+bug/880493/+subscriptions

Vlad Orlov (monsta) wrote :

Funny. The version in Presise didn't get the update. And Precise is LTS. Nice "support".

description: updated
Ritesh Khadgaray (khadgaray) wrote :
Sebastien Bacher (seb128) wrote :

@Ritesh: thanks, could you use a valid name for the changelog though?

Michael Vogt (mvo) on 2014-04-02
Changed in synaptic (Ubuntu Precise):
status: Confirmed → In Progress
Changed in synaptic (Ubuntu Quantal):
status: Confirmed → Won't Fix
Michael Vogt (mvo) on 2014-04-02
Changed in synaptic (Ubuntu Precise):
status: In Progress → Fix Committed

Hello Stian, or anyone else affected,

Accepted synaptic into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/synaptic/0.75.9ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
Marius B. Kotsbak (mariusko) wrote :

Version 0.75.9ubuntu1.1 works fine for me. Thanks!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package synaptic - 0.75.9ubuntu1.1

---------------
synaptic (0.75.9ubuntu1.1) precise-proposed; urgency=low

  [ Ritesh Khadgaray (khadgaray) ]
  * debian/patch/bug_880493.patch:
    - Synaptic crashes in vfprintf() with Norwegian locale (lp: #880493)
 -- Michael Vogt <email address hidden> Wed, 02 Apr 2014 15:58:10 +0200

Changed in synaptic (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers