Out of date java 6 plugin installed

Bug #291135 reported by Doug Holton on 2008-10-30
124
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Sun Java
Invalid
Undecided
Unassigned
sun-java6 (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu Intrepid has support for the latest version of java (version 6 update 10 build 33), but the old plugin is still enabled, not the new one with support for draggable applets, jnlp-based applets and other new features. These applets for example will not work: https://scenegraph-demos.dev.java.net/demo-applets.html

To fix this I ran:
sudo update-alternatives --install /etc/alternatives/xulrunner-1.9-javaplugin.so xulrunner-1.9-javaplugin.so /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so 50

sudo update-alternatives --config xulrunner-1.9-javaplugin.so

But perhaps other plugin alternatives should point to the new plugin location:
/usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so
instead of:
/usr/lib/jvm/java-6-sun/jre/plugin/i386/ns7/l
ibjavaplugin_oji.so

That includes those listed in /usr/lib/jvm/.java-6-sun.jinfo:
xulrunner-1.9-javaplugin.so
firefox-javaplugin.so
iceape-javaplugin.so
iceweasel-javaplugin.so
mozilla-javaplugin.so
midbrowser-javaplugin.so
xulrunner-javaplugin.so

Changed in sun-java:
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sun-java6 - 6-11-0ubuntu1

---------------
sun-java6 (6-11-0ubuntu1) jaunty; urgency=low

  * New upstream release.
    Release notes at http://java.sun.com/javase/6/webnotes/ReleaseNotes.html.
  * sun-java6-plugin: Use the libnpjp2 plugin instead of libjavaplugin_oji.
    LP: #291135.

 -- Matthias Klose <email address hidden> Wed, 03 Dec 2008 11:43:53 +0100

Changed in sun-java6:
status: New → Fix Released
Adam Niedling (krychek) wrote :

Will this be fixed in Intrepid as well?

Jimmy Merrild Krag (beruic) wrote :

..:: This is how I got java working in Intrepid ::..
(I develop a bit in Java, so installed the JDK. Change the paths if you install jre)

I installed the binary from Sun in /opt/
Added the following in th end of /etc/profile:
"
# Java
PATH="$PATH:/opt/jdk1.6.0_11/bin"
JAVA_HOME="/opt/jdk1.6.0_11"
export PATH
export JAVA_HOME
"

And ran this in /usr/lib/firefox-addons/plugins :
sudo ln -s sudo ln -s /opt/jdk1.6.0_11/jre/lib/i386/libnpjp2.so

Tom Martin (tompoges) wrote :

This worked for me thanks.
I did the same for update 12 that was recently released.

Is this a typo?
sudo ln -s sudo ln -s /opt/jdk1.6.0_11/jre/lib/i386/libnpjp2.so

I think you meant
sudo ln -s /opt/jdk1.6.0_11/jre/lib/i386/libnpjp2.so

Jimmy Merrild Krag (beruic) wrote :

Yes, it is a typo, and yes, it should read:
sudo ln -s /opt/jdk1.6.0_11/jre/lib/i386/libnpjp2.so

Jimmy Merrild Krag (beruic) wrote :

btw

run in terminal:
jconsole for java console
jcontrol for java control panel

mbien (mbien) wrote :

I am curious, why is there still no u11 or u12 available for autoupdate (with this fix in it)? Wasn't u11 a security update? u11 fixed also some annoying bugs on ubuntu (like the combobox issue).

Rune K. Svendsen (runeks) wrote :

Thank you Jimmy, that works perfectly. Even with jre 6.0.12 which I installed.

Leo Milano (lmilano) wrote :

I can confirm this. However, I am not sure this is fixed in Jaunty. I just installed sun-java6 from the jaunty repository, in my Intrepid box (it installs just fine). The problems with Java persisted (applets that used to work in Hardy were crashing firefox in Intrepid). A look into /etc/alternatives revealed that all the symlinks were pointing to the old location. For instance:

 xulrunner-javaplugin.so -> /usr/lib/jvm/java-6-sun/jre/plugin/i386/ns7/libjavaplugin_oji.so

Symlinking everything pointing to libjavaplugin_oji.so into libnpjp2.so fixed my java issues:

cd /etc/alternatives/

sudo ln -sf /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so firefox-javaplugin.so
sudo ln -sf /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so iceape-javaplugin.so
sudo ln -sf /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so iceweasel-javaplugin.so
sudo ln -sf /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so midbrowser-javaplugin.so
sudo ln -sf /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so mozilla-javaplugin.so
sudo ln -sf /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so xulrunner-1.9-javaplugin.so
sudo ln -sf /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so xulrunner-javaplugin.so

Can this be fixed in both Intrepid and Jaunty? It seems to be a simple matter of correcting some symbolic links :-)

Many thanks!
Leo

Doug Holton (edtechdev) wrote :

Yeah I can confirm this hasn't been fixed yet, too, in intrepid or jaunty alpha 6.

Would be great if this could be corrected by the time of the jaunty release.

Doug Holton (edtechdev) on 2009-03-20
Changed in sun-java6:
status: Fix Released → Confirmed
Doug Holton (edtechdev) wrote :

Actually it has been fixed in Jaunty for the past month.

I tested with a fresh install of jaunty alpha 6, installed the java6-plugin package, and those new applets worked.

So I marked this as fix released again.

See these other notes:

James Stansell indicates that 6u12 is in Jaunty: (comment near bottom)
https://bugs.launchpad.net/debian/+source/sun-java6/+bug/104512

And there is a Feb 6th note here to "Use the libnpjp2 plugin instead of
libjavaplugin_oji": (jaunty only)
https://launchpad.net/ubuntu/+source/sun-java6

Changed in sun-java6:
status: Confirmed → Fix Released
Åskar (olskar) wrote :

Please go to https://test.bankid.com/sv/testbankidcom/ and press Nästa twice. It freeze on Intrepid but works fine in Jaunty. This should not be marked fixed until it is fixed in Intrepid as well (and Hardy perhaps, dont know if it is a problem there)

hi

i have to confirm this bug in sun-java6-plugin...

i tried all, remove sun-java6 including plugin, remove manually the plugin from firefox, reinstalling sun-java6 including the plugin but no chance...

i had to do Leo Milano's workaround to get all the java sites working:
https://bugs.launchpad.net/ubuntu/+source/sun-java6/+bug/291135/comments/9

no in firefox about:plugins i see this:
libnpjp2.so
    File name: /usr/lib/jvm/java-6-sun-1.6.0.13/jre/lib/i386/libnpjp2.so

by the way, my system is here:
Linux hercules 2.6.28-13-generic #44-Ubuntu SMP Tue Jun 2 07:57:31 UTC 2009 i686 GNU/Linux
lsb_release -rd
Description: Ubuntu 9.04
Release: 9.04

thomi

Steve Kroon (kroon) wrote :

I see the status of this bug is "Fix released", but what is the fix? [The comments just say "it has been fixed in Jaunty"]

I still have the problem in Jaunty with Java freezing Firefox-3.0.11 and firefox-3.5b4pre (e.g. The Java test page at www.java.com/en/download/help/testvm.xml causes a freeze). I am using the most recent Java as far as i know - from about:plugins:

Java(TM) Plug-in 1.6.0_13-b03

    File name: libjavaplugin_oji.so
    Java(TM) Plug-in 1.6.0_13

Doug Holton (edtechdev) wrote :

The fix is to use libnpjp2.so instead of javaplugin.so.

If you can see some applets but not these:
https://scenegraph-demos.dev.java.net/demo-applets.html
Then it wasn't fixed.

If you get the freeze for any applets or random applets, then that's another java bug.

Hi

I have fixed it manually, see my comment above... and firefox uses now libnpjp2.so.
The test with the site https://scenegraph-demos.dev.java.net/demo-applets.html was successfully.

Just wait, the dev's are on work ;)

greetings
thomi

Steve Kroon (kroon) wrote :

Thanks - changing the links works for me.

Doesn't fix released mean that if my Jaunty system is up to date, I shouldn't need to manually fix this?

I'd change it myself, but I'm not sure if this bug's fix has now been committed into an unreleased update or not. Perhaps In Progress is a better status?

Elias Naur (elias-naur) wrote :

In my experience, a freshly installed Jaunty works fine and uses the new plugin. For an updated Jaunty, re-installing the plugin package fixed the symlinks.

Steve Kroon (kroon) wrote :

So the correct fix is:

sudo apt-get reinstall sun-java6-plugin

I still don't get is how it can be "Fix released" if my system never got a patch/update for it. How are users supposed to know to update?

If the relevant update just hasn't got to end-users yet, I presume the status should be fix-committed?

[I'm new to all these statuses, so just trying to clarify things]

Steve Kroon (kroon) wrote :

Erm - can't see how to edit my previous submission:

I meant: "How are users supposed to know to _reinstall_ (the package)"

Leo Milano (lmilano) wrote :

I now have a new 64 bit machine , and a fresh install of Jaunty. I went ahead and installed the Sun Java6 packages:

sudo apt-get install sun-java6-jre sun-java6-plugin sun-java6-fonts

Going to the applets test page would make Java use 100% of one of the cores and would keep hang even after exiting firefox. Needles to say, the applets would fail to load. I noticed this:

cd /etc/alternatives/
ls -l |grep javap

lrwxrwxrwx 1 root root 49 2009-07-09 19:51 firefox-javaplugin.so -> /usr/lib/jvm/java-6-sun/jre/lib/amd64/libnpjp2.so
lrwxrwxrwx 1 root root 49 2009-07-09 19:51 iceape-javaplugin.so -> /usr/lib/jvm/java-6-sun/jre/lib/amd64/libnpjp2.so
lrwxrwxrwx 1 root root 49 2009-07-09 19:51 iceweasel-javaplugin.so -> /usr/lib/jvm/java-6-sun/jre/lib/amd64/libnpjp2.so
lrwxrwxrwx 1 root root 49 2009-07-09 19:51 midbrowser-javaplugin.so -> /usr/lib/jvm/java-6-sun/jre/lib/amd64/libnpjp2.so
lrwxrwxrwx 1 root root 49 2009-07-09 19:51 mozilla-javaplugin.so -> /usr/lib/jvm/java-6-sun/jre/lib/amd64/libnpjp2.so
lrwxrwxrwx 1 root root 58 2009-07-09 19:51 xulrunner-1.9-javaplugin.so -> /usr/lib/jvm/java-6-openjdk/jre/lib/amd64/IcedTeaPlugin.so
lrwxrwxrwx 1 root root 49 2009-07-09 19:51 xulrunner-javaplugin.so -> /usr/lib/jvm/java-6-sun/jre/lib/amd64/libnpjp2.so

Clearly, icedtea6-plugin was on the way. Removing it fixed the issue:

lmilano@grisell:alternatives$ ls -l |grep javap
lrwxrwxrwx 1 root root 49 2009-07-09 19:51 firefox-javaplugin.so -> /usr/lib/jvm/java-6-sun/jre/lib/amd64/libnpjp2.so
lrwxrwxrwx 1 root root 49 2009-07-09 19:51 iceape-javaplugin.so -> /usr/lib/jvm/java-6-sun/jre/lib/amd64/libnpjp2.so
lrwxrwxrwx 1 root root 49 2009-07-09 19:51 iceweasel-javaplugin.so -> /usr/lib/jvm/java-6-sun/jre/lib/amd64/libnpjp2.so
lrwxrwxrwx 1 root root 49 2009-07-09 19:51 midbrowser-javaplugin.so -> /usr/lib/jvm/java-6-sun/jre/lib/amd64/libnpjp2.so
lrwxrwxrwx 1 root root 49 2009-07-09 19:51 mozilla-javaplugin.so -> /usr/lib/jvm/java-6-sun/jre/lib/amd64/libnpjp2.so
lrwxrwxrwx 1 root root 49 2009-07-09 20:04 xulrunner-1.9-javaplugin.so -> /usr/lib/jvm/java-6-sun/jre/lib/amd64/libnpjp2.so
lrwxrwxrwx 1 root root 49 2009-07-09 19:51 xulrunner-javaplugin.so -> /usr/lib/jvm/java-6-sun/jre/lib/amd64/libnpjp2.so

Now the applets load just fine. Shouldn't the sun-java6-plugin package conflict with the icedtea6-plugin? Meaning that when you install dpkg would force you to uninstall the other?

Hope this helps ...

Hi

By the was, the comand to fix it is: sudo aptitude reinstall sun-java6-plugin
apt-get has no reinstall function..

And now, how Users know about that Problem and how to fix it... read this Bugreport.. Users have to search trough launchpad if there is any Problem...

But, it will be easier if an update fix it with reinstalling the package automatically... and cleaning the conflict as Leo Milano's comment explains...

have a nice day
thomi

Steve Kroon (kroon) wrote :

Thanks for the correction, Thomas.

Re: users knowing how to fix it - see https://bugs.launchpad.net/malone/+bug/163694 . If your system is up to date (all updates applied), and the bug is "Fix released", my impression is that you shouldn't be suffering from the bug (as I was).

Leo Milano (lmilano) wrote :

I think, besides the semantics of "Fixed Released" that Steve correctly pointed out, there is a misunderstanding.

The original bug seems to have been _partially_ fixed by sun-java6 (6-11-0ubuntu1). However, there is a remaining bug, in that the sun plugin conflicts with icedtea's plugin. So, I think the bug should be re-opened but for sun-java6-plugin ... does anyone know how to do that? I may open a new bug for that, and link it from here ... or is there another way? I don't want to mess up.

Igor Gomes (igorgomes) wrote :

Thanks for the tip Leo! I'm using Jaunty with all the updates and just after this workaround I can access some pages.

Igor Gomes

Changed in sun-java6 (Ubuntu):
status: Fix Released → Incomplete
Adam Niedling (krychek) wrote :

Why did you set this to incomplete? Is this bug still occurring to you?

Changed in sun-java6 (Ubuntu):
status: Incomplete → Fix Released
markauro (markauro) on 2010-03-15
Changed in sun-java6 (Ubuntu):
status: Fix Released → In Progress

This bug is fixed in oneiric (and probably previous Ubuntu release) in this package version:

Package: sun-java6-plugin
Version: 6.26-1oneiric1

The postinst script /var/lib/dpkg/info/sun-java6-plugin.postinst only deals with the libnpjp2.so plugin.

For older systems, the java packages do not cleanup older alternatives. Here is what I did (as root) on my system to clean up:

rm /var/lib/dpkg/alternatives/*javaplugin*
rm `locate libjavaplugin.so`
/var/lib/dpkg/info/sun-java6-plugin.postinst update

Changed in sun-java6 (Ubuntu):
status: In Progress → Fix Released
dino99 (9d9) wrote :

outdated flavor, report about a newer active version if needed

Changed in sun-java:
importance: Unknown → Undecided
status: Confirmed → New
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.