Ubuntu

java applets freeze firefox in intrepid

Reported by Hein van Dam on 2008-10-24
This bug report is a duplicate of:  Bug #291135: Out of date java 6 plugin installed. Edit Remove
56
This bug affects 7 people
Affects Status Importance Assigned to Milestone
firefox-3.0 (Ubuntu)
Undecided
Unassigned
sun-java6 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox-3.0

No crash with me but the sytem freezes with java applets. When I try to detect whether I have java this happens as well of course and I get the message: GNU Class path's security implementation is not complete.
The sites I have tried are in the whitelist.
No problem with Opera, so I have the correct java installed.

N.B. 1. About Mozilla firefox gives firefox 3.0.3, but the bug report says that one doesn't exist in ubuntu.
2. Reinstall of installed version 3.0.3+nobinonly-Ou doesn't help

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
NonfreeKernelModules: fglrx
Package: firefox-3.0 3.0.3+nobinonly-0ubuntu2
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox-3.0
Uname: Linux 2.6.27-7-generic i686

Hein van Dam (h-van-dam13) wrote :
ThorbjørnTux (martsummsw) wrote :

I am unsure what the ubuntu team can do - but I would like to confirm.

https://www.eikbank.dk/netbank/logon/tidligere_skandiabanken_kunde
I fill 'Brugernr' with 11111111111 (not my number)
I mark: Jeg har anvendt Netbank før
I press møste (next.)

After that I am supposed to get a java logon-screen.
However I get a freeze with firefox
It works with Opera.

The problem also occurs on a local installed version
(downloaded from mozillas page)

Alexander Sack (asac) wrote :

which applet product are you using? which version? how did you install it?

Changed in firefox-3.0:
status: New → Incomplete
ThorbjørnTux (martsummsw) wrote :

I have tried with sun-java5-plugin and sun-java6-plugin (with kubuntu 8.10 final)

This is however not related to this. The problem is in firefox.
It works with opera (unfortunately it has other problems later on)
and it works with firefox 2.0.0.17.

ThorbjørnTux (martsummsw) wrote :

PS:
Installed with
sudo apt-get install sun-java6-plugin

afterwards I tried with

sudo apt-get remove sun-java6-plugin
and
sudo apt-get install sun-java5-plugin

Are you unable to reproduce the error with the above example ?

James Stansell (jamesstansell) wrote :

"GNU Class path's security implementation is not complete." is not a message from sun-java6-plugin. My guess would be the gcjwebplugin package, which uses either cacao or jamvm for the java runtime.

It is easy (and generally good that it's possible) to have multiple java runtimes installed at the same time. My understanding is that opera calls java directly without using a plugin, and it's probably finding the sun-java6-jre runtime even though the plugin in firefox is using the cacao (probably?) runtime.

Does this make a difference for you?

$ sudo aptitude install sun-java6-plugin
$ sudo update-java-alternatives -s java-6-sun

ThorbjørnTux (martsummsw) wrote :

Unlike Hein van Dam - I do NOT get any message - just the freeze. This could come any firefox dependency.
(e.g in libstdc++6 - since firefox 2.0.0.17 wants libstdc++5)

However I do not believe it is in the (sun) java-plugin. It works with other browsers - and it worked with 3.0 beta in 8.04.
(And I have tried both sun-java5-plugin and sun-java6-plugin)

Can somebody try the example I give - and see if it can be reproduced?

James Stansell (jamesstansell) wrote :

Yes, using the eikbank.dk link I can reproduce a hang.

The java console shows RMI warnings repeatedly.

I haven't tried the plugin2 version yet.

Morten Holmstrup (robotjox) wrote :

confirming this- I am a Eik Bank customer and have not been able to connect to my bank account since upgrading to intrepid. Any workaround? Opera does not seem to work either.

Bonaldo2000 (morten-m-olsen) wrote :

I can also confirm this bug. I have tried with both sun-java6-plugin and sun-java5-plugin.

Adam Niedling (krychek) wrote :

I can also confirm this bug. Java applets don't work on any of my 3 intrepid computers. I'm using sun java 6.

Changed in sun-java6:
status: Incomplete → New
Adam Niedling (krychek) wrote :

I forgot to mention that I've also tried Epiphany and java applets don't work with it either. Everything was fine in Hardy.

James Stansell (jamesstansell) wrote :

When I tried icedtea6-plugin the applet loaded and appeared to be running ok. So Morten, that would be a possible work-around. Can you give it a try?

James Stansell (jamesstansell) wrote :

Confirmed on https://www.eikbank.dk/netbank/logon/tidligere_skandiabanken_kunde with the classic plugin from sun-java{5,6}-plugin

Changed in sun-java6:
status: New → Confirmed
Morten Holmstrup (robotjox) wrote :

thanks a bunch, James - your suggestion worked!

James Stansell (jamesstansell) wrote :

Morten - that's great to hear!

I just tried with the plugin2 java plugin, and it also appears to work.

ThorbjørnTux (martsummsw) wrote :

In case anybody needs suns java it can be made to work with firefox 2.0.0.17

a) install libstdc++5 and sun-java6-plugin (sudo apt-get install libstdc++5 sun-java6-plugin)
b) download firefox 2.0.0.17 from http://www.mozilla.com/en-US/firefox/all-older.html
c) install it

go to the installation folder in a terminal and then
cd plugins

ln -s /etc/alternatives/firefox-javaplugin.so libjavaplugin.so

larmoe (larmoe) wrote :

Bug confirmed on https://shb.dk/webbank using Mozilla Firefox 3.0.3 and java6. Firefox freezes shortly after the java-applet has started. Same problem with Opera. Maybe it's related to this bug: https://bugs.launchpad.net/ubuntu/intrepid/+source/ca-certificates-java/+bug/289934.

Alexander Sack (asac) wrote :

Thorbjorn: this is really not the place to suggest other software. do that i support forums please. not in bugs.

ThorbjørnTux (martsummsw) wrote :

This Bug will occur on all danish banks that uses the BEC bank system (about 85% of them) - there are no need to confirm more of these.

@Alexander:
I would have answered Morten - however James answered first. However I felt 'my solution' was better since I have always ran into problems with som java-apps when using other than suns java-plugin (incl icedtea). I respect your big work for ubuntu - but I had hoped to not to get slammed when I try to help ubuntu and ubuntu-users with this problem.

Alexander Sack (asac) wrote :

I appreciate your willingness to help users. The point is that posting workarounds to use different software to bugs will make those bugs become a mess and will prevent us from doing proper bug work, because users will get confused and wont answer the questions I ask. There are lots of bugs that gone completely out of control because users posted workarounds there.

So please remember that in future. We have various support channels where hints about how to workaround by using different software are fitting nicely.

Alexander Sack (asac) wrote :

also, if i reply with short comments its not ment offensive ... it just means that i am processing zillions of bugs and cannot type enough to explain everything in detail to everyone. Thanks for understand this and sorry if it felt like your help isnt welcomed!

Tarik Jabri (tjabri) wrote :

I am having this problem with an e-learning website for my university. Once I log in, some java applets try to load and it causes the same freeze. Tried switching to the IcedTea plugin, but that one doesn't run the Java applets correctly. I also tried switching to plugin2, but that brought on the freeze too.

Adam Niedling (krychek) wrote :

The importance of this bug should be set to high or even critical. Java doesn't work in Intrepid...
Does it work for anyone at all?

I can confirm this as well. My netbanking (eikbank) is not working on 8.10 either. The strange thing is that is works under epiphany-browser. Maybe it is a firefox bug and not a java bug.

Adam Niedling (krychek) wrote :

My netbanking (cib bank) is not working under epiphany either. Tjansson: other java applets work for you under firefox?

amark (amark-amark) wrote :

A workaround that works for me. No idea why, but it works.

Visit the following link and wait for the java applet to load:
http://java.com/en/download/help/testvm.xml?ff3

now open the page with the applet that freezes firefox. It now works.

Adam Niedling (krychek) wrote :

The workaround described by amark does not work for me. :(

sebek (sebeeek) wrote :

Confirm problem on a fresh install of the webtool SalomeTMF (no direct link to reproduce sorry) with ubuntu Intrepid Ibex. Going to the home page (java applet for authentification) makes firefox freezes. No such problem with Hardy Heron.
Problems with both Sun java6 and OpenJDK IcedTea (set the one you want to use with sudo update-alternatives --config java ).
Problem not reproduced with epiphany-browser.
The workaround described by amark does not work for me.

Versions :

sabeille@sabeille-laptop:~/tmp/crash$ java -version
java version "1.6.0_0"
IcedTea6 1.3.1 (6b12-0ubuntu6) Runtime Environment (build 1.6.0_0-b12)
OpenJDK Server VM (build 1.6.0_0-b12, mixed mode)

sabeille@sabeille-laptop:~/tmp/crash$ java -version
java version "1.6.0_10"
Java(TM) SE Runtime Environment (build 1.6.0_10-b33)
Java HotSpot(TM) Server VM (build 11.0-b15, mixed mode)

sabeille@sabeille-laptop:~/tmp/crash$ firefox --version
Mozilla Firefox 3.0.3, Copyright (c) 1998 - 2008 mozilla.org

ThorbjørnTux (martsummsw) wrote :

Amarks workaround also does not work for me / my example.
Beside I agree with Adam that the importance of this bug should be set to high.

(Many new users giving linux a change and seeing this problem will not be impressed when java applets / their netbank does not work)

Adam Niedling (krychek) wrote :

Guess what happened.. I still have a computer with Hardy, I installed the latest updates and it broke the java applets thing too. When I tried to access my netbank a new window pops up and asks where I want to store some jnlp temporary files. The default choice is /tmp. I clicked OK and then the applet starts loading and nothing happens after that. At least firefox doesn't freeze this time.

Adam Niedling (krychek) wrote :

OK.. removing the openjdk package fixed my problem in Hardy. Issue remains in Intrepid.

Adam Niedling (krychek) wrote :
James Stansell (jamesstansell) wrote :

Is this a duplicate of Bug #288397?

santiago (chanderlie) wrote :

When I deleted ~/.java and ~/.mozilla, firefox didn't freeze in sites with java applet keyboard. However, when I reinstalled google toolbar extension, firefox freezes went back. So, I've experimented disable google toolbar extension and firefox freezes is gone. I still have flash block and google notebook extensions enabled and firefox. Maybe some firefox extensions are the cause of the problem. My java packages are:

ii java-common 0.30ubuntu3 Base of all Java packages
ii javahelp2 2.0.05-3 Java based help system
ii libcommons-codec-java 1.3-4 encoder and decoders such as Base64 and hexa
ii libcommons-lang-java 2.4-1ubuntu1 Extension of the java.lang package
ii libjaxp1.2-java 1.2.01-2 Java XML parser and transformer APIs (DOM, S
ii libjcalendar-java 1.3.2-2ubuntu1 Java date chooser bean for graphically picki
ii libjgoodies-forms-java 1.2.0-1 Framework to lay out and implement elegant S
ii librelaxng-datatype-java 1.0-2.1 Datatype interfaces for Relax NG
ii sun-java6-bin 6-10-0ubuntu2 Sun Java(TM) Runtime Environment (JRE) 6 (ar
ii sun-java6-demo 6-10-0ubuntu2 Sun Java(TM) Development Kit (JDK) 6 demos a
ii sun-java6-doc 6-10-0ubuntu2 Sun JDK(TM) Documention -- integration insta
ii sun-java6-fonts 6-10-0ubuntu2 Lucida TrueType fonts (from the Sun JRE)
ii sun-java6-javadb 6-10-0ubuntu2 Java(TM) DB, Sun Microsystems' distribution
ii sun-java6-jdk 6-10-0ubuntu2 Sun Java(TM) Development Kit (JDK) 6
ii sun-java6-jre 6-10-0ubuntu2 Sun Java(TM) Runtime Environment (JRE) 6 (ar
ii sun-java6-plugin 6-10-0ubuntu2 The Java(TM) Plug-in, Java SE 6
ii sun-java6-source 6-10-0ubuntu2 Sun Java(TM) Development Kit (JDK) 6 source

Terrax (tball-es) wrote :

I do also have this bug with intrepid and firefox 3 + java sun 6.

When I try using www.sallingbank.dk, firefox starting to freeze when it try to load the java applet. The weird this is it sometimes work.

Troels Liebe Bentsen (tlbdk) wrote :

I can confirm this bug as well, going to https://www.netbank.nordea.dk/netbank/index.jsp will hang firefox 3 with sun-java6-plugin and sun-java5-plugin when adblock-plus or no-script extension are enabled.

At least for me this seems to be a problem with sub-java*-plugin and a special type of firefox extension such as adblock-plus or no-script.

To reproduce:
1. Install and enable adblock-plus or no-script extension
2. sudo apt-get install sun-java6-plugin sun-java5-plugin

# Freeze with java 1.5
3. update-java-alternatives -s java-1.5.0-sun
4. start firfox and goto https://www.netbank.nordea.dk/netbank/index.jsp

# Freeze with java 1.6
3. update-java-alternatives -s java-6-sun
4. start firfox and goto https://www.netbank.nordea.dk/netbank/index.jsp

To fix:
1. apt-get install icedtea6-plugin
2. update-java-alternatives -s java-6-openjdk
3. start firfox and goto https://www.netbank.nordea.dk/netbank/index.jsp # Everything works as it should.

The above suggestions from Troels did not help me for eikbank.dk , but renaming the .java directory made sun-java-6 work.
I can unfortunately not reproduce the error by renaming the original .java back .

Doug Holton (edtechdev) wrote :

It doesn't hang if you switch to the new java plugin (libnpjp2.so). The new java plugin will be enabled by default in Java 6 update 11.

See https://bugs.launchpad.net/ubuntu/+source/sun-java6/+bug/291135

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers