Ubuntu

[needs-packaging] Provide Subversion 1.7.x in the Ubuntu Software Repo

Reported by che--- on 2012-03-07
118
This bug affects 22 people
Affects Status Importance Assigned to Milestone
subversion (Debian)
Fix Released
Unknown
subversion (Ubuntu)
Wishlist
Unassigned

Bug Description

Current in the Ubuntu repos only Subversion 1.6.12 is provided. And as far as I can see this version is planned for 12.04, too.
This version is outdated and only partially supported by the Apache team (see http://subversion.apache.org/docs/release-notes/). Further it should be noted that this version has new features, which make the life a bit easier with svn.

The source is available @ http://subversion.apache.org/download/

So please package and provide subversion in version 1.7.x in the upcoming Ubuntu 12.04.

Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

summary: - Provide Subversion 1.7.x in the Ubuntu Software Repo
+ [needs-packaging] Provide Subversion 1.7.x in the Ubuntu Software Repo
Changed in subversion (Ubuntu):
importance: Undecided → Wishlist
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in subversion (Ubuntu):
status: New → Confirmed
tags: added: upgrade-software-version

1.7.x was a HUGE jump from 1.6.x if only because of the move to a single .svn directory. It would be REALLY nice to get this into 12.04

Maarten Bezemer (veger) wrote :

These kind of 'core' packages are obtained from Debian. They do not provide version 1.7.x, so Ubuntu is also not providing this version as well.
I would suggest to open a report at Debian with this feature request (if there is not one already). And add the link to the report to the bug watcher, so we can keep track of their progress.

Changed in subversion (Debian):
status: Unknown → New
Maarten Bezemer (veger) wrote :

Replaced upstream report with the original report describing the progress

Changed in subversion (Debian):
status: New → Unknown
Changed in subversion (Debian):
status: Unknown → New
Chelmite (steve-kelem) wrote :

Subversion was changed to version 1.7 in Ubuntu 11.10 a few months ago.
To use 1.7, I had to convert all my subversion-controlled directories from the pre-1.7 format to the 1.7 format.

Now that I've upgraded to Ubuntu 12.04, subversion 1.6 DOES NOT WORK on 1.7-formatted subversion directories.

I have real work to do that needs subversion 1.7 asap.

Maarten Bezemer (veger) wrote :

According to the package numbers, subversion did not change to 1.7 in Oneiric... (or another other distribution): https://launchpad.net/ubuntu/+source/subversion

Did you grab the packages from another source?

Benji (benjim) wrote :

I like to support the "wish" to have version 1.7 packaged with Ubuntu 12.04. Accrding to Dominik's page [1], it should work fine with the current distribution.

[1] https://launchpad.net/~dominik-stadler/+archive/subversion-1.7

Changed in subversion (Debian):
status: New → Fix Released
Jeremy Bicha (jbicha) wrote :

Subversion 1.7.5 has been uploaded to Ubuntu 12.10 Alpha "Quantal Quetzal".

Changed in subversion (Ubuntu):
status: Confirmed → Fix Released
Simon Olofsson (simono) wrote :
Dave Vree (hdave) wrote :

@Simon -- Thanks for that backport. Subversion 1.7 is needed to get JavaHL 1.7 which is needed to run Subclipse 1.8, which is needed if you want to do a "Project->New->Maven->Check Out from SCM" and have it work!

che--- (hcguersoy) wrote :

@Simon: thnx for the good job
@Dave: if you're missing JavaHL you may try SVNKit - I use it with Subversive in STS.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.