Does not show nvidia driver if intel card is active

Bug #1126234 reported by _dan_ on 2013-02-15
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Nvidia
Undecided
Unassigned
software-properties (Ubuntu)
High
Unassigned
ubuntu-drivers-common (Ubuntu)
High
Alberto Milone

Bug Description

Since 12.10 i am unable to install the nvidia drivers via the gui, update-manager settings (Software Sources -> Additional Drivers) will not give me an option to install, just shows an empty list.
jockey-text returns an empty list aswell
"jockey-text
Additional Drivers
Searching for available drivers...
"
jockey-kde on the other hand shows a list of 6 drivers with the same title.

lspci|grep VGA shows me:

01:00.0 VGA compatible controller: NVIDIA Corporation G92 [GeForce 8800 GT] (rev a2)

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: update-manager 1:0.174.4
ProcVersionSignature: Ubuntu 3.5.0-24.37-generic 3.5.7.4
Uname: Linux 3.5.0-24-generic x86_64
ApportVersion: 2.6.1-0ubuntu10
Architecture: amd64
Date: Fri Feb 15 14:40:06 2013
GsettingsChanges:
 b'com.ubuntu.update-manager' b'first-run' b'false'
 b'com.ubuntu.update-manager' b'launch-time' b'1360933283'
 b'com.ubuntu.update-manager' b'show-details' b'true'
 b'com.ubuntu.update-manager' b'window-height' b'484'
 b'com.ubuntu.update-manager' b'window-width' b'937'
MarkForUpload: True
PackageArchitecture: all
SourcePackage: update-manager
UpgradeStatus: No upgrade log present (probably fresh install)

_dan_ (dan-void) wrote :
Robert Roth (evfool) on 2013-07-06
affects: update-manager (Ubuntu) → jockey (Ubuntu)
dino99 (9d9) wrote :

install software-properties-kde, and purge all the jockey installed packages.

Jockey has been superseded by software-properties, which now handles
third-party driver configuration.

Changed in jockey (Ubuntu):
status: New → Invalid
_dan_ (dan-void) wrote :

I did not file it against jockey, i dont see how that is invalid, freshly installed ubuntu wont give me the option to install proper nvidia drivers.

Changed in jockey (Ubuntu):
status: Invalid → Confirmed
affects: jockey (Ubuntu) → software-properties (Ubuntu)
dino99 (9d9) wrote :

Thats it, the kde team should only use software-properties, and drop jockey, as its a very buggy app. There is no issue for installing nvidia-xxx-updates from the ubuntu repo.

Changed in software-properties (Ubuntu):
status: Confirmed → Invalid
_dan_ (dan-void) wrote :

What are you talking about kde, i am not using kde at all. There is an issue, i am experiencing and reporting it.

jockey-kde was the only thing that actually showed me drivers...

Changed in software-properties (Ubuntu):
status: Invalid → Confirmed
dino99 (9d9) wrote :

hey Dan,
your installation is surely borked; better to start with a fresh installation again. If you do so, note that Raring is a better quality choice.

Changed in software-properties (Ubuntu):
status: Confirmed → Incomplete
_dan_ (dan-void) wrote :

This is really getting tiresome.
It was a *fresh* install, how would that be borked and where do you get your information that its borked? Are you guessing?
I reported the bug back when 12.10 was the latest, the bug still exists in 13.04, with a fresh install.
It worked properly with my other graphics card, just not with my old gt 8800.

Why is this bug report invalid? What information is missing?

Changed in software-properties (Ubuntu):
status: Incomplete → New
_dan_ (dan-void) wrote :

incomplete, not invalid, my apologies.

dino99 (9d9) wrote :

im very sorry for your weird experience indeed; but you really seems having oldish settings around, messing your system: i mean, those settings inside either .gconf, .local, .gnome2, .config inside your /home (ctrl+h to unhide). Rename these folders and reboot to know if that problem still persist. As i know no one else have reported your issue, the 8800gt fully works with the nvidia-319-updates driver.

Changed in software-properties (Ubuntu):
status: New → Invalid
status: Invalid → Incomplete
_dan_ (dan-void) wrote :

Ill give up, i told you its with a fresh, in other words NEW install, it is with a fresh/new install with latest 13.04 i dont know what more to tell you. Sure mark it invalid, mark it incomplete, i give up. I know how to fix this, i know how to manually install those drivers, many other ppl dont know it, they dont know how to report a bug, they dont know how to use apt, you know what will happen?
They see the sluggish behaviour of the default graphics driver and think "oh this ubuntu cant even handle simple windows properly, ill switch back to windows 7" or they look if special drivers are available and see none listed -> purge ubuntu.
i tried to be helpful and contribute and report this bug, so others may not run into this, but you are making it impossible for me to contribute.
You are not reading what i am writing and making wild assumptions about my installation and marking a bug *invalid* while glancing over the description.

I do NOT have old files lying around(its is/was a fresh install), its not the settings in .gconf, .gnome2 or whatever. It is a fresh install, 2 different versions of ubuntu(12.10 and 13.04), its an issue with jockey/software-properties or whatever and with this version of the gt880.

I give up, lets mark it invalid.

Changed in software-properties (Ubuntu):
status: Incomplete → Invalid
Changed in software-properties (Ubuntu):
status: Invalid → New
Matthew Paul Thomas (mpt) wrote :

_dan_, sorry for the bad experience you had in this bug report.

I understand how the report started out filed against update-manager: that's one of the ways to access software-properties. Unfortunately, that meant the report doesn't yet contain the hardware and driver information that would be useful in figuring out what went wrong.

If you're still willing to contribute for a few minutes, :-) could you please enter this command in a terminal:
apport-collect 1126234

That should automatically attach info relevant to the bug. Thanks!

_dan_ (dan-void) wrote :

Meanwhile i installed nvidia driver manually, wont show up as "in use driver" either.
apport-collect gives me:

"Package software-properties not installed and no hook available, ignoring"

apt-get install software-properties returns "has no installation candidate

dpkg -l|grep software-prop
ii python3-software-properties 0.92.17.1 all manage the repositories that you install software from
ii software-properties-common 0.92.17.1 all manage the repositories that you install software from (common)
ii software-properties-gtk 0.92.17.1 all manage the repositories that you install software from (gtk)

please advice ;)

Sebastien Bacher (seb128) wrote :

_dan_: could you run "ubuntu-drivers debug > log" and add the log file it creates to the bug report? that should contain the needed debug informations

_dan_ (dan-void) wrote :

Attached the requested output

_dan_ (dan-void) wrote :

After upgrading my BIOS, software-properties shows available nvidia drivers+currently installed one.
Motherboard is an Asrock b75 pro 3. Weird.

_dan_ (dan-void) wrote :

After upgrading to 13.10, even with upgraded BIOS Ubuntu does not find nvidia graficscard and offers no drivers to install.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-properties (Ubuntu):
status: New → Confirmed
Changed in ubuntu-drivers-common (Ubuntu):
status: New → Confirmed
Sergio Benjamim (sergio-br2) wrote :

Ubuntu Saucy has this problem yet, it did not recognize Nvidia GT 740M from my Asus R751JB laptop.

Description: Ubuntu Saucy Salamander (development branch)
Release: 13.10
Linux ubuntu 3.11.0-7-generic #14-Ubuntu SMP Mon Sep 16 18:37:27 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

ubuntu-drivers-common:
  Installed: 1:0.2.83
  Candidate: 1:0.2.83
  Version table:
 *** 1:0.2.83 0
        500 http://archive.ubuntu.com/ubuntu/ saucy/main amd64 Packages
        100 /var/lib/dpkg/status

software-properties-gtk:
  Installed: 0.92.25
  Candidate: 0.92.26
  Version table:
     0.92.26 0
        500 http://archive.ubuntu.com/ubuntu/ saucy/main amd64 Packages
 *** 0.92.25 0
        100 /var/lib/dpkg/status

My Hardware:

    description: Notebook
    product: X750JB (ASUS-NotebookSKU)
    vendor: ASUSTeK COMPUTER INC.
    version: 1.0
    serial: D6N0CV496603257
    width: 64 bits
    capabilities: smbios-2.7 dmi-2.7 vsyscall32
    configuration: boot=normal chassis=notebook family=X sku=ASUS-NotebookSKU uuid=80E6E821-2863-E381-3555-AC220B065291
  *-core
       description: Motherboard
       product: X750JB
       vendor: ASUSTeK COMPUTER INC.
       physical id: 0
       version: 1.0
       serial: BSN12345678901234567
       slot: MIDDLE
     *-firmware
          description: BIOS
          vendor: American Megatrends Inc.
          physical id: 0
          version: X750JB.207
          date: 05/24/2013
          size: 64KiB
          capacity: 4032KiB
          capabilities: pci upgrade shadowing cdboot bootselect socketedrom edd int13floppy1200 int13floppy720 int13floppy2880 int5printscreen int9keyboard int14serial int17printer acpi usb biosbootspecification uefi

  *-display UNCLAIMED
       description: 3D controller
       product: GK208M [GeForce GT 740M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:f7000000-f707ffff
  *-display
       description: VGA compatible controller
       product: 4th Gen Core Processor Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 06
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:46 memory:f7400000-f77fffff memory:d0000000-dfffffff ioport:f000(size=64)

Sergio Benjamim (sergio-br2) wrote :

After I install nvidia-319-updates and nvidia-prime using Synaptic, and reboot, Additional Drivers show some options (see image). The command ubuntu-drivers returns some things too:

ubuntu-drivers devices
== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
vendor : NVIDIA Corporation
model : GK208M [GeForce GT 740M]
modalias : pci:v000010DEd00001292sv00001043sd0000122Dbc03sc02i00
driver : nvidia-319 - distro non-free recommended
driver : xserver-xorg-video-nouveau - distro free builtin
driver : nvidia-319-updates - distro non-free

tags: added: saucy
tags: added: nvidia
Changed in ubuntu-drivers-common (Ubuntu):
status: Confirmed → Triaged
Changed in software-properties (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Changed in ubuntu-drivers-common (Ubuntu):
importance: Undecided → High
Changed in hundredpapercuts:
status: New → Confirmed
no longer affects: hundredpapercuts
Martin Pitt (pitti) wrote :

The ubuntu-drivers debug output that _dan_ attached looks fine, it returns several nvidia-* driver packages and marks nvidia-310 for auto-install, which sounds right. Keeping the software-properties task. There is a screenshot that shows that software-properties does offer the driver, but it's not from the original bug reporter.

Changed in ubuntu-drivers-common (Ubuntu):
status: Triaged → Invalid
Changed in software-properties (Ubuntu):
status: Triaged → New
_dan_ (dan-void) wrote :

After upgrading to saucy, the problem is back.
ubuntu-drivers debug shows the following issue:

=== log messages from detection ===
DEBUG:root:X.org log reports loaded intel driver, disabling driver nvidia-173 for hybrid system
DEBUG:root:X.org log reports loaded intel driver, disabling driver nvidia-304 for hybrid system
DEBUG:root:X.org log reports loaded intel driver, disabling driver nvidia-304-updates for hybrid system
DEBUG:root:X.org log reports loaded intel driver, disabling driver nvidia-319 for hybrid system
DEBUG:root:X.org log reports loaded intel driver, disabling driver nvidia-319-updates for hybrid system

Although my monitors are connected to the nvidia card, not the intel , and X runs via nouveau.

Changed in ubuntu-drivers-common (Ubuntu):
status: Invalid → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-properties (Ubuntu):
status: New → Confirmed
Changed in ubuntu-drivers-common (Ubuntu):
status: New → Confirmed
igork (igor.k.) wrote :

I've same issue on fresh install, the list of additional drivers is empty and screen is full of garbage.
I'm using nVidia GTX 580 on Z87 chipset motherboard, nothing is connected to intel card, only nvidia one is used. ubuntu-drivers log is attached.

Not sure that this is the right place to ask, but maybe someone knows if there is workaround for this issue? Having troubles with ubuntu install for 2 years now, primarily with screen lockup/garbage on it, even in install stage.

_dan_ (dan-void) wrote :

Workaround is to manually install the drivers via apt-get.
For the lockup/garbage you have to raise a seperate bug report.

igork (igor.k.) wrote :

I've tried to install nvidia-current (which installs nvidia-304) , and nvidia-319, both after fresh install caused kernel to halt with this message:

nvidia: module license 'NVIDIA' taints kernel.
Disabling lock debugging due to kernel taint
nvidia: module verification failed: signature and/or required key missing - tainting kernel

seems like i can't manage it to get working, thanks for reply and sorry for taking your time.

_dan_ (dan-void) wrote :

No Problem.
The tainting stuff is normal.
do a "lsmod|grep nvidia" to see if its loaded.

igork (igor.k.) wrote :

I've found workaround, went into bios and disabled integrated graphics completely. After that system was installed without any problem and I was able to select proprietary nvidia driver from "Software & updates -> additional drivers".

Hope this will help other users too.

Changed in software-properties (Ubuntu):
status: Confirmed → Triaged
Changed in ubuntu-drivers-common (Ubuntu):
status: Confirmed → Triaged
Martin Pitt (pitti) wrote :

> DEBUG:root:X.org log reports loaded intel driver, disabling driver nvidia-173 for hybrid system

_dan_, indeed we don't show the nvidia driver if the intel card is active, as at least in the past the nvidia driver was not compatible with the intel one. There has been some work in that area, I'll ask Alberto about the current state.

Changed in software-properties (Ubuntu):
status: Triaged → Invalid
summary: - Additional Drivers won't show option to install proper nvidia drivers
+ Does not show nvidia driver if intel card is active
_dan_ (dan-void) wrote :

Then dont load Intel drivers, if monitors are connected to nvidia card.
I installed nvidia manually and it works fine.

Martin Pitt (pitti) wrote :

Alberto says that with the latest nvidia-prime packages it actually behaves sensibly with hybrid. Assigning to you, for either adjusting the logic yourself, or giving me some sketch how it should behave (then I'm happy to assist in implementing it).

Changed in ubuntu-drivers-common (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
_dan_ (dan-void) wrote :

I think there is a small misunderstanding, if i read and interpret the last post right.
Its not a hybrid system, no need for nvidia-prime package.

I am running a Desktop, with an intel cpu that has a gpu built in and a seperate nvidia card.
So its not a hybrid like in laptops where it switched gpus depending on what power you need, so no optimus setup.

I am not using the gpu on the intel chip at all, but ubuntu-drivers-common still detects it and disables the use of nvidia driver even tho monitors are connected to the nvidia card and the opensource thingie is used (nouveau)

Alberto Milone (albertomilone) wrote :

@dan: in that case you should really disable the Intel GPU from the BIOS. Some BIOSes do it automatically, some require manual intervention

Cant in mine, can only choose which to use as primary (which i did, with no
effect)
Problem is tho, this is not very user friendly. A normal desktop user does
not know what a bios is, nor how to to stuff in it.
Also he/she usually does not know how to manually install nvidia drivers.
I dont think forcing users to frickle in their bios (whats the plural of
bios? biose, biosi, bioses?) is the way to go, since how should one know to
do this?
Normal user only sees "no nvidia drivers available" or does not even know
there are any and just experiences poor performance and not working games
resulting in an unhappy user.

On Tue, Jan 7, 2014 at 10:52 AM, Alberto Milone <
<email address hidden>> wrote:

> @dan: in that case you should really disable the Intel GPU from the
> BIOS. Some BIOSes do it automatically, some require manual intervention
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1126234
>
> Title:
> Does not show nvidia driver if intel card is active
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/nvidia/+bug/1126234/+subscriptions
>

Sergio Benjamim (sergio-br2) wrote :

Is this report bug for hybrid cards (Optimus technology), or to computers that it's possible disable Intel card from BIOS?

Or both?

_dan_ (dan-void) wrote :

I reported this bug for a NON hybrid system.
It just happens that my cpu has a built in gpu.

Alberto Milone (albertomilone) wrote :

Ok, thank you for reporting the problem, Dan, I'll work on a fix, at least for Ubuntu 14.04.

Sergio Benjamim (sergio-br2) wrote :

I activeted the onboard Intel in one HP desktop, and i can reproduce this issue.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1126234

tags: added: iso-testing
Changed in ubuntu-drivers-common (Ubuntu):
status: Triaged → In Progress
aljosa (aljosa-p) wrote :

Hi all,
before trying "Xubuntu 14.04 Alpha 2 live CD" on my Asus N750JV-T4069H notebook, I was hopping that new development version provides new results, something similar to the following screenshots "Kubuntu 14.04 Alpha 2 live CD" related:

http://cromalternativemoney.org/mediafiles/linux_test_1
http://cromalternativemoney.org/mediafiles/linux_test_2
http://cromalternativemoney.org/mediafiles/linux_test_3

Unfortunately, situation remains identically equal bad as described here:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1264057/comments/0

Sergio Benjamim (sergio-br2) wrote :

aljosa, your hardware probably has Optimus technology, i think it's a little different from this bug issue. Take a look at bug #1268750.

Changed in nvidia:
status: New → Invalid
neon1ks (neon1ks) wrote :

Alberto Milone,
Please, fix this bug #1268750

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-drivers-common - 1:0.2.89.3

---------------
ubuntu-drivers-common (1:0.2.89.3) trusty; urgency=low

  * debian/rules:
    - Temporarily disable all tests. We'll switch them back on as
      soon as we find out the cause of these failures.
  * tests/gpu-manager.py:
    - Do not run on anything but x86 family.

ubuntu-drivers-common (1:0.2.89.2) trusty; urgency=low

  * tests/gpu-manager.py:
    - Fix FTBFS.

ubuntu-drivers-common (1:0.2.89.1) trusty; urgency=low

  * tests/gpu-manager.py:
    - Remove leftover print that caused tests to fail in -proposed.

ubuntu-drivers-common (1:0.2.89) trusty; urgency=low

  * debian/control:
    - Breaks: nvidia-prime (<< 0.6). We don't want the gpu-manager
      to compete with the old nvidia-prime on hybrid systems.
  * share/hybrid/gpu-manager.c:
    - Fix memory leaks and complete the different test cases.
  * tests/gpu-manager.py:
    - Add test suite for gpu-manager to reproduce different
      hardware/software scenarios.
  * UbuntuDrivers/detect.py, tests/ubuntu_drivers.py:
    - Enable installing graphics drivers on laptops with hybrid
      graphics (LP: #1126234), and on desktop systems where the
      BIOS doesn't disable the integrated GPU when a discrete
      card is available (LP: #1126234). This is now possible
      thanks to the gpu-manager (now enabled by default).
  * Replace the deprecated hybrid-detect program with gpu-manager (now
    enabled by default). In case of problems with the gpu-manager, it
    can be disabled by passing "nogpumanager" as a boot parameter.
 -- Alberto Milone <email address hidden> Thu, 06 Mar 2014 16:30:54 +0100

Changed in ubuntu-drivers-common (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers