[GTK3] Navigation bar is ugly in Radiance and other light themes

Bug #828092 reported by Matthew Paul Thomas on 2011-08-17
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Matthew McGowan

Bug Description

software-center-gtk3 trunk 2114, Ubuntu Ocelot

1. Launch USC.
2. Using gnome-tweak-tool or similar, switch to the Radiance theme (or any similar light theme, such as Raleigh), and the corresponding ubuntu-mono-light icon theme.

What happens:
A. The edges of USC's Back and Forward buttons are hard to see.
B. The section buttons ("All Software", "Installed", "History" etc) have unnecessary black borders.
C. The button for the current section has an odd shiny background.
D. The section button icons are grey on grey.
E. The section button text is grey on grey.

Screenshot of Radiance: https://launchpadlibrarian.net/77454179/Navigation%20bar.png
Screenshot of Adwaita: https://launchpadlibrarian.net/78138057/software-center-gtk3.png

This bug is Low importance if bug 828073 will not be fixed, but High importance if it will be.

It may save time to fix this bug at the same time as bug 828762.

Matthew Paul Thomas (mpt) wrote :
description: updated
Jeremy Bicha (jbicha) wrote :

Could we please just use the primary-toolbar class that is used in gnome-control-center? And if we don't like the way it looks, we really ought to just theme GTK, instead of each Ubuntu app developing its own UI, inconsistent with the rest of the OS.

Code is at http://git.gnome.org/browse/gnome-control-center/tree/shell/shell.ui#n18

Beware that that key isn't recognized in Glade yet.

Matthew Paul Thomas (mpt) wrote :

There was no plan to develop a custom UI. While mocking up the new USC appearance, one of our visual designers experimented with a style for toolbars that might have become the standard for Ambiance. It turned out not to be, but the mockup wasn't updated before it was implemented.

Thanks for the pointer to the primary-toolbar class. I agree we should use it, but it's not clear to me that using it would fix any of the issues I described in this bug report. I've reported bug 828762 on the inconsistent appearance of the navigation bar as a whole.

description: updated
Jjed (jjed) wrote :

Hello,

Unfortunately, USC's custom GlobalPane widget packs some very specialized behavior that will be impossible to port to Gtk.Toolbar for UI freeze.

If we ship a theme switcher, I'd be willing to hack a provisional kludge to fix the toolbar's symbolic icon rendering. For now, I think looking decent for Radiance is an okay place to be.

Changed in software-center (Ubuntu):
status: New → Confirmed
description: updated
Matthew McGowan (mmcg069) wrote :

Hi all,

i have a branch which modifies the globalpane to inherit from a Gtk.Toolbar instead of HBox, as well it contains assorted changes to the various buttons making them consistent with the users gtk theme.

Feedback welcome.

Matthew Paul Thomas (mpt) wrote :

Ubuntu now ships Appearance settings that let you choose the Radiance theme, so this is High importance.

Changed in software-center (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
status: Triaged → In Progress
assignee: nobody → Matthew McGowan (mmcg069)
Matthew Paul Thomas (mpt) wrote :

r2158 of lp:~mmcg069/software-center/globalpane-themeability looks like a beautiful fix for this bug. Nicely done.

Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 4.1.21

---------------
software-center (4.1.21) oneiric; urgency=low

  [ Kiwinote ]
  * AUTHORS:
    - add credits for the new icon (LP: #834882)
  * a stash of unicode fixes to make s-c-gtk3 usable around the world
    (LP: #831865, LP: #834409, LP: #834312)
  * softwarecenter/db/update.py:
    - fix reinstall previous purchases (LP: #834984)
  * softwarecenter/ui/gtk3/panes/availablepane.py:
    - set title for 'previous purchases' list view (LP: #833960)
  * softwarecenter/ui/gtk3/panes/softwarepane.py:
    - fix None.copy() such that switching panes works again (LP: #834196)
  * softwarecenter/ui/gtk3/widgets/buttons.py:
    - escape application name in tiles (LP: #835876)

  [ Jacob Johan Edwards ]
  * softwarecenter/ui/gtk3/panes/softwarepane.py:
    - fix the spinner display when loading slow views (LP: #830682)

  [ Gabor Kelemen ]
  * po/POTFILES.in,
    po/POTFILES.skip:
    - update per latest configuration, add new gtk3 files

  [ Matthew McGowan ]
  * softwarecenter/ui/gtk3/widgets/buttons.py :
    - resize fix for Top Rated and What's New tiles (LP: #833697)
  * softwarecenter/ui/gtk3/views/catview_gtk.py,
    softwarecenter/ui/gtk3/widgets/containers.py:
    - disable the rendering of the checkboard pattern in the
      grid views (at request of mpt)
   * lp:~mmcg069/software-center/description-tweaks:
     - fix badly rendered package descriptions, other tweaks
       (LP: #833954)
   * lp:~mmcg069/software-center/globalpane-themeability:
     - various theming fixes (LP: #828092, LP: #830681,
       LP: #830738 and LP: #838382)

  [ Gary Lasker ]
  * software-center,
    software-center-gtk3,
    softwarecenter/db/update.py:
    - enable CJK support in Xapian (LP: #745243)
  * po/software-center.pot:
    - refresh .pot file
  * softwarecenter/ui/gtk/widgets/thumbnail.py:
    - fix missing icon in theme to let non-gtk3 version
      launch again, also fixes all gtk unit tests
  * test/test_database.py:
    - update unit test

  [ Didier Roche ]
  * softwarecenter/ui/gtk3/panes/installedpane.py,
    softwarecenter/ui/gtk3/views/appview.py,
    softwarecenter/ui/gtk3/widgets/menubutton.py,
    softwarecenter/ui/gtk3/widgets/oneconfviews.py,
    softwarecenter/db/appfilter.py,
    softwarecenter/ui/gtk3/app.py,
    data/ui/gtk3/SoftwareCenter.ui:
    - brings back OneConf to software center gtk3 with a fresh new design
      (LP: #838623)
  * debian/control:
    - depends on latest oneconf
 -- Gary Lasker <email address hidden> Thu, 01 Sep 2011 11:55:14 -0400

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers