Free licenses sould be tagged as "Libero" instead of "Open source" in italian translation

Bug #811489 reported by Lucio Crusca on 2011-07-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Undecided
Unassigned

Bug Description

Here in Italy we have a word, namely "Libero", which means "Free as in `Free speech`". In Natty Software Center tags free software licenses as "Open source", but this idiom has a debatable meaning, at least here in Italy where english is not a widely understood language, and Microsoft did a good job on confusing people between open source and shared source. If you were to ask OSI, "Open source" basically means "free as in free speech", but here few people know OSI and most ones translate Open Source literally as "sorgente aperto", which meaning, once literally translated, clashes with the meaning of "Shared source".

Sure enough, anyone reading "Open source" understands he has not to pay, but there's still a strong point in using the word "Libero" instead, both because it is an italian word and because it is the correct one.

Lucio Crusca (lucrus) on 2011-07-16
Changed in software-center (Ubuntu):
status: New → Opinion
Matthew Paul Thomas (mpt) wrote :

(Please don't use the "Opinion" state for USC bug reports. People don't realize that it is a closed state.)

Changed in software-center (Ubuntu):
assignee: nobody → Launchpad Italian translators (lp-l10n-it)
status: Opinion → New
Milo Casagrande (milo) wrote :

Hi Lucio,

thanks for your bug report.

When we first thought about the translation to give to that particular string, we thought about other possible implications, but in the end we decided to keep that string similar to the English one.

In this particular case we are talking about a license, so using "libero" for a license is not really well suited, we are considering a lot of different licenses too, all of which could have their particular meaning.

Also, consider the fact that that "same" string, is used in this case:
Open source, with proprietary part

and in this case, using "libero" is not really the best choice.

I'm marking the issue as invalid. If you would like to contact the Ubuntu Italian translation, you can use our team mail:
https://launchpad.net/~ubuntu-l10n-it

Ciao.

Changed in software-center (Ubuntu):
status: New → Invalid
assignee: Launchpad Italian translators (lp-l10n-it) → Traduttori Italiani del software di Ubuntu (ubuntu-l10n-it)
Lucio Crusca (lucrus) wrote :

Thanks Milo for the explanation.

I reported this issue in the first place because the question arose on a local LUG mailing list, so I still think that somehow the problem is there.

After reading your explanation two things seem clear to me:
1. the problem exists, because the italian team chose the lesser of two evils when they decided what to use as "open source" translation (namely they left it as it was). I suspect other translation teams faced the same problem.
2. the problem cannot be solved by the italian team, because the same string is used for other situations where it needs different translations. I think this problem is then a design flaw of Ubuntu Software Center in the way strings are used around the UI.

For those reasons I think the bug should be reopened and assigned back to USC.

Ciao
Lucio.

Changed in software-center (Ubuntu):
status: Invalid → New
Lucio Crusca (lucrus) wrote :

I can't assing the bug to USC, please someone do it for me, TIA.

Matthew Paul Thomas (mpt) wrote :

I don't know what you mean by "assign the bug to USC". Bug reports are assigned to people or teams.

Anyway, you say there is "a design flaw of Ubuntu Software Center in the way strings are used around the UI". So what is that design flaw?

Changed in software-center (Ubuntu):
assignee: Traduttori Italiani del software di Ubuntu (ubuntu-l10n-it) → nobody
status: New → Incomplete
Lucio Crusca (lucrus) wrote :

Sorry for my imprecise jargon, I supposed USC=Ubuntu Software Center developers team and assumed there existed one, but that's only my assumption.

About the design flaw: if a string has different meanings based on where it should be placed (e.g. as descriptive text for different licenses), the code should use two (three, ..., N) different strings regardless of the fact that in a particular language (english in this case) those meanings have a unique representation ("open source" in this case). USC now groups many licenses under the "open source" umbrella because in english that idiom well represents all those licences (I suppose), but in many other languages different licenses need different translations of "open source" string (see Milo's reply).

This is true for any strings, but the "open source" one in particular covers an ethical role in Ubuntu that we should take care of more than other strings cases.

Matthew Paul Thomas (mpt) wrote :

USC uses the phrase "Open source" to cover any license allowed by the "main" component license policy <http://www.ubuntu.com/project/about-ubuntu/licensing> -- not because we want it to be vague, but because there is currently no way for it to be more precise (bug 435183). I have updated the specification for being more precise to include your suggestion that the phrase should be adaptable for each license, rather than being a separate string. <https://wiki.ubuntu.com/SoftwareCenter?action=diff&rev2=529&rev1=528>

So if there is no way for the Italian translation to be better while there is a single string covering all open source licenses, maybe this is now a duplicate of bug 435183.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers