review sorting incorrect

Bug #773289 reported by Michael Vogt on 2011-04-29
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Michael Vogt
Natty
Medium
Unassigned

Bug Description

TEST CASE:
1. open software-center from stock natty (4.0)
2. navigate to inkscape
3. verify that the first review is from 2011-04-04
4. install softare-center 4.0.1 and close/reopen s-c
5. navigate to inkscape
6. verify that the reviews are sorted by: higher version / most useful / most recent

-
Binary package hint: software-center

The sorting of the reviews is currently a bit random. E.g. gimp has a wild mix of dates. Instead it should display the most useful ones first, then the most recent ones. Then older versions.

Michael Vogt (mvo) on 2011-04-29
Changed in software-center (Ubuntu):
status: New → In Progress
importance: Undecided → High
importance: High → Medium
Changed in software-center (Ubuntu Natty):
status: New → In Progress
importance: Undecided → Medium
Michael Vogt (mvo) on 2011-04-29
description: updated

Accepted software-center into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in software-center (Ubuntu Natty):
status: In Progress → Fix Committed
tags: added: verification-needed
Jean-Baptiste Lallement (jibel) wrote :

SRU verification for Natty:
I have reproduced the problem with software-center 4.0 in natty and the version of software-center 4.0.1 in -proposed doesn't fix the issue. The reviews are still unsorted.
For Gimp I have: 2011-01-29, 2011-01-31, 2011-02-20, ...
For Moovida: 2011-02-10, 2011-04-03, 2 days ago, 4 days ago

I've tried with english and french if that makes a difference.

Marking as verification-failed

tags: added: verification-failed
removed: verification-needed
Gary Lasker (gary-lasker) wrote :

Hi Jean-Baptiste, thanks very much for testing this. To clarify, the reviews sorting criteria isn't strictly by date alone. In fact, it is first by package version so that reviews for older versions get pushed to the end of the list, followed by usefulness ratings so reviews that have been rated most useful come earliest, and then finally by date so that reviews with the same usefulness rating will be sorted as most recent first.

Based on these criteria, I can verify that reviews are now sorted as expected for Inkscape, Moovida and The Gimp. However, there is a caveat in that sometimes reviews for a given upstream version are not always correctly sorted by usefulness. This is due to a separate bug and I've opened a new report for that. Please see bug 777583 for further details, including a screenshot showing this problem for the Inkscape package.

Gary Lasker (gary-lasker) wrote :

I'll set this one back to verification-needed. Please recheck this based on my clarification in comment #3 and set to verification-done if appropriate. Thanks again!

tags: added: verification-needed
removed: verification-failed
description: updated
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your clarification, that makes more sense and I updated the verification clause of the test case, but it still doesn't exactly match the sort criteria. For example, for inkscape in English the list is (Version, Usefulness, Date)
1. - / 7-7 / 2011-04-04
2. - / 4-4 / 2011-04-15
3. - / 3-3 / 2011-04-05
4. - / 4-4 / 2011-03-09
5. - / 3-5 / 2011-02-07
6. - / 1-4 / 2011-02-05
7. 0.48.0 / 20-20 / 2011-01-31
8. 0.48.0 / 10-10 / 2011-02-04
9. 0.48.0 / 5-5 / 2011-01-28
10. 0.48.0 / 2-3 / 2011-01-28

Following the sort criteria, records 3 and 4 should be inverted unless the version number includes the ubuntu version (-2ubuntuX) as well as the major version (0.48.1)

You can see this with Brasero where the last 8 results don't follow this sort order and there is no mention of the version.

I'm marking as verification-done because it is an improvement over the previous release, results are not sorted randomly, and it introduces no regression but it needs improvement.

tags: added: verification-done
removed: verification-needed
Gary Lasker (gary-lasker) wrote :

Hi Jean-Baptiste, thanks! Indeed, I also noticed the problem you mention in comment 5 and I have reported it separately in bug 777583 (see my note at the end of comment 3). I have committed a fix for that one and that'll come along with 4.0.2 when it is ready.

Thanks again!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 4.0.1

---------------
software-center (4.0.1) natty-proposed; urgency=low

  [ Michael Vogt ]
  * debian/control:
    - point to 4.0 bzr branch
  * merged lp:~mmcg069/software-center/Bug635994, many thanks
    (LP: #635994)
  * utils/submit_review.py:
    - fix missing translation (LP: #770439)
  * utils/submit_review.py:
    - improve logging on SSO failure (LP: #773214)
    - do not translate "appname" as ubuntu-sso-login will fail
      for translated names with utf8 chars (LP: #773214)
  * softwarecenter/db/reviews.py:
    - apply review sorting (LP: #773289)
  * softwarecenter/app.py:
    - do not translate "appname" as ubuntu-sso-login will fail
      for translated names with utf8 chars (LP: #773214)

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/translation-fixes-lp770439:
    - fix translation not showing up (LP: #770439)
  * softwarecenter/view/appdetailsview_gtk.py,
    softwarecenter/view/widgets/reviews.py,
    test/test_appdetails_view.py:
    - enable writing a review immediately after the package
      installation is complete, add test case (LP: #769439)
 -- Michael Vogt <email address hidden> Fri, 29 Apr 2011 16:40:32 +0200

Changed in software-center (Ubuntu Natty):
status: Fix Committed → Fix Released
Changed in software-center (Ubuntu):
status: In Progress → Fix Released
assignee: nobody → Michael Vogt (mvo)
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers