No handlers found for logger "softwarecenter.db.update"

Bug #728896 reported by dino99 on 2011-03-04
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Undecided
Aaron Peachey

Bug Description

Binary package hint: software-center

natty i386 updated

Applying updates i get this comment into details dialog box:

Updating software catalog ...
No handlers could be found for logger "softwarecenter.db.update"

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: software-center 3.1.21
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic-pae 2.6.38-rc6
Uname: Linux 2.6.38-5-generic-pae i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Fri Mar 4 08:23:11 2011
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=fr_FR:fr:en_GB:en
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

dino99 (9d9) wrote :
Robert Roth (evfool) on 2011-03-04
Changed in software-center (Ubuntu):
status: New → Confirmed
Aaron Peachey (aaronp) on 2011-03-05
Changed in software-center (Ubuntu):
assignee: nobody → Aaron Peachey (aaronp)
Aaron Peachey (aaronp) wrote :

I've fixed this locally and will upload a fix shortly.
The underlying cause of the update.py file trying to log appears to be an issue in the gnome-do.desktop file.

Output below (this output now replaces the original error):

2011-03-05 18:21:46,687 - softwarecenter.db.update - WARNING - error processing: /usr/share/app-install/desktop/gnome-do.desktop File contains parsing errors: /usr/share/app-install/desktop/gnome-do.desktop
 [line 12]: '\xd0\xb6\xd3\x99\xd0\xbd\xd0\xb5 \xd1\x82\xd0\xb0\xd2\x93\xd1\x8b \xd0\xba\xd0\xb5\xd0\xb7-\xd0\xba\xd0\xb5\xd0\xbb\xd0\xb3\xd0\xb5\xd0\xbd \xd0\xb1\xd0\xb0\xd1\x80 \xd0\xbd\xd3\x99\xd1\x80\xd1\x81\xd0\xb5\xd0\xbb\xd0\xb5\xd1\x80\xd1\x96\xd2\xa3\xd1\x96\xd0\xb7\xd0\xb1\xd0\xb5\xd0\xbd \xd0\xbc\xd2\xaf\xd0\xbc\xd0\xba\xd1\x96\xd0\xbd\xd0\xb4\xd1\x96\xd0\xb3\xd1\x96\xd0\xbd\xd1\x88\xd0\xb5 \xd0\xb6\xd1\x8b\xd0\xbb\xd0\xb4\xd0\xb0\xd0\xbc (\xd0\xb1\xd1\x96\xd1\x80\xd0\xb0\xd2\x9b \xd0\xb6\xd1\x8b\xd0\xbb\xd0\xb4\xd0\xb0\xd0\xbc\xd1\x8b\xd1\x80\xd0\xb0\xd2\x9b \xd0\xb5\xd0\xbc\xd0\xb5\xd1\x81) \xd0\xb6\xd2\xb1\xd0\xbc\xd1\x8b\xd1\x81 \xd1\x96\xd1\x81\xd1\x82\xd0\xb5\xd2\xa3\xd1\x96\xd0\xb7!\n'

Changed in software-center (Ubuntu):
status: Confirmed → In Progress
Aaron Peachey (aaronp) wrote :

Issue causing this is in the gnome-do.desktop file. Lines 11 and 12 (offending line) shown below.
On my system, this was updated on 2 March

Comment=Do things as quickly as possible (but no quicker) with your files, bookmarks, applications, music, contacts, and more!
және тағы кез-келген бар нәрселеріңізбен мүмкіндігінше жылдам (бірақ жылдамырақ емес) жұмыс істеңіз!

Aaron Peachey (aaronp) wrote :

Raised new bug for the desktop file issue in app-install-data-ubuntu. LP: #729543

dino99 (9d9) wrote :

on mine: gnome-do.desktop March 1 15:36 CET

dino99 (9d9) wrote :

have these packages installed on natty i386:

app-install-data 0.11.04.6
app-install-data-partner 12.10.10.3
app-install-data-medibuntu 10.10.0

dino99 (9d9) wrote :

wonder if i can force gnome-do.desktop to be regenerated ?

Aaron Peachey (aaronp) wrote :

I'm not sure, I'm not 100% certain how the generation of these files works. I've submitted a fix to app-install-data-ubuntu to fix the issue in the file, but I'm not 100% sure if it comes from that package or from the gnome-do package itself.

If you are keen to get rid of the error then you could just edit the gnome-do.desktop file to remove the foreign language line underneath the comment line. However, the only impact that this error should have is that GnomeDo will not appear in Software Centre so if that doesn't worry you then you can probably just wait for the fixes to happen.

dino99 (9d9) wrote :

Thanks,
i'm so a GnomeDo user, so i wait for some fixes. By the way, seems there is sad effect other than these warnings.

Aaron Peachey (aaronp) wrote :

Are you seeing something else?

dino99 (9d9) wrote :

hi Aaron,

i've made some tweaks:

first , how gnome-do.desktop is on my system:
[Desktop Entry]
X-AppInstall-Package=gnome-do
X-AppInstall-Popcon=10776
X-AppInstall-Section=universe

Name=GNOME Do
Type=Application
Exec=gnome-do
Terminal=false
Icon=gnome-do
Comment=Do things as quickly as possible (but no quicker) with your files, bookmarks, applications, music, contacts, and more!
және тағы кез-келген бар нәрселеріңізбен мүмкіндігінше жылдам (бірақ жылдамырақ емес) жұмыс істеңіз!
Categories=Utility;
X-Ubuntu-Gettext-Domain=app-install-data

so the "Comment=" part is very differnt as yours, following your #8 post, i edit it (gnome-do.desktop) and remove the cyrillic sentence, and save it. My surprise is: gedit has saved it as "Gnome Do" instead of initial "gnome-do.desktop", overriding it.
Going back to synaptic, i choose to install a package to check comments into the dialog box: nothing have change, get the same warnings. So the problem seems to be somewhere else.

dino99 (9d9) wrote :

Sorry about the typo into my previous #9 post: i'm NOT a gnome-do user, and i DONT see sad effect; so its not a big deal :)

dino99 (9d9) wrote :

One reboot later, the dialog box dont complaint about software-center. So i'm confused and dont know what to think, is it random ?

Aaron Peachey (aaronp) wrote :

Sorry not too sure. I'd suggest waiting until the fixes are released and then see if the problem is still there, as this issue may just be one symptom of another issue.
The fix for the software centre issue component of this bug will be available in the next release of Software Center. As per my post above, I've filed another bug LP: #729543 for the gnome-do.desktop file problem.

Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
dino99 (9d9) wrote :

Thanks Aaron,

latest 3.1.23.1 package take care of your fix

Aaron Peachey (aaronp) on 2011-03-13
Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
Eyad Salah (eyad-salah) wrote :

I just got this error when I ran the update-software-center command

Aaron Peachey (aaronp) wrote :

Hi ComputerJy, thanks for reporting this.
Can you please confirm which version of software centre you are using?

KevinM (kevbert1) wrote :

Got the error on the latest updates from the UK server:
Updating software catalog...this may take a moment.
No handlers could be found for logger "softwarecenter.db.update"
Software catalog update was successful.
Using software catalogue 3.1.26.8 (update from 3.1.26.3), but software centre seems to run OK.

Aaron Peachey (aaronp) wrote :

Thanks, I can't reproduce this (running this succeeds without errors on my machine) but will see if I can find a regression in the code.

Aaron Peachey (aaronp) wrote :

The change I made to fix this bug was reverted in version 3.1.25 to fix an unwanted side effect (see bug # 688682). So setting this back to confirmed and looking for a smarter way to fix it.

At the moment this is not fatal as it generally just means the cache update process tripped up on one desktop file, but this exception covers up the real cause of the error (and inevitably means the package with the broken file will not be available in software centre)

Michael Vogt (mvo) wrote :

Thanks a lot Aaron! I removed the fix-released state now.

Changed in software-center (Ubuntu):
status: Fix Released → In Progress
Aaron Peachey (aaronp) wrote :

Attached branch should (re)fix this issue.

Aaron Peachey (aaronp) on 2011-05-17
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Steph Bredenhann (bredsj) wrote :

On my 11.04 Natty x86-64 I still get this message:

No handlers could be found for logger "softwarecenter.db.update"

I can't install anything through the software centre

Kiwinote (kiwinote) wrote :

It would seem that the new branch was merged? This would have occurred after the natty release which explains the last comment.

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers