[karmic] 407 proxy authentication failure in Ubuntu software centre and IM even after applying systemwide proxy

Bug #466142 reported by rahul ranjan on 2009-10-31
58
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Aptdaemon
Undecided
Unassigned
software-center (Ubuntu)
Undecided
Unassigned

Bug Description

Description: Ubuntu 9.10
Release: 9.10

while installing pidgin from ubuntu software center
following error occured.

Failed to fetch http://ftp.iitm.ac.in/ubuntu/pool/main/p/pidgin/pidgin-data_2.6.2-1ubuntu7_all.deb 407 Proxy Authentication Required
Failed to fetch http://ftp.iitm.ac.in/ubuntu/pool/main/p/pidgin/pidgin_2.6.2-1ubuntu7_i386.deb 407 Proxy Authentication Required
Failed to fetch http://ftp.iitm.ac.in/ubuntu/pool/main/p/pidgin-libnotify/pidgin-libnotify_0.14-1ubuntu11_i386.deb 407 Proxy Authentication Required

i have applied proxy settings system wide from network proxy tool.
empathy is also not working perhaps for the same reason

synaptic package manager and firefox is working fine because they have their own proxy settings

Related branches

Luke Symes (allsymes) wrote :

Here is a patch that uses proxy authentication (if needed) for downloading screenshots and packages.

Changed in aptdaemon:
status: New → Invalid
Luke Symes (allsymes) wrote :
affects: ubuntu → software-center (Ubuntu)
rahul ranjan (imrahulranjan) wrote :

sir i'm new to ubuntu and i don't know how to apply patches..
:(

Luke Symes (allsymes) wrote :

There is a file you could edit if you needed it working instantly, however that would mean further updates would overwrite the fix. It would be best to wait until it is fixed by the developers. I have uploaded a "branch" with the proposed changes included, and I've proposed it for merging. I will investigate if I can create a package you could try out.

rahul ranjan (imrahulranjan) wrote :

thanks a lot..
i dont know much about this OS but when i was going through gconf editor i found that http proxy authentication isn't applied everywhere even after applying proxy systemwide from proxy settings tools... may be that could be a reason even empathy is not working..

i'm attaching a screenshot.. while taking screenshot i was using kde environment.. otherwise i use gnome..

Luke Symes (allsymes) wrote :

I have made my first attempt at uploading to a ppa. If you want, you can try it out (I suggest just downloading the software-center package): https://launchpad.net/~allsymes/+archive/ppa/

I tested it out and it worked with my http proxy.

rahul ranjan (imrahulranjan) wrote :

it worked!!!! thanks a lot!!! :)
i hope this will be added to main repository soon as an update!!

gumm (janhendrik-badenhorst) wrote :

Thanks Luke, same here. Your ppa works a charm

Bela Lubkin (filbo) wrote :

Hi --

I have a variant of this bug. I've installed the 1.1.0~ppa1 update and (as I suspected) it didn't fix my issue.

The issue is that software-center does not pass system-wide proxy settings to its subprocesses. This means that packages which are wrappers for alternative download methods still fail.

Two examples of such packages are flashplugin-installer and ttf-mscorefonts-installer.

Attached (evidence.tar.gz) is some terminal output, a window shot of a stuck software-center process, and a window shot of gconf-editor showing the proxy config.

software-center is perfectly happy to install normal packages; in fact it had to download flashplugin-installer.deb to get as far as it did.

The actual bug here might arguably be in some other layer -- debconf, aptd, dpkg itself?, or the individual packages (flashplug-installer). Perhaps it should even be addressed in multiple places. I encountered it with software-center so that's where I'm injecting this.

Bela Lubkin (filbo) wrote :
Luke Symes (allsymes) wrote :

Hi Bela,

The issues you mention are also a problem when using Synaptic, Update Manager, apt-get and dpkg. I think that the packages themselves use their own settings for wget (which is what they use to download their files). Each package will probably need changes to respect the system-wide proxy. (Note: this issue has been around for years.)

Bela Lubkin (filbo) wrote :

I was able to demonstrate that all of [apt-get, dpkg, aptitude, gdebi, gdebi-gtk, synaptic] _do_ allow the $http_proxy environment variable to propagate down to the package's install script, and therefore to `wget`:

   cd /var/cache/apt/archives
   rm -f flashplugin-installer*
   apt-get install flashplugin-installer # to cache it
   RMV(){ apt-get remove flashplugin-installer; }
   RMV; http_proxy=fail:// apt-get install flashplugin-installer
   RMV; http_proxy=fail:// dpkg -i flashplugin-installer*.deb
   RMV; http_proxy=fail:// aptitude reinstall flashplugin-installer
   RMV; http_proxy=fail:// gdebi flashplugin-installer*.deb
   RMV; http_proxy=fail:// gdebi-gtk flashplugin-installer*.deb
   RMV; http_proxy=fail:// synaptic& # then install flashplugin-installer

These of course all fail with a `wget` error message about wrong schema for the proxy URL; clearly demonstrating that $http_proxy got to them.

Whereas this one:

   RMV; http_proxy=fail:// software-center&

passes _no_ proxy setting to the install script -- which then proceeds to try a fruitless direct connect.

So the actual current situation is that this problem is _fixed_ for the other installers, at least the ones I tried, while software-center recreates the problem for itself by purging $http_proxy from the environment of its subprocess; or, in any case, failing to get it across to `aptd`.

The same behaviors apply with respect to synaptic & software-center when loaded from my window manager menus. $http_proxy is set by something and propagates down as it should, except in software-center.

I did not test update-manager, not knowing how to trick it into thinking a back-rev version of flashplugin-installer was on my system needing an update.

(There's another whole set of bugs with this: my GUI-configured proxy setting is supposed to be the same for all protocols, but only $http_proxy is getting into my env, and `wget`, at least, interprets this literally as proxying only HTTP.)

Andrew (and471) wrote :

Can someone test latest trunk and clarify whether this is still a bug? If so, please mark the status as confirmed

Changed in software-center (Ubuntu):
status: New → Incomplete
Luke Symes (allsymes) on 2009-11-30
Changed in software-center (Ubuntu):
status: Incomplete → Fix Committed
Nigel Babu (nigelbabu) on 2010-08-25
tags: added: patch-accepted-upstream
Omer Akram (om26er) wrote :

closing this bug as it seems no body is affected by this issue anymore

Changed in software-center (Ubuntu):
status: Fix Committed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers