SIMPLE-SCAN crashes when set to photo scanning

Bug #1769126 reported by José A. Novoa on 2018-05-04
38
This bug affects 5 people
Affects Status Importance Assigned to Milestone
simple-scan (Ubuntu)
Undecided
Unassigned

Bug Description

WHAT I EXPECTED TO HAPPEN
I expected to scan a photo and get it showing in Simple scan alongside the other pages scanned in text mode.

WHAT HAPPENS INSTEAD
Simple scan crashes when set to scan images. When scan button is pressed, the app seems to begin the scanning process, scanner takes the page (if on the ADF), the app shows as if beginning to scan and then suddenly disappears with no message shown.

However if the app is launched again, the app opens immediately showing all pages scanned up to that moment (in text mode) except for the newly scanned photo, as if the app was always there and had never closed.

When set to scan text, it is ok, but page size is much larger than actual sheet or flat-bed size (higher, actually, width is ok).

OS: Ubuntu 18.04LTS fresh install and updated
Sw centers sais: version 3.28.0-0ubuntu1
(no other OS on the computer)
Multi-function printer scanner: Brother MFC-J5330DW connected to the network (didn't try USB)
Computer: HP notebook 15-ay117ns with serial CND70308KK

Chris Rainey (ckrzen) wrote :

I found the solution, here: https://bugs.launchpad.net/ubuntu/+source/simple-scan/+bug/1777268/comments/2

I just used the 'linux-brprinter-installer-2.2.0-1' installer and then installed the newer 'brscan4-0.4.5-1.amd64.deb' over it.

I believe that rebooting or restarting the services after install _is_ required/helpful.

Good Luck!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in simple-scan (Ubuntu):
status: New → Confirmed
Chris Rainey (ckrzen) wrote :
Download full text (3.3 KiB)

I filed this bogie upstream @ https://help.brother-usa.com/app/ask:

From: <email address hidden>
Date: Tue, Jul 3, 2018 at 10:02 AM
Subject: [DCP-L2550DW] How to submit a bug-report against the "brscan4" Linux drivers [Incident: 180702-002756]
To: <*redacted*>

Image

Recently you requested personal assistance from our on-line support center. Below is a summary of your request and our response.

We are continuing to work on your issue. To update your question with additional information, click here

Subject

[DCP-L2550DW] How to submit a bug-report against the "brscan4" Linux drivers

Response By Email (Paul) (07/03/2018 11:02 AM)

Dear Chris,

Thank you for this information. I will provide your feedback to our development team.

At Your Side,
Paul
Brother

Did you know that Brother is at your side 24/7? Visit us on the web at www.brother-usa.com and see how quickly you can find drivers, user guides, videos and answers to frequently asked questions.

Customer By Service Email (CHRIS RAINEY) (07/03/2018 10:48 AM)

Hi Paul,

Thank you for your reply.

Definition of a "Bug Report":

Bug Report

A software bug is an error, flaw, failure, or fault in a computer program or system that causes it to produce an incorrect or unexpected result or to behave in unintended ways.
What Is A Bug Report? The Essential Guide To Bug Reports! - Usersnap
Usersnap

My "issue"(bug):

When I installed the Linux driver for my DCP, using the automated installer script, it pulled an older version of the "brscan4" driver: "brscan4-0.4.4-3.amd64.deb"

This older version(0.4.4-3) has an error(bug) in that it crashes the "Simple Scan" app at 24-bit dpi(Photo) mode in Ubuntu 18.04 LTS.

Manually downloading the newer(current) version of brscan4: "brscan4-0.4.5-1.amd64.deb" fixes this problem.

The automatic installer script for my DCP(and perhaps all others?): "linux-brprinter-installer-2.2.0-1" is not pulling the current version of the "brscan4" driver and is installing the older one which crashes my scanning app(simple-scan) when using the "Photo"(24-bit) setting.

Please ask the developers to update(fix) the automatic installer script: "linux-brprinter-installer-2.2.0-1".

Additional information:

1. https://bugs.launchpad.net/ubuntu/+source/simple-scan/+bug/1769126?comments=all

2. https://bugs.launchpad.net/ubuntu/+source/simple-scan/+bug/1777268

Thank you!

~Chris

Response By Email (Paul) (07/03/2018 10:24 AM)
Dear Chris,

What is the bug report? You can provide me with the information and I will send it over to the development team.

At Your Side,
Paul
Brother

Did you know that Brother is at your side 24/7? Visit us on the web at www.brother-usa.com and see how quickly you can find drivers, user guides, videos and answers to frequently asked questions.

Customer By Service Web (CHRIS RAINEY) (07/02/2018 01:18 PM)

Ubuntu 18.04 LTS
HP Slimline Desktop
DCP-L2550DW
802.11n(2.4 GHz) WiFi connection

Hello,

I just bought and set up a DCP-L2550DW printer. I need to submit a bug report against the "Driver Install Tool" on the "Downloads" page @ http://support.brother.com/g/b/downloadlist.aspx?c=us_ot&lang=en&prod=dcpl2550dw_us&os=12...

Read more...

José A. Novoa (jose-a-novoa) wrote :

Solution given by Chris Rainey (ckrainey) on 2018-07-02 solves the problem for me. Thanks a lot

Changed in simple-scan (Ubuntu):
status: Confirmed → Fix Released
status: Fix Released → Confirmed
Forrest Voight (forrestv) wrote :

I looked into this issue at length and posted a write-up here: http://forre.st/brother_printer

The gist of it is that setting up a Brother printer with an invalid model name (e.g. "MFCL5900DW" instead of "MFC-L5900DW") can cause crashes in some cases (namely simple-scan in photo mode).

Fix:

* (optional) Check "/opt/brother/scanner/brscan4/brsanenetdevice4.cfg" to see if the configured device has an invalid model name (by cross-referencing with the output of "brsaneconfig4 -q")
* Delete /opt/brother/scanner/brscan4/brsanenetdevice4.cfg
* Re-add the scanner with a command similar to "brsaneconfig4 -a name=MFC-L5900DW model=MFC-L5900DW nodename=BRN3C2AF4738657"

@Forrest Voight: Awesome write-up. Thanks!

On Sat, Feb 16, 2019 at 3:05 AM Forrest Voight <email address hidden>
wrote:

> I looked into this issue at length and posted a write-up here:
> http://forre.st/brother_printer
>
> The gist of it is that setting up a Brother printer with an invalid
> model name (e.g. "MFCL5900DW" instead of "MFC-L5900DW") can cause
> crashes in some cases (namely simple-scan in photo mode).
>
> Fix:
>
> * (optional) Check "/opt/brother/scanner/brscan4/brsanenetdevice4.cfg" to
> see if the configured device has an invalid model name (by
> cross-referencing with the output of "brsaneconfig4 -q")
> * Delete /opt/brother/scanner/brscan4/brsanenetdevice4.cfg
> * Re-add the scanner with a command similar to "brsaneconfig4 -a
> name=MFC-L5900DW model=MFC-L5900DW nodename=BRN3C2AF4738657"
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1769126
>
> Title:
> SIMPLE-SCAN crashes when set to photo scanning
>
> Status in simple-scan package in Ubuntu:
> Confirmed
>
> Bug description:
> WHAT I EXPECTED TO HAPPEN
> I expected to scan a photo and get it showing in Simple scan alongside
> the other pages scanned in text mode.
>
> WHAT HAPPENS INSTEAD
> Simple scan crashes when set to scan images. When scan button is
> pressed, the app seems to begin the scanning process, scanner takes the
> page (if on the ADF), the app shows as if beginning to scan and then
> suddenly disappears with no message shown.
>
> However if the app is launched again, the app opens immediately
> showing all pages scanned up to that moment (in text mode) except for
> the newly scanned photo, as if the app was always there and had never
> closed.
>
> When set to scan text, it is ok, but page size is much larger than
> actual sheet or flat-bed size (higher, actually, width is ok).
>
>
> OS: Ubuntu 18.04LTS fresh install and updated
> Sw centers sais: version 3.28.0-0ubuntu1
> (no other OS on the computer)
> Multi-function printer scanner: Brother MFC-J5330DW connected to the
> network (didn't try USB)
> Computer: HP notebook 15-ay117ns with serial CND70308KK
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/simple-scan/+bug/1769126/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers