Enable grilo plugin

Bug #973295 reported by Roman Yepishev on 2012-04-04
168
This bug affects 36 people
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Undecided
Unassigned

Bug Description

At the moment grilo plugin is not being built thus leaving Jamendo and UPnP out of rhythmbox. This is only a packaging issue and can be easily fixed:

debian/control:
  - Add libgrilo-0.1-dev to Build-Depends
  - Add gir1.2-grilo-0.1 to Depends on rhythmbox-plugins (or create a new package)

debian/rhythmbox-plugins.install (or specific to a new package)
  - Add usr/lib/rhythmbox/plugins/grilo

All grilo packages are now in Universe so this may not be done that easily though.

Related branches

Roman Yepishev (rye) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in rhythmbox (Ubuntu):
status: New → Confirmed
benste (benste) wrote :

Even though i don't see it as plugin in rhythmbox it does install - so my questions - isn't this bug fixed than ?

Jeremy Bicha (jbicha) wrote :

Retitling since this won't be fixed for Precise.

summary: - [precise] Enable grilo plugin
+ Enable grilo plugin
Andres Gomez (Tanty) (tanty) wrote :

This is yet not fixed in Quantal and it seems is neither fixed yet in Raring.

Also, the same problem seems to happen for Totem:
https://bugs.launchpad.net/ubuntu/+source/totem/+bug/1035701

In here there are instructions for installing through PPA in Precise:
http://bernaerts.dyndns.org/linux/240-ubuntu-precise-upnp-dlna-client
http://blog.andresgomez.org/2012/09/05/nslu2-grilo-and-upnp-in-ubuntus-gnome/

Timo Jyrinki (timo-jyrinki) wrote :

Same as with totem, grilo would need a main inclusion request so that these packages in main can build depend on it.

Changed in rhythmbox (Ubuntu):
status: Confirmed → Triaged
Timo Jyrinki (timo-jyrinki) wrote :

grilo MIR at bug #1116098.

Florian W. (florian-will) wrote :

I've modified and uploaded (to PPA) the raring rhythmbox package to enable grilo plugin support, in case anyone else wants to use this on raring:
https://launchpad.net/~florian-will/+archive/grilo-rb

luca (l-savio) wrote :

Good job Florian! ;-)

Florian W. (florian-will) wrote :

It looks like grilo is moving to main, so maybe we can get this bug fixed upstream in Trusty+1 or even Trusty?

This bug fixed plus the most recent minidlna = nice setup :) [Older minidlna releases like the one in Trusty are not compatible with current grilo.]

Florian W. (florian-will) wrote :

This is the debdiff I use in my PPA to enable grilo in the current trusty package (3.0.2-0ubuntu2).

Ordering of dependencies etc. is slightly different in the debian package… I noticed too late that it might be a good idea to reduce the debian->ubuntu diff size instead of increasing it.

The attachment "Enable grilo in rhythmbox" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Timo Jyrinki (timo-jyrinki) wrote :

I agree that once bug #1116098 is really fixed (grilo moved to main), it'd be nice to have Rhythmbox with grilo enabled.

Florian W. (florian-will) wrote :

You know Ubuntu/Canonical processes much better than I do, so I guess that Wiki page might be wrong/misleading:
https://wiki.ubuntu.com/MainInclusionProcess

It says "The MIR team reviews the reports, and sets acceptable ones to [..] Fix Committed. [..] Add the package to a seed, or as a (build-)dependency of a package in main. [..] The archive administrators will promote approved packages to main if some other package or the seeds want it"

According to that page I'd assume that someone needs to add a main dependency to grilo somewhere, like for example from rhythmbox, in order for the main inclusion process to continue. Something like the debdiff I posted above.

If that is not the case, what else needs to happen? Something the MIR team needs to do?

Timo Jyrinki (timo-jyrinki) wrote :

Hey Florian, thanks for your work with the debdiff, it works great!

I've prepared a branch (with you as the commit and upload author) to make sponsoring team's life even easier. I just capitalized the "lp" in changelog :) I've also built it in the PPA and tested myself since I needed to stream music from my DLNA server anyway: https://launchpad.net/~timo-jyrinki/+archive/grilo

Florian W. (florian-will) wrote :

Thanks Timo, it's really nice to see some DLNA love in Ubuntu.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 3.0.2-0ubuntu3

---------------
rhythmbox (3.0.2-0ubuntu3) utopic; urgency=medium

  [ Florian Will ]
  * Build and install the grilo plugin (LP: #973295)

  [ Iain Lane ]
  * debian/control.in: Update rhythmbox-plugins description to reflect plugins
    shipped.
 -- Iain Lane <email address hidden> Wed, 04 Jun 2014 15:58:57 +0100

Changed in rhythmbox (Ubuntu):
status: Triaged → Fix Released
Klaus Bielke (k-bielke) wrote :

Need grilo support backported to current LTS version (trusty, 14.04) !

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers