grilo plugins should be enabled in Totem

Bug #1035701 reported by Doug McMahon on 2012-08-11
90
This bug affects 17 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Unassigned
totem (Ubuntu)
Low
Unassigned

Bug Description

I see no good reason why they're not. For the most part they all work, any that don't are a grilo bug, (like vimeo), & shouldn't affect being enabled.
If sticking with 3.4.3/gstreamer .10/grilo 0.1 (0.1.2 is available) it would seem straightforward to enable & have installed
(inc. it in totem-plugins here in a test rebuild

If moving to totem 3.4.4+/gstreamer1.0/grilo 0.2 then have tested that here, works ok though ATM not as good as 0.1 , though again any grilo issies are grilo bugs

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: totem 3.4.3-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-9.9-generic 3.5.0
Uname: Linux 3.5.0-9-generic x86_64
ApportVersion: 2.4-0ubuntu6
Architecture: amd64
Date: Sat Aug 11 14:32:15 2012
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120707)
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: totem
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Doug McMahon (mc3man) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in totem (Ubuntu):
status: New → Confirmed
Riku Voipio (riku-voipio) wrote :

It is rather amusing, that ubuntu prides itself as "it just works" distro - yet grilo and upnp in totem work out of box in debian, and someone decided to explicitly disable in ubuntu...

Add grilo back. UPNP and friends should just work out of box, currently people write horrible instructions like the one below to make it happen:

http://bernaerts.dyndns.org/linux/240-ubuntu-precise-upnp-dlna-client

Instead, just apply this patch to totem packaging.

The attachment "Re-add grilo support." of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Micah Gersten (micahg) wrote :

This needs an FFe [1] and an MIR [2] for grilo. Unsubscribing ubuntu-sponsors until this is done

[1] https://wiki.ubuntu.com/FreezeExceptionProcess
[2] https://wiki.ubuntu.com/MainInclusionProcess

Doug McMahon (mc3man) wrote :

Considering that Ubuntu has kept the same old gst-plugins-bad0.10 source for 3 releases now there doesn't seem much point here in adding grilo.
The broken bad plugin will cause many youtube videos not to display which may lead to more bug reports
Maybe better suited to a ppa which could also offer a decent bad plugin patched to fix libgstvideoparsersbad.so (h264 parser) & even opus support in gstreamer

Feels like no ones home concerning the bad plugin

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem - 3.6.3-0ubuntu1

---------------
totem (3.6.3-0ubuntu1) raring; urgency=low

  * New upstream release
    - Really stop using the soundpitch plugin
    - Fix playback of some audio types failing
  * Add patch to use scaletempo from -good (this is an Ubuntu-local patch as
    this move has not yet happened in upstream gstreamer). Remove gstreamer
    -bad BD and dep accordingly.
  * Remove Grilo until MIRed

totem (3.6.2-0ubuntu1) UNRELEASED; urgency=low

  * New upstream release.
    - Make Ogg video streaming work again (the soundpitch plugin in
      gst-plugins-bad is broken)
    - Fix memory leaks when using download buffering
    - Fix spinning cursor when launching videos from the file manager
    - Fix bugs in video searches
    - Fix screensaver not being inhibited (browser plugin)
    - Fix some streams' video canvas being hidden (browser plugin)
  * debian/rules: Build with --fail-missing, to ensure we install everything.
    - Ignore libtotem.{,l}a since we delibrately don't install these.
  * debian/control: Refresh BDs to match configure.in

totem (3.6.0-0ubuntu1~12.10.1) quantal; urgency=low

  [ Rico Tzschichholz ]
  * New upstream release. (LP: #1042018)
    - In GNOME3 PPA since it uses gstreamer1.0 and the Ubuntu image won't
      be using that until 13.04.
    - Adds proxy support (LP: #477160)
  * debian/control.in:
    - Replace gstreamer0.10 dependencies with gstreamer1.0
    - Bump minimum glib & gtk
    - Drop mx dependency
    - Build-depend on gsettings-desktop-schemas-dev (>= 3.5.5)
    - Build-depend and depend on gstreamer1.0-plugins-bad
      (TODO: look into moving soundtouch to -good)
    - Build-depend on grilo (TODO: needs MIR) (LP: #1035701)
  * debian/totem-plugins-extra.install:
    - iplayer has been dropped
    - Add grilo plugin (but it doesn't seem to be working yet)
  * Refreshed debian/patches/91_quicklist_entries.patch
  * Dropped git patches

  [ Jeremy Bicha ]
  * debian/control.in:
    - Point to GNOME3 team bzr branch
    - Update totem-plugins-extra description & dependencies
 -- Iain Lane <email address hidden> Thu, 29 Nov 2012 17:11:44 +0000

Changed in totem (Ubuntu):
status: Confirmed → Fix Released
Timo Jyrinki (timo-jyrinki) wrote :

Putting back to Triaged, as disabled in 3.6.3-0ubuntu1. Like mentioned, grilo needs MIR:ing first, see https://wiki.ubuntu.com/MainInclusionProcess for instructions.

Changed in totem (Ubuntu):
status: Fix Released → Triaged
Chris Carlin (crcarlin) wrote :

Just to be clear about what happened above, in the Janitor's message, this bug was fixed in 3.6.0-0ubuntu1~12.10.1 but then (immediately?) unfixed in 3.6.3-0ubuntu1... is that right?

Does anyone have a ppa with packages that don't have grilo disabled?

On 01/24/2013 01:00 AM, Chris Carlin wrote:
> Just to be clear about what happened above, in the Janitor's message,
> this bug was fixed in 3.6.0-0ubuntu1~12.10.1 but then (immediately?)
> unfixed in 3.6.3-0ubuntu1... is that right?
>
> Does anyone have a ppa with packages that don't have grilo disabled?
>
probably the raring build in this ppa has an ok version, would be in the
extras package
https://launchpad.net/~gnome3-team/+archive/gnome3
Would be using gst1.0 so you'd get away from the not quite yet fix
released gst bad plugin bug that could affect many vids accessed thru grilo

Andres Gomez (Tanty) (tanty) wrote :

This is yet not fixed in Quantal and it seems is neither fixed yet in Raring.

Also, the same problem seems to happen for Rhythmbox:
https://bugs.launchpad.net/ubuntu/+source/rhythmbox/+bug/973295

In here there are instructions for installing through PPA in Precise:
http://blog.andresgomez.org/2012/09/05/nslu2-grilo-and-upnp-in-ubuntus-gnome/

Timo Jyrinki (timo-jyrinki) wrote :

Seems no-one filed the MIR yet (a pre-requirement for fixing this bug) so I did it now in bug #1116098.

Doug McMahon (mc3man) on 2014-01-20
tags: added: trusty
Changed in totem (Ubuntu):
importance: Undecided → Low
Changed in hundredpapercuts:
status: New → Triaged
importance: Undecided → Low
Florian W. (florian-will) wrote :

Since the MIR was approved, if I understand the main inclusion process correctly, someone needs to enable the grilo plugins in totem and rhythmbox and possibly other apps (i.e. add a grilo dependency from main).

Maybe this happens in time for Utopic? *crosses fingers for out-of-the-box-DLNA-experience*

Tim Lunn (darkxst) wrote :

MIR was approved so enable grilo support

Tim Lunn (darkxst) wrote :

MIR was approved so enable grilo support

Timo Jyrinki (timo-jyrinki) wrote :

Hi Tim, thanks for the debdiff!

I've prepared a branch (with you as the commit and upload author) to make sponsoring team's life even easier. I've also built it in a PPA and tested myself since I needed to stream music from my DLNA server anyway: https://launchpad.net/~timo-jyrinki/+archive/grilo

Doug McMahon (mc3man) wrote :

As far as new totem packages - may be good to edit descriptions of totem-plugins & totem-plugins-extra to reflect grilo plugin being in totem-plugins & not in totem-plugins-extra.

I guess if this if accepted & part of 14.10 then that opens the door to bugs on grilo-plugins?
(currently many of the available ones exposed in totem > browse or search either segfault, do nothing or use unsupported codec.

Sebastien Bacher (seb128) wrote :

@Doug: are you suggesting that the grilo plugin is quite buggy? in which case we should maybe reconsider enabling it

Florian W. (florian-will) wrote :

Doug: I can't test totem with grilo (I'm on trusty) so I can only speak for rhythmbox with grilo, which works almost perfectly fine (the rhythmbox-grilo plugin itself shows some strange behaviour though). I know that rhythmbox has a blacklist of grilo plugins to ignore so maybe the bad plugins are filtered.

* DLNA plugin: I have observed no crashes / misbehaviours
* Jamendo plugin: Admittedly I don't use it a lot, but I don't remember it crashing or failing
* The Guardian Videos, Radio France, Euronews: These just show no contents. Probably no audio items served through those plugins. I noticed the rhythmbox git version has some changes related to filtering out sources without audio content.

Adding a blacklist for every application that uses grilo seems overkill.

So… The DLNA plugin is probably the most important one for both, rhythmbox and totem. If some of the grilo plugins cause problems, maybe the -plugins package should be split (grilo-plugins-bad / -ugly / -whatever) or broken plugins simply removed from the package.

Andres Gomez (Tanty) (tanty) wrote :

Isn't this a problem in rythmbox's grilo plugin implementation rather than a bug in grilo plugins?

Check:
https://bugzilla.gnome.org/show_bug.cgi?id=682574

Doug McMahon (mc3man) wrote :

I'm not at machine ATM so in general - (totem
4 plugins work
Dlna
Apple trailers
Raitv
Bliptv
All the rest that totem exposes either thru 'browse' or 'search ' have issue's that either cause a segfault or nothing to happen
Note that this is with totem 3,10, 3.12 is quite different, it seems to use 'channels' where only a few are exposed.
The bad behavior in 3.10 is seen both in 14.10 & 14.04 with current grilo-plugins, plparser, ect.

Florian: I don't think rhythmbox is filtering the bad plugins, though any maintainer can confirm it. I think they just filter out those plugins not interesting for rhythmbox, maybe because there's another plugin in rhythmbox already providing such content, or just because the the content provided is of no interest (like plugins providing video, when we are interested on audio, something that have changed in upstream, as you have noticed).

So if a plugin works bad, I think the proper solution is to fix a bug for it, and if it's very urgent, maybe removing the plugin. Using a blacklist isn't a good idea.

Also, if something is working bad, it doesn't mean that the problem is in the grilo plugins. Note that Totem and in Rythmbox also have use Grilo through a totem-grilo or rhythmbox-grilo plugin. So the problem can be there.

Grilo provides a test-ui that is useful to check if the problem is in Grilo itself or in the application using it (totem/rhythmbox-plugin).

Florian W. (florian-will) wrote :

I tried to make exactly that point: grilo works fine with rhythmbox (on trusty, and ignoring a UI issue with expanding an item in the tree view that has no child containers).

If totem segfaults, that must be either due to bad grilo integration or totem uses some grilo plugins that are not used by rhythmbox and those segfault.
In the first case, someone should fix totem or totem can't use grilo. In the second case, those plugins should be identified and fixed/removed.

In any case, throwing grilo out of [all?] major music players like Ubuntu used to do is a bad idea IMHO. I've read numerous complaints about missing DLNA functionality in Ubuntu. Even getting rid of every grilo plugin other than DLNA and just using that in rhythmbox is an improvement over Trusty, where grilo exists in Universe but no[?] common music player supports it.

Doug McMahon (mc3man) wrote :

I don't think any of the 'misbehaving' plugins seen in Videos(totem) are critical or any reason to not proceed.
As far as bug reports there hasn't been any means in Ubuntu to do so yet, whether all is well in Debian no idea, maybe they all work or maybe few actually use..

Current state as seen in 14.10 fresh with ppa build.
The 4 previously mentioned work.
The rest -
youtube , search & browse segfault, (in 14.04 no segfault, just nothing, maybe a plparser issue
magnatune, nothing on either
euronews, segfault on browse
radio france, nothing on browse
guardian videos, unsupported codec or something (- generic text/html message
jamendo, nothing on browse or search (displays folders, that's all
optical media, nothing on browse
vimeo, nothing on search (finds vids, they don't playback

I've been using grilo in totem for some time, likely since 12.04. At some point all or most of the above 'worked', most have been broken for at least 6 months or longer

The one users would be likely to try is the yt one , either in search or browse. Can't see how grilo, plparser or whatever is going to keep up with youtube changes so maybe best to remove . (unless it can be fixed.. & maintained as needed

The point is that the misbehaving could be in either the grilo plugins, or in totem itself. So if the problem is in Totem, and you remove plugins from the system, then other applications that work fine with such plugins won't have the opportunity to use them.

On the other hand, such bugs could be already fixed in recent versions. Are those problems specific to Ubuntu? Any idea if they are present also in Debian?

Regarding the last paragraph, Grilo and plparser use mainly two libraries for the work: GData, that provides access to the Youtube API, and libquvi, that helps to get the real URL for further displaying. The changes that YouTube does are mainly about the later. So it totally depends on the libquvi version you have in the system. In general libquvi is pretty updated, so if you keep in sync with the latest releases very likely everthing will work fine.

Florian W. (florian-will) wrote :

Thanks Doug for your extensive plugin review. Maybe we should continue this in a new grilo-plugins bug (I noticed we can report bugs at https://bugs.launchpad.net/ubuntu/+source/grilo-plugins , is that a bad idea?).

One of them might be an actual totem bug though: jamendo works in rhythmbox (at least on 14.04). Though I noticed there is at least 1 empty folder called "Westing*House", not sure if that is a bug (related to the non-alphanumeric character?) or if it's simply served empty by jamendo. The other folders I tested work and I can listen to the contained media.

I agree that screen-scraping youtube is probably a bad idea, if that's how the youtube plugin works.
I'm not opposed to disabling most of the apparently(?) under-maintained plugins after testing them in the special grilo browse test tool. Most of the content can easily be retrieved using a web browser. While it'd be nice to search and watch youtube through totem, it's almost impossible to listen to/watch DLNA shared media without a proper client. VLC has a strange "fetch all media from the media share before doing anything" implementation leading to a few minutes wait time before I can listen to my music, XBMC is not what I'm looking for, and the other clients I know need grilo.

While this bug and the rhythmbox bug have few "affects me too" clicks, that's probably because the average user has no idea what grilo is, they just want DLNA and from a quick google search, there's almost no DLNA support in Ubuntu, so… :-) [Sorry for evangelizing all the time BTW. I'm a big fan of UPnP, but I realize this might be annoying so I'll stop now.]

Doug McMahon (mc3man) wrote :

Well I see there was an attempt to push this into utopic -proposed (failed on a dep wait though the package "libgrilo-0.2-dev" is certainly available.
The changelog is misleading as "- install grilo plugins" is not going to happen (& probably shouldn't though if not grilo-plugins-0.2 could be a suggest for totem-plugins

Also see no reason not to adjust the descriptions for both totem-plugins & totem-plugins-extra packages to reflect what they can provide

Tim Lunn (darkxst) wrote :

Doug, libgrilo will need to be promoted to main as per the MIR. Once the archive admins get to that, then it will build.

that changelog entry is referring to the totem built grilo plugins not the package

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem - 3.10.1-1ubuntu6

---------------
totem (3.10.1-1ubuntu6) utopic; urgency=medium

  * Enable grilo for upnp/dlna support (LP: #1035701)
    - bring back libgrilo-0.2-dev build-dep
    - install grilo plugins
    - drop 93_grilo_optional.patch
 -- Tim Lunn <email address hidden> Mon, 12 May 2014 16:48:28 +1000

Changed in totem (Ubuntu):
status: Triaged → Fix Released
Changed in hundredpapercuts:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.