Music residing on GVFS mounted SMB shares won't be imported

Bug #559658 reported by iGadget on 2010-04-09
152
This bug affects 35 people
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: rhythmbox

When I try to import a folder or file to Rhythmbox and that file or folder happens to reside on a GVFS mounted SMB share, I can browse the folders and files, but nothing happens when I click 'open'.

When that same file or folder is copied to the local harddrive, importing works without any problem.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: rhythmbox 0.12.8-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sat Apr 10 00:31:44 2010
ExecutablePath: /usr/bin/rhythmbox
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
ProcEnviron:
 LANGUAGE=en
 LANG=nl_NL.utf8
 SHELL=/bin/bash
SourcePackage: rhythmbox

iGadget (igadget) wrote :
Sebastien Bacher (seb128) wrote :

thank you for your bug report, do you have gstreamer0.10-gnomevfs installed? (you should not)

Changed in rhythmbox (Ubuntu):
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

the apport log seems to indicate it's not installed, should probably be sent to GNOME by somebody running into the issue

rik_j (s001852) wrote :

I have this error as well

When I try to add a folder on a smb-share, nothing happens. It worked on 9.10

rik_j, could you please click 'This bug affects me' on the top of the
page? Thanks.

FXB (fxbelloir) wrote :

Same for me with or w/o gstreamer0.10-gnomevfs installed.

iGadget (igadget) wrote :

FXB, could you please click 'This bug affects me' on the top of the
page if you haven't already done so? Thanks.

FXB (fxbelloir) wrote :

Matthijs, I already clicked.

I have the same problem and also not gstreamer0.10-gnomevfs installed. I attach a file with the output that Rhythmbox (in -d mode) gives when it tries to import a file (also importing a folder does not work)

Christopher Blake (4thblake) wrote :

I have the same problem. No gstreamer0.10-gnomevfs installed. 32 bit Lucid.

FXB (fxbelloir) wrote :

I noticed that a directory named .gstreamer-0.10 exists in my home.
I renamed it to .gstreamer-0.10.old. But when Rhythmbox is launched, a new .gstreamer-0.10 is created beside the .old one.
I confirm that .gstreamer0.10-gnomevfs is not installed.

m4t (m4t) wrote :

i can verify this in 10.04/i386 desktop. smb:// uris seem to work without issue in totem, however in rhythmbox, nothing happens. i've attached what is likely a redundant rb-debug.txt.

i see that '0.12.8-0ubuntu4' is pending, but i don't see any mention of this issue in the changes made there. perhaps this should be investigated further and considered for inclusion into the next update? i haven't hit any of the bugs fixed in that version, but because all of my media is stored on a gvfs mounted smb share, i'm unable to do anything with rhythmbox.

upon further testing, i am able to use sftp:// uri's without issue. the remote version of samba being used is 3.3.12.

thanks,
-matt

miles_g0ods (miles-treacher) wrote :

This bug has been present since at least 10.4 Beta 2, (and possibly earlier), and still affects me. Please can we get it fixed?

m4t (m4t) wrote :

still exists in 0.12.8-0ubuntu4
-matt

Leon Breedt (bitserf) wrote :

This may be related to https://bugs.launchpad.net/ubuntu/+source/gstreamer0.10/+bug/273294.

Regardless, I have found why it seems to be occurring.

It seems that entries on an SMB share do not necessarily have the G_FILE_ATTRIBUTE_ACCESS_CAN_READ attribute, therefore the check in _should_process() fails for these entries.

The result of this is that no directories are recursed into, and no files are imported, with no feedback to the user that this has occurred.

My NAS Samba version:

  MediaServer> /usr/syno/sbin/smbd --version
  Version 3.0.20b

This appears to be fixed upstream by commit a57a51913b1057c85603bf3ada52f6d76582d139 in the Rhythmbox GIT repository (patch attached), however applying that patch to the Ubuntu Rhythmbox exposes some other problems which may be because the patch modifies assumptions made by other code. E.g. Now it enumerates the directories on the NAS, but I get "not mounted" errors later halfway through the process, followed by a segfault.

Leon Breedt (bitserf) wrote :

Just to clarify, applying the patch in my previous comment does cause Rhythmbox to successfully add a number of files to its database before it crashes.

FXB (fxbelloir) wrote :

All this being said, still can't use Rhythmbox (means I have to use Listen...) with remotly stored files.

m4t (m4t) wrote :

i've checked the gnome bugzilla and there doesn't seem to be anything regarding this issue posted there. if someone already has a gnome bugzilla account, maybe they could post some info on this bug there. the url is https://bugzilla.gnome.org/simple-bug-guide.cgi?product=rhythmbox

or, if the bug is already posted there, perhaps someone could post the link.

thanks,
-matt

m4t (m4t) wrote :

i rebuild rhythmbox, with the patch applied, and the i386 .deb produced imported my library without issue. no segfaults encountered here.

-matt

FXB (fxbelloir) wrote :

Patch (.deb) worked for me.
Especially the last one built by Ubik.
http://blog.ezrodlo.pl/archeo/rhythmbox_0.12.8-0ubuntu4_i386.deb

m4t (m4t) wrote :

initial tests with '0.12.8-0ubuntu6' indicate that the problem is now fixed in the repos.

-matt

I have the same problem but with webdav mounted filesystem.
The WebDav filessystem is mounted with Nautilus.
Rhythmbox (rhythmbox_0.12.8-0ubuntu6) is then directed to the mounted filesystem.
Accessing the mounted filesystem on the command line (e.g. ls ~/.gvfs/Webdav) or through Nautilus works fine.
Playing files throught the Totem Movie Player (totem_2.30.2-0ubuntu1) works fine.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in rhythmbox (Ubuntu):
status: New → Confirmed
Attilio Pannella (ppan70) wrote :

I experienced the same problem with gvfs!
For quite some time I had been using automount for my samba shares and importing all my music from my samba server into rhythmbox was working fine.
Since I decided to get rid of automount and use gvfs to mount my shares instead, I started having this import problem as well (I'm currently using rhythmbox version 2.97 provided with Ubuntu 12.04).
Just to play, I decided to use my old automount mountpoints and actually change them to symbolic links to my gvfs entries.
In such a case, having chosen the symbolic link as the import folder, rhythmbox is now re-importing the files properly back again (and yes, I scratched the old database beforehand).
I hope this could be of some help for both troubleshooting and as a temporary dirty workaround for users.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers