Rhythmbox can not use smb:// as library location

Bug #273294 reported by Tom on 2008-09-22
256
This bug affects 36 people
Affects Status Importance Assigned to Milestone
GnomeVFS
Confirmed
Undecided
Unassigned
Rhythmbox
Invalid
Medium
gstreamer0.10 (Ubuntu)
Medium
Unassigned
Lucid
Low
Unassigned
Maverick
Medium
Unassigned
rhythmbox (Ubuntu)
High
Sebastien Bacher
Lucid
Low
Sebastien Bacher
Maverick
High
Sebastien Bacher

Bug Description

Binary package hint: rhythmbox

In current test version of Intrepid it is not possible to add a samba share as the music library location. It gives the error message "The folder contents could not be displayed.

It works in Hardy (and previous versions). I can also open the share in nautilus and play the file with totem.

Versions used:
Ubuntu Intrepid Ibex
Rhythmbox 0.11.6, package 0.11.6svn20080916-0ubuntu1
Samba 3.2.3, package 2:3.2.3-1ubuntu2
Gnome 2.23.92, package

Tom (thomas-geel) on 2008-09-22
description: updated
Tom (thomas-geel) on 2008-09-23
description: updated
Pedro Villavicencio (pedro) wrote :

thanks for your report, could you send this upstream to bugzilla.gnome.org since you're having the issue? For forwarding instructions please have a look to https://wiki.ubuntu.com/Bugs/Upstream/GNOME ; thanks in advance.

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Sebastien Bacher (seb128) wrote :
Changed in rhythmbox:
importance: Low → Medium
status: Incomplete → Triaged
Changed in rhythmbox:
status: Unknown → New
markba (mark-baaijens) wrote :

This bug only takes place when using a gvfs connection (smb://...). When mounting through smbfs in /etc/fstab, it all workes fine. This can considered as a workaround. Also, title should be changed, more detailed, Samba it self is not to blame.

There is something awfully wrong in how rhythmbox connects to gvfs.

Adding /home/dir/.gvfs/share name/ works fine.
This workaround also works for https://bugs.launchpad.net/bugs/286010

I also attach a debug-run...

jokerejoker (jokerejoker) wrote :

I don't know in what update things has been fixed but for about one week ago things startet working for me, on all my computers, with rhythmbox to connect to gvfs file shares.

Btw, I use Ubuntu Intrepid ;)

Cyril Jaquier (cyril-jaquier) wrote :

Still not working here :/ Do you need the output of "rhythmbox --debug" or do you have enough information about this bug?

Sebastien Bacher (seb128) wrote :

the bug has enough information, no need to add a new log

maybe a temporary workaround

my music files are stored in smb://mywinpc/mymusic

i tried this

gnomevfs-ls smb://mywinpc/mymusic

it asks me for a username, a domain and a password

after that, playing and importing files or folder in rhythmbox works fine for me.

can someone confirm?

Works for me on Ubuntu 8.10 x86_64

TheEfrit (theefrit) wrote :

The workaround proposed by Manu (gnomevfs-ls over the samba share) works for me too.

This is my scenario:
- client with ubuntu 8.10 x86 i386, rhythmbox version 0.11.6svn20081008-0ubuntu
- samba server ubuntu 8.10 x6_64

The credentials used by rhythmbox are stored in the gnome keyring, properly unlocked.

Hope this helps tracking down the source of the problem.

Thierry Carrez (ttx) wrote :

Fixed in Jaunty (as of 0.11.99.1)

Changed in rhythmbox:
status: Triaged → Fix Released
bingo1912 (travis-wenks) wrote :

i am using jaunty rc i386 and am having the issue on a live disk and install

i cannot use sftp or smb to play from

i tried removing the authentication from seahorse and restarted no dice

also tried the .gvfs directory also no dice

if i copy the files to the local desktop i can play no prob

this is flac and mp3 files

the server is 8.10 x64

my laptop will play

i started with jaunty alpha and used the terminal to upgrade to rc

this desktop is a clean rc install

in rythm box i get "could not open resource for reading"

Hannes Ovrén (kigurai) wrote :

I just tried with Jaunty as well, and I could NOT import music from my samba share unless I did "gnomevfs-ls smb://mywinpc/mymusic" first. After that it worked.

Madko (madko) wrote :

still not fixed in Jaunty...
At least the workaround gnomevfs-ls works.

fableman (fableman) wrote :

I got fresh install of ubunto 9.04 same error. other music players in my dist works fine but impossible to import smb: shares from Rhytmbox 0.12.0

1 comments hidden view all 104 comments
Glebushka (venom2001) wrote :

For me this showed up in Jaunty and rb 0.12.0 after 1st hybernate. Before that it was ok.

Glebushka (venom2001) wrote :

After restart it works ok. Don't know if it's the same bug. Sorry for double post.

Changed in rhythmbox:
status: New → Incomplete

As Bastien Nocera said in Gnome Buzilla, i tried to remove /usr/lib/gstreamer-0.10/libgstgnomevfs.so

I can import a folder and listen music from a smb share.

it's a good news but what about dependencies?

Sebastien Bacher (seb128) wrote :

gstreamer0.10-gnomevfs will not be installed by default on karmic

Nothing mentioned so far works for me. I'll continue to use VLC to play media off my server. Shame, I liked Rhythmbox but it appears to be broken for good. This has been an issue for a long time now.

Lightbreeze (nedhoy-gmail) wrote :

This is not a paper cut because it is not a general usability issue, but rather a bug affecting a relatively small user population.

Changed in hundredpapercuts:
status: New → Invalid
Jan Lillelund (jan-lillelund) wrote :

I have the same problem on two different machines both running ubuntu 9.04.

Emmanuels excellent suggestion of using "gnomevfs-ls smb://smbserver/mymusic" fixed the problem for me too, but it's localized to rhythmbox as VLC and Movie Player has no problems regardless of whether gnomevfs-ls has been run or not.

I am also certain there is a problem with rhythmbox as calling gstreamer directly as instructed in /usr/share/doc/rhythmbox/README.debian (i.e. gst-launch playbin uri=smb://smbserver/mymusic/musicfile.ogg) plays the music.

Jan Lillelund (jan-lillelund) wrote :

The music just stopped playing again and I got the same error again. Reissuing the gnomevfs-ls command fixed it again. The computer connects via 802.11g on an Atheros chipset which may be the cause for some minor network instability. It seems that although Ubuntu as such handles this fine, it throws Rhythmbox out of its zen...

It might be relevant to note that Rhythmbox worked fine out of the box up until a week ago (on the same WiFi connection), when update manager replaced some packages. What update manager replaced is beyond me, but if I can get some guidance, I'd be happy to provide input if it can help.

This is not a paper cut because it is not a general usability issue, but rather a bug affecting a relatively small user population.

I disagree. Rhythmbox is touted as the default music player in Ubuntu and it doesn't function properly.

Vish (vish) wrote :

@Larry Laird :
A paper cut is a minor usability annoyance that an average user would encounter on his/her first day of using a new installation of Ubuntu 9.10.

 For further info about papercuts criteria , pls read > https://wiki.ubuntu.com/PaperCut

Jan Lillelund (jan-lillelund) wrote :

I've given up on this. I am at a loss to understand how Rhythmbox can fail on a Plain Vanilla 9.04 install reading a file while using the same file system as the other applications on the system. I.e. Movie Player and Image browser can access the same SMB shares (and files for that matter) without a problem.

Having such frustratingly basic problems for so long has led me to another approach. I ditched the workstation (was only for playing music), installed Squeezeserver and am running everything over a Squeezebox. Works perfectly, has much less of a footprint, and I can now again spend my evenings listening to my favorite music. :-)

I hope that the rest of you guys who persevere longer (or has more insight) than me have more luck in getting rhytmbox to work. I still have another Ubuntu machine which exhibits the same problems....

Sebastien Bacher (seb128) wrote :

did you try moving the gstreamer gnomevfs code on the side and see if that fixes the issue?

naomi (naomikeuning) on 2009-08-06
Changed in rhythmbox (Ubuntu):
status: Fix Released → Fix Committed
Changed in rhythmbox (Ubuntu):
status: Fix Committed → Fix Released
markba (mark-baaijens) wrote :

None of the workarounds work on Jaunty
- terminal: gnomevfs-ls smb://lin01/public/music/all
- entering a ~/.gvfs path in rhythmbox preferences (this is immediately translated by the gui into smb://<server>/<share>
- removing /usr/lib/gstreamer-0.10/libgstgnomevfs.so (and rebooting)

I tried also:
- entering a ~/.gvfs path in gconf-editor
- make a connection through ssh via gvfs

In Karmic this is also not working (tried all workaround as on Jaunty). I noticed that the file libgstgnomevfs.so is indeed not installed (as indicated by Sebastian), but nevertheless, no go.

It seems like RB doesn't 'understand' gvfs, in contrast to Totem, etc. and this bug is not fixed.

It works for me here, using Karmic Beta on both the library machine and the player machine. It isn't totally bug free, as occasionally the stream apparently breaks and Rhythmbox truncates the track and moves on to the next one in playing order. But I can add files of the type smb://thepathtomymusiconthelaptop to the Rhythmbox instance on my graphics workstation and it plays them fine apart from sometimes skipping out of a track before it should end.

markba (mark-baaijens) wrote :

Very odd that in karmic it seems to work. Maybe it is something specific to my setup, but I cannot imagine that, because 'everything' except RB seems to work with gfvs. I'll do a couple of more tests, to other samba-shares on another server maybe.

Jeruvy (jeruvy) wrote :

Confirmed the workaround works on Karmic. If you access the share via 'guest' access it may require you to specify this when it requests the login details. I use user permissions and when entered the command asked for username, workgroup name and password, then mounted the drive (even though nautilus had already mounted it).

I'm not really agreeing with the fact that it's not a paper cut, since if a new user was migrating from Windows or setting up a dual-boot like the majority of new users, it's possible they would have a share with their music and would want to tell Rythmbox to look there. Since the SMB would already be available or can be setup this isn't a truly intuitive method since it would complain that a 'valid' share isn't accessible. Especially since Rythmbox is the default player. If this was not the default I'd agree with this invalidation. If I hadn't found a workaround, first I'd have looked for an alternative player, failing that I would have considered NOT using Ubuntu for this reason alone. I guess if I had never used a computer before (I think it should be assumed anyone who's used a computer has used or is using Windows due to bug#1) then I may agree, but I think they are very very rare.

Jeruvy (jeruvy) wrote :

Hmm, I guess it was a bit premature to say this workaround works. The files are capable of being imported, but not playable.

Failed to start playback of smb://jeruvy@*.mp3

These files do play in other programs.

markba (mark-baaijens) wrote :

Jeruvy said:

> If you access the share via 'guest' access it may require you to specify this when
> it requests the login details.

I have a public accessible share, so without any loginh credentials. I guess this is what my situation sets apart.

Jeruvy (jeruvy) wrote :

Could not open vfs file "smb://jeruvy@*.mp3" for reading: Access denied (16)
This would seem to be the relevant error from the debug log. Not sure why it's getting this error. Share is properly mounted and accessible.

Ubik (ubik-pl) wrote :

Hi,

OS: Ubuntu Karmic 2.6.31-16-generic #53-Ubuntu SMP Tue Dec 8 04:01:29 UTC 2009 i686 GNU/Linux
smb share(password protected) mounted with "connect to server.." bookmark

Today I installed "soundconverter" and RB started skipping out songs over my smb share.
Later I could not listen to music at all because of an "access denied" error. So I de-installed "soundconverter"
(gstreamer0.10-gnomevfs also was deleted as it is a dependency) and everything is OK.
In my case It seems that gstreamer0.10-gnomevfs broke playing over smb shares.

Upgrade from Jaunty to Karmic also breaks RB.
I can confirm that clean installation of Karmic does not have described issue.

KonTe (fkonteski) wrote :

Hi

First of all, im a noob about ubuntu but i have this bug too. And UBIK resolve it and it helped. Sorry about my english. Rhythmbox plays mp3 over SMB if u remove gstreamer0.10-gnomevfs from sinaptic. Regards

igi (igor-cali) wrote :

Hello,

Thank you KonTe, removing gstreamer0.10-gnomevfs and soundconverter worked for me too.

I hope gstreamer0.10-gnomevfs will be fixed, since i need soundconverter.
Regards.

igi (igor-cali) wrote :

I have just updated my Karmic 9.10 release with rhythmbox 0.12.5-0ubuntu5.1.
As long as gstreamer0.10-gnomevfs package is installed, rhythmbox can't access network shares.

Changed in rhythmbox (Ubuntu):
status: Fix Released → Confirmed

I upgraded as well and gstreamer0.10-gnomevfs is NOT enabled on my system and I still cannot access network shares.

Amit Kucheria (amitk) on 2010-04-20
Changed in gstreamer0.10 (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Vish (vish) on 2010-04-20
Changed in rhythmbox (Ubuntu):
status: Confirmed → Invalid
24 comments hidden view all 104 comments
romuald_geo (romuald1988) wrote :

Thank you very much Ubik , worked out for me :)

Christian C. (mellowsnow) wrote :

Hi,

I'm using a 64 bit Lucid and propose the following two workarounds:

1.) Mount only your mp3 directory and import the .gvfs folder into the library (imports everything).

2.) As I'm not happy with the first solution I developed a second approach which lets one import any folder or file from the network share. First create a symbolic link for the .gvfs directory (e.g. ln -s .gvfs/ gnome-shares). Then mount your mp3 share and import the desired data from the symbolic link (gnome-shares/somedir/...). The only problem now is that if one starts rhythmbox and the share is not mounted the imported files will be displayed as missing. To overcome this issue I edited the rhythmbox gnome menu (right click on menu -> edit menu -> rhythmbox -> edit) to mount my share before rhythmbox starts: bash -c 'gvfs-mount "smb://yourDomain;yourUser@yourServer/yourshare/"; rhythmbox %U'.

Hope it helps someone.

Ubik (ubik-pl) wrote :

Hi,

I built deb package one more time, but this time without changing the version(so it won't break rhythmbox-plugins or something else)

69da2ddbd5eef449eade39f6fbb5b884 rhythmbox_0.12.8-0ubuntu4_i386.deb

http://blog.ezrodlo.pl/archeo/rhythmbox_0.12.8-0ubuntu4_i386.deb

bohemier (bohemier) wrote :

Nice workaround Christian, Thanks

Ubik (ubik-pl) wrote :

3b69415af7190f756816f4fe90bd9f70 rhythmbox_0.12.8-0ubuntu4_amd64.deb

http://blog.ezrodlo.pl/archeo/rhythmbox_0.12.8-0ubuntu4_amd64.deb

bohemier (bohemier) wrote :

thanks Ubik for taking the time to make it for amd64

I installed your 64 bit deb Ubik but all I get are import errors.

Ubik (ubik-pl) wrote :

Purge rhythmbox packages and try again. The deb I built works for me.
If it does not work for you, use the workaround with symilnk.

OK, now I'm working! Ubik's 64 bit deb AND the removal of gstreamer0.10-gnomevfs did it for me. Thanks all, especially Ubik.

Gijs Molenaar (gijzelaar) wrote :

i've made a PPA for the fix:

https://launchpad.net/~gijzelaar/+archive/rhythmbox

You can enable this PPA by typing (in a console):
 $ sudo add-apt-repository ppa:gijzelaar/rhythmbox

and updating your system/rhythmbox.

have fun.

Nigel Morton (nigelamorton) wrote :

Gijs' PPA works for me. Many thanks.

motang (mohan-ram) wrote :

The PPA worked like a charm, thank you very much.

Changed in gstreamer0.10 (Ubuntu):
status: Confirmed → Invalid
Changed in gnome-vfs:
status: New → Invalid
Changed in rhythmbox (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Invalid → Fix Committed
Changed in rhythmbox (Ubuntu Lucid):
assignee: nobody → Sebastien Bacher (seb128)
importance: Undecided → Low
status: New → Fix Committed
Sebastien Bacher (seb128) wrote :

The upload has the change from http://git.gnome.org/browse/rhythmbox/commit/?id=4394826f36fad0ad36ea773b6d4525dfcfcd389b as well which avoid crashing with newer python, the change is already in the version which is in maverick and should avoid issues with python updates later

1 comments hidden view all 104 comments
Sebastien Bacher (seb128) wrote :
John Dong (jdong) wrote :

Is there a LP bug number for the Python initialization patch?

I'd also prefer for the SRU to use the SRU versioning scheme as outlined in https://wiki.ubuntu.com/StableReleaseUpdates but I recall we've had this conversation before.

The contents of the patch look reasonable, so ACK from me :)

Sebastien Bacher (seb128) wrote :

the bug number

tags: added: verification-needed

Accepted rhythmbox into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Sebastien Bacher (seb128) wrote :

to reply to the previous questions:

- the python issue is bug #587534, I didn't add it to the changelog though since it's not likely it will be confirmed to work on lucid since we would need a python update triggering the issue first to test it
- the versions scheme has already been discussed, the version in maverick is -1ubuntu<n> now so there is possible conflict
- thanks for reviewing the upload ;-)

darylb (darylblanc) wrote :

I enabled the lucid-proposed repository and updated rhythmbox from there.
With the new package my samba share immediately started appearing in Rhythmbox!
Thanks for fixing this!

$ apt-cache policy rhythmbox
rhythmbox:
  Installed: 0.12.8-0ubuntu6
  Candidate: 0.12.8-0ubuntu6
  Version table:
 *** 0.12.8-0ubuntu6 0
        500 http://gb.archive.ubuntu.com/ubuntu/ lucid-proposed/main Packages
        100 /var/lib/dpkg/status
     0.12.8-0ubuntu5 0
        500 http://gb.archive.ubuntu.com/ubuntu/ lucid-updates/main Packages
     0.12.8-0ubuntu3 0
        500 http://gb.archive.ubuntu.com/ubuntu/ lucid/main Packages

Gijs Molenaar (gijzelaar) wrote :

Works for me with Lucid 64, samba server is also lucid 64. Great work

Martin Pitt (pitti) on 2010-06-02
tags: added: verification-done
removed: verification-needed
bohemier (bohemier) wrote :

Works for me too, Lucid 64 with Samba-3.0.33 server. Thanks

Ubik (ubik-pl) wrote :

Ok, Lucid 64(samba 3.2.5 debian lenny)

Sarastro (sa3p83) wrote :

Unfortunately, using Rhythmbox on Lucid 64 still gives me problems. Some files will indeed play normally on the Samba share, others I receive the error message ¨text/html decoder is required to play this stream but is not installed¨. All files are *.flac so I am lost as to why some play and others do not. I only have this problem in Rhythmbox. Totem plays these files without problem.

Rhythmbox quit playing these files on 8.04 or 8.10. The only answer I have found is to rid myself of Rhythmbox.

Pedro Villavicencio (pedro) wrote :

Sarastro, may you please open a new bug report for that issue? Thanks.

romuald_geo (romuald1988) wrote :

The package in proposed repository doesn't work for me. But the one built by Ubik does the trick

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.12.8-0ubuntu6

---------------
rhythmbox (0.12.8-0ubuntu6) lucid-proposed; urgency=low

  * debian/patches/98_git_dont_require_can_read.patch:
    - git change to not require the can-read attribute to be available since
      the smb mounts sometime don't have it and that breaks import (lp: #273294)
  * debian/patches/99_git_python_initialization.patch:
    - git change to fix python initialization issues, the change is not
      technically required in lucid but it will avoid having crashes if the
      changes to python from maverick are backport to lucid later
 -- Sebastien Bacher <email address hidden> Tue, 01 Jun 2010 15:45:56 +0200

Changed in rhythmbox (Ubuntu Lucid):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Seb, please upload the SRU fix to maverick as well. Thanks!

Changed in rhythmbox (Ubuntu Maverick):
assignee: nobody → Sebastien Bacher (seb128)
importance: Medium → High
milestone: none → maverick-alpha-2
Sebastien Bacher (seb128) wrote :

the git snapshot in maverick has this change so closing the bug

Changed in rhythmbox (Ubuntu Maverick):
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :

the issue was not a gstreamer one

Changed in gstreamer0.10 (Ubuntu Lucid):
importance: Undecided → Low
status: New → Invalid
Andrew F. R. Rogers (andrewfr) wrote :

Just updated rhythmbox from the lucid-proposed repository. It now works perfectly and reads my networked music collection with no problem.

Many thanks!

Changed in rhythmbox:
importance: Unknown → Medium
status: Incomplete → Invalid

could it be this BUG did retun in the Ubuntu 12.04 x64 release?
Im having this issue since a clean installation of 12.04.

motang (mohan-ram) wrote :

I get the sound for a second and then it goes slient, but it seems the song plays vis smb:// but no sound.

vtec (vitekcvachoucek) wrote :

I can confirm reappearence of this problem in 12.04 both 32-bit and 64-bit, both clean install and upgrade. For me it is about accessing WebDAV rather then SMB. It is working flawlessly in 11.10 but in 12.04 you can only get a sound for a second and then silence. Both Rhythmbox and Banshee are affected but Totem does work properly.

I gave up on that Itunes wannabe a long time ago.

On 05/27/2012 03:15 PM, vtec wrote:
> I can confirm reappearence of this problem in 12.04 both 32-bit and
> 64-bit, both clean install and upgrade. For me it is about accessing
> WebDAV rather then SMB. It is working flawlessly in 11.10 but in 12.04
> you can only get a sound for a second and then silence. Both Rhythmbox
> and Banshee are affected but Totem does work properly.
>

Ubik (ubik-pl) wrote :

Ubuntu 12.04
3.2.0-24-generic #39-Ubuntu SMP Mon May 21 16:52:17 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Maybe I'm lucky, but playing music over smb share works for me.
As for wdav share(https) I can confitm it does not work.

Playing over a "regular" mounted SMB share into the filesystem works. However it does not on a natuilus mounted SMB link (tryed in 12.04 64bit)

Ubik (ubik-pl) wrote :

Clean install of 12.04 64 bit(virtualbox). Share mounted by nautilus. Works for me. I see only import errors(timeout)

Chris Wilson (notgary) on 2013-02-11
no longer affects: hundredpapercuts
martin (la-feuille) on 2015-12-20
Changed in gnome-vfs:
status: Invalid → Confirmed
Changed in gstreamer0.10 (Ubuntu):
status: Invalid → Confirmed
Changed in gstreamer0.10 (Ubuntu Lucid):
status: Invalid → Confirmed
Changed in gstreamer0.10 (Ubuntu Maverick):
status: Invalid → Confirmed
Rolf Leggewie (r0lf) on 2016-04-24
Changed in gstreamer0.10 (Ubuntu Lucid):
status: Confirmed → Won't Fix
Changed in gstreamer0.10 (Ubuntu Maverick):
status: Confirmed → Won't Fix
Displaying first 40 and last 40 comments. View all 104 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.