Ubuntu

Rhythmbox does not save playlist on iPod

Reported by Lorenz on 2009-12-14
140
This bug affects 26 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Medium
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs
Declined for Lucid by Sebastien Bacher
Declined for Maverick by Sebastien Bacher

Bug Description

Binary package hint: rhythmbox

this bug seems to be similar to bug #117925 which was set to 'Fix Released' in year 2008.

1. playlist: when moving a file to the playlist which is already on the iPod I can see it there, but when syncing/ejecting the iPod it looses the playlist and it's content.

2. copying a song/file from the musik folder via drag&drop directly to a iPod-playlist does not work at all. it looks like it works, because a + is on the icon but when checking the playlist no song is there. I would expect the song to be on the iPod and in the playlist where I draged it to.

version: ubuntu 9.10,
rhythmbox 0.12.5,
8GB iPod (Model No: A1285 EMC No: 2287) listed in my ubuntu as ModelNumStr: xB745

ProblemType: Bug
Architecture: amd64
Date: Mon Dec 14 20:53:20 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/rhythmbox
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027.1)
Package: rhythmbox 0.12.5-0ubuntu5
ProcEnviron:
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-16.53-generic
SourcePackage: rhythmbox
Uname: Linux 2.6.31-16-generic x86_64

Lorenz (lorenz-schwaerzler) wrote :
WeatherGod (ben-v-root) wrote :

Lorenz, thank you for reporting this issue. I am curious, was the iPod initialized by iTunes on a Mac or Windows? Depending on which OS initializes it, determines what kind of filesystem is used (hfs+ for Mac, fat32 for Windows). Knowing which file system is on the iPod will help determine your issue.

Changed in rhythmbox (Ubuntu):
status: New → Incomplete
Lorenz (lorenz-schwaerzler) wrote :

hi WeatherGod, thank you for responding to this so quickly. the iPod was used on a windows computer and was formated with it. (windows is decommissioned already. therefore I hope for full iPod support in ubuntu). is there anything else I could do to support this bug-fixing?

Changed in rhythmbox (Ubuntu):
importance: Undecided → Low
Avery (docaltmed) wrote :

Same problem. Ubuntu 9.10, Ipod Nano 3G initialized on Windows XP.

Sara Safavi (sjsafavi) wrote :

Can confirm; playlists appear to be created but don't appear on the ipod after disconnecting. Oddly I was able to create a playlist with Rhythmbox with 1 track and have it appear on disconnected ipod, however cannot further add to or modify it. Ubuntu 9.10, 3g Nano running fat32 filesystem.

WeatherGod (ben-v-root) on 2010-01-03
Changed in rhythmbox (Ubuntu):
status: Incomplete → Confirmed
Changed in rhythmbox (Ubuntu):
status: Confirmed → Triaged
Changed in rhythmbox (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
Arnaud Dessein (arnaud.dessein) wrote :

Same problem here with Karmic and an IPod formated under WIndows.

Since I am using Ubuntu (3 years), I have never been able to create any playlist with Rhytmbox. Did it already work once for someone ?
I had other problems with IPods and Rhytmbox : friends of mine complained that their IPod went completely empty after connecting to my computer at new year's Eve but that's a different problem, another bug I should open...

Thanks ;)

I just spent an hour creating a playlist on my iPod only to find out later that the playlist could not be saved, so I lost an hour's work. This is unacceptable, Rhythmbox should not allow you to create a playlist on the iPod if it cannot be saved, or should at least warn you that you will lose it once you remove the iPod. Why is this bug marked as Low priority? Surely given that data can be lost it should be marked Critical?

This affects us as well, but gtkpod doesn't display the ipod when mounted so isn't working as an alternative.

This is with Karmic and Rhythmbox 0.12.5 and a Windows formatted i-pod nano (latest generation). The ability to create playlists and drag across/sync to i-pod is critical for the way my wife uses the i-pod with her dance classes.

What isn't so far clear is if this is actually an intended feature that is broken or if we all think it ought to be a feature.

Finally, while it would be brilliant if Rhythmbox got this sorted, we need to be able to do this soon and I'm not sure what other apps will do the job. If Banshee could do this, then I'm prepared to do the workaround to get it too work. Songbird perhaps?

Thanks.

Tim Hockin (thockin-hockin) wrote :

Banshee can not make playlists on ipod either, but it is a less awful ipod experience than rhythmbox.

The only app I found to make playlists on the ipod is gtkpod. To make it find your ipod you have to unmount it from the desktop (not eject!) and then remount it from Places. Then gtkpod can find it.

<shrug>

Broken ass GNOME ....

Just for the record: I have the same problem with a Mac-formatted iPod (hfs+, no journaling). That is, the playlists get created, but there's nothing in them.

I'm using Rhythmbox 0.12.5 on Karmic.

has anyone found a work-around, yet? I want some until bug is fixed

WeatherGod (ben-v-root) wrote :

I forget which one worked for me a while back: gtkpod or hipo management tool. But one of them certainly did work.

hotani (hotani) wrote :

I've never seen playlists work in ubuntu/rhythmbox. I was hopeful after hearing about updates to rhythmbox in ubuntu 10.04, but after trying playlist modifications I see nothing has changed in that department.

I can create a playlist and it saves, but no changes to the playlist are saved. Rearranging song order, adding/removing tracks, none work in rhythmbox on ubuntu 10.04.

(though I can now drag/drop music from the ipod to the computer, and that is damn awesome)

Wesley (wesley-wezside) wrote :

I have the same issue. Nano 3rd Gen initialized on Win XP. I can however create playlists on my iPod provided I use the "Safely remove drive" when right clicking on the desktop icon. Using the Eject button either from Rhythmbox or from the desktop will effectively ignore my new playlist or any alterations I've made.

Bill Edgar (wmsedgar) wrote :

I am seeing the same issue. I have a 4th generation iPod Nano, formatted originally via Windows XP. I'm using Lucid with Rhythmbox 0.12.8. Functionality is much better than in previous versions of Rhythmbox, I can successfully add new music to my iPod via drag and drop and also create playlists. It seems I can also add songs to a playlist. However, any modifications I make to song order within the playlist are lost every time I disconnect the iPod. I've tried disconnecting the iPod various ways, nothing seems to work.

caseyboardman (casey-boardman) wrote :

1st generation 1GB shuffle, same issue. Changes are not saved on the ipod. This doesn't seem to be working in any program anymore. I did have to uninstall libgpod-common in order to get the ipod to mount itself. It was working in Karmic under KDE, I am running Gnome on Lucid now.

Lee G. (lee-in-berlin) wrote :

Green iPod shuffle 2nd Gen here. I tried "Safely remove drive" as work-around described in post #14. I also tried uninstalling libgpod-common as in post #16. Both work-arounds didn't work.

The iPod works fine under Windows XP using iTunes. I even did reset it.

I tried using gtkpod. It doesn't even recognize the iPod. Maybe gtkpod depends on hal?

If anybody wants to debug this, I'm willing to help with testing patches, etc.

Lee G. (lee-in-berlin) wrote :

Argh, meant iPod nano. Firmware version is 1.1.3.

Changed in rhythmbox:
status: Unknown → New

I also have this problem and would like this issue bumped up to a higher importance.

Here are my details.

Ipod: 5th gen 80gb formatted on windows

I used to use Amarok on Ubuntu 8.04 and everything worked fine. When I upgraded to 9.10 I got a new version of Amarok that was useless for podcasts. So I switched to Rhythmbox and it appeared to work ok. But it will not create playlists reliably. It will copy podcasts to the ipod, and will sometimes create playlists, but mostly not. It always *appears* to create the play list but the play list is almost always empty in reality. It does appear that it is creating some artifact on the ipod because when I plug it back in the play list is there, but it is empty. It appears that the ipod itself will not list an empty play list, but gtkpod does see these empty play lists and can put songs into them which them show up when the ipod is unpluged. gtkpod works fine with this ipod but does not manage podcasts so I want Rhythmbox to work properly please

Harsha (harsha-85) wrote :

Hey all ... the workaround mentioned in a reply above worked for me ... finally !!!!

Details:

iPod Nano 3G formatted on Windows XP. Trying Rhythmbox 0.12.8 on Ubuntu 10.04 Lucid.

To save the playlist and the changes in the playlist, i tried the "Safely Remove Drive" an NOT the eject from Rhythmbox.

It Worked for me ... Thanx Wesley !!!! :)

Hope it works for you guys as well ....

WeatherGod (ben-v-root) wrote :

hmm, maybe rhythmbox is not triggering an fsync() call before telling the user that it is ok to remove the device? Or, maybe it is prematurely telling the user that it is ok to disconnect? Could somebody try doing it the "wrong" way (i.e. - eject through rhythmbox), but wait about 5 minutes before disconnecting? Maybe also see if the device is still listed on the desktop even after ejecting it from rhythmbox?

james (jw-mach1) wrote :

Well WeatherGod, I did the eject through rhythmbox. the ipod (5th gen 80GB dos formatted) did get removed from the desktop. There was never a message via Ubuntu/Rhythmbox indicating ok to disconnect, but the waiting minutes after the Ipod said it was OK to disconnect had no effect. I ran these steps twice. The first time attempting to add music to a playlist, and the second time trying to create a new playlist with music. The first time, I got a segfault in messages (seen below). The second time, no seg fault but no new playlist.

Using "safely remove" seems to only sometimes work for me. I haven't found the exact magic sequence of steps to have a reliable work around.

Jul 4 12:12:46 amdblack kernel: [ 2492.721392] rhythmbox[2453]: segfault at 6369737545 ip 00007ffd96778dfd sp 00007fff81bf72b0 error 4 in libc-2.11.1.so[7ffd966fb000+178000]

This is still broken in Rhythmbox 0.13.

There is a new "Sync" feature, which allows you to select Rhythmbox playlists and sync them with the ipod, but it does not work. One time it worked with one playlist, in subsequent attempts it corrupted the ipod and it needed to be restored using itunes.

Aside from the sync feature, there is still not a way to right click on the ipod, create a new playlist, and then copy songs into the playlist.

Hi everyone,

I think I have important information about this.

I was playing with my ipod classic (ipod 6G), and I could sync it with my rhythmbox 0.12.8.

The situation is, when you create a new playlist and rename it, no changes are saved in the ipod, I don't know why, but, the only form that I could work fine was: first, connect the Ipod and create a single new playlist. Don't rename it. Just add songs as you like. Second, close rhythmbox (not only close the window, rythhmbox shouldn't be running). Third, right click on the desktop Ipod's icon and select Safetly remove.
After everything ends, you can check your Ipod's playlist and should be the New Playlist with the songs you added.
If you want, you can reconnect your ipod and, now you can rename the playlist as you wish and follow the instructions again.
For me, this works fine.

I hope this helps to all of you and to the developers.

Bye
P.D. Sorry my bad english

Changed in rhythmbox:
importance: Unknown → Medium
Changed in rhythmbox:
status: New → Fix Released
Ted_Smith (tedsmith28) wrote :

I am using Ubuntu 10.04, Rhytmbox 0.12.8 and as of 13th March 2011 I still have this exact same problem. An 8Gb iPod Nano formatted and used initially using Windows XP and iTunes.

What is the fix and where can I read about it and more importantly, how to apply it?

Ted_Smith (tedsmith28) wrote :

And to add insult to injury, I've just tried the "Create new playlist" trick by creating a new playlist and then deleting the original one. Not only did the newly created playlist in Rhytmbox not get written to the iPod, but the old playlist that I was originally trying to edit was deleted from the iPod. So it seems RB has no problem deleting stuff off it - just not adding or editing new stuff.

cometdog (ericctharley) wrote :

Not working in Rhythmbox 2.96 on Precise. Can create list in Rhythmbox and add songs to it. If I then choose to sync the ipod the list disappears. Instead, if I eject the iPod after creating the list but without syncing, I see an empty playlist on the iPod with that name.

maksymov.vlad (maksymov.vlad) wrote :

i have iPod shuffle 4g and I can't write my music on it (sync or drag'n'drop)
ubuntu 12.04 x64
rhythmbox 2.96

JanCeuleers (jan-ceuleers) wrote :

@cometdog: In the iPod's Sync menu, first disable syncing with all of your playlists. Sync. Then re-enable syncing with all of your playlists and sync again. That did it for me (Rhythmbox 2.96 on Ubuntu 12.04 and a 30GB 4th-gen iPod).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.