Ubuntu

nvidia-glx-legacy has disabled GL by default

Reported by Sitsofe Wheeler on 2007-03-10
16
Affects Status Importance Assigned to Milestone
restricted-manager (Ubuntu)
Medium
Martin Pitt
xorg (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

Description of the problem:
By default composite is enabled in xorg. However unless it is disabled or an extra option added, GL applications will be unable to run when using the binary nvidia-glx-legacy drivers.

Steps to reproduce:
1. Install Feisty (Herd 5).
2. Install
nvidia-glx-legacy
on a GeForce 1.
3. Restart gdm .
4. Run
glxgears
.

Expected result:
Spinning gears to be displayed.

Actual result:
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual

Additional information:
The following is reported in /var/log/Xorg.0.log :
(EE) GLX is not supported with the Composite extension

This can be worked around by adding either of the following to /etc/X11/xorg.conf :
Section "Extensions"
        Option "Composite" "Disable"
EndSection

or (Under Section "Device")
       Option "AllowGLXWithComposite" "True"

With regard to the later option the README has this to say:
[AllowGLXWithComposite] Enables GLX even when the Composite X extension is loaded. ENABLE AT YOUR OWN RISK. OpenGL applications will not display correctly in many circumstances with this setting enabled.

(this option has often worked for me but I don't do too much GL stuff)

This problem has also been documented over in the wiki:
https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia#head-d3968a4d3bed6eeef4b10fd3202bcdf313b1e75d

Version information:
xorg 7.2-0ubuntu6
nvidia-glx-legacy 1.0.7184+2.6.20.2-9.8

Sitsofe Wheeler (sitsofe) wrote :

Not dissimilar to Bug #90688 which was for fglrx . Behaviour might be different for the other two NVIDIA drivers.

Miłosz Kosobucki (mikom) wrote :

The problem is also present with restricted-manager. When nvidia legacy driver is installed it cannot handle composite extension. So, either composite should be disabled with driver installation or

Option "AllowGLXWithComposite" "true"

should be added to Device section in xorg.conf .

So, I can confirm the bug. It was present in edgy and now in Feisty it's still there.

Miłosz Kosobucki (mikom) wrote :

Sorry, I didn't read the whole description and submitted resolution again.

Sitsofe Wheeler (sitsofe) wrote :

Milosz:
Hey that's OK - you caught yourself in the end : ) Is there any chance you can click on "xorg (Ubuntu)" at the top and change this bug to confirmed?

Changed in xorg:
status: Unconfirmed → Confirmed
Miłosz Kosobucki (mikom) wrote :

Done.
I'm not yet familiar enough with launchpad :)

Martin Pitt (pitti) wrote :

Thanks for pointing this out. I don't have a legacy card to test this with. :/

It's easy enough to add this option by default when using r-m. Is it also required for the non-legacy driver?

Changed in xorg:
assignee: nobody → pitti
importance: Undecided → Medium
status: Confirmed → In Progress
Sitsofe Wheeler (sitsofe) wrote :

Well there are now three sets of drivers:

http://us.download.nvidia.com/XFree86/Linux-x86/1.0-9755/README/appendix-a.html
o Legacy 71xx drivers (broadly GeForce 2 and below)
o New legacy 96xx (broadly GeForce 2MX- GeForce 4 4000)
o "Supported" new drivers (broadly GeForce 5000 and above)

I strongly suspect the new drivers will no enable GL even when composite is in use as NVIDIA feel the worst of the composite problem have been ironed out in newer Xorg releases: .http://us.download.nvidia.com/XFree86/Linux-x86/1.0-9755/README/appendix-s.html

Sitsofe Wheeler (sitsofe) wrote :

Let me rewrite one of the above sentences:
I strongly suspect the new drivers will now enable GL even when composite is in use... I do not know what the situation is regarding the new legacy 96xx drivers. Information about Composite and the 7184 drivers is found here http://http.download.nvidia.com/XFree86/Linux-x86/1.0-7184/README/readme.txt under the (app-u) heading.

Miłosz Kosobucki (mikom) wrote :

So, now we will need three packages for nvidia drivers.

nvidia-glx
nvidia-glx-legacy
nvidia-glx-even-more-legacy
:)

I looked into my xorg.conf file in my other system (gentoo) where I have GeForce 6600. It didn't have AllowGLXWithComposite set and the acceleration was working so probably we don't need this option with latest drivers. However I need:

        Option "AddARGBGLXVisuals" "true"

to be set in "Screen" section to have Beryl running properly. Without it, Beryl didn't show windows decorations (however everything else, like wobbly windows, cube) was working.

Martin Pitt (pitti) on 2007-03-26
Changed in restricted-manager:
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

 restricted-manager (0.13) feisty; urgency=low
 .
   * restricted-manager: Drop 'In Use' checkboxes which could not be operated
     anyway and were confusing for too many users. Replace them with a 'status'
     text, saying 'In use', 'Needs computer restart', or nothing. (LP: #95901)
   * RestrictedManager/nvidia.py, legacy driver: Enable AllowGLXWithComposite.
     (LP: #91064)

Changed in restricted-manager:
status: Fix Committed → Fix Released
Timo Aaltonen (tjaalton) on 2007-04-03
Changed in xorg:
status: Unconfirmed → Rejected
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers