qt4 apps such as vlc: QGtkStyle was unable to detect the current GTK+ theme unless libgnome2-common is installed

Bug #1094360 reported by Doug McMahon on 2012-12-28
60
This bug affects 11 people
Affects Status Importance Assigned to Milestone
qt4-x11 (Ubuntu)
High
Dmitry Shachnev

Bug Description

This is on a fresh raring install with 12/28 image.
There seems to be no way to configure vlc or thru QT 4 settings to use the gtk+ theme, in this case ambiance.
Installing libgnome2-common, (desktop_gnome_interface.schemas), fixes this but it's not default installed nor a dep of vlc.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: vlc 2.0.5-1
ProcVersionSignature: Ubuntu 3.7.0-7.15-generic 3.7.0
Uname: Linux 3.7.0-7-generic x86_64
ApportVersion: 2.7-0ubuntu2
Architecture: amd64
Date: Fri Dec 28 16:38:23 2012
InstallationDate: Installed on 2012-12-28 (0 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20121228)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: vlc
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Doug McMahon (mc3man) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in vlc (Ubuntu):
status: New → Confirmed
affects: vlc (Ubuntu) → qt4-x11 (Ubuntu)

Took a look at which package 'fixed' this in a unity session
Installing just libgnome2-common removes the error & let's vlc theme ok with unity/ambiance

description: updated
summary: - vlc: QGtkStyle was unable to detect the current GTK+ theme
+ vlc: QGtkStyle was unable to detect the current GTK+ theme unless
+ libgnome2-common is installed
Doug McMahon (mc3man) wrote :

Specifically desktop_gnome_interface.schemas

(Putting just that file back & getting " Processing triggers for gconf2 .." & or some other "triggers" fixes here

Doug McMahon (mc3man) on 2013-01-21
description: updated
Brian Murray (brian-murray) wrote :

I have removed the tag regression-update from this bug report as the tag should be used for a regression which happened when installing a package from the -updates repository. This tag is used by the Stable Release Updates team to watch for regressions in packages from -updates and inappropriate usage of this tag makes it harder to find this category of regression. Thanks for your understanding. To learn more about how we use tags you may want to review http://wiki.ubuntu.com/Bugs/Tags.

tags: removed: regression-update
Leuke (leuke) wrote :

This bug is not limited to vlc, in fact I'm experiencing the same issue running minitube. In this case installing libgnome2-common is not a solution because, although the theme becomes Gtk, all icons keep missing.

gutigen (gutigen) wrote :

Same bug with Qbittorrent and Smplayer. Ubuntu 13.04 (updated).

Harald Sitter (apachelogger) wrote :

From a Qt POV we could only make a package suggest on gnome2-common which does not change the situation other than there being a message (when using apt-get!) that one might want t install gnome2-common too. So it probably would be better to have this pulled in by ubuntu-desktop.

affects: qt4-x11 (Ubuntu) → ubuntu-meta (Ubuntu)
Esokrates (esokrarkose) wrote :

This is true for all Qt applications on raring and should therefore be valued "high".

Deluxo (deluxo64) wrote :

Installing libgnome2-common fixes the problem for vlc, skype versions that are in default ubuntu 13.04 repos.

Doug McMahon (mc3man) on 2013-03-03
summary: - vlc: QGtkStyle was unable to detect the current GTK+ theme unless
- libgnome2-common is installed
+ qt4 apps such as vlc: QGtkStyle was unable to detect the current GTK+
+ theme unless libgnome2-common is installed
Dmitry Shachnev (mitya57) wrote :

That's because of https://bazaar.launchpad.net/~ubuntu-branches/ubuntu/raring/qt4-x11/raring/view/head:/src/gui/styles/qgtkstyle_p.cpp#L688. I'm working on a fix for Qt 5, but I'm not sure if it will be backportable to Qt 4.

affects: ubuntu-meta (Ubuntu) → qt4-x11 (Ubuntu)
Changed in qt4-x11 (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Jeremy Bicha (jbicha) on 2013-03-09
Changed in qt4-x11 (Ubuntu):
importance: Medium → High
Changed in qt4-x11 (Ubuntu):
assignee: nobody → Dmitry Shachnev (mitya57)
status: Triaged → In Progress

This bug also happens with Guitar Pro 6 which i believe uses QT 4, even though libgnome2-common is installed. It will not launch beyond the greeting screen.

Dmitry Shachnev (mitya57) wrote :

I've tried to ping Kubuntu developers about this branch without any success, so subscribing ~ubuntu-sponsors to get the fix at least uploaded. Note that the branch also fixes a FTBFS.

For those who want to test the fix, updated packages are available in ppa:mitya57/test2.

Doug McMahon (mc3man) wrote :

Works fine here, (ppa), tested fresh install with vlc, smplayer

Dimitri John Ledkov (xnox) wrote :

Core devs have upload rights into ~kubuntu-packages. So you should have earlier subscribe sponsors on the bug report, or request review from ubuntu branches on the merge proposal (like for UDD branches).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qt4-x11 - 4:4.8.4+dfsg-0ubuntu8

---------------
qt4-x11 (4:4.8.4+dfsg-0ubuntu8) raring; urgency=low

  [ Harald Sitter ]
  * Drop kdeqt.pot creation. Not used anymore (fixes build with new
    pkg-kde-tools)

  [ Dmitry Shachnev ]
  * debian/patches/kubuntu_41_remove_gtk_theme_check.diff:
    do not check that Gtk theme is not empty (LP: #1094360).
 -- Harald Sitter <email address hidden> Mon, 18 Mar 2013 11:10:45 +0100

Changed in qt4-x11 (Ubuntu):
status: In Progress → Fix Released
Dmitry Shachnev (mitya57) wrote :

This is also fixed upstream now, see https://qt.gitorious.org/qt/qt/commit/a9dc50330acee2ac.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers