7.10: Qt3 /etc/qt3/qtrc owner root result in ugly appearance

Bug #145709 reported by Savvas Radevic on 2007-09-27
62
Affects Status Importance Assigned to Milestone
qt-x11-free (Ubuntu)
Undecided
Jonathan Riddell
Gutsy
Undecided
Unassigned

Bug Description

--Changed by Saïvann--

/etc/qt3 folder is missing or empty with very low permissions ( drwxr----- 2 root root ).

Because the /etc/qt3/qtrc file doesn't exist or cannot be accessed because of the low permissions of the /etc/qt3 folder, all qt3 programs have HUGE fonts and become near to unusable.

This problem is caused by the absence of the "/etc" value in the debian/libqt3-mt.install file, so the package won't install his config files to /etc/qt3.

A quick workaround to fix that problem is to create the /etc/qt3 folder and create the file "qtrc" into that folder. qtrc file should contain this:

[3.3]
libraryPath=/usr/lib/kde3/plugins/

[General]
GUIEffects=general^eanimatecombo^e
embedFonts=true
enableXft=true
font=Sans Serif,9,-1,5,50,0,0,0,0,0
fontPath=\0
useXft=true
style=Plastik

[KDE]
contrast=7
kdeAddedLibraryPaths=/usr/lib/kde3/plugins/^e

[KWinPalette]
activeBackground=#1f26ad
activeBlend=#259bb8
activeForeground=#ffffff
activeTitleBtnBg=#e6e6e6
frame=#efefef
inactiveBackground=#cdcdcd
inactiveBlend=#ababab
inactiveForeground=#dddddd
inactiveFrame=#efefef
inactiveTitleBtnBg=#ebebeb

[Palette]
active=#000000^e#dddfe4^e#ffffff^e#ffffff^e#555555^e#c7c7c7^e#000000^e#ffffff^e#000000^e#ffffff^e#efefef^e#000000^e#678db2^e#ffffff^e#0000ee^e#52188b^e
disabled=#808080^e#dddfe4^e#ffffff^e#ffffff^e#555555^e#c7c7c7^e#c7c7c7^e#ffffff^e#808080^e#ffffff^e#efefef^e#000000^e#567594^e#ffffff^e#0000ee^e#52188b^e
inactive=#000000^e#dddfe4^e#ffffff^e#ffffff^e#555555^e#c7c7c7^e#000000^e#ffffff^e#000000^e#ffffff^e#efefef^e#000000^e#678db2^e#ffffff^e#0000ee^e#52188b^e

Savvas Radevic (medigeek) wrote :
Saivann Carignan (oxmosys) wrote :

I confirm the existence of that bug. More people experienced the same problems in the duplicate bug #119990.

Fonts are big and ugly in HPLIP and VirtualBox, running Ubuntu Gutsy with all updates.

Savvas Radevic (medigeek) wrote :

you know the package name? libqt3-mt ?

Björn (bjoernw) wrote :

yes, propably it's libqt3-mt since in feisty this package defined a global qt3-theme like medigeeks in /etc/qt3/qtrc . but in gutsy its missing.

Savvas Radevic (medigeek) wrote :

just checked the differences between libqt3-mt in feisty (7.04) and gutsy (7.10), qtrc is missing in the latter

I found the problem!

There's two reasons why this problem happens :

#1 : The /etc/qt3 folder has very low permissions which refuses anyone else than root to access or list the files

In Gutsy : drwxr----- 2 root root
In Feisty : drwxr-xr-x 2 root root

#2 : The config file /etc/qt3/qtrc doesn't exist.

It isn't created during the installation process of the libqt3-mt package. for a unknown reason, the /etc entry has been removed from the debian/libqt3-mt.install file in the source package. Re-building the source package after adding /etc gives a binary .deb which fix the problem.

I attached a Debdiff which fixes this problem.

Saivann Carignan (oxmosys) wrote :

If you want to test this, please purge the libqt3-mt package and remove the /etc/qt3 folder before installing the package :

sudo aptitude purge libqt3-mt
sudo rm /etc/qt3

The binary package is attached.

Changed in qt-x11-free:
status: Confirmed → In Progress
Saivann Carignan (oxmosys) wrote :

Here's a Debdiff between the Feisty and the Gutsy source package.

unggnu (unggnu) wrote :

I can confirm this with hp-setup of hplip package. It makes hp-setup unusable for newbies since the buttons are not accessible.

Savvas Radevic (medigeek) wrote :

I have an amd64, can you provide me with the amd64 version? or give me some more info on how to use the patch to test it?

Savvas Radevic (medigeek) wrote :

ah wait, sorry, it's an older version, will be waiting for a deb package to test it out on amd64 :)

Saivann Carignan (oxmosys) wrote :

medigeek : I provided a patch for the source package. Do you want to know the steps to apply that patch and build this package on your amd64 architecture? (It's not a very easy process, you'll need patience)

Jonathan Riddell (jr) wrote :

That debdiff has a lot of changes in it, presumably more than was intended.

I think the real culprit here is kdesudo (used as kdesu in gutsy), which should probably set $HOME to not overwrite files.

Saivann Carignan (oxmosys) wrote :

Jonathan Riddell : You took the wrong debdiff, take the first one ( debdiff.diff ), the other one is the debdiff between the feisty package and the actual Gutsy package.

Savvas Radevic (medigeek) wrote :

Saïvann Carignan: I'd prefer if you had a ready-made deb package for me to use, easier for my fingers, if it's no problem that is :)

Saivann Carignan (oxmosys) wrote :

medigeek : Sorry, I would need a amd64 computer :) . But I emailed Jonathan Riddell which is the last person who worked on that package, once he will get the good debdiff, I think that this will be fixed quickly.

Same problem on i386 and am64:

Qt 3 default appearance is horrible, but if you upgrade feisty to Gutsy, this bug don't appear.

Hurry up !! please close this bug before The stable release !!!

Savvas Radevic (medigeek) wrote :

I think it'll make it :) we're waiting for the kubuntu dev to state his opinion

Jonathan Riddell (jr) wrote :

Uploaded patch from comment 7, thanks for the fix.

Changed in qt-x11-free:
status: In Progress → Fix Released
Changed in qt-x11-free:
status: Fix Released → Fix Committed
Saivann Carignan (oxmosys) wrote :

this patch is very important and must be released with the Gutsy final or the final release will get wrong folder permissions! the patch has been uploaded since 4 days by Jonathan Riddell and is still not in the repositories.

Savvas Radevic (medigeek) wrote :

it didn't even reach the binary packages:
https://launchpad.net/ubuntu/gutsy/amd64/libqt3-mt
https://launchpad.net/ubuntu/gutsy/i386/libqt3-mt

I'll see if I can find someone to "push" it.

Saivann Carignan (oxmosys) wrote :

The patch has been rejected for final release and they took the decision to upload the patch as an update for Gutsy. I must speak with Riddell and slangasek about this choice.

Savvas Radevic (medigeek) wrote :

If it will be an update, no problem from me, but I'd hate to see users complain about the "old school" appearance of some widely applications, like virtualbox and hp

This problem is not only an appearance problem ...

In virtualbox for example but it is right for all the QT3 programs, you can't view what tab is in the foreground ...

this bug cause a problem for some people that don't see well or in the screen with bad contrast ...

Saivann Carignan (oxmosys) wrote :

The patch has been uploaded too late in the Gutsy development phase so it will be released as a update after the Final Gutsy Release. This will also give a chance to add a fix for the low permissions problem of the /etc/qt3 folder.

Jonathan Riddell takes care of this.

Jonathan Riddell (jr) wrote :
Saivann Carignan (oxmosys) wrote :

Because the package hasn't been updated for Gutsy Final Release, something need to be done around the low permissions of the /etc/qt3 folder ( this folder will not have right permissions in the final release ).

I updated the debdiff to create a postint file which will change the permissions of the /etc/qt3 folder during the installation of the package. It's the only solution I can see to fix that problem.

hasan (hassanidin) wrote :

I just upgraded to Gutsy, and added Virtualbox from

deb http://www.virtualbox.org/debian gutsy non-free

and the user interface still looks really ugly.
If the fix is committed to the repositories?

Saivann Carignan (oxmosys) wrote :

Yes it has been committed. The maintainer of the package is Jonathan Riddell. The patch as been released too late in the Gutsy development cycle so it will be released as a update for Gutsy Final Release.

Saivann Carignan (oxmosys) wrote :

the debdiff that I attached 3 comments ago is just necessary for people who installed Gutsy Alpha / Beta. I attached it in the case that it could be needed.

The debdiff used by Jonathan Riddell will work for Gutsy Final Release.

description: updated
Martin Pitt (pitti) wrote :

I rejected the upload from gutsy-proposed. To make any sense, this also needs transitional code to fix existing installations (from beta or final). Everyone who installs Kubuntu final will have such a broken directory already.

Changed in qt-x11-free:
assignee: nobody → jr
status: Fix Committed → In Progress
Saivann Carignan (oxmosys) wrote :

that's why I suggest that patch which will fix everything for everyone ( fix the bad folder permission problem and fix the absence of /etc/qt3/qtrc files )

Saivann Carignan (oxmosys) wrote :

I worked with Martin Pitt to finish the work that I've done and here's the result patch.

It has been tested by me and works flawlessly.

Martin Pitt (pitti) wrote :

Confirmed, thanks Saivann! Jonathan, please upload to gutsy-proposed.

Jonathan Riddell (jr) wrote :

Uploaded

Changed in qt-x11-free:
status: In Progress → Fix Committed
Jonathan Riddell (jr) wrote :

Uploaded as 3.3.8really3.3.7-0ubuntu11.1

Saivann Carignan (oxmosys) wrote :

I still don't seem it in the repositories, is it all Ok?

Martin Pitt (pitti) wrote :

Accepted into gutsy-proposed.

Changed in qt-x11-free:
status: New → Fix Committed
Matt Austin (mattaustin) wrote :

I still can't find this package in gutsy-proposed as an update? Is it available?

Apologies if this is a stupid question.

Conrad Knauer (atheoi) wrote :

Matt Austin: I was a little confused too; the 11.1 package version Jonathan Riddell spoke of appears to be source code only for now.

Note the files:

qt-x11-free_3.3.8really3.3.7-0ubuntu11.1.diff.gz
qt-x11-free_3.3.8really3.3.7-0ubuntu11.1.dsc

in http://archive.ubuntu.com/ubuntu/pool/main/q/qt-x11-free/

I'm guessing that its just a matter of time before they're built into binaries; qt-x11-free appears to be the source package that produces binary packages

libqt3-mt-psql, libqt3-i18n, libqt3-headers, qt3-doc, libqt3-mt, qt3-designer, qt3-dev-tools-compat, libqt3-mt-sqlite, libqt3-mt-dev, qt3-apps-dev, libqt3-mt-mysql, qt3-assistant, qt3-qtconfig, qt3-linguist, qt3-dev-tools, qt3-examples, libqt3-mt-odbc, qt-x11-free-dbg, libqt3-compat-headers, qt3-dev-tools-embedded

as per http://archive.ubuntu.com/ubuntu/dists/gutsy-proposed/main/source/Sources.gz

Someone please correct me if I'm mistaken however :)

Martin Pitt (pitti) wrote :

Sorry, the buildds are hogged due to the thousands of new packages in Hardy. I bumped the build priority of this update now, it should be available in a few hours.

Saivann Carignan (oxmosys) wrote :

Updated today! It works, thanks to everybody who spent time on this!

Changed in qt-x11-free:
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
Daniel Hahler (blueyed) wrote :

Back to "Fix Committed": it's only in -proposed yet and needs verification (see https://wiki.ubuntu.com/SRU).

Changed in qt-x11-free:
status: Fix Released → Fix Committed
Matt Austin (mattaustin) wrote :

I have also successfully applied the update. Thanks to all those who resolved this.

Conrad Knauer (atheoi) wrote :

I too downloaded the gutsy-proposed version and it works great! (I deleted ~/.qt first, just to be sure that it would work)

Screenshot of a beautiful Virtualbox-OSE attached!

Brian Murray (brian-murray) wrote :

I have installed libqt3-mt version 3:3.3.8really3.3.7-0ubuntu11.1 from gutsy-proposed and now an /etc/qt3/ directory exists on my system while with 3.3.8really3.3.7-0ubuntu11 the directory was not created.

Martin Pitt (pitti) wrote :

Copied to gutsy-updates.

Changed in qt-x11-free:
status: Fix Committed → Fix Released
Apostolos Giokas (t-giokas) wrote :

As soon as I update to version 3:3.3.8really3.3.7-0ubuntu11.1: on my ubuntu 7.10 pc
all my kde applications were unable to start.

There were no symbolic links to the /usr/lib/libqt-mt.so.3.3.8
I didn't work when I created them myself
/usr/lib/libqt-mt.so.3 -> /usr/lib/libqt-mt.so.3.3.8

I had to downgrade again.

Conrad Knauer (atheoi) wrote :

Apostolos Giokas: That's odd; Kbounce and K3b still work find on Ubuntu for me.

Also, it might be that you couldn't create a link to "ibqt-mt.so.3.3.8" because the package installs /usr/lib/libqt-mt.so.3.3.7 (note the file version; 3:3.3.8***really3.3.7***-0ubuntu11.1 Emphasis added :)

As per Synaptic, the 11.1 version installs the following files in /usr/lib/

libqt-mt.so.3.3.7
libqui.so.1.0.0
libqt-mt.so.3
libqt-mt.so.3.3
libqui.so.1.0
libqui.so.1

So I don't know what happened on your system. Check to make sure the disk isn't full and try reinstalling libqt3-mt and see if that works.

Apostolos Giokas (t-giokas) wrote :

I made
 sudo apt-get clean and updated again

It worked this time. I really don't know what happened.

Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers