Enable spice in kvm

Bug #723796 reported by Ahmed Kamal on 2011-02-23
This bug report is a duplicate of:  Bug #828789: please enable spice support. Edit Remove
56
This bug affects 9 people
Affects Status Importance Assigned to Milestone
qemu-kvm (Ubuntu)
Low
Ahmed Kamal

Bug Description

Binary package hint: qemu-kvm

Can you please add -enable-spice to the configure args?

Currently, trying to run kvm binary directly, passing the following parameters " -vga qxl -spice port=5930,disable-ticketing" results in

kvm: -spice port=5930,disable-ticketing: there is no option group "spice"
spice is not supported by this qemu build

Related branches

Ahmed Kamal (kim0) on 2011-02-23
Changed in qemu-kvm (Ubuntu):
status: New → Confirmed

Hmm, i just tried doing this and I got:

./configure \
            --target-list="x86_64-softmmu i386-softmmu
x86_64-linux-user i386-linux-user" \
            --prefix=/usr \
            --interp-prefix=/etc/qemu-binfmt/%M \
            --disable-blobs \
            --disable-strip \
            --enable-spice \
            --audio-drv-list="pa,alsa,sdl,oss" --enable-vnc-sasl --enable-docs
ERROR
ERROR: User requested feature spice
ERROR: configure was not able to find it
ERROR

Dustin Kirkland  (kirkland) wrote :

Looks like we need the spice libraries to compile against...

takahiro watanabe (tawa777) wrote :

Me too when i build qemu.

But strangingly i can build qemu on my local machine.

To see my failure, please check my PPA.

If you can build local, can you tell me the output of the following:

 $ sudo updatedb
 $ what-provides spice.h

Serge Hallyn (serge-hallyn) wrote :

Quoting Dustin Kirkland (<email address hidden>):
> If you can build local, can you tell me the output of the following:
>
> $ sudo updatedb
> $ what-provides spice.h

Not sure who you're asking this of. I'm currently working on
building spice in ppa:serge-hallyn/spice. spice.h is coming
from the spice-protocol package (which is built and available
in that ppa) in /usr/include/spice/spice.h. Just having some
trouble making automake and the package builder play nicely
together.

takahiro watanabe (tawa777) wrote :

> If you can build local, can you tell me the output of the following:

> $ sudo updatedb
> $ what-provides spice.h

As for me,

# updatedb
# what-provides spice.h
zsh: command not found: what-provides

But by following the instruction of
http://nicholaskuechler.com/2011/02/10/debian-ubuntu-equivalents-of-yum-whatprovides/,
I got the following:

# dpkg -S /usr/include/spice-server/spice.h
spice: /usr/include/spice-server/spice.h

Anyway, i continue resolving the failure.

Dustin Kirkland  (kirkland) wrote :

Hmm, where did you get a spice package from? Its not in the Ubuntu archive...

takahiro watanabe (tawa777) wrote :

I got the packege from koji (a.k.a RetHat,http://koji.fedoraproject.org/koji/).
Then i create tar ball by extracting source rpm.

Serge Hallyn (serge-hallyn) wrote :

I've put packages containing spice and spice-enabled qemu in ppa:serge-hallyn/spice.

Tested locally, seemed to work great.

Reassigning to Ahmed to file MIR.

Changed in qemu-kvm (Ubuntu):
assignee: nobody → Ahmed Kamal (kim0)
importance: Undecided → Low
Ahmed Kamal (kim0) wrote :

Serge has built a separate kvm-spice binary at ppa:serge-hallyn/spice, this should be pushed. Closing since no need for MIR

Changed in qemu-kvm (Ubuntu):
status: Confirmed → Fix Committed
Changed in qemu-kvm (Ubuntu):
status: Fix Committed → Fix Released
Dave Gilbert (ubuntu-treblig) wrote :

qemu-kvm 0.14.1+noroms-0ubuntu2

It seems to be failing again, flicking the video output to spice on an existing vm gives me:

Error starting domain: unsupported configuration: spicevmc not supported in this QEMU binary on Oneiric

Dave

Doug Stanley (doug-stanley) wrote :

Is this supposed to be fixed for qemu-kvm? Or am i supposed to install another package to get spice support? I'm running oneric and using qemu-kvm from the main repos, but no spice support seems to be available.

Serge Hallyn (serge-hallyn) wrote :

Quoting Doug Stanley (<email address hidden>):
> Is this supposed to be fixed for qemu-kvm? Or am i supposed to install
> another package to get spice support? I'm running oneric and using qemu-
> kvm from the main repos, but no spice support seems to be available.

This is awaiting a feature freeze exception (FFE) for spice-gtk and
for qemu-kvm. If/when that is granted, the feature will be available
in the 'kvm-spice' executable provided by the qemu-kvm-spice package.

Jeremy Nickurak (nickurak) wrote :

Doesn't "fix released" imply that it's fixed in a released version of qemu-kvm in Ubuntu? That's not the case today.

Jeremy Nickurak (nickurak) wrote :

Further, even the ppa suggested here doesn't have support for oneiric.

Serge Hallyn (serge-hallyn) wrote :

I don't know why this was ever set to fix released. This should be getting done as soon as precise opens up, but not in oneiric, as theat FFE got stalled (several times).

Changed in qemu-kvm (Ubuntu):
status: Fix Released → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qemu-kvm - 0.14.1+noroms-0ubuntu7

---------------
qemu-kvm (0.14.1+noroms-0ubuntu7) precise; urgency=low

  * Create new qemu-kvm-spice package (LP: #723796)
    - debian/control: add libspice-protocol-dev and libspice-server-dev
      to build-depends, and define the qemu-kvm-spice package.
    - debian/rules: add a new spice-build target (based on old -static rules):
      * add --enable-spice to its configure args
      * rename its wanted binaries to *-spice
    - debian/qemu-kvm-spice.links and debian/qemu-kvm-spice.dirs: install
      kvm-spice and qemu-system-x86_64-spice
 -- Serge Hallyn <email address hidden> Mon, 17 Oct 2011 16:22:37 +0000

Changed in qemu-kvm (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers