oneiric->precise upgrade failed: E:Internal Error, Could not early remove python-minimal

Bug #986374 reported by Jean-Baptiste Lallement on 2012-04-20
92
This bug affects 19 people
Affects Status Importance Assigned to Milestone
python2.7 (Ubuntu)
Critical
Steve Langasek

Bug Description

Last run of upgrades from Oneiric to Precise failed with the error

2012-04-20 20:24:46,660 ERROR Exception during pm.DoInstall()
Traceback (most recent call last):
  File "/tmp/update-manager-4jsTvT/DistUpgradeView.py", line 203, in run
    res = pm.do_install(self.writefd)
SystemError: E:This installation run will require temporarily removing the essential package python-minimal due to a Conflicts/Pre-Depends loop. This is often bad, but if you really want to do it, activate the APT::Force-LoopBreak option., E:Internal Error, Could not early remove python-minimal

Jean-Baptiste Lallement (jibel) wrote :
Jean-Baptiste Lallement (jibel) wrote :
Jean-Baptiste Lallement (jibel) wrote :
Jean-Baptiste Lallement (jibel) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-manager (Ubuntu):
status: New → Confirmed
Steve Langasek (vorlon) on 2012-04-20
affects: update-manager (Ubuntu) → python2.7 (Ubuntu)
Changed in python2.7 (Ubuntu):
importance: Undecided → Critical
milestone: none → ubuntu-12.04
status: Confirmed → Triaged
Steve Langasek (vorlon) on 2012-04-20
tags: added: rls-p-tracking

Should we try to activate APT::Force-LoopBreak or should we wait for this bug to be solved?

Steve Langasek (vorlon) on 2012-04-20
Changed in python2.7 (Ubuntu):
assignee: nobody → Steve Langasek (vorlon)
Patrick McEvoy (patrickmcevoy) wrote :

I ran...

sudo apt-get install -o APT::Force-LoopBreak=1 python2.7

and then continued the upgrade with

sudo apt-get upgrade

Steve Langasek (vorlon) wrote :

Test package is in -proposed now. We should not consider this fix good unless it's passed muster with *all* our upgrade tests this time.

Changed in python2.7 (Ubuntu):
status: Triaged → Fix Committed

#8 When can we expect that to happen?

thefuzz4 (jason-hamilton) wrote :

I can also confirm this bug as well. Happened on all 3 of my Mythbuntu machines.

Leo Milano (lmilano) wrote :

Same here. Patrick's workaround (thanks) wasn't quite enough. I needed to run it on the python program

sudo apt-get install -o APT::Force-LoopBreak=1 python

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python2.7 - 2.7.3-0ubuntu3

---------------
python2.7 (2.7.3-0ubuntu3) precise-proposed; urgency=low

  * python2.7-minimal needs a versioned depends on python-minimal, not a
    Conflicts. Conflicts with essential packages, versioned or otherwise,
    are a serious problem for upgrades, as the previous upload demonstrated.
    Instead, we allow a circular dependency between python2.7-minimal and
    python-minimal, and rely on the fact that the package manager ensures
    new versions of both packages will be unpacked before running the
    maintainer script from python2.7-minimal. LP: #986374.
  * Our versioned dependency on python-minimal is 2.6.6-3+squeeze1, which is
    the first version shipping a pycompile that supports passing a -V option
    referring to a version python-minimal doesn't already know about.
 -- Steve Langasek <email address hidden> Fri, 20 Apr 2012 14:19:23 -0700

Changed in python2.7 (Ubuntu):
status: Fix Committed → Fix Released
Bill Hammond (gellmu) wrote :

This may have been fixed for 11.10 -> 12.04, but it's BROKEN for the LTS upgrade from 10.04 to 12.04.

Meanwhile, where is python-minimal 2.6.6-3+squeeze1?

Bill Hammond (gellmu) wrote :

Umm... I found 2.6.6-3+squeeze7 at debian.org, but it depends on 2.6.6-1 and on dpkg (??), while ubuntu 10.04.4 LTS has version 2.6.5-1ubuntu6 -- which has no dependency on either dpkg or an earlier version of python-minimal.

Steve Langasek (vorlon) wrote :

This change was extensively regression-tested for both LTS and non-LTS upgrades before the precise release. Whatever problem you're having, Bill, you should file a new bug report for.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers