package python2.6-minimal 2.6.1-1ubuntu8 failed to install/upgrade:

Bug #354228 reported by Vnon on 2009-04-03
284
This bug affects 27 people
Affects Status Importance Assigned to Milestone
python-central (Ubuntu)
High
Michael Vogt
Intrepid
Undecided
Unassigned
Jaunty
High
Michael Vogt
python2.6 (Ubuntu)
High
Michael Vogt
Intrepid
Undecided
Unassigned
Jaunty
High
Michael Vogt
python3.0 (Ubuntu)
Undecided
Unassigned
Intrepid
Undecided
Unassigned
Jaunty
Undecided
Unassigned

Bug Description

Binary package hint: python2.6

package python2.6-minimal 2.6.1-1ubuntu8 failed to install/upgrade:

ProblemType: Package
Architecture: i386
Dependencies:
 libgcc1 1:4.3.3-5ubuntu4
 zlib1g 1:1.2.3.3.dfsg-12ubuntu2
 gcc-4.3-base 4.3.3-5ubuntu4
 findutils 4.4.0-2ubuntu3
 libc6 2.9-4ubuntu5
DistroRelease: Ubuntu 9.04
ErrorMessage:
 ErrorMessage: podproces post-installation script zwrócił kod błędu 1
Package: python2.6-minimal 2.6.1-1ubuntu8
SourcePackage: python2.6
Title: package python2.6-minimal 2.6.1-1ubuntu8 failed to install/upgrade:
Uname: Linux 2.6.28-11-generic i686

Vnon (vnon) wrote :
Anders Kaseorg (andersk) wrote :

Seems to be the same problem as bug 354251 in python3.0, possibly caused by the fix to bug 353251.

Changed in python2.6 (Ubuntu):
status: New → Confirmed
Nelson Elhage (nelhage) wrote :

I can confirm this here, as well. I suspect this is related to the fix to #353251. I've attached my terminal log.

Note that this broke the Intrepid→Jaunty upgrade for me, so I think this is pretty bad.

Nelson Elhage (nelhage) wrote :

I can confirm this here, as well. I suspect this is related to the fix to #353251. I've attached my terminal log.

Note that this broke the Intrepid→Jaunty upgrade for me, so I think this is pretty bad.

Steve Beattie (sbeattie) wrote :

mvo: can you please look at this; it's hitting a number of upgraders, myself included. Thanks!

Changed in python2.6 (Ubuntu):
importance: Undecided → High
Michael Vogt (mvo) wrote :

Here is the bugreport. This is a python central bug, I reassign:

Konfigurowanie python2.6-minimal (2.6.1-1ubuntu8) ...
Linking and byte-compiling packages for runtime python2.6...
pycentral: pycentral rtinstall: installed runtime python2.6 not found
pycentral rtinstall: installed runtime python2.6 not found
dpkg: błąd przetwarzania python2.6-minimal (--configure):
 podproces post-installation script zwrócił kod błędu 1

affects: python2.6 (Ubuntu Jaunty) → python-central (Ubuntu Jaunty)
Changed in python-central (Ubuntu Jaunty):
status: Confirmed → Triaged
Michael Vogt (mvo) wrote :

Here is a proposed fix, but when testing it turns out this is not enough. It will still error because its the intrepid version of python-central that is installed when python2.6 gets installed.

Michael Vogt (mvo) wrote :

So in addition to fixing python-central there needs to be a conflicts against the intrepid version of python-central in python2.6-minimal. This hopefully fixes this issue too.

Savvas Radevic (medigeek) wrote :

Same in python3.0:
$ sudo aptitude -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following partially installed packages will be configured:
  python3.0 python3.0-minimal
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Setting up python3.0-minimal (3.0.1-0ubuntu10) ...
Linking and byte-compiling packages for runtime python3.0...
pycentral: pycentral rtinstall: installed runtime python3.0 not found
pycentral rtinstall: installed runtime python3.0 not found
dpkg: error processing python3.0-minimal (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of python3.0:
 python3.0 depends on python3.0-minimal (= 3.0.1-0ubuntu10); however:
  Package python3.0-minimal is not configured yet.
dpkg: error processing python3.0 (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                          Errors were encountered while processing:
 python3.0-minimal
 python3.0
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up python3.0-minimal (3.0.1-0ubuntu10) ...
Linking and byte-compiling packages for runtime python3.0...
pycentral: pycentral rtinstall: installed runtime python3.0 not found
pycentral rtinstall: installed runtime python3.0 not found
dpkg: error processing python3.0-minimal (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of python3.0:
 python3.0 depends on python3.0-minimal (= 3.0.1-0ubuntu10); however:
  Package python3.0-minimal is not configured yet.
dpkg: error processing python3.0 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 python3.0-minimal
 python3.0
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done

Michael Vogt (mvo) wrote :

I disabled release upgrade for now until this problem is fixed.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-central - 0.6.11ubuntu6

---------------
python-central (0.6.11ubuntu6) jaunty; urgency=low

  * fix logic in get_installed_runtime() to not error when a
    new runtime gets installed (LP: #354228).

    the root of the problem is that the debian_defaults file is not yet
    the jaunty version when python2.6-minimal gets installed and pycentral
    errors on versions it has no explicit knowledge about (from
    debian_defaults)

 -- Michael Vogt <email address hidden> Fri, 03 Apr 2009 09:42:57 +0200

Changed in python-central (Ubuntu Jaunty):
status: Triaged → Fix Released
Michael Vogt (mvo) wrote :

Hm, the python3.0 problem makes it even more tricky. In jaunty its not listed in any suppored/unsupported/old-versions. So currently python-central ignores it complettely. What should it now do?

Robert D. Martin (ets3rodamar) wrote :

Python3 installed under jaunty for me just now without a hitch. So at least if the upgrade from Intrepid to Jaunty has been completed then Python3 is available / installable thereafter under jaunty.

As I recall, my upgrade from intrepid to jaunty also entailed problems with the installation of python 2.6 being in conflict with the then standard use of python 2.5. That problem got corrected in the course of jaunty being upgraded daily (my common practice).

Michael Vogt (mvo) wrote :
Heitzso (heitzso) wrote :

Please provide a clear "do this and then this" sequence to fix a trashed Intrepid->Jaunty upgrade. For example, while there's mention of an out of date python central control file causing this problem it would be nice if someone could write:
 * in file /etc/blat/blat.conf
 * add/common/delete the following lines
 * run apt-get install python-central
or whatever. Please remember that what is second nature for you, the python maintainers, is black magic for many of us who just assume python runs.

Because the upgrade is currently so broken I'm assuming sequences of update/dist-upgrade can't untangle, and, so far this morning, that's been the case. If this should work, but just not for X hours/days/? until changes percolate through the mirrors I'd appreciate a simple "please hold tight till Saturday morning (or whatever) and then let a standard aptitude update && aptitude dist-upgrade fix it." --- Thanks.

darren (darrenm) wrote :

I've got around an Intrepid>Jaunty upgrade by doing this:

dpkg -i /var/cache/apt/archives/python-central_0.6.11ubuntu6_all.deb

apt-get -f install

apt-get dist-upgrade

> Please provide a clear "do this and then this" sequence to fix a trashed Intrepid->Jaunty upgrade.

This makes sure you use archive.ubuntu.com and not xx.archive.ubuntu.com:

sudo sed -i 's#http://\S*archive\.ubuntu\.com#http://archive.ubuntu.com#'
/etc/apt/sources.list

Then you simply update:

sudo apt-get update
sudo apt-get dist-upgrade

Savvas Radevic (medigeek) wrote :

gmail broke the commands, here you go an updated list of commands:

sudo sed -i 's#http://\S*archive\.ubuntu\.com#http://archive.ubuntu.com#' /etc/apt/sources.list
sudo apt-get update
sudo apt-get -f install
sudo apt-get dist-upgrade

Mind you that I haven't tried it and it might not work as expected.

Michael Vogt (mvo) wrote :

Closeing the intrepid tasks.

Changed in python-central (Ubuntu Intrepid):
status: New → Won't Fix
affects: python-defaults (Ubuntu Intrepid) → python2.6 (Ubuntu Intrepid)
Changed in python2.6 (Ubuntu Intrepid):
status: New → Won't Fix
Heitzso (heitzso) wrote :

I manually ran the dpkg -i command suggested above.
Then removed some wx python packages that were hanging.
After that, started getting some clean installs.
I'm running "apt-get upgrade" now and will polish off later.

Michael Vogt (mvo) on 2009-04-03
Changed in python2.6 (Ubuntu Jaunty):
assignee: nobody → mvo
importance: Undecided → High
status: New → In Progress
Changed in python-central (Ubuntu Jaunty):
assignee: nobody → mvo
Michael Vogt (mvo) wrote :

The fix for this is in the archive now.

Changed in python2.6 (Ubuntu Jaunty):
status: In Progress → Fix Released
Savvas Radevic (medigeek) wrote :

I'm not sure, but is any action required for python3.0 to work?
Personally, I've installed it without any problems now that correct python-central is in the archive. It shows the "INFO: using unkown version ..." line. :)

Changed in python3.0 (Ubuntu Intrepid):
status: New → Invalid
NavadeHo (nvdh2) wrote :

I was trying to update, but it wasn't showing 9.04.

Now I know that it was caused by this, that's good to know.

When is it going to be enabled again?

Aaron Mayse (eyeless1) wrote :

Is this what's keeping me from upgrading? I'm getting:

2009-04-04 05:01:38,394 ERROR Dist-upgrade failed: 'Trying to install blacklisted version 'python2.6_2.6.1-1ubuntu8''

when trying to upgrade to 9.04 from 8.10. I'm not the only one either:

http://ubuntuforums.org/showthread.php?p=7015567

though all of that was in the past 12 hours, so I'm guessing this is the cause.

No. I only get new patches from server. I have allready installed 9.04.

Mit freundlichen Grüßen

Anne und Burghard Schatz
Vochemsweg 53
50259 Pulheim
Telefon +49-(0)2234-986169
Fax +49-(0)2234-986170

-----Ursprüngliche Nachricht-----
Von: <email address hidden> [mailto:<email address hidden>] Im Auftrag von
Aaron Mayse
Gesendet: Sonntag, 5. April 2009 05:08
An: <email address hidden>
Betreff: [Bug 354228] Re: package python2.6-minimal 2.6.1-1ubuntu8 failed
toinstall/upgrade:

Is this what's keeping me from upgrading? I'm getting:

2009-04-04 05:01:38,394 ERROR Dist-upgrade failed: 'Trying to install
blacklisted version 'python2.6_2.6.1-1ubuntu8''

when trying to upgrade to 9.04 from 8.10. I'm not the only one either:

http://ubuntuforums.org/showthread.php?p=7015567

though all of that was in the past 12 hours, so I'm guessing this is the
cause.

--
package python2.6-minimal 2.6.1-1ubuntu8 failed to install/upgrade:
https://bugs.launchpad.net/bugs/354228
You received this bug notification because you are a direct subscriber of a
duplicate bug.

Status in "python-central" source package in Ubuntu: Fix Released Status in
"python2.6" source package in Ubuntu: Fix Released Status in "python3.0"
source package in Ubuntu: New Status in python-central in Ubuntu Intrepid:
Won't Fix Status in python2.6 in Ubuntu Intrepid: Won't Fix Status in
python3.0 in Ubuntu Intrepid: Invalid Status in python-central in Ubuntu
Jaunty: Fix Released Status in python2.6 in Ubuntu Jaunty: Fix Released
Status in python3.0 in Ubuntu Jaunty: New

Bug description:
Binary package hint: python2.6

package python2.6-minimal 2.6.1-1ubuntu8 failed to install/upgrade:

ProblemType: Package
Architecture: i386
Dependencies:
 libgcc1 1:4.3.3-5ubuntu4
 zlib1g 1:1.2.3.3.dfsg-12ubuntu2
 gcc-4.3-base 4.3.3-5ubuntu4
 findutils 4.4.0-2ubuntu3
 libc6 2.9-4ubuntu5
DistroRelease: Ubuntu 9.04
ErrorMessage:
 ErrorMessage: podproces post-installation script zwrócił kod błędu 1
Package: python2.6-minimal 2.6.1-1ubuntu8
SourcePackage: python2.6
Title: package python2.6-minimal 2.6.1-1ubuntu8 failed to install/upgrade:
Uname: Linux 2.6.28-11-generic i686

KevinM (kevbert1) wrote :

This problem is now resolved for me in Jaunty Kubuntu as of today after performing an update and dist-upgrade.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python3.0 - 3.0.1-0ubuntu11

---------------
python3.0 (3.0.1-0ubuntu11) jaunty; urgency=low

  [Matthias Klose]
  * Update to 20090405 from the release30-maint branch.
  * Always use the `unix_prefix' scheme for setup.py install in a virtualenv
    setup. LP: #339904.
  * Revert inverting the supported/unsupported check for rtinstall.
    LP: #354858, #354228.
  * Py_DECREF: Add `do { ... } while (0)' to avoid compiler warnings.
  * Fix build failure building the documentation.

  [Marc Deslauriers]
  * debian/pyhtml2devhelp.py: Update parsing logic.

 -- Matthias Klose <email address hidden> Sun, 05 Apr 2009 15:52:57 +0200

Changed in python3.0 (Ubuntu Jaunty):
status: New → Fix Released
hunterk (hunter-kaller) wrote :

I am having what I believe is a related issue with python2.6-minimal:

$ sudo dpkg --configure python2.6-minimal
Setting up python2.6-minimal (2.6.2~rc1-0ubuntu1) ...
Linking and byte-compiling packages for runtime python2.6...
Traceback (most recent call last):
  File "/usr/bin/pycentral", line 2186, in <module>
    main()
  File "/usr/bin/pycentral", line 2180, in main
    rv = action.run(global_options)
  File "/usr/bin/pycentral", line 1736, in run
    pkg = DebPackage('package', pkgname, oldstyle=False)
  File "/usr/bin/pycentral", line 377, in __init__
    self.read_pyfiles()
  File "/usr/bin/pycentral", line 408, in read_pyfiles
    self.pkgconfig.set('pycentral', 'include-links', '0')
  File "/usr/lib/python2.6/ConfigParser.py", line 669, in set
    ConfigParser.set(self, section, option, value)
  File "/usr/lib/python2.6/ConfigParser.py", line 377, in set
    raise NoSectionError(section)
ConfigParser.NoSectionError: No section: 'pycentral'
dpkg: error processing python2.6-minimal (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 python2.6-minimal

$ sudo dpkg -l | grep python2.6
iU libpython2.6 2.6.2~rc1-0ubuntu1 Shared Python runtime library (version 2.6)
iU python2.6 2.6.2~rc1-0ubuntu1 An interactive high-level object-oriented la
rF python2.6-minimal 2.6.2~rc1-0ubuntu1 A minimal subset of the Python language (ver

please let me know if I need to attach any logs

Mickaël Delahaye (mdelahaye) wrote :

I don't have any problem now with python2.6 but python3 does not install correctly.

Linking and byte-compiling packages for runtime python3.0...
  File "/usr/bin/py_compilefiles", line 27
    print "file does not exist:", fullname
                               ^
SyntaxError: invalid syntax
pycentral: pycentral rtinstall: package python-bittorrent: error byte-compiling files (31)
pycentral rtinstall: package python-bittorrent: error byte-compiling files (31)

I looked at /usr/bin/pycentral and it effectively uses py_compilefiles for all python versions instead of py3_compilefiles for python 3. But after altering pycentral accordingly, the python3.0-minimal-postinst tries to compile all python modules in python 3, and there are NOT compatible with python 3 yet.

The problem seems more general: this package's philosophy is 'just another version of python' while python3 is not backward compatible...

Robbie Williamson (robbiew) wrote :

@Mickaël Delahaye,

Thanks for the update. Please open another bug against python-central in ubuntu on this. As this is not the same problem as what was originally reported in this bug.

Changed in python2.6 (Ubuntu):
status: Fix Released → In Progress

Yrjo, wasn't this fixed? If it is a problem for 9.10 (karmic), open a new bug!

On 8/6/09, Yrjö Pokkinen <email address hidden> wrote:
> ** Changed in: python2.6 (Ubuntu)
> Status: Fix Released => In Progress
>
> --
> package python2.6-minimal 2.6.1-1ubuntu8 failed to install/upgrade:
> https://bugs.launchpad.net/bugs/354228
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Sent from my mobile device

Changed in python2.6 (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.