pysvn FTBFS

Bug #426677 reported by Charlie_Smotherman on 2009-09-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pysvn (Ubuntu)
High
Unassigned

Bug Description

pysvn FTBFS

Changed in pysvn (Ubuntu):
status: New → In Progress
assignee: nobody → Charlie_Smotherman (porthose) (cjsmo)
Charlie_Smotherman (cjsmo) wrote :
Changed in pysvn (Ubuntu):
status: In Progress → New
Scott Kitterman (kitterman) wrote :

This is a good start, but needs more work before it's ready for upload:

1. This package should build for Python 2.5 and 2.6. For 2.5 it needs to use site-packages and for 2.6 is needs to use dist-packages. Your change currently switches everything from site-packages do dist-packages. (Note: I'm currently doing a test build to verify this, but that's what my reading of your patch suggests. If it turns out different, I'll comment again).

2. Your debian/changelog entry must be a new one on top of the most recent one. Currently it replaces it.

3. This is a line removed from Import/pycxx-5.5.0/setup.py. This stray change should be removed.

4. There has been a recent change in the rules for maintainer (the update-maintainer in Karmic is fixed, the one in Jaunty is not). Instead of Ubuntu MOTU Developers <email address hidden>, it should be Ubuntu Developers <email address hidden>. If this had been the only issue, I would have just fixed and uploaded it, but since you've got other changes to make, I'll leave it to you.

This is a good start, it just needs a bit more work to get there.

Changed in pysvn (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Changed in pysvn (Ubuntu):
status: Confirmed → In Progress
Charlie_Smotherman (cjsmo) wrote :

1) It now builds for python 2.5 and 2.6

2) My mistake it has been corrected.

3) Not sure how that happened but it has been corrected.

4) The maintainers field has been corrected and now uses Ubuntu Developers <email address hidden>

Changed in pysvn (Ubuntu):
status: In Progress → Confirmed
status: Confirmed → New
assignee: Charlie_Smotherman (porthose) (cjsmo) → nobody
Scott Kitterman (kitterman) wrote :

Closer. __init__.py is Python version specific and so needs to go into site/dist-packages. Currently you've got the python 2.5 one in pyshared.

Changed in pysvn (Ubuntu):
assignee: nobody → Charlie_Smotherman (porthose) (cjsmo)
status: New → In Progress
Charlie_Smotherman (cjsmo) wrote :

ScottK

I think I have it but not sure, __init__.py is now being sym linked from pyshared to dist-packages

Changed in pysvn (Ubuntu):
status: In Progress → New
assignee: Charlie_Smotherman (porthose) (cjsmo) → nobody
Changed in pysvn (Ubuntu):
status: New → In Progress
assignee: nobody → Charlie_Smotherman (porthose) (cjsmo)
Charlie_Smotherman (cjsmo) wrote :

ScottK,

Thanks for the hint on IRC.

The 2.5 version of __init__.py now resides in /usr/lib/python2.5/site-packages/pysvn and the 2.6 version of __init__.py resides in
/usr/lib/python2.6/dist-packages/pysvn

Changed in pysvn (Ubuntu):
status: In Progress → New
assignee: Charlie_Smotherman (porthose) (cjsmo) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pysvn - 1.7.0-1ubuntu2

---------------
pysvn (1.7.0-1ubuntu2) karmic; urgency=low

  * updated debin/rules to install files into
    /usr/lib/python2.6/dist-packages, fixes FTBFS. (LP: #426677)
  * Removed DH_PYCENTRAL=nomove from debian/rules.
  * Added python-central to debian/control Build-Depends.

 -- Charlie Smotherman <email address hidden> Wed, 09 Sep 2009 16:22:22 -0500

Changed in pysvn (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments