Comment 2 for bug 426677

Scott Kitterman (kitterman) wrote :

This is a good start, but needs more work before it's ready for upload:

1. This package should build for Python 2.5 and 2.6. For 2.5 it needs to use site-packages and for 2.6 is needs to use dist-packages. Your change currently switches everything from site-packages do dist-packages. (Note: I'm currently doing a test build to verify this, but that's what my reading of your patch suggests. If it turns out different, I'll comment again).

2. Your debian/changelog entry must be a new one on top of the most recent one. Currently it replaces it.

3. This is a line removed from Import/pycxx-5.5.0/setup.py. This stray change should be removed.

4. There has been a recent change in the rules for maintainer (the update-maintainer in Karmic is fixed, the one in Jaunty is not). Instead of Ubuntu MOTU Developers <email address hidden>, it should be Ubuntu Developers <email address hidden>. If this had been the only issue, I would have just fixed and uploaded it, but since you've got other changes to make, I'll leave it to you.

This is a good start, it just needs a bit more work to get there.