pulseaudio version defined as UNKNOWN, which breaks everything with build-dep on libpulse-dev

Bug #523716 reported by Brian Rogers on 2010-02-18
142
This bug affects 31 people
Affects Status Importance Assigned to Milestone
alsa-lib (Ubuntu)
Medium
Daniel T Chen
alsa-plugins (Ubuntu)
High
Daniel T Chen
pulseaudio (Ubuntu)
High
Daniel T Chen

Bug Description

Binary package hint: pulseaudio

$ grep Version /usr/lib/pkgconfig/libpulse*
/usr/lib/pkgconfig/libpulse-browse.pc:Version: UNKNOWN
/usr/lib/pkgconfig/libpulse-mainloop-glib.pc:Version: UNKNOWN
/usr/lib/pkgconfig/libpulse.pc:Version: UNKNOWN
/usr/lib/pkgconfig/libpulse-simple.pc:Version: UNKNOWN

This causes anything that has a minimum version requirement for pulseaudio to not build pulseaudio support. For example, the newly uploaded mythtv trunk package.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, that's breaking other builds and need to be fixed for alpha3, targetting the bug

Changed in pulseaudio (Ubuntu):
importance: Undecided → High
milestone: none → lucid-alpha-3
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Luke, could you have a look to this issue?

Changed in pulseaudio (Ubuntu):
assignee: nobody → Luke Yelavich (themuso)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu8

---------------
pulseaudio (1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu8) lucid; urgency=low

  * Back out 307bd1 until we can roll a new tarball. Applying it to the
    current source package requires all sorts of nasty hacks.
    (LP: #523716)
  * Drop 0094-autoconf.patch, as it's no longer needed
 -- Daniel T Chen <email address hidden> Thu, 18 Feb 2010 07:32:58 -0500

Changed in pulseaudio (Ubuntu):
status: Confirmed → Fix Released
Daniel T Chen (crimsun) wrote :

FWIW, I'm linking (well, marking as dupes) all bugs affected by this one.

Martin-Éric Racine (q-funk) wrote :

Sorry, but 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu8 does not fix the issue. I still get the following:

$ LC_ALL=C sudo alsamixer
ALSA lib conf.c:3272:(snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.so
ALSA lib control.c:902:(snd_ctl_open_noupdate) Invalid CTL default
cannot open mixer: No such file or directory

Daniel T Chen (crimsun) wrote :

alsa-plugins (1.0.22-0ubuntu5) lucid; urgency=low

  * debian/control: Rebuild against fixed libpulse-dev

Date: Thu, 18 Feb 2010 07:44:32 -0500

summary: - pulseaudio version defined as UNKNOWN
+ pulseaudio version defined as UNKNOWN, which breaks everything with
+ build-dep on libpulse-dev
Changed in alsa-plugins (Ubuntu):
assignee: nobody → Daniel T Chen (crimsun)
importance: Undecided → High
status: New → Fix Released
Daniel T Chen (crimsun) wrote :

For clarification, you need the latest version of libasound2-plugins (as implied above).

zika (4zika4) wrote :

There is a problem:

~$ alsamixer
ALSA lib conf.c:3272snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.so
ALSA lib control.c:902snd_ctl_open_noupdate) Invalid CTL default
cannot open mixer: No such file or directory

~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
ALSA lib conf.c:3272snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.so
ALSA lib control.c:902snd_ctl_open_noupdate) Invalid CTL hw:0
aplay: device_list:232: control open (0): No such file or directory
card 1: default [USB Audio DAC ], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 2: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0

I have sound in rhythmbox and totem but no sound in any flash... I have pulseaudio set in MultimediaSystemsSelector...

So, there is a problem with ALSA<->PulseAudio integration...

~$ apt-cache policy pulseaudio
pulseaudio:
  Installed: 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu8
  Candidate: 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu8
  Version table:
 *** 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu8 0
        500 http://archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status
~$ apt-cache policy libasound2-plugins
libasound2-plugins:
  Installed: 1.0.22-0ubuntu4
  Candidate: 1.0.22-0ubuntu4
  Version table:
 *** 1.0.22-0ubuntu4 0
        500 http://archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status

tad1073 (tad1073) wrote :

:~/Desktop$ apt-cache policy pulseaudio
pulseaudio:
  Installed: 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu8
  Candidate: 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu8
  Version table:
 *** 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu8 0
        500 http://us.archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status

still no sound

:~$ lshw -C sound
WARNING: you should run this program as super-user.
  *-multimedia
       description: Audio device
       product: 82801I (ICH9 Family) HD Audio Controller
       vendor: Intel Corporation
       physical id: 1b
       bus info: pci@0000:00:1b.0
       version: 02
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list
       configuration: driver=HDA Intel latency=0
       resources: irq:22 memory:fdff4000-fdff7fff

*-multimedia
       description: Multimedia audio controller
       product: VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller
       vendor: VIA Technologies Inc.
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 01
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master cap_list
       configuration: driver=ICE1724 latency=64
       resources: irq:21 ioport:ef00(size=32) ioport:ee00(size=128)

Hi,

Please retry with libasounds-plugins version 1.0.22-0ubuntu5 - which
was released about 30 minutes ago.

Thanks,
Anand

On Thu, Feb 18, 2010 at 4:21 PM, zika <email address hidden> wrote:
>
> There is a problem:
>
> ~$ alsamixer
> ALSA lib conf.c:3272snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.so
> ALSA lib control.c:902snd_ctl_open_noupdate) Invalid CTL default
> cannot open mixer: No such file or directory
>
> ~$ aplay -l
> **** List of PLAYBACK Hardware Devices ****
> ALSA lib conf.c:3272snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.so
> ALSA lib control.c:902snd_ctl_open_noupdate) Invalid CTL hw:0
> aplay: device_list:232: control open (0): No such file or directory
> card 1: default [USB Audio DAC ], device 0: USB Audio [USB Audio]
> Subdevices: 1/1
> Subdevice #0: subdevice #0
> card 2: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
> Subdevices: 1/1
> Subdevice #0: subdevice #0
>
> I have sound in rhythmbox and totem but no sound in any flash... I have
> pulseaudio set in MultimediaSystemsSelector...
>
> So, there is a problem with ALSA<->PulseAudio integration...
>
> ~$ apt-cache policy pulseaudio
> pulseaudio:
>  Installed: 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu8
>  Candidate: 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu8
>  Version table:
>  *** 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu8 0
>        500 http://archive.ubuntu.com lucid/main Packages
>        100 /var/lib/dpkg/status
> ~$ apt-cache policy libasound2-plugins
> libasound2-plugins:
>  Installed: 1.0.22-0ubuntu4
>  Candidate: 1.0.22-0ubuntu4
>  Version table:
>  *** 1.0.22-0ubuntu4 0
>        500 http://archive.ubuntu.com lucid/main Packages
>        100 /var/lib/dpkg/status
>
> --
> pulseaudio version defined as UNKNOWN, which breaks everything with build-dep on libpulse-dev
> https://bugs.launchpad.net/bugs/523716
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in “alsa-plugins” package in Ubuntu: Fix Released
> Status in “pulseaudio” package in Ubuntu: Fix Released
>
> Bug description:
> Binary package hint: pulseaudio
>
> $ grep Version /usr/lib/pkgconfig/libpulse*
> /usr/lib/pkgconfig/libpulse-browse.pc:Version: UNKNOWN
> /usr/lib/pkgconfig/libpulse-mainloop-glib.pc:Version: UNKNOWN
> /usr/lib/pkgconfig/libpulse.pc:Version: UNKNOWN
> /usr/lib/pkgconfig/libpulse-simple.pc:Version: UNKNOWN
>
> This causes anything that has a minimum version requirement for pulseaudio to not build pulseaudio support. For example, the newly uploaded mythtv trunk package.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/alsa-plugins/+bug/523716/+subscribe
>
>

Anand Kumria (wildfire) wrote :

What does:

$ apt-cache policy libasound2-plugins

show as the version?

Pleas retry with 1.0.22-0ubuntu4 (release about 30 minutes ago).

Anand

On Thu, Feb 18, 2010 at 4:28 PM, tad1073 <email address hidden> wrote:
> :~/Desktop$ apt-cache policy pulseaudio
> pulseaudio:
>  Installed: 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu8
>  Candidate: 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu8
>  Version table:
>  *** 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu8 0
>        500 http://us.archive.ubuntu.com lucid/main Packages
>        100 /var/lib/dpkg/status
>
>
> still no sound
>
> :~$ lshw -C sound
> WARNING: you should run this program as super-user.
>  *-multimedia
>       description: Audio device
>       product: 82801I (ICH9 Family) HD Audio Controller
>       vendor: Intel Corporation
>       physical id: 1b
>       bus info: pci@0000:00:1b.0
>       version: 02
>       width: 64 bits
>       clock: 33MHz
>       capabilities: bus_master cap_list
>       configuration: driver=HDA Intel latency=0
>       resources: irq:22 memory:fdff4000-fdff7fff
>
> *-multimedia
>       description: Multimedia audio controller
>       product: VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller
>       vendor: VIA Technologies Inc.
>       physical id: 0
>       bus info: pci@0000:02:00.0
>       version: 01
>       width: 32 bits
>       clock: 33MHz
>       capabilities: bus_master cap_list
>       configuration: driver=ICE1724 latency=64
>       resources: irq:21 ioport:ef00(size=32) ioport:ee00(size=128)
>
> --
> pulseaudio version defined as UNKNOWN, which breaks everything with build-dep on libpulse-dev
> https://bugs.launchpad.net/bugs/523716
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in “alsa-plugins” package in Ubuntu: Fix Released
> Status in “pulseaudio” package in Ubuntu: Fix Released
>
> Bug description:
> Binary package hint: pulseaudio
>
> $ grep Version /usr/lib/pkgconfig/libpulse*
> /usr/lib/pkgconfig/libpulse-browse.pc:Version: UNKNOWN
> /usr/lib/pkgconfig/libpulse-mainloop-glib.pc:Version: UNKNOWN
> /usr/lib/pkgconfig/libpulse.pc:Version: UNKNOWN
> /usr/lib/pkgconfig/libpulse-simple.pc:Version: UNKNOWN
>
> This causes anything that has a minimum version requirement for pulseaudio to not build pulseaudio support. For example, the newly uploaded mythtv trunk package.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/alsa-plugins/+bug/523716/+subscribe
>
>

Daniel T Chen (crimsun) wrote :

Anand of course meant 1.0.22-0ubuntu5 above...

zika (4zika4) wrote :

~$ apt-cache policy libasound2-plugins
libasound2-plugins:
Installed: 1.0.22-0ubuntu5
Candidate: 1.0.22-0ubuntu5
~$ alsamixer
ALSA lib conf.c:3272: (snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.so
ALSA lib control.c:902: (snd_ctl_open_noupdate) Invalid CTL default
cannot open mixer: No such file or directory
~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
ALSA lib conf.c:3272: (snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.so
ALSA lib control.c:902: (snd_ctl_open_noupdate) Invalid CTL hw:0
aplay: device_list:232: control open (0): No such file or directory
card 1: default [USB Audio DAC ], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 2: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0

No sound in Flash still...

zika (4zika4) wrote :

/usr/lib/alsa-lib$ ls libasound_module_conf_pulse.so -lt
-rw-r--r-- 1 root root 6184 2010-02-18 16:11 libasound_module_conf_pulse.so
I did reboot before I posted my previous answer...
Here comes the output of strace...

Daniel T Chen (crimsun) wrote :
Download full text (3.5 KiB)

From zika's strace:

...
18151 open("/lib/tls/x86_64/libasound_module_conf_pulse.so", O_RDONLY) = -1 ENOENT (No such file or directory)
18151 stat("/lib/tls/x86_64", 0x7fffa908e1b0) = -1 ENOENT (No such file or directory)
18151 open("/lib/tls/libasound_module_conf_pulse.so", O_RDONLY) = -1 ENOENT (No such file or directory)
18151 stat("/lib/tls", 0x7fffa908e1b0) = -1 ENOENT (No such file or directory)
18151 open("/lib/x86_64/libasound_module_conf_pulse.so", O_RDONLY) = -1 ENOENT (No such file or directory)
18151 stat("/lib/x86_64", 0x7fffa908e1b0) = -1 ENOENT (No such file or directory)
18151 open("/lib/libasound_module_conf_pulse.so", O_RDONLY) = -1 ENOENT (No such file or directory)
18151 stat("/lib", {st_mode=S_IFDIR|0755, st_size=12288, ...}) = 0
18151 open("/usr/lib/tls/x86_64/libasound_module_conf_pulse.so", O_RDONLY) = -1 ENOENT (No such file or directory)
18151 stat("/usr/lib/tls/x86_64", 0x7fffa908e1b0) = -1 ENOENT (No such file or directory)
18151 open("/usr/lib/tls/libasound_module_conf_pulse.so", O_RDONLY) = -1 ENOENT (No such file or directory)
18151 stat("/usr/lib/tls", 0x7fffa908e1b0) = -1 ENOENT (No such file or directory)
18151 open("/usr/lib/x86_64/libasound_module_conf_pulse.so", O_RDONLY) = -1 ENOENT (No such file or directory)
18151 stat("/usr/lib/x86_64", 0x7fffa908e1b0) = -1 ENOENT (No such file or directory)
18151 open("/usr/lib/libasound_module_conf_pulse.so", O_RDONLY) = -1 ENOENT (No such file or directory)
18151 stat("/usr/lib", {st_mode=S_IFDIR|0755, st_size=65536, ...}) = 0
18151 open("/lib/x86_64-linux-gnu/tls/x86_64/libasound_module_conf_pulse.so", O_RDONLY) = -1 ENOENT (No such file or directory)
18151 stat("/lib/x86_64-linux-gnu/tls/x86_64", 0x7fffa908e1b0) = -1 ENOENT (No such file or directory)
18151 open("/lib/x86_64-linux-gnu/tls/libasound_module_conf_pulse.so", O_RDONLY) = -1 ENOENT (No such file or directory)
18151 stat("/lib/x86_64-linux-gnu/tls", 0x7fffa908e1b0) = -1 ENOENT (No such file or directory)
18151 open("/lib/x86_64-linux-gnu/x86_64/libasound_module_conf_pulse.so", O_RDONLY) = -1 ENOENT (No such file or directory)
18151 stat("/lib/x86_64-linux-gnu/x86_64", 0x7fffa908e1b0) = -1 ENOENT (No such file or directory)
18151 open("/lib/x86_64-linux-gnu/libasound_module_conf_pulse.so", O_RDONLY) = -1 ENOENT (No such file or directory)
18151 stat("/lib/x86_64-linux-gnu", 0x7fffa908e1b0) = -1 ENOENT (No such file or directory)
18151 open("/usr/lib/x86_64-linux-gnu/tls/x86_64/libasound_module_conf_pulse.so", O_RDONLY) = -1 ENOENT (No such file or directory)
18151 stat("/usr/lib/x86_64-linux-gnu/tls/x86_64", 0x7fffa908e1b0) = -1 ENOENT (No such file or directory)
18151 open("/usr/lib/x86_64-linux-gnu/tls/libasound_module_conf_pulse.so", O_RDONLY) = -1 ENOENT (No such file or directory)
18151 stat("/usr/lib/x86_64-linux-gnu/tls", 0x7fffa908e1b0) = -1 ENOENT (No such file or directory)
18151 open("/usr/lib/x86_64-linux-gnu/x86_64/libasound_module_conf_pulse.so", O_RDONLY) = -1 ENOENT (No such file or directory)
18151 stat("/usr/lib/x86_64-linux-gnu/x86_64", 0x7fffa908e1b0) = -1 ENOENT (No such file or directory)
18151 open("/usr/lib/x86_64-linux-gnu/libasound_module_conf_pulse.so", O_RDONLY) = -1 ENOENT (No...

Read more...

mkoubik (koubik) wrote :

This is strange:

~$ ls /usr/lib/alsa-lib/ | grep conf_pulse
libasound_module_conf_pulse.so

~$ alsamixer
ALSA lib conf.c:3272:(snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.so
ALSA lib control.c:902:(snd_ctl_open_noupdate) Invalid CTL default
cannot open mixer: No such file or directory

~$ apt-cache policy libasound2-plugins
libasound2-plugins:
  Installed: 1.0.22-0ubuntu5
  Candidate: 1.0.22-0ubuntu5

Susan Cragin (susancragin) wrote :

$ apt-cache policy libasound2-plugins
libasound2-plugins:
  Installed: 1.0.22-0ubuntu5
  Candidate: 1.0.22-0ubuntu5
  Version table:
 *** 1.0.22-0ubuntu5 0
        500 http://us.archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status
$ alsamixer

I thought I would weigh in because my system is slightly different. I have Ubuntu-Studio and pulseaudio disabled in the start preferences menu. I also have edited client.conf to de-activate autospawn.

Alsamixer came up with the above. I have attached a screenshot.

Daniel T Chen (crimsun) on 2010-02-18
Changed in alsa-lib (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Daniel T Chen (crimsun) wrote :

alsa-lib's debian/rules configure-stamp target is missing the --with-plugindir=\$${prefix}/lib/alsa-lib flag.

I am at work and thus don't have access to my development box, but if a core dev wants to make the above change and rebuild, that's what needs to be done.

Jamie Strandboge (jdstrand) wrote :

I'll take a look at it. If it works for me, I'll upload.

David Svensson (davidsvensson) wrote :
Martin-Éric Racine (q-funk) wrote :

Actually, the solution seems more involved than just adding a missing configure option. It will also involve rebuilding alsa-plugins with the updated alsa-lib.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-lib - 1.0.22-0ubuntu3

---------------
alsa-lib (1.0.22-0ubuntu3) lucid; urgency=low

  * debian/rules: add --with-plugindir=\$${prefix}/lib/alsa-lib to
    configure-stamp. Thanks to Daniel T Chen. (LP: #523716)
 -- Jamie Strandboge <email address hidden> Thu, 18 Feb 2010 11:54:14 -0600

Changed in alsa-lib (Ubuntu):
status: Triaged → Fix Released
Jamie Strandboge (jdstrand) wrote :

Updating alsa-lib fixed the missing library, so I uploaded it. However, the pa-mixer does not unmute. Q-FUNK mentioned in irc that alsa-plugins will need to be recompiled against the newer alsa-lib, so I am trying that locally. If it works, I'll upload.

Jamie Strandboge (jdstrand) wrote :

pavucontrol still doesn't unmute with alsa-plugins compiled against alsa-lib 1.0.22-0ubuntu3. Since the new combination of alsa-lib, pulseaudio and alsa-plugins does work if you unmute via alsamixer, I am going to step back from this bug and let the people who actually know what they are doing with all of this handle it. :)

Jamie Strandboge (jdstrand) wrote :

Just to be clear-- I am not uploading a new alsa-plugins at this time.

Jamie Strandboge (jdstrand) wrote :

One more clarification:
For me, my Front speakers were muted. If I unmute with alsamixer, all is fine and pavucontrol can adjust volume, etc. If I mute the Front speakers with alsamixer, I cannot unmute again with pavucontrol. This may be a totally unrelated issue.

zika (4zika4) wrote :

After some time away from the machine and reboot or two, one upgrade, I think, I have everything working... Flash, alsamixer...? I'll try to see what was upgraded in the meantime...

Martin-Éric Racine (q-funk) wrote :

The updated alsa-lib doesn't work, because the prefix is not expanded as it should be:

$ LC_ALL=C alsamixer
ALSA lib control.c:867:(snd_ctl_open_conf) Cannot open shared library ${prefix}/lib/alsa-lib/libasound_module_ctl_pulse.so
cannot open mixer: No such file or directory

zika (4zika4) wrote :

After some time away from the machine and reboot or two, one upgrade, I think, I have everything working... Flash, alsamixer...? I'll try to see what was upgraded in the meantime...

zika (4zika4) wrote :
Download full text (11.1 KiB)

===============================================================================

Log complete.
Aptitude 0.4.11.11: log report
Thu, Feb 18 2010 10:24:22 +0100

IMPORTANT: this log only lists intended actions; actions which fail due to
dpkg problems may not be completed.

Will install 0 packages, and remove 0 packages.
===============================================================================
===============================================================================

Log complete.
Aptitude 0.4.11.11: log report
Thu, Feb 18 2010 10:50:20 +0100

IMPORTANT: this log only lists intended actions; actions which fail due to
dpkg problems may not be completed.

Will install 0 packages, and remove 0 packages.
===============================================================================
===============================================================================

Log complete.
Aptitude 0.4.11.11: log report
Thu, Feb 18 2010 12:47:30 +0100

IMPORTANT: this log only lists intended actions; actions which fail due to
dpkg problems may not be completed.

Will install 0 packages, and remove 0 packages.
===============================================================================
===============================================================================

Log complete.
Aptitude 0.4.11.11: log report
Thu, Feb 18 2010 14:32:02 +0100

IMPORTANT: this log only lists intended actions; actions which fail due to
dpkg problems may not be completed.

Will install 0 packages, and remove 0 packages.
===============================================================================
===============================================================================

Log complete.
Aptitude 0.4.11.11: log report
Thu, Feb 18 2010 15:35:49 +0100

IMPORTANT: this log only lists intended actions; actions which fail due to
dpkg problems may not be completed.

Will install 3 packages, and remove 0 packages.
12.3kB of disk space will be used
===============================================================================
[UPGRADE] libpam-modules 1.1.1-1ubuntu1 -> 1.1.1-2ubuntu1
[UPGRADE] libpam-runtime 1.1.1-1ubuntu1 -> 1.1.1-2ubuntu1
[UPGRADE] libpam0g 1.1.1-1ubuntu1 -> 1.1.1-2ubuntu1
===============================================================================

Log complete.
Aptitude 0.4.11.11: log report
Thu, Feb 18 2010 16:28:24 +0100

IMPORTANT: this log only lists intended actions; actions which fail due to
dpkg problems may not be completed.

Will install 24 packages, and remove 0 packages.
20.5kB of disk space will be used
===============================================================================
[UPGRADE] apport-symptoms 0.7 -> 0.8
[UPGRADE] dmsetup 2:1.02.39-1ubuntu2 -> 2:1.02.39-1ubuntu3
[UPGRADE] gtk2-engines-pixbuf 2.19.5-1ubuntu2 -> 2.19.5-1ubuntu3
[UPGRADE] libdevmapper1.02.1 2:1.02.39-1ubuntu2 -> 2:1.02.39-1ubuntu3
[UPGRADE] libdrm-intel1 2.4.17+git20100210.4f0f8717-0ubuntu0sarvatt -> 2.4.18+git20100217.2d9990c7-0ubuntu0sarvatt
[UPGRADE] libdrm-nouveau1 2.4.17+git20100210.4f0f8717-0ubuntu0sarvatt -> 2.4.18+git20100217.2d9990c7-0ubuntu0sarvatt
[UPGRADE] libdrm-radeon1 2.4.17+git20100210.4f0f8717-0ubuntu0sarvatt -> 2.4.18+git20100217.2d9990c7-0ubunt...

David Svensson (davidsvensson) wrote :

pulseaudio:
  Installed: 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu8
  Candidate: 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu8
  Version table:
 *** 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu8 0
        500 http://fi.archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status

My sound is back in working condition!

kaij74 (kaij74) wrote :

I have all the latest versions and still no sound... and it did work before these audio related updates today.

kaij74 (kaij74) wrote :

Alsamixer is broken too, it doesn't have any effect on any gui volume controls.

zika (4zika4) wrote :

I've lost sound in Flash, again, with no reboot, and several upgrades:
[quote]Aptitude 0.4.11.11: log report
Thu, Feb 18 2010 19:11:27 +0100

IMPORTANT: this log only lists intended actions; actions which fail due to
dpkg problems may not be completed.

Will install 3 packages, and remove 0 packages.
4,096B of disk space will be used
===============================================================================
[UPGRADE] libindicate-gtk2 0.3.2-0ubuntu1 -> 0.3.3-0ubuntu1
[UPGRADE] libindicate4 0.3.2-0ubuntu1 -> 0.3.3-0ubuntu1
[UPGRADE] libindicator0 0.3.2-0ubuntu1 -> 0.3.3-0ubuntu1
===============================================================================

Log complete.
Aptitude 0.4.11.11: log report
Thu, Feb 18 2010 21:31:57 +0100

IMPORTANT: this log only lists intended actions; actions which fail due to
dpkg problems may not be completed.

Will install 8 packages, and remove 0 packages.
418kB of disk space will be used
===============================================================================
[UPGRADE] indicator-me 0.2.3-0ubuntu2 -> 0.2.4-0ubuntu1
[UPGRADE] indicator-sound 0.1.0-0ubuntu2 -> 0.1.1-0ubuntu2
[UPGRADE] libasound2 1.0.22-0ubuntu2 -> 1.0.22-0ubuntu3
[UPGRADE] libdbusmenu-glib1 0.2.4-0ubuntu1 -> 0.2.5-0ubuntu1
[UPGRADE] libdbusmenu-gtk1 0.2.4-0ubuntu1 -> 0.2.5-0ubuntu1
[UPGRADE] rhythmbox 0.12.6-1ubuntu10 -> 0.12.6git20100218-0ubuntu1
[UPGRADE] rhythmbox-plugin-cdrecorder 0.12.6-1ubuntu10 -> 0.12.6git20100218-0ubuntu1
[UPGRADE] rhythmbox-plugins 0.12.6-1ubuntu10 -> 0.12.6git20100218-0ubuntu1
===============================================================================

Log complete.
Aptitude 0.4.11.11: log report
Thu, Feb 18 2010 21:44:49 +0100

IMPORTANT: this log only lists intended actions; actions which fail due to
dpkg problems may not be completed.

Will install 0 packages, and remove 0 packages.
===============================================================================
===============================================================================

Log complete.
Aptitude 0.4.11.11: log report
Thu, Feb 18 2010 22:39:02 +0100

IMPORTANT: this log only lists intended actions; actions which fail due to
dpkg problems may not be completed.

Will install 2 packages, and remove 0 packages.
90.1kB of disk space will be used
===============================================================================
[UPGRADE] indicator-messages 0.3.1-0ubuntu2 -> 0.3.2-0ubuntu1
[UPGRADE] indicator-session 0.2.2-0ubuntu2 -> 0.2.3-0ubuntu1
===============================================================================
[/quote]...

kaij74 (kaij74) wrote :

If i try to run speaker-test, i get this ALSA lib pcm.c:2171:(snd_pcm_open_conf) Cannot open shared library ${prefix}/lib/alsa-lib/libasound_module_pcm_pulse.so
Playback open error: -2,No such file or directory

tad1073 (tad1073) wrote :

I just updated about 10 min. ago...still no sound

The pulseaudio packages were only recently published. If you are using a mirror, please bare in mind that it can take up to several hours before your mirror has all the pieces to allow you to fetch the updates.

Brian Rogers (brian-rogers) wrote :

alsa-lib is broken. It's literally looking for ${prefix}/lib/alsa-lib/libasound_module_pcm_pulse.so. The ${prefix} isn't being expanded at build time. Just running aplay (no parameters) gives this error:

ALSA lib pcm.c:2171:(snd_pcm_open_conf) Cannot open shared library ${prefix}/lib/alsa-lib/libasound_module_pcm_pulse.so
aplay: main:608: audio open error: No such file or directory

kaij74 (kaij74) wrote :

I managed to solve my other issues but alsa-lib is indeed broken.

Alberto Aldegheri (albyrock87) wrote :

Pulseaudio is no longer broken, but the problem is in the alsa-lib.

Cannot open shared library ${prefix}/lib/alsa-lib/libasound_module_pcm_pulse.so

Harry (harry33) wrote :

Indeed, there is something wrong with the alsamixer function.
I cannot open it as gui, but it will open in terminal.

From therminal I could turn up the volume of the front speakers.
Now sound is working again, also after boot.up.

It is just that you need alsamixer to do this.
And, alsamixer is not supported by canonical.

Daniel T Chen (crimsun) on 2010-02-19
Changed in pulseaudio (Ubuntu):
assignee: Luke Yelavich (themuso) → Daniel T Chen (crimsun)
Changed in alsa-lib (Ubuntu):
assignee: nobody → Daniel T Chen (crimsun)
Alberto Aldegheri (albyrock87) wrote :

Now it's working! Great Work!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers