Ubuntu

Pulseaudio is blocking normal sound after resume

Reported by Liken Otsoa on 2008-03-14
380
This bug affects 45 people
Affects Status Importance Assigned to Milestone
PulseAudio
Fix Released
Unknown
gnome-power-manager (Baltix)
Undecided
Unassigned
gnome-power-manager (Ubuntu)
Undecided
Unassigned
Intrepid
Undecided
Unassigned
Jaunty
Undecided
Unassigned
pulseaudio (Ubuntu)
Low
Daniel T Chen
Intrepid
Undecided
Daniel T Chen
Jaunty
Low
Daniel T Chen

Bug Description

jaunty SRU information follows:

Note that this SRU involves two separate bugs, this one and bug 326532.

Impact: Users who experience problems with PulseAudio often kill it (using "pulseaudio -k" or "killall pulseaudio", the latter of which is more reliable). Jaunty's current pm-utils sleep hook looks for the session-invoked command line. Users who invoke pulseaudio manually, after killing it, with "pulseaudio -D" (or other variants) do not have this session-invoked command line, and thus, when they suspend to ram or disk, the pm-utils sleep hook does not suspend their pulseaudio daemons.

Note that the use case of killing the pulseaudio daemon and allowing it to autospawn afterward is unaffected; jaunty's existing pm-utils sleep hook correctly reaps all pulseaudio instances. This SRU only applies to manually invoked "pulseaudio -D", "pulseaudio -vvv", etc.

Resolution: Modify the pm-utils sleep hook to correctly reap all pulseaudio instances regardless of pulseaudio invocation command line.

SRU debdiff: http://launchpadlibrarian.net/25941550/pulseaudio_0.9.14-0ubuntu20.1.debdiff

TEST CASE: Boot into a jaunty install. In a Terminal, issue "killall pulseaudio;pulseaudio -D". Suspend to ram, then resume. Note the inaudible audio from PulseAudio.

Regression potential: No regressions have been identified in production.
--
old intrepid SRU information follows:

Impact: A portion of users with a default or updated (intrepid-updates) Ubuntu 8.10 install experience inaudible audio from PulseAudio after resuming from suspend-to-ram. This symptom is due to the PulseAudio daemon not having received proper notification to suspend clients and release the sound device(s).

Resolution: Configure users' pulseaudio daemons to suspend prior to suspending to ram and to resume after resuming. This sequence is accomplished via a pm-utils sleep hook. The corresponding fixed version (0.9.13-2ubuntu3) is available in jaunty.

SRU debdiff: http://launchpadlibrarian.net/20316781/pulseaudio_0.9.10-2ubuntu9.2.debdiff

TEST CASE: Boot into a default or updated (intrepid-updates) Ubuntu 8.10 install. Suspend to ram, then resume. Note the inaudible audio from PulseAudio.

Regression potential: No regressions have been identified in production.

Background information follows:

Binary package hint: pulseaudio

> aplay squish.au
Sonando Audio Sparc 'squish.au' : Mu-Law, Ratio 8000 Hz, Mono

[Suspend to Ram/Resume]

> aplay squish.au
ALSA lib pcm_dmix.c:874:(snd_pcm_dmix_open) unable to open slave
aplay: main:546: error al abrir audio: Dispositivo ó recurso ocupado

Then you need to killall pulseaudio for apps that use pcm starts working again.
(Question: How you can stop/start/restart pulseudio? In Ubuntu /etc/init.d/pulseaudio script is disabled)

If you need more information, please let me know.

Thx.

----------------------------------
Hardy Uptodate
IBM Thinkpad X41 Tablet
pulseaudio 0.9.9-1ubuntu2

zpon (zpon-dk) wrote :

I got here because I had a similar problem (with mocp), it helped to killall pulseaudio - but the I experienced some weird problems with gnome-power-manager, not that it took 100% CPU, but that i used up most my memory (bout 600 MiB), can this relay be on purpose? or is it some kind of memory leak or what ever?
I have attached a screenshot of Systemmanager(? I only know the danish name - "Systemovervågning" - but it kind of does the same as the top command).

So basically i can confirm both that there can be a problem with pulseaudio and that gnome-power-manager has a problem.
I also use a uptodate version of Hardy.
IBM Thinkpad T61
Version: 0.9.9-1ubuntu2

If you need more info just let me know

hackel (hackel) wrote :

For me, this is triggered not when I resume (as resuming from suspend *always* causes a hard freeze), but when I unplug my power cable. Pulseaudio starts to use a lot of CPU, so then I kill it, and then gnome-power-manager uses 100% cpu, with the above mentioned memory leak. If I don't kill gnome-power-manager in time, it will take down my whole system.

I've got an ATI Technologies Inc IXP SB400 AC'97 Audio Controller (rev 02) with all the latest hardy packages.

akira (akira.spb) wrote :

Skype not play sound.
./skype
ALSA lib pcm_dmix.c:874:(snd_pcm_dmix_open) unable to open slave
ALSA lib pcm_dmix.c:874:(snd_pcm_dmix_open) unable to open slave
ALSA lib pcm_dmix.c:874:(snd_pcm_dmix_open) unable to open slave
ALSA lib pcm_dmix.c:874:(snd_pcm_dmix_open) unable to open slave
ALSA lib pcm_dmix.c:874:(snd_pcm_dmix_open) unable to open slave
ALSA lib pcm_dmix.c:874:(snd_pcm_dmix_open) unable to open slave

Gregory Oschwald (osch0001) wrote :

Also I am experiencing this in Skype with the latest version of Hardy.

akira (akira.spb) wrote :

PulseAudio is a Evil! =\

christooss (matic-ahacic) wrote :

Same problem with PulseAudio. If devs need more info I will be glad to provide it.

Kieran Hogg (xerosis) wrote :

Confirming this bug, I see it too. I removed the info about the gnome-power-manager, that should be logged as another bug, this is just for blocking sound after resume.

description: updated
Changed in pulseaudio:
status: New → Confirmed
Andy Kniss (akniss) wrote :

Same happens to me. After resuming, I can get sound working with killall pulseaudio. However, when I do, gnome-power-manager starts using large amounts of cpu and memory. After killing pulseaudio, I watched the Memory column in gnome-system-monitor climb quite rapidly. It reached 1.3 GB while I was watching before I killed gnome-power-manager. I'm using Ubuntu amd64 Beta with all updates applied.

Andy Kniss (akniss) wrote :

lspci | grep Audio:
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

Dell XPS m1330 laptop

  PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
11259 fritsch 20 0 1805m 1.5g 9200 S 50 77.9 2:35.84 gnome-power-man

Same bug hitting me - also killing power manager fixes this for me ;-). But this is not really a fix and a regression from gutsy - here sound worked after resume without problems.

Dennis Dirdjaja (dcd-ditsch) wrote :

Confirming this bug on a MacbookPro3,1 (Santa Rosa) with an up-to-date Hardy. If there is a need for more information, please ask.

Leonardo Prosperi (leo1981) wrote :

I have the same problem.
Is this the same of Bug #198218?

zpon (zpon-dk) wrote :

I haven't had any problems with gnome-power-manager for some time now, but today the problem came back, more screenshots attached.

Victor Osadci (victor-os) wrote :

#zpon - the g-p-m is a different bug, please subscribe yourself to bug #196688

Carl (navlrac) wrote :

I get this as well, gnome-power-manager plays suspend chime and somtimes suspend happens before its done. On resume, pulseaudio does not release sound card --- skype etc can't access audio. Other pulse audio apps continue to work however.

Kill and restart gnome-power-manager: this releases pulseaudio and sound in skype etc works again for me.

I have the same issue although I don't have the debug experience to tell if it is Pulseaudio, alsa or the (in my case) snd-hda-intel driver that is causing issues.

Data are:

1) Linux Wordsworth 2.6.24-14-generic #1 SMP Thu Apr 3 04:49:29 UTC 2008 i686 GNU/Linux

2) Dmesg.log and lspci-vvnn.log attached

The same issue did not occur with Gutsy and the workaround suggested above does not work on my hardware since the module will not "rmmod" despite pulseaudio being killed.

I would see this as a very high priority bug for a lot of users. Anyone disagree?

Skype doesn't work for me because of the same reason. But I have a work-around

Problem description:

1. log in
2. open a terminal
3. start skype from terminal

Expected results:

Skype works...

Actual:

"ALSA lib pcm_dmix.c:874:(snd_pcm_dmix_open) unable to open slave"

displayed 4 times, and sound doesn't work in skype (works in rest of desktop).

Work-around:

remove the snd_hda_intel module and reload it. To be able to remove it, I need to close all applications using it, i.e. pulseaudio. Thus I have to close my current session.

Detailed work-around

1- close session (log out)
2- CTRL+ALT+F1 to go to a tty
3- log in
4- sudo rmmod snd_hda_intel
5- sudo modprobe snd_hda_intel
6- CTRL+ALT+F7 and log in again

skype works :)

(or should I say :( as it isn't free)

zdzichu (zdzichu-gmail) wrote :

gnome-power-manager issue seems to be related to http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=472637 , which got fixed in recent ubuntu import from debian.

Victor Osadci (victor-os) wrote :

This seems to be working for me for some time now. Can anyone confirm ?

Kieran Hogg (xerosis) wrote :

Seems to be fixed here too.

Dennis Dirdjaja (dcd-ditsch) wrote :

Yes, I did not see this happening any more since one of the last Pulseaudio updates, I think.

Gregory Oschwald (osch0001) wrote :

I am still occasionally on my Thinkpad X60s (Intel audio) with an up-to-date Hardy install. In fact, I just had it happen this morning. User apps such as Rhythmbox will not play sound after resume until I kill pulseaudio.

still the same problem for me, hardy with latest updates..

Lubosz Sarnecki (lubosz) wrote :

i get this when i want to play a flash video in firefox while vlc is playing sound.
the flash video has no sound.
if i play the flash video first / start firefox first, vlc has no sound.
vlc instanced themselfes and flash videos in mulitple tabs can have sound at the same time.
fix this, it came with RC1

Matt LaPaglia (mlapaglia) wrote :

If i have rhythmbox open playing something, press pause, open firefox and go to youtube, the video will not play. turning firefox on without rhythmbox on allows youtube to work properly.

Victor Osadci (victor-os) wrote :

@lubosz, this is a problem with the non-free flash plugin, and not related to this bug.

PS: try to install libflashsupport

Giovanni Mellini (merlos) wrote :

I have the same problem back with last update.

I tried to open youtube video in FireFox, and on console I have lot of the following messages

  ALSA lib pcm_dmix.c:874:(snd_pcm_dmix_open) unable to open slave

and no video sound (while rhythmbox works well); same problem with skype.

Kill the pulseaudio daemon restore the rigth behavior

merlos@merlos-lap:/var/log$ ps axf | grep puls
 7188 ? Sl 0:31 | \_ /usr/bin/pulseaudio --log-target=syslog
 7191 ? S 0:00 | \_ /usr/lib/pulseaudio/pulse/gconf-helper
10592 pts/0 S+ 0:00 \_ grep puls
merlos@merlos-lap:/var/log$ killall pulseaudio
merlos@merlos-lap:/var/log$ ps axf | grep puls
10601 pts/0 S+ 0:00 \_ grep puls
merlos@merlos-lap:/var/log$

tks
Giovanni

Giovanni Mellini (merlos) wrote :

@Victor Osadci
I noticed that libflashsupport were removed this morning with the "partial upgrade"

Same problem here, no sound from flash (nonfree), latest up to date Hardy.

Error in console:

ALSA lib pcm_dmix.c:874:(snd_pcm_dmix_open) unable to open slave

Tom Wright (twright-tdw) wrote :

libflashsupport should be restored as a dependancy of flash

I'm still experiencing this bug after resuming.

Victor Osadci (victor-os) wrote :

This bug is back for me - clean 8.04 install on the same laptop.

dr-phil (philliple01) wrote :

ALSA lib pcm_dmix.c:874:(snd_pcm_dmix_open) unable to open slave

I get this error when i open wc3 and my graphics are completely stuffed but they may be unrelated, not sure yet.

Rodrigo Primo (rodrigosprimo) wrote :

I think I have the same problem. I'm running a fresh install of Ubuntu 8.04 64bits on a HP Pavilion DV6338se. If I start, for example, Amarok and after Skype, Skype says it is unable to use the sound device:

"ALSA lib pcm_dmix.c:874:(snd_pcm_dmix_open) unable to open slave"

If I run "killall pulseaudio", Skype starts working.

I've attached the lspci -vvnn and dmesg in case this can be helpful. Please let me know if I can help providing more information or testing.

Rodrigo Primo (rodrigosprimo) wrote :

The lspci -vvnn file.

zpon (zpon-dk) wrote :

I have earlier had problems with gnome-power-manager (and was told it was do to another bug - https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/196688), but yesterday I got a similar problem with pidgin:

The sound suddenly wasn't working, and I did a "killall pulseaudio", this used to help but didn't, so instead I did "ps aux | grep pulseaudio" and "kill -9 xxxx", and in the same moment I got a pidgin sound (like when you receive a message), even though it was at least an hour since I last got one. And then the system got slow, real slow, but i manage to open up gnome-system-monitor, and I saw that pidgin was eating up more that 500MB of my memory. Killing pidgin made the system run normal again.

It might be another bug again, but kind of weird it comes at the same as the gnome-power-manager did.

zpon (zpon-dk) wrote :

Pidgin using 625MB memory

Jason Sheedy (jason-jmpj) wrote :

I'm receiving the same error when trying to run Neverwinter Nights. The problem has started after I upgraded to Hardy 8.04. I'm also been experiencing problems with flash audio.

ALSA lib pcm_dmix.c:874:(snd_pcm_dmix_open) unable to open slave

Changed in pulseaudio:
status: Unknown → Invalid
Daniel T Chen (crimsun) on 2008-10-18
Changed in pulseaudio:
assignee: nobody → crimsun
importance: Undecided → Low
status: Confirmed → In Progress
Changed in gnome-power-manager:
status: New → Invalid
Changed in pulseaudio:
status: Invalid → New
Daniel T Chen (crimsun) on 2008-12-09
description: updated
Changed in pulseaudio:
status: In Progress → Fix Released
Daniel T Chen (crimsun) on 2008-12-10
description: updated
Martin Pitt (pitti) on 2008-12-15
Changed in gnome-power-manager:
status: New → Invalid
Changed in pulseaudio:
assignee: nobody → crimsun
status: New → Confirmed
Martin Pitt (pitti) on 2008-12-17
Changed in pulseaudio:
status: Confirmed → Fix Committed
59 comments hidden view all 139 comments

I'm following this bug having seen it on my Hardy install. Any chance this
fix makes it into Hardy as well?

2008/12/17 Martin Pitt <email address hidden>

> Accepted into intrepid-proposed, please test and give feedback here.
> Please see https://wiki.ubuntu.com/Testing/EnableProposed for
> documentation how to enable and use -proposed. Thank you in advance!
>
> ** Changed in: pulseaudio (Ubuntu Intrepid)
> Status: Confirmed => Fix Committed
>
> ** Tags added: verification-needed
>
> --
> Pulseaudio is blocking normal sound after resume
> https://bugs.launchpad.net/bugs/202089
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Chow Loong Jin (hyperair) wrote :

On Wed, 2008-12-17 at 07:33 +0000, Martin Pitt wrote:
> Accepted into intrepid-proposed, please test and give feedback here.
> Please see https://wiki.ubuntu.com/Testing/EnableProposed for
> documentation how to enable and use -proposed. Thank you in advance!
>
> ** Changed in: pulseaudio (Ubuntu Intrepid)
> Status: Confirmed => Fix Committed
>
> ** Tags added: verification-needed
>
I've tested the update, and can confirm that it works.
--
Chow Loong Jin

rbg (ross-girshick) wrote :

I've tested this using intrepid-proposed and can report that it partially works. With the updated package I no longer have to manually restart pulseaudio, however it doesn't work in the sense that I *do* have to restart firefox in order to make flash applications play audio again (e.g., streaming music via pandora).

erlguta (gonzalomarcote) wrote :

I've tested in my 3 machines with the jsteinhart propossed PPA packages
In two it works and in one Dell with Creative Labs SB Audigy LS it does not works:
PC 1:
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
It works sound after suspend

PC 2:
05:00.0 Multimedia audio controller: Creative Labs SB Audigy LS
It still not works after suspend

Laptop Dell Mini 9:
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
It works sound after suspend

rbg:
>have to restart firefox in order to make flash applications play audio again

Have you tested youtube for example?
For me it works ok after suspend.

rbg (ross-girshick) wrote :

elguta:
> Have you tested youtube for example?
> For me it works ok after suspend.

No sounds from youtube either, until I restart firefox. I'm testing on a lenovo thinkpad z61t with:
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

Did you have firefox open before suspending?

Chow Loong Jin (hyperair) wrote :

On Fri, 2008-12-19 at 12:32 +0000, rbg wrote:
> elguta:
> > Have you tested youtube for example?
> > For me it works ok after suspend.
>
> No sounds from youtube either, until I restart firefox. I'm testing on a lenovo thinkpad z61t with:
> 00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
>
> Did you have firefox open before suspending?
>
I have Youtube playing sound before suspending, and upon resuming, the
sound continues. Using flashplugin-nonfree version 10.0.12.36ubuntu1.
--
Chow Loong Jin

skflyfish (jpeasley) wrote :

I have a Thinkpad R61 with:

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
flashplugin-nonfree 10.0.15.3ubuntu1~intrepid1

and the last proposed update cured the blocked sound after resume. No need to restart Firefox at all. HTH.

rbg (ross-girshick) wrote :

I'm also using flashplugin-nonfree 10.0.15.3ubuntu1~intrepid1. If I run pulseaudio from a terminal using `pulseaudio -vv`, when my system comes back from suspend I see this error message:

module-alsa-sink.c: Got POLLERR from ALSA

Please let me know if there's any additional information that I can add to help. Thanks.

Chow Loong Jin (hyperair) wrote :

The 01PulseAudio sleep hook for pm-utils included in pulseaudio
0.9.10-2ubuntu9.2 does not work if PulseAudio was not started using the
full path. In my case, I started PulseAudio manually, after accidentally
killing it, using this command: "pulseaudio -D". The sleep hook fails to
do its job. Specifically, the get_pulse_users() function does not return
my username, eventhough pulseaudio is running under my username, because
it searches the output of "ps aux" for "/usr/bin/pulseaudio -D" as
opposed to just "pulseaudio -D" or "pulseaudio"
--
Chow Loong Jin

rbg (ross-girshick) wrote :

I noticed that my user wasn't part of the groups "pulse", "pulse-access", or "pulse-rt". I'm not sure what the correct membership should be, but I tried adding myself to all of those groups. After making that change I have audio from flash applications in firefox after suspending and resuming. Yay!

Tom Wright (twright-tdw) wrote :

this seems to be fixed in the glitch free pulseaudio release in openSUSE

zorblek (zorblek) wrote :

I, too have been experiencing this bug with Ubuntu Intrepid. Jsteinhart's fix appears to partially fix the problem. Before installing the fix, when I attempted to play a flash video after a suspend cycle it would play for a few seconds then stop, with no sound. When I switched over to a console and back, the video would then resume and sounds would play as normal.

Now that I have installed the fix, flash videos don't stop after a few seconds. They continue to play, but I still don't get any sound from them (or anything else). When I switch back from a console, the video will pause in the middle of playback while all of the audio that i missed plays, then it will resume from where I left off.

In any event, I still don't get any other sounds (with or without the fix) until I switch to and from a console.

If there's any more useful information I can give you, let me know.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 0.9.10-2ubuntu9.2

---------------
pulseaudio (0.9.10-2ubuntu9.2) intrepid-proposed; urgency=low

  * Add pm-utils sleep hook to suspend (and resume) users' pulseaudio
    daemons (LP: #202089). Based on a patch by
    Chow Loong Jin <email address hidden>.

 -- Daniel T Chen <email address hidden> Mon, 08 Dec 2008 22:11:32 -0800

Changed in pulseaudio:
status: Fix Committed → Fix Released
Dave Gilbert (ubuntu-treblig) wrote :

I still seem to be seeing this on 0.9.10-2ubuntu9.3 which is what is currently installed on my Intrepid box.

This morning I had to do a pasuspender /bin/true to get the sound going again after I woke it up from hibernate.

(Yesterday I had to restart the demon after it had gone completely - but that's rarer)

Dave

I'm seeing this on Intrepid with kernel 2.6.27.11 on AMD 64 with pulseaudio 0.9.13-0ubuntu1~ppa2

Just after resume:
Feb 6 20:53:02 AppleCider pulseaudio[6415]: alsa-util.c: Got POLLERR from ALSA
Feb 6 20:53:02 AppleCider pulseaudio[6415]: alsa-util.c: PCM state is SUSPENDED
Feb 6 20:53:02 AppleCider pulseaudio[6415]: alsa-util.c: Got POLLERR from ALSA
Feb 6 20:53:02 AppleCider pulseaudio[6415]: alsa-util.c: PCM state is RUNNING
Feb 6 20:53:02 AppleCider pulseaudio[6415]: alsa-util.c: Got POLLERR from ALSA
Feb 6 20:53:02 AppleCider pulseaudio[6415]: alsa-util.c: PCM state is RUNNING
etc

While this is happening the speaker emits a clicking or buzzing sound.

Download full text (3.1 KiB)

I'm pretty sure I was still experiencing this bug with the latest update,
but I can't check at the moment because a separate issue is preventing Gnome
from loading.

On Sun, Feb 8, 2009 at 8:24 AM, Nikolaj Sheller
<email address hidden>wrote:

> I'm seeing this on Intrepid with kernel 2.6.27.11 on AMD 64 with
> pulseaudio 0.9.13-0ubuntu1~ppa2
>
> Just after resume:
> Feb 6 20:53:02 AppleCider pulseaudio[6415]: alsa-util.c: Got POLLERR from
> ALSA
> Feb 6 20:53:02 AppleCider pulseaudio[6415]: alsa-util.c: PCM state is
> SUSPENDED
> Feb 6 20:53:02 AppleCider pulseaudio[6415]: alsa-util.c: Got POLLERR from
> ALSA
> Feb 6 20:53:02 AppleCider pulseaudio[6415]: alsa-util.c: PCM state is
> RUNNING
> Feb 6 20:53:02 AppleCider pulseaudio[6415]: alsa-util.c: Got POLLERR from
> ALSA
> Feb 6 20:53:02 AppleCider pulseaudio[6415]: alsa-util.c: PCM state is
> RUNNING
> etc
>
> While this is happening the speaker emits a clicking or buzzing sound.
>
> --
> Pulseaudio is blocking normal sound after resume
> https://bugs.launchpad.net/bugs/202089
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in PulseAudio sound server: New
> Status in "gnome-power-manager" source package in Ubuntu: Invalid
> Status in "pulseaudio" source package in Ubuntu: Fix Released
> Status in gnome-power-manager in Ubuntu Intrepid: Invalid
> Status in pulseaudio in Ubuntu Intrepid: Fix Released
> Status in "gnome-power-manager" source package in Baltix: New
>
> Bug description:
> SRU information follows:
>
> Impact: A portion of users with a default or updated (intrepid-updates)
> Ubuntu 8.10 install experience inaudible audio from PulseAudio after
> resuming from suspend-to-ram. This symptom is due to the PulseAudio daemon
> not having received proper notification to suspend clients and release the
> sound device(s).
>
> Resolution: Configure users' pulseaudio daemons to suspend prior to
> suspending to ram and to resume after resuming. This sequence is
> accomplished via a pm-utils sleep hook. The corresponding fixed version
> (0.9.13-2ubuntu3) is available in jaunty.
>
> SRU debdiff:
> http://launchpadlibrarian.net/20316781/pulseaudio_0.9.10-2ubuntu9.2.debdiff
>
> TEST CASE: Boot into a default or updated (intrepid-updates) Ubuntu 8.10
> install. Suspend to ram, then resume. Note the inaudible audio from
> PulseAudio.
>
> Regression potential: No regressions have been identified in production.
>
> Background information follows:
>
> Binary package hint: pulseaudio
>
> > aplay squish.au
> Sonando Audio Sparc 'squish.au' : Mu-Law, Ratio 8000 Hz, Mono
>
> [Suspend to Ram/Resume]
>
> > aplay squish.au
> ALSA lib pcm_dmix.c:874:(snd_pcm_dmix_open) unable to open slave
> aplay: main:546: error al abrir audio: Dispositivo ó recurso ocupado
>
> Then you need to killall pulseaudio for apps that use pcm starts working
> again.
> (Question: How you can stop/start/restart pulseudio? In Ubuntu
> /etc/init.d/pulseaudio script is disabled)
>
> If you need more information, please let me know.
>
> Thx.
>
> ----------------------------------
> Hardy Uptodate
> IBM Thinkpad X41 Tablet
> pulseaudio 0.9.9...

Read more...

Jim Hunziker (landtuna) wrote :

I can confirm Dave Gilbert's report that this is still a problem on Intrepid with pulseaudio-0.9.10-2ubuntu9.3. My sound still disappears after a resume, and pasuspender echo makes my sound start working again.

Daniel T Chen (crimsun) wrote :

What happens if you modify /usr/lib/pm-utils/sleep.d/01PulseAudio to use sudo -H instead of just sudo?

i.e., http://package-import.ubuntu.com/p/pulseaudio/jaunty/annotate/head%3A/debian/01PulseAudio

Daniel T Chen (crimsun) wrote :

Note: look only at lines 11 and 17 of the above URL. Don't replace intrepid-updates's version of the file with jaunty's, because the command invocation is different.

Owen Williams (ywwg) wrote :

On a Dell 1420n of mine, recently upgraded to Intrepid, the default pulseaudio suspend/resume script doesn't work. If I use that script, I have to do the "pasuspender echo" trick to get sound back.

However, the script in this message does work: http://groups.google.com/group/linux.debian.bugs.dist/browse_thread/thread/bef8342095751302

What is the difference between these scripts that causes the second one to work?

Chow Loong Jin (hyperair) wrote :

On Wed, 2009-04-08 at 22:02 +0000, Owen Williams wrote:
> On a Dell 1420n of mine, recently upgraded to Intrepid, the default
> pulseaudio suspend/resume script doesn't work. If I use that script, I
> have to do the "pasuspender echo" trick to get sound back.
>
> However, the script in this message does work:
> http://groups.google.com/group/linux.debian.bugs.dist/browse_thread/thread/bef8342095751302
>
> What is the difference between these scripts that causes the second one
> to work?
>

The reason is that pacmd is flaky. Sometimes it works, sometimes it
doesn't work. I'm reopening this bug so that the fix shown in the link
you've provided can be used instead.

  affects ubuntu/pulseaudio
  status confirmed
--
Chow Loong Jin

Changed in pulseaudio (Ubuntu):
status: Fix Released → Confirmed
Chow Loong Jin (hyperair) wrote :

Here's a debdiff for Jaunty's package.
--
Chow Loong Jin

Luke Yelavich (themuso) wrote :

Chow, the user checking/sudo code is still needed, since one call to pactl as root will not suspend all sinks for all users. Please re-do the debdiff replacing the echo/pacmd stuff with the pactl call, and still using the for loop with sudo.

Thanks.

Chow Loong Jin (hyperair) wrote :

Actually, forget the previous patch. I just checked, and it doesn't work
unless you run pactl under the said user. This said patch includes a
more robust get_pulse_users() function.
--
Chow Loong Jin

Chow Loong Jin (hyperair) wrote :

Revised to use suspend-source as well.
--
Chow Loong Jin

Daniel T Chen (crimsun) on 2009-04-08
Changed in pulseaudio (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:0.9.14-0ubuntu20

---------------
pulseaudio (1:0.9.14-0ubuntu20) jaunty; urgency=low

  * debian/01PulseAudio: use pactl instead of pacmd (LP: #202089)

 -- Daniel T Chen <email address hidden> Wed, 08 Apr 2009 18:54:30 -0400

Changed in pulseaudio (Ubuntu):
status: Fix Committed → Fix Released
Daniel T Chen (crimsun) wrote :

reopening for release team approval

Changed in pulseaudio (Ubuntu):
status: Fix Released → Fix Committed
Daniel T Chen (crimsun) wrote :

Changes made to debian/01PulseAudio in the previous upload (1:0.9.14-0ubuntu20) work for the common case where the user has not manually killed the pulseaudio daemon. If, however, the user has killed the pulseaudio daemon, the existing check fails to pick up the new autospawned instance. Fix this corner case by harvesting all instances of pulseaudio.

Martin Pitt (pitti) wrote :

Please get it uploaded ASAP, so that we can consider it for post-RC. However, chances are that it gets rejected, and that it needs to become an SRU, if the remaining case is important enough.

Steve Langasek (vorlon) wrote :

Sorry, yes, rejecting this for jaunty. I think it's unlikely to warrant an SRU, but we can discuss that if you think it's needed.

Changed in pulseaudio (Ubuntu):
status: Fix Committed → Triaged
Martin Pitt (pitti) wrote :

Daniel, can you please upload this to jaunty-proposed as an SRU? (Please note that you can already do this, it just won't get accepted until after Jaunty is released).

Martin Pitt (pitti) wrote :

The most common case is fixed in Jaunty/intrepid-updates, and the remaining corner case should be fixed in Karmic.

Daniel, I'm happy to sponsor the debdiff to karmic once it opens.

Changed in pulseaudio (Ubuntu Jaunty):
status: Triaged → Won't Fix
Changed in pulseaudio (Ubuntu):
status: Triaged → Fix Committed
Daniel T Chen (crimsun) on 2009-04-23
Changed in pulseaudio (Ubuntu Jaunty):
status: Won't Fix → Fix Committed
1 comments hidden view all 139 comments
Martin Pitt (pitti) wrote :

Daniel, so you think the remaining case is still important enough for an SRU? Can you please update the bug description accordingly? Thanks!

Daniel T Chen (crimsun) on 2009-04-24
description: updated
tags: removed: verification-done
1 comments hidden view all 139 comments
skflyfish (jpeasley) wrote :

FWIW, while this was an issue when Intrepid came out and Daniels patch corrected it. I have not experienced this issue with Jaunty on my Thinkpad R61.

Martin Pitt (pitti) wrote :

Accepted into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:0.9.15-1ubuntu2

---------------
pulseaudio (1:0.9.15-1ubuntu2) karmic; urgency=low

  * debian/01PulseAudio: harvest users more robustly. Thanks,
    Chow Loong Jin <email address hidden>! (LP: #202089)
  * debian/control: pulseaudio depends on pulseaudio-module-hal
    to fix LP: #326532

 -- Daniel T Chen <email address hidden> Thu, 09 Apr 2009 17:03:00 -0400

Changed in pulseaudio (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-power-manager (Baltix):
status: New → Invalid
Kees Cook (kees) wrote :

This SRU needs to be updated since a security update has been published above the unverified -proposed upload for this bug.

Changed in pulseaudio (Ubuntu Jaunty):
status: Fix Committed → Incomplete
Steve Langasek (vorlon) on 2009-07-16
Changed in pulseaudio (Ubuntu Jaunty):
status: Incomplete → Triaged
Changed in pulseaudio:
status: New → Fix Released
Martin Pitt (pitti) wrote :

Not worth an SRU for Jaunty IMHO.

Changed in pulseaudio (Ubuntu Jaunty):
status: Triaged → Won't Fix
Displaying first 40 and last 40 comments. View all 139 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.