No sound after suspend to RAM

Bug #222428 reported by Yann Arnaud on 2008-04-26
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
PulseAudio
New
Undecided
Unassigned
pulseaudio (Ubuntu)
Undecided
Unassigned

Bug Description

Problem description: when recovering from suspend to RAM there is no sound.
Sound is working fine the rest of the time, closing the session does not restore sound but a reboot does.

1) Ubuntu version: Hardy Heron upgraded from Gutsy, default configuration; output of uname -r: 2.6.24-16-generic

2) Output of aplay -l
**** Liste des PLAYBACK périphériques ****
carte 0: VT82xx [HDA VIA VT82xx], périphérique 0 : ALC883 Analog [ALC883 Analog]
  Sous-périphériques: 1/1
  Sous-périphérique: #0: subdevice #0
carte 0: VT82xx [HDA VIA VT82xx], périphérique 1 : ALC883 Digital [ALC883 Digital]
  Sous-périphériques: 1/1
  Sous-périphérique: #0: subdevice #0

3) lspci -v
 04:01.0 Audio device: VIA Technologies, Inc. VIA High Definition Audio Controller (rev 10)
 Subsystem: Europop AG Unknown device e028
 Flags: bus master, fast devsel, latency 0, IRQ 23
 Memory at dfafc000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>

4) sudo modprobe snd-via82xx
Display nothing but still no sound

5) cat /proc/asound/cards
 0 [VT82xx ]: HDA-Intel - HDA VIA VT82xx
                      HDA VIA VT82xx at 0xdfafc000 irq 23

6) Restarting ALSA (sudo /etc/init.d/alsa-utils start ) doesn't change the issue

7) Stopping (pulseaudio -k) and relaunch pulseaudio (pulseaudio -D) doesn't help either

8) uname -a
Linux 2.6.24-16-generic #1 SMP i686 GNU/Linux

9) dpkg -s linux-ubuntu-modules-$(uname -r)
Package: linux-ubuntu-modules-2.6.24-16-generic
Status: install ok installed
Priority: optional
Section: base
Installed-Size: 15420
Maintainer: Ubuntu Kernel Team <email address hidden>
Architecture: i386
Source: linux-ubuntu-modules-2.6.24
Version: 2.6.24-16.23
Provides: ndiswrapper-modules-1.9
Depends: linux-image-2.6.24-16-generic
Pre-Depends: dpkg (>= 1.10.24)

I don't know what I can test in addition of this., I tried to follow troubleshooting procedure.
If more information is needed please don't hesitate to contact me.

Thanks for your help,
Yann

Yann Arnaud (taytaybob) wrote :
Yann Arnaud (taytaybob) wrote :
Chris D (cdekter) wrote :

Confirmed - identical problems here on a Sound Blaster Audigy:

01:08.0 Multimedia audio controller: Creative Labs SB Audigy LS
 Subsystem: Creative Labs Unknown device 100a
 Flags: bus master, medium devsel, latency 96, IRQ 19
 I/O ports at dc00 [size=32]
 Capabilities: <access denied>

Using Hardy AMD64 released version (clean install)

Andrey Vihrov (andrey.vihrov) wrote :

Same here on 64-bit Ubuntu Hardy with HDA Intel.

uname -a: Linux phoenix 2.6.24-16-generic #1 SMP Thu Apr 10 12:47:45 UTC 2008 x86_64 GNU/Linux

Andrey Vihrov (andrey.vihrov) wrote :

Confirmed here as well, with a fix (at least it works for me). running kubuntu hardy

try out
sudo /etc/init.d/alsa-utils stop
sudo alsa force-reload
sudo /etc/init.d/alsa-utils start

the force-reload is key since some kde processes are using the sound modules, and a normal reaload won't work.

if that works, create a file:

sudo vim /etc/pm/sleep.d/fixsound

#!/bin/bash
/etc/init.d/alsa-utils stop
alsa force-reload
/etc/init.d/alsa-utils start

now change permissions:
sudo chmod 770 /etc/pm/sleep.d/fixsound

Adding this file will make sound automatically work when you resume.

For whatever reason adding my snd modules to /etc/default/acpi-support (so they should in theory get reloaded) didn't work.

James

Yann Arnaud (taytaybob) wrote :

Thank you James for your workaround.
Although it crashes the gnome volume applet it works after the applet being reloaded.
This is not perfect but it does the job, thanks again!

Andrey Vihrov (andrey.vihrov) wrote :

Works on my side too, but indeed all sound programs crash or hang after that.

Trip Ericson (rovfan) wrote :

I also have this problem (Intel ICH8 w/ Realtek ALC268) and your fix worked. Thanks!

Ralph Wabel (rwabel) wrote :

Are you using pulseaudio?
If yes try to stop pulseaudio and start it again, worked for me
pulseaudio -k
pulseaudio -D

Andrey Vihrov (andrey.vihrov) wrote :

Doesn't work for me.

Did also work for me!

But instead of fighting with the "vim" i went: "sudo nautilus" and created that file with the nicer editor.

steve hardy (hardysteven) wrote :

Thanks - the fixsound alsa reload described above fixed this problem for me - as mentioned above it does crash any audio apps you have running at the time tho.

Intel Integrated audio :

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Aud
io Controller (rev 01)
 Subsystem: Foxconn International, Inc. Unknown device 0cbf
 Flags: bus master, fast devsel, latency 0, IRQ 16
 Memory at fdff8000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>

The pulseaudio approach did not work for me.

Cerebrate (robojoos) wrote :

This happens for me too. I have an HDA-Intel soundcard

cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xdc440000 irq 22

lspci -v

 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
 Subsystem: Toshiba America Info Systems Device ff01
 Flags: bus master, fast devsel, latency 0, IRQ 22
 Memory at dc440000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>

I'm running an upgraded 8.04 to Intrepid (kernel version 2.6.27-5-generic). This only started happening once I upgraded to Intrepid. I have to restart in order for this to fix itself. Affects all sound programs, haven't tried the pulseaudio reload or alsa reload.

I noticed that there's a single alsa process that goes zombie, which is a child of wish 8.5, running aMsn. Killing wish 8.5 doesn't fix the problem, even though the zombie alsa process does get cleaned up

Michael Gratton (mjog) wrote :

is this duplicate of bug #202089?

Cerebrate (robojoos) wrote :

Not that I can tell. It doesn't happen if I just unplug my power cable, only after a suspend. Also, pulseaudio dies by itself if I stop alsa with a reload. Gnome power manager also doesn't use a whole bunch of ram once pulseaudio does die.

doing this:
sudo /etc/init.d/alsa-utils stop
sudo alsa force-reload
sudo /etc/init.d/alsa-utils start

does fix it, though, as I said, pulseaudio dies by itself afterwards. I can then just run pulseaudio, and restart an app if it uses sound, and it works again.

Stem (stem21) wrote :

Sorry for my bad english.
This worked for me (also with playing amarok):

sudo gedit /etc/default/acpi-support
adding soundcore module to MODULES="" section like this:
MODULES="soundcore"

this remove and reload after suspend all sound modules (maybe a bug of a snd* module).
my soundcard is a realtek ALC861VD with snd-hda-intel module
I have downloaded and compiled HDA driver from productor's site.
I use ubuntu 8.04.1 on fujitsu siemens amilo li 1718.

also worked the previous:
sudo /etc/init.d/alsa-utils stop
sudo alsa force-reload
sudo /etc/init.d/alsa-utils start

WIGGMPk (wiggmpk) wrote :

I am having this similar issue, and have first experienced it in Gutsy Gibbon (amd64).

Adding the snd module to /etc/default/acpi-support does not work for me.

However the script shown above seems to work around the problem for now.

Just thought I should share my experience.

Liuskur (liuskur) wrote :

I am experiencing the same problems and I have a notebook with Intel HDA883 sound.
I have fresh installed ubuntu 8.04 LTS.
I tested my system for hours and finally found a solution that works for me without totally rebooting.
sudo alsa force-reload
pulseaudio -D

these are the only lines necessary for me, anyone with the same problem may also try:
sudo /etc/init.d/alsa-utils stop
sudo alsa force-reload
sudo /etc/init.d/alsa-utils start
pulseaudio -k
pulseaudio -D

WHAT ABOUT MAKING IT TO A SCRIPT!!
There is one problem for me, why i cant just write it to a file and let ubuntu load it every time it resumes.
The problem is:
when alsa force-reload is executed the volume control crashes and it asks you to not to reload or to reload.
this must be answered before pulseaudio -D is typed in.
So if it all is in script, then the script runs all those commands(including pulseaudio -D) in row and the volume control prompt is left on your desktop.

So for a script it is necessary to close the volume-control before alsa force-reload and then start the volume control again.

I DO NOT KNOW THE NEEDED COMMANDS FOR THAT please help!

On Wed, 2009-03-04 at 14:41 +0000, Liuskur wrote:
> *** This bug is a duplicate of bug 202089 ***
> https://bugs.launchpad.net/bugs/202089
>
> I am experiencing the same problems and I have a notebook with Intel HDA883 sound.
> I have fresh installed ubuntu 8.04 LTS.
> I tested my system for hours and finally found a solution that works for me without totally rebooting.
> sudo alsa force-reload
> pulseaudio -D
>
> these are the only lines necessary for me, anyone with the same problem may also try:
> sudo /etc/init.d/alsa-utils stop
> sudo alsa force-reload
> sudo /etc/init.d/alsa-utils start
> pulseaudio -k
> pulseaudio -D
>
> WHAT ABOUT MAKING IT TO A SCRIPT!!
> There is one problem for me, why i cant just write it to a file and let ubuntu load it every time it resumes.
> The problem is:
> when alsa force-reload is executed the volume control crashes and it asks you to not to reload or to reload.
> this must be answered before pulseaudio -D is typed in.
> So if it all is in script, then the script runs all those commands(including pulseaudio -D) in row and the volume control prompt is left on your desktop.
>
> So for a script it is necessary to close the volume-control before alsa
> force-reload and then start the volume control again.
>
> I DO NOT KNOW THE NEEDED COMMANDS FOR THAT please help!
>
This bug is fixed in Intrepid. See Bug #202089 and please do not post on
duplicate bugs.
--
Chow Loong Jin

zorblek (zorblek) wrote :
Download full text (4.1 KiB)

I'm not sure if it is the same bug. I'm still experiencing with the latest
updates in Intrepid. By the way, this fix works for me as well. I can't help
with a script, though.

On Wed, Mar 4, 2009 at 7:09 AM, hyperair <email address hidden> wrote:

> *** This bug is a duplicate of bug 202089 ***
> https://bugs.launchpad.net/bugs/202089
>
> On Wed, 2009-03-04 at 14:41 +0000, Liuskur wrote:
> > *** This bug is a duplicate of bug 202089 ***
> > https://bugs.launchpad.net/bugs/202089
> >
> > I am experiencing the same problems and I have a notebook with Intel
> HDA883 sound.
> > I have fresh installed ubuntu 8.04 LTS.
> > I tested my system for hours and finally found a solution that works for
> me without totally rebooting.
> > sudo alsa force-reload
> > pulseaudio -D
> >
> > these are the only lines necessary for me, anyone with the same problem
> may also try:
> > sudo /etc/init.d/alsa-utils stop
> > sudo alsa force-reload
> > sudo /etc/init.d/alsa-utils start
> > pulseaudio -k
> > pulseaudio -D
> >
> > WHAT ABOUT MAKING IT TO A SCRIPT!!
> > There is one problem for me, why i cant just write it to a file and let
> ubuntu load it every time it resumes.
> > The problem is:
> > when alsa force-reload is executed the volume control crashes and it asks
> you to not to reload or to reload.
> > this must be answered before pulseaudio -D is typed in.
> > So if it all is in script, then the script runs all those
> commands(including pulseaudio -D) in row and the volume control prompt is
> left on your desktop.
> >
> > So for a script it is necessary to close the volume-control before alsa
> > force-reload and then start the volume control again.
> >
> > I DO NOT KNOW THE NEEDED COMMANDS FOR THAT please help!
> >
> This bug is fixed in Intrepid. See Bug #202089 and please do not post on
> duplicate bugs.
> --
> Chow Loong Jin
>
> --
> No sound after suspend to RAM
> https://bugs.launchpad.net/bugs/222428
> You received this bug notification because you are a direct subscriber
> of the bug (via bug 202089).
>
> Status in “pulseaudio” source package in Ubuntu: Confirmed
>
> Bug description:
> Problem description: when recovering from suspend to RAM there is no sound.
> Sound is working fine the rest of the time, closing the session does not
> restore sound but a reboot does.
>
> 1) Ubuntu version: Hardy Heron upgraded from Gutsy, default configuration;
> output of uname -r: 2.6.24-16-generic
>
> 2) Output of aplay -l
> **** Liste des PLAYBACK périphériques ****
> carte 0: VT82xx [HDA VIA VT82xx], périphérique 0 : ALC883 Analog [ALC883
> Analog]
> Sous-périphériques: 1/1
> Sous-périphérique: #0: subdevice #0
> carte 0: VT82xx [HDA VIA VT82xx], périphérique 1 : ALC883 Digital [ALC883
> Digital]
> Sous-périphériques: 1/1
> Sous-périphérique: #0: subdevice #0
>
> 3) lspci -v
> 04:01.0 Audio device: VIA Technologies, Inc. VIA High Definition Audio
> Controller (rev 10)
> Subsystem: Europop AG Unknown device e028
> Flags: bus master, fast devsel, latency 0, IRQ 23
> Memory at dfafc000 (64-bit, non-prefetchable) [size=16K]
> Capabilities: <access denied>
>
> 4) sudo modprobe snd-via82xx
> Display nothing but still no sound
...

Read more...

Chow Loong Jin (hyperair) wrote :

On Wed, 2009-03-04 at 19:44 +0000, zorblek wrote:
>
> I'm not sure if it is the same bug. I'm still experiencing with the
> latest
> updates in Intrepid. By the way, this fix works for me as well. I
> can't help
> with a script, though.
>
If the fix works for you, then it _is_ the same bug. And the bug you're
posting is marked duplicate of Bug #202089. If the issue you're
experiencing is not Bug #202089, then it certainly isn't this either.
--
Chow Loong Jin

I really don't think this is duplicate of #202089 because this happens also in lubuntu which doesn't use pulseaudio.

My tests show that this happens on the latest lubuntu 13.10 amd64.

I have a HPCompaq 6720s laptop with the following sound card:

ubuntu@ubuntu:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
ubuntu@ubuntu:~$

After resume this is what I do in order to get the sound back:

1. kill all processes keeping devices in /dev/snd/ open. You can find them by typing:

lsof /dev/snd/*

After that you use the kill command on them

2. force an alsa reload. You do this with the following command:

sudo alsa force-reload

3. IF NEEDED: You start again the programs you previously killed

dzingishan (dzingishan) wrote :

The bug is almost 10 years old and still not fixed ?
I have Xubuntu 16.04 and still if I suspend comp I loose audio after restart from suspend.
Pity

Daniel van Vugt (vanvugt) wrote :

dzingishan,

This bug is marked as a duplicate of bug 202089 which was fix released 8 years ago, so is considered closed. Rightly or wrongly...

If you continue to experience a problem then please open a new bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions