Ubuntu

privoxy not start at boot - karmic

Reported by Greg Eden on 2009-09-11
154
This bug affects 28 people
Affects Status Importance Assigned to Milestone
privoxy (Debian)
Fix Released
Unknown
privoxy (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: privoxy

Privoxy works fine when started from the command line, but fails to start in the boot sequence. This was not an issue with Jaunty. I also use Debian Sid and the same bug manifests there.

It may be that it is trying to start too soon in the boot sequence as it relies on other services being running.

thanks

Confirmed on upgrade from Jaunty to Karmic; S20privoxy exists in /etc/rc{2345}.d/ linked to /etc/init.d/privoxy but does not start on boot.

No error messages seen in daemon.log.

Scripts start Privoxy successfully when manually invoked.

fghj (hjkl-deactivatedaccount) wrote :

I can second this, for privoxy 3.0.13-01 on a fresh karmic alpha 6 install.

/var/log/privoxy/logfile reads

Fatal error: can't bind to localhost:8118: The hostname is not resolvable

starslights (starslights) wrote :

hello,

i am on Kubuntu karmic 64 bits, 2.6.31-10-generic and privoxy 3.0.13 on home encrypted

It have always right worked so far but from the last update , it was unable to start at boot and don't find anymore the config.

I have reinstalled it and work again. I have not restarted the system since i have reinstall.

I will comment if it will non boot again after the next start.

starslights (starslights) wrote :

well , after restarted, privoxy are enable at start again.

So just reinstall privoxy and all will run again fine. The config will not lost, it just fix the braked link.

starslights (starslights) wrote :

well bug still, today i become this message:

Sep 23 11:25:34.732 7f11e92f26f0 Fatal error: can't check configuration file '/home/starslights/config': No such file or directory

i have need reinstall again privoxy .

Kubuntu Karmic 9.10 64 bits, 2.6.31-10-generic and privoxy 3.0.13 on home encrypted

my best

Stars

Architecture: amd64
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: privoxy 3.0.13-1
PackageArchitecture: amd64
ProcEnviron:
 SHELL=/bin/bash
 LANG=fr_CH.UTF-8
 LANGUAGE=
ProcVersionSignature: Ubuntu 2.6.31-10.35-generic
Uname: Linux 2.6.31-10-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

tags: added: apport-collected

Per the above suggestion I reininstalled privoxy 3.0.13-1 but it still does not start at boot.

Still seeing:

Sep 24 09:06:51.303 b805e8d0 Fatal error: can't bind to localhost:8118: The hostname is not resolvable

CPKS (c-1) wrote :

Encountered the same on new install of 9.10, but not on the installation I've been running since early alpha (both 64-bit). Changing the config file to '127.0.0.1:8118' doesn't make any difference.

starslights (starslights) wrote :

Hello,

From Karmic beta1 and all last updates, i have no more problem with privoxy, it boot enable again.

So fixed for me

my best

CPKS (c-1) wrote :

Still a problem here (up to date with kernel 2.6.31-14) on one of two installations. I wonder if it's anything to do with peculiarities of the hardware, and in particular the problem occurs on a pretty fast box (boots in under half a minute). Workaround was to rename /etc/rc2.d/S20privoxy to /etc/rc2.d/S30privoxy - not happy with this, but it fixes the problem. Possibly the privoxy start script fails to check (and wait?) for something else to be loaded before trying to initialize?

kuminamoya (kuminamoya) wrote :

I can confirm this problem ("hostname is not resolvable") with karmic rc - the workaround with setting the listen-address to ::1 worked for me.

I work on a laptop with only WLAN connection - probably name resolution is not available fast enough? I *think* I saw the same problem with another daemon (stunnel) at startup, but I´ll have to check this more thououghly.

Yunkwan (chanyunkwan0217) wrote :

I am having this issue too. It's so annoying~~~ to type everytime to start privoxy~ But the workaround above doesn't work at all for me ~~

Victor Marin (vms368) wrote :

Hi,
I am getting these same errors:
- At /var/log/privoxy/logfile it says: "Nov 05 10:01:59.980 7f261602e6f0 Fatal error: can't bind to localhost:8118: The hostname is not resolvable"
- If I then try to start privoxy from the console: ~$ privoxy
Nov 05 12:35:58.191 7fd28c1876f0 Fatal error: can't check configuration file '/home/<username>/config': No such file or directory

So I can't use Tor after restarting Ubuntu.

If I re-install Tor it then works.. until next restart.

Rgds,
Victor

Greg Eden (grege) wrote :

@836v

If you only want tor then you can bypass privoxy altogether. Just Uninstall privoxy and set tor to use Socks5, 127.0.0.1 and port 9050. In foxyproxy edit the setup to these settings and it will work without privoxy.

cheers

Greg Eden (grege) wrote :

ps

If the system will not let you uninstall privoxy without removing tor, just leave it there and bypass with above settings. The changes you made to the first line of privoxy config are ignored and can be removed.

CPKS (c-1) wrote :

Further workaround suggestions: rename /etc/rc2.d/S?0privoxy to /etc/rc2.d/S99privoxy. If even that doesn't work, then edit /etc/init.d/privoxy and replace the do_start function with the following:
((begins))
do_start()
{
 # Return
 # 0 if daemon has been started
 # 1 if daemon was already running
 # 2 if daemon could not be started
 start-stop-daemon --start --quiet --pidfile $PIDFILE --exec $DAEMON --test > /dev/null \
  || return 1
 start-stop-daemon --start --quiet --pidfile $PIDFILE --exec $DAEMON -- \
  $DAEMON_ARGS \
  && return 0
 # Add code here, if necessary, that waits for the process to be ready
 # to handle requests from services started subsequently which depend
 # on this one. As a last resort, sleep for some time.
        sleep 1
 start-stop-daemon --start --quiet --pidfile $PIDFILE --exec $DAEMON -- \
  $DAEMON_ARGS \
  || return 2
}
((ends))

Not pretty, but it worked for me.

nickthecook (nickthecook) wrote :

+1. Karmic Koala x86_64 Final.

This issue also occurs after suspend/resume.

Zack Evans (zevans23) wrote :

I'm running kubuntu so I don't get wireless until knetworkmanager has run, -after- desktop login.

For me, Privoxy starts, but never seems to notice that I have a got a network . It seems to assume that if there was no network when it started up, there never will be one. So I have to restart the service once I am connected...

I am sure there must be a way to make this work by changing Privoxy settings somehow?

Alex Wauck (awauck) wrote :

On my desktop (wired ethernet only), changing the privoxy upstart script to depend on $named seems to work, but it doesn't work on my notebook (wireless only).

starslights (starslights) wrote :

hello,

After last kernel update for karmic, the bug is appear again.

I need all new start reinstall privoxy .

So bug still , depend of the kernel it seem.

best regards

Architecture: amd64
DistroRelease: Ubuntu 9.10
InstallationMedia: Kubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
NonfreeKernelModules: nvidia
Package: privoxy 3.0.13-1
PackageArchitecture: amd64
ProcEnviron:
 SHELL=/bin/bash
 LANG=fr_CH.UTF-8
 LANGUAGE=
ProcVersionSignature: Ubuntu 2.6.31-15.50-generic
Uname: Linux 2.6.31-15-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (polkit-gnome-authentication-agent-1:3217): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (synaptic:3887): Gtk-CRITICAL **: gtk_tree_view_unref_tree_helper: assertion `node != NULL' failed

Richard Grenville (richardgv) wrote :

I have the same issue. "127.0.0.1:8118" workaround doesn't work for me, too. Reinstallation does not work, either.

Nov 14 10:38:19.591 b77198d0 Fatal error: can't bind to localhost:8118: The hostname is not resolvable
Nov 14 11:36:50.056 b78ad8d0 Fatal error: can't bind to 127.0.0.1:8118: The hostname is not resolvable

There's a similar report in Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=534735

Stevan Kew Ell (slql) wrote :

This has been driving me to distraction too, as the combination of privoxy and epiphany-webkit is great. I think I have just stumbled onto a temporary workaround, which hopefully will help to locate the bug. If you disable IPv6, it starts correctly.

I put the line:-

net.ipv6.conf.all.disable_ipv6 = 1

into /etc/sysctl.conf and rebooted, and privoxy started correctly, as expected.

As this disables IPv6, it's not a fix, just a workaround, but hopefully may point to thereal problem.

S

Richard Grenville (richardgv) wrote :

@Stevan Kew Ell
The workaround does not work for me. After disabling ipv6, I receive still the same error:

Nov 17 11:02:53.989 b77028d0 Fatal error: can't bind to localhost:8118: The hostname is not resolvable

Richard Grenville (richardgv) wrote :

Hopefully this bug can be fixed soon.
@Stevan Kew Ell
I just found the workaround works if listen address is set to "127.0.0.1:8118" instead of "localhost:8118". Thanks.

Stevan Kew Ell (slql) wrote :

@ richardgv #27 - sorry, yes, I have the listen address as 127.0.0.1:8118 in my config too. Before this bug really took hold, that was the first change necessary top get karmic working on comparison with Jaunty. Glad those two workarounds work for you too.

Stevan Kew Ell (slql) wrote :

Confusion continues. With no apparent updates, and before I could apply the IPv6 workaround, one of my machines has started working correctly again, starting privoxy at startup.

Since this also affects me with Ubuntu 9.10 (not with earlier versions), I am setting this bug to "confirmed".

Changed in privoxy (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
description: updated
Tim (tfraser-us) wrote :

FYI, I tried the above "listen address is set to 127.0.0.1:8118 instead of localhost:8118" workaround and it didn't work for me. Privoxy still failed to start on boot (although a later manual start worked fine). From /var/log/privoxy/logfile:

 Error: Can not resolve 127.0.0.1: Address family for hostname not supported
 Fatal error: can't bind to 127.0.0.1:8118: The hostname is not resolvable

So I tried adding the above "net.ipv6.conf.all.disable_ipv6 = 1 into /etc/sysctl.conf" workaround and privoxy starts fine on boot.

So now I have both workarounds... I didn't try the ipv6 workaround by itself.

Ubuntu karmic
Linux 2.6.31-14-generic #48-Ubuntu SMP i686 GNU/Linux
privoxy 3.0.13-1

Hamish Downer (mishd) on 2009-11-25
tags: added: ubuntu-boot-experience
Hamish Downer (mishd) wrote :

I'm wondering if this is related to

"rc2 currently does not wait for localhost"

from https://wiki.ubuntu.com/FoundationsTeam/Specs/LucidUpstartServerReview - which links to a possibly related bug in samba - bug #462169.

Victor Marin (vms368) wrote :

Thanks Greg Eden for the workarounds on Tor.
I am using JAP Jondo instead, but I will try to use Tor this way.

Rgds.
Victor

t54 (t54) wrote :

I had this problem running privoxy under Ubuntu karmic with all available updates installed through 12 Dec 2009 :

Privoxy (version 2.0.0.23 (20090817)) installed but after a week or so, it would never actually load, whether started from the command line or by Vidalia.

All of privoxy's files were in the correct places. Reinstalling privoxy did not help. The appropriate lines in privoxy config were all enabled, eg, 'forward-socks4a / 127.0.0.1:9050 .'

I cured this problem by searching privoxy's config file for EVERY active, ie, enabled, config line which contained 'localhost'. There were several and I eventually changed them all to: '127.0.0.1'.

On the first go, I overlooked an instance of localhost on an enabled config line and privoxy would not run until I changed every such instance in the config file to 127.0.0.1 Since then it has loaded and run perfectly.

I hope this helps someone....

t54 (t54) wrote :

sorry, I gave the incorrect version of privoxy in my post above at #34.

Instead of 'Privoxy (version 2.0.0.23 (20090817))' it should read as
'Privoxy (version 3.0.13-1)'

Roland Rosenfeld (roland) wrote :

I just uploaded a new 3.0.15-2 version to the Debian archive, that should solve this issue.
Maybe someone is interested to try out, whether this is the solution for you.
If the package is not available via the Debian archive, have a look at http://www.spinnaker.de/debian/privoxy.html

Ryan Nowakowski (tubaman) wrote :

Roland,

Your uploaded 3.0.15-2 does not fix all the problems caused by this bug. Your fix, if I'm not mistaken, forces privoxy to listen on IPv6 ::1 (localhost) instead of IPv4 127.0.0.1. This breaks IPv4 applications that attempt to forward stuff to privoxy. the workaround that I use until a fix can be found is this. I've added a privoxy-restart script in /etc/network/if-up.d/

#!/bin/bash

service privoxy restart

yarly (ih8junkmai1) wrote :

Is this ever going to be address by the package maintainers?

George Rodriguez (m8r-snj4o3) wrote :

same problem here
+ mostly very, very sluggish performance when running with opera 10.10 or firefox 3.5.6

uninstall claimed to free 311MB disk space.

privoxy 3.0.13-1, karmic latest updates, kernel 2.6.31(-16?)

workaround ::1 autostarts here, but only works for firefox,
opera won't accept settings.
still sluggish performance.

Bug affects me too, but the following workaround is successful (as mentioned several times above):
1. disable ipv6 by adding "net.ipv6.conf.all.disable_ipv6 = 1" to /etc/sysctl.conf
2. change all localhost lines to 127.0.0.1 in the /etc/privoxy/config file
3. reboot

splashis (splashote) wrote :

I'm having the same issue with 9.10, Privoxy 3.0.13-1 and the workaround does NOT work in my case. I still get the same error messages

CPKS (c-1) wrote :

This problem is strangely inconsistent for me across several machines that I maintain. My laptop is currently running 10.4 beta, has been running latest betas since Intrepid, and has never ever had a problem with privoxy startup. Another machine which was OK with the 9.10 install developed the problem recently after upgrade to 10.4. I cannot see any common ground between those machines that exhibit the problem and those that don't. Will report back on the fix mentioned in #40.

CPKS (c-1) wrote :

Update: problem gone after update to kernel 2.6.32-21 on the 10.4 beta upgrade box mentioned in #42 - using standard privoxy startup scripts.

Alan Lord (theopensourcerer) wrote :

Running Lucid Lynx, found that firehol, dansguardian, privoxy stopped working recently. Only error reported - in syslog - was dansgaurdian unable to connect to proxy.

dansguardian[1741]: Error connecting to proxy

After updating Lucid this morning. Problem still apparent. privoxy appears to be running however. I changed one line in the /etc/privoxy/config file from:

listen-address localhost:8118
listen-address 127.0.0.1:8118

Restarted privoxy and it worked. Rebooted Ubuntu and it works.

Hope this helps.

The Fiddler (stapostol) wrote :

The workaround from #44 (change localhost:8118 to 127.0.0.1:8118) didn't work for me.

Running Lucid amd64, upgraded from Karmic. Privoxy was installed after the upgrade (and wasn't installed before).

Christoph (christop) wrote :

Fiddler, can you verify that privoxy is even running?
Can you post the output of "sudo ps auxww|grep privoxy" and "sudo netstat -anp | grep 8118"?
Oh, and to check if privoxy is not only running, but also you can connect to try "telnet localhost 8118" or "telnet 127.0.0.1 8118".

By the way, over at https://bugs.launchpad.net/ubuntu/+source/privoxy/+bug/571148 miq seems to have found the cause of the problem.

CPKS (c-1) wrote :

On one of my 64-bit 10.4 machines, privoxy starts up and runs fine with Firefox, but needs a restart before it will deign to accept connexions from Opera 10.6. Both browsers are configured to use "localhost:8118" as proxy.

Andreas Moog (amoog) wrote :
Changed in privoxy (Ubuntu):
status: Confirmed → Fix Released
Changed in privoxy (Debian):
status: Unknown → Fix Released
Download full text (3.2 KiB)

>>> http://tusis.ru

- There is no reason to feel depressed if you, like so many other men today, have hit the rough spot of your sexual life when you cannot seem to be performing as well as you used to do. Your agitation and frustration are easily understood, and still you should know that with the modern development of worldwide pharmacological industries it is but natural that there is bound to be a solution for your own needs when it comes down to solving your erectile dysfunction problems.

- We suggest you getting erectile dysfunction drugs from our online drugstore cheaply, easily and without much to-do. You will always be taken care of and attended to with extreme care, and you will have the possibility of choosing from a wide range of erectile dysfunction products to find a solution that will best suit your particular needs.

- The whole world puts great trust in those famous diamond shaped pills, and if you are not an exception we would like to revise some basic points that speak in favor of putting your male health in the hands of those magical tablets.
Firstly, there is no need for regular therapy – those blue pills have to be taken directly before the planned sexual contact, and extra convenience shines through when you come to realize that the pills will not start working unless sufficient sexual stimulation is provided.

- Secondly, this erectile dysfunction solution is known for its extremely low adverse side effects profile, which makes it available for all age groups of patients. Besides, it really does not matter how old you are when it goes about taking erectile dysfunction pills – just make sure that you do not overdose, and they will work for you at their best!

- Finally, those fabulous pills do not only provide you with stable erection that can be maintained for as long as you need it – they also help you to achieve unheard sensitivity during the sexual act as well as make your genitals look much more sizey!

- Think of all those benefits of taking erectile dysfunction pills and the effect you can produce on your loved one – and do not hesitate to make your order and / or refills right away!

--- > http://tusis.ru < ---

 _V______C________L
 ___I_______I_______E
 _____A_______A_______V
 _______G_______L_______I
 _________R_______I_______T
 ___________A_______S_______R
 _____________________________A

   Like coffee can make your mind tuned for a day, Our male caplets can make your manhood ready for the real crazy night! We welcome you to our store and promises you to please you with lowered prices and valuable gifts regularly! Try this lovemaking madness!
-
 - - -
--------- http://tusis.ru
 - - -
-
                    ...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.