Please compile portaudio with Jack support

Bug #360590 reported by Matthias Klumpp on 2009-04-13
54
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Mixxx
High
Unassigned
Ubuntu Studio
Medium
Unassigned
portaudio (Ubuntu)
Wishlist
Unassigned
portaudio19 (Ubuntu)
Undecided
Unassigned

Bug Description

PortAudio is not compiled with Jack support in Jaunty.
Can someone please compile it with Jack support? (We had the same problem in Intrepid already)

Related branches

affects: ubuntu → portaudio (Ubuntu)
ironstorm (ironstorm-gmail) wrote :

H Matthias, Mixxx does not package portaudio. The portaudio maintainers have to be the ones to fix this.

Changed in mixxx:
importance: Undecided → High
status: New → Invalid
Murat Gunes (mgunes) on 2009-04-13
Changed in portaudio (Ubuntu):
importance: Undecided → Wishlist
Albert Santoni (gamegod) wrote :

Ok, hang on a second - I just want to make sure there hasn't been a miscommunication here:

Having PortAudio compiled with JACK support is absolutely critical for a large number of Mixxx users on Ubuntu for various reasons. There's going to a lot of people complaining about this if this doesn't get fixed. This happened before with Gutsy:
https://bugs.launchpad.net/mixxx/+bug/183011

Thanks,
Albert

Matthias Klumpp (ximion) wrote :

Yes, this is really essential for Mixxx users. Please fix this in Jaunty!

Adam Davison (adamdavison) wrote :

Hi,

Has there been any news on this? This is a big issue for Mixxx. Our development team is going to be fielding an awful lot of bug reports about this when people upgrade to Jaunty. We'd like to have some useful advice for them like "update/install packages x,y,z" rather than having to tell them to recompile portaudio from source.

Also, given that this has happened before we'd like to work out how to avoid something like this happening again.

Thanks,

Adam Davison

Matthias Klumpp (ximion) wrote :

I patched the portaudio package on my system to get Jack support working with Mixxx.
Next days I will upload the fixed package to my PPA.
Until someone has fixed this bug in the Ubuntu repositories, you can advise the people to use the patched package from my PPA. (But I will need some time to get it ready, please be patient!)

Adam Davison (adamdavison) wrote :

Thanks Matthias. Obviously we need an official response from the Ubuntu people as well. I'm not sure if the correct person is cced here or not, so if we don't have any response within the next day or so I will escalate it.

Eric Hedekar (stochastic) wrote :

Clearly the best solution to this would be to get Jackd moved back into the Main repositories. Pulse audio is also not compiled against Jack, do many musician's detriment, confusion, and disgust. Mixxx is one of the, if not THE, best DJ software for linux and people with firewire soundcards (a very large segment) are forced to use Jack for their audio driver. I for one, wish I could use Mixxx!

RJ Ryan (rryan) wrote :

Matthias -- have you had the chance to setup that PPA? That would be a nice thing to point at for our users who run into this bug in the Ubuntu portaudio package.

People come to the Mixxx IRC channel regularly asking about why JACK doesn't work in Ubuntu 9.04. Can we get this fixed for Karmic?

Best,
RJ Ryan

Manual workaround for users for now:

1) Get PA source: http://portaudio.com/archives/pa_snapshot.tgz
2) Build with 'scons prefix=/usr'
3) Install with 'sudo scons prefix=/usr install' - this will overwrite any version installed by apt
4) Get Mixxx source: http://downloads.mixxx.org/mixxx-1.7.0/mixxx-1.7.0-src.tar.gz
5) Build with 'scons prefix=/usr'
6) Install with 'sudo scons prefix=/usr install' - this will overwrite the version installed by apt
7) Start JACK with qjackctl
8) Start Mixxx and enjoy.

Artem Popov (artfwo) wrote :

Confirming this on Jaunty and Karmic. I also suggest changing the importance from Wishlist to Medium, because it results in a HUGE lack of functionality for laptop DJs with external JACK-only (firewire) audio interfaces, and it's a certain regression from previous versions of Ubuntu.

Changed in portaudio (Ubuntu):
status: New → Confirmed
Artem Popov (artfwo) wrote :

Huh, it turns out that jack support was intentionally disabled in Ubuntu:
http://launchpadlibrarian.net/22657643/portaudio19_19%2Bsvn20071207-0ubuntu5_19%2Bsvn20071207-0ubuntu6.diff.gz

Because jack is not in main, portaudio cannot depend on it. How can this be resolved?

Changed in portaudio19 (Ubuntu):
status: New → Confirmed
Matthias Klumpp (ximion) on 2009-08-01
Changed in ubuntustudio:
status: New → Confirmed
Changed in ubuntustudio:
importance: Undecided → Medium
Eric Hedekar (stochastic) wrote :

This bug relies on Jack getting accepted into Main (as Артём Попов had mentioned). However, before that can be done, all of the necessary dependencies of Jack need to be accepted into Main (I believe libffado is one particular important piece). Some members of the Ubuntu Studio dev team have been talking about this/working on this for a bit now and maybe if someone wants to spearhead this effort they could help guide things along.

Here are a few other bugs that also depend on Jack's inclusion into Main:
Bug #152487 Jack output for xine apps
Bug #84900 libasound2-plugins misses alsa pcm jack plugin
Bug #109659 jack sink missing in pulseaudio
and this one that I've just reported against the Jack-audio-connection-kit package:
Bug #407841 Jack package is not currently in Main repository which prevents many Main audio servers from integrating with it

Scott Lavender (slavender) wrote :

I have been working on the main inclusion report for libffado.

I believe that Luke will be reviewing it soon so it can be submitted to MIR-bugs.

Matthias Klumpp (ximion) wrote :

We are in Feature Freeze in Karmic and Portaudio has still no Jack support, KDE's Phonon framework also.
Is there anything I can do so jackd is accepted for main faster?

Eric Hedekar (stochastic) wrote :

Matthias, Jack getting into main is waiting on two things: 1) Bug #416778 2) Jack dropping the celt dependency (easily taken care of, just waiting on confirmation from jack devs that this will only cause a minor feature in netjack to break). I'd say if you want to help on getting Jack into main, focus on Bug #416778

Motin (motin) wrote :

Rebuilding the ubuntu package with jack support compiled in:

sudo apt-get build-dep portaudio19
sudo apt-get install libjack0.100.0-dev
apt-get source portaudio19
cd portaudio*
gedit debian/rules

Here change the commented:

#ENABLE_JACK=no

to

ENABLE_JACK=no

(uncommented)

and also "--with-jack=no" to "--with-jack=yes" just below that line

Then rebuild and install:

dpkg-buildpackage -rfakeroot -b
cd ..
sudo dpkg -i libportaudio2_19+svn20090620-0ubuntu1_i386.deb
sudo dpkg -i libportaudiocpp0_19+svn20090620-0ubuntu1_i386.deb
sudo dpkg -i portaudio19-doc_19+svn20090620-0ubuntu1_all.deb

(More or less from the instructions for Gutsy in Bug #183011)

Motin (motin) wrote :

I believe I managed to upload the 32-bit packages to my ppa: https://launchpad.net/~motin/+archive/ppa

Log from dput:

$ dput my-ppa portaudio19_19+svn20090620-0ubuntu1~withjack0_i386.changes
Checking Signature on .changes
gpg: Signatur gjordes mån 19 okt 2009 02.03.24 CLST med DSA nyckel-id B7D91961
gpg: Korrekt signatur från "Motin <email address hidden>"
Good signature on /home/motin/src/portaudio19_19+svn20090620-0ubuntu1~withjack0_i386.changes.
Uploading to my-ppa (via ftp to ppa.launchpad.net):
  Uploading portaudio19-doc_19+svn20090620-0ubuntu1~withjack0_all.deb: done.
  Uploading libportaudio2_19+svn20090620-0ubuntu1~withjack0_i386.deb: done.
  Uploading portaudio19-dev_19+svn20090620-0ubuntu1~withjack0_i386.deb: done.
  Uploading libportaudiocpp0_19+svn20090620-0ubuntu1~withjack0_i386.deb: done.
  Uploading portaudio19_19+svn20090620-0ubuntu1~withjack0_i386.changes: done.
Successfully uploaded packages.

Although I have never done this before and I don't see the package in my ppa right now. Maybe later it will show up... ? :)

Matthias Klumpp (ximion) wrote :

The package is not available in your PPA, please check all log files and mails.
I think it is now possible to compile PortAudio with Jack support, because Jack will be in main soon. Expect Jack support in Lucid Lynx.

Motin (motin) wrote :

Ok, now packages are available in the following PPA: https://launchpad.net/~motin/+archive/until-jack-is-included-in-main

I added the PPA to my sources, apt-get updated but an apt-get upgrade currently does not opt for installing the "~withjack1" appended versions
Maybe someone can help me with what version number I should use so that the packages gets proposed for upgrade?

PS. I added a rebuild of xine as well (with the xine JACK plugin included)

Motin (motin) wrote :

Now I got the versions right... The trick is to increment the # in "0ubuntu#", then add ~something0...

I'll try to get alsa-plugins and pulseaudio with jack support in the ppa as well...

Eric Hedekar (stochastic) wrote :

Attaching a patch to fix this bug now that Jack has been promoted into Main.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package portaudio19 - 19+svn20090620-0ubuntu2

---------------
portaudio19 (19+svn20090620-0ubuntu2) lucid; urgency=low

  * Added jack to build depends to allow jack output (LP: #360590)
 -- Eric Hedekar <email address hidden> Thu, 18 Feb 2010 02:21:24 -0800

Changed in portaudio19 (Ubuntu):
status: Confirmed → Fix Released
Benjamin Drung (bdrung) wrote :

Nothing to sponsor left, unsubscribing ubuntu-universe-sponsors

Emmet Hikory (persia) wrote :

This isn't going to be fixed for portaudio (18.x). The only reverse dependencies remaining are a couple of games, and it's sufficiently unlikely that there is a need to use this audio output as part of a JACK session. Those who really need this audio are encouraged to capture it in other ways (parec might be a good candidate), and then use that capture in a session.

Changed in portaudio (Ubuntu):
status: Confirmed → Won't Fix
Changed in ubuntustudio:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers