JACK disabled in Gutsy PortAudio package

Bug #183011 reported by Albert Santoni on 2008-01-14
10
Affects Status Importance Assigned to Milestone
Mixxx
Critical
Albert Santoni
portaudio19 (Ubuntu)
Undecided
Unassigned

Bug Description

JACK does not appear as an API when using PortAudio-v19 in Gutsy. Might occur in Hardy too, haven't tried it yet.

What appears to be happening is that JACK support is disabled when the package is being built. I've tried to fix this myself, but I can't figure out why. It always gets disabled for some reason.

I've had about 100 Mixxx users complain that JACK support was removed from Mixxx when they upgrade from Feisty->Gutsy, but it's a problem with the PortAudio package, not Mixxx. (It's not even a problem with PortAudio itself - it's just that JACK support is being disabled somehow in the rules file in the DEB package.)

Help!!!!!

(This bug is also in Mixxx's tracker:
http://sourceforge.net/tracker/index.php?func=detail&aid=1835494&group_id=47577&atid=449891
)

Tom Jennings (tomj-wps) wrote :

same experience here, Asus dual-core laptop, Linux zx 2.6.22-14-rt #1 SMP PREEMPT RT Tue Dec 18 10:01:34 UTC 2007 i686 GNU/Linux (same with non-RT kernel). Worked with 7.04, stopped working with 7.10 release.

Also, all apps that want to connect to jackd have to do so as root. This wasn't the case previously; once jackd was running (sudo'd) clients could connect as non-root users. No longer true.

Gabriel Nordeborn (t4-zenith) wrote :

Don't work here either, AMD 3200+, and latest linux rt-kernel.

Also same problem with jackd! Weird.

Albert Santoni (gamegod) wrote :

A large number of Mixxx users on Gutsy are reporting this problem... something's going on with PortAudio and maybe the jackd package.

Changed in mixxx:
importance: Undecided → Critical
status: New → Confirmed
djhampster (schaefer-jason) wrote :

I have spent much time troubleshooting this issue, jack support is broken in this package. Thanks for your attention!

Albert Santoni (gamegod) wrote :

This is said to have been fixed in Hardy's PortAudio-v19 package. Can anyone test it?

Changed in mixxx:
status: Confirmed → In Progress
amias (amias) wrote :

Its still present in hardy , i've just upgraded and there is still not JACK option in the sound api selector.

If you need any tests done let me know.

amias (amias) wrote :

got 1.6.0 beta2 working with jack by rebuilding the portaudio package with the second instance of JACK_ENABLED=NO removed from debian/rules.
The logic was broken , it set this to no then conditionaly set it to yes for i386 , ppc and then unconditionaly set it to no again so it could only be no.

works really nicely now.

amias (amias) wrote :

oops should have said , that was in gutsy , not tried it in hardy

amias (amias) wrote :

Its the same on hardy.
so to do the fix on both hardy and gutsy :

sudo apt-get source portaudio19
sudo apt-get build-dep portaudio19

cd /portaudio19-19+svn20071207/debian

edit rules and remove ENABLE_JACK = no from line 48

cd ..

dpkg-buildpackage -rfakeroot -b

then cd back to below your portaudio source directory

install the new debs
sudo dpkg -i libportaudiocpp0_19+svn20071207-0ubuntu1_i386.deb portaudio19-dev_19+svn20071207-0ubuntu1_i386.deb libportaudio2_19+svn20071207-0ubuntu1_i386.deb

then restart mixxx and jack and it should all work

it runs slower than it used to on gutsy for me.

Albert Santoni (gamegod) wrote :

Hi Amias,

Ok, if you'd like to carry this fix forwards, what you need to do is generate a debdiff or something and get the fixed package into Universe. If you need help, ask someone in #ubuntu-motu on Freenode. They'll be more than happy to help, and we'd really appreciate it if you could see this through.

Thanks!
Albert

Albert Santoni (gamegod) wrote :

Nevermind, this appears to be fixed in Hardy (according to apt-cache, thanks TheMuso!). We need someone to test Mixxx on Hardy to be sure though...

amias (amias) wrote :

the package has indeed changed , i've just upgraded to 64bit hardy and jack seems to be disabled.
i was able to forceably re-enable it by patching the debian/rules file and rebuilding but it is very
unstable to the point of being unusable.

Albert Santoni (gamegod) wrote :

Amias, can you paste the output of this command on 64-bit Hardy:

ldd /usr/lib/libportaudio.so.2

Thanks again...
(I vaguely recall people seeing that portaudio-v19 was linked against JACK on gutsy, but it still didn't show up in Mixxx, so it was like half-disabled...)

amias (amias) wrote :

[amias@home:~]-[16:35:54]
>ldd /usr/lib/libportaudio.so.2
 linux-vdso.so.1 => (0x00007fffafffe000)
 librt.so.1 => /lib/librt.so.1 (0x00007f34a7a80000)
 libasound.so.2 => /usr/lib/libasound.so.2 (0x00007f34a779b000)
 libm.so.6 => /lib/libm.so.6 (0x00007f34a7519000)
 libpthread.so.0 => /lib/libpthread.so.0 (0x00007f34a72fd000)
 libc.so.6 => /lib/libc.so.6 (0x00007f34a6f9b000)
 /lib64/ld-linux-x86-64.so.2 (0x00007f34a7ec4000)
 libdl.so.2 => /lib/libdl.so.2 (0x00007f34a6d96000)

Yeah, audacity is also using portaudio for jack and people are using
it in gutsy. Although, it does not work very well. I was curious so I
installed pa19 with apt and ldd did show jack support, but obviously
not working completely.

On Tue, Mar 4, 2008 at 8:13 AM, Albert Santoni <email address hidden> wrote:
> Amias, can you paste the output of this command on 64-bit Hardy:
>
> ldd /usr/lib/libportaudio.so.2
>
> Thanks again...
> (I vaguely recall people seeing that portaudio-v19 was linked against JACK on gutsy, but it still didn't show up in Mixxx, so it was like half-disabled...)
>
>
>
> --
> JACK disabled in Gutsy PortAudio package
> https://bugs.launchpad.net/bugs/183011
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Albert Santoni (gamegod) wrote :

DJ Hampster: Audacity ships with it's own version of PortAudio-v19, not the one in the Ubuntu repositories.

Amias: Can you paste the output of "apt-cache depends libportaudio2" for me too? Thanks again!

amias (amias) wrote :

[amias@home:~]-[10:16:44]
>apt-cache depends libportaudio2
libportaudio2
  Depends: libasound2
  Depends: libc6

Albert Santoni (gamegod) wrote :

Hi Amias, looks like JACK support is missing only from the AMD64 package:

http://packages.ubuntu.com/hardy/libportaudio2
      * dep: libjack0 (>= 0.109.2) [not amd64]
        JACK Audio Connection Kit (libraries)

(Thanks Garth!)

However, the rules file says the ringbuffer implementation in PortAudio with JACK is only SMP-safe on 32-bit machines (so JACK's disabled on purpose). I'm going to get in touch with the PortAudio guys to find out exactly what that means for our 64-bit users....

Albert Santoni (gamegod) wrote :

Fixed in latest upload to hardy.

Changed in portaudio19:
status: New → Fix Committed
Albert Santoni (gamegod) wrote :

Requested a backport of latest hardy package to gutsy here:
https://bugs.launchpad.net/gutsy-backports/+bug/201290

amias (amias) wrote :

just tried it hardy with the updated portaudio and yes i get a jack option in mixxx but its not at all stable , it crashes jack when it connects.

as an aside its scanning my mp3 files on every startup , which takes ages (i have about 11,000 files which takes 5mins or so) although is faster
than it used to be and is definitely doing the same files again. on the upside mixxx is now faster (non jack) .

Just to confirm i'm now using a Intel Core Duo with 2gig of DDR ram

Toodle-pip
Amias

Albert Santoni (gamegod) wrote :

Gutsy users can upgrade to Hardy.

Changed in mixxx:
assignee: nobody → gamegod
status: In Progress → Fix Committed
Changed in mixxx:
status: Fix Committed → Fix Released
Changed in portaudio19:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers