polkit-gnome-authentication-agent-1 crashed with SIGSEGV in g_datalist_id_set_data_full() during logout

Bug #697095 reported by Gary M on 2011-01-04
This bug affects 948 people
Affects Status Importance Assigned to Milestone
PolicyKit GNOME
Fix Released
Undecided
Erasmo
policykit-1-gnome (Ubuntu)
Low
Abhishek kumar singh
Natty
Low
Unassigned
Oneiric
High
Unassigned

Bug Description

NOTE: This crash only happens during session logout, at which point it is fairly irrelevant. Apport presents the crash at the start of the next session, which might falsely suggest that the crash happens at session start.

Binary package hint: policykit-1-gnome

Crash occurred shortly after a gnome session login (following updates during the previous session), and followed an expected UbuntuOne crash.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: policykit-1-gnome 0.99-1ubuntu3
ProcVersionSignature: Ubuntu 2.6.37-11.25-generic 2.6.37-rc7
Uname: Linux 2.6.37-11-generic i686
Architecture: i386
CrashCounter: 1
Date: Tue Jan 4 19:28:00 2011
ExecutablePath: /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101202)
ProcCmdline: /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
ProcEnviron:
 LANGUAGE=en_AU:en
 LANG=en_NZ.UTF-8
 LC_MESSAGES=en_AU.utf8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0xd39e68 <g_datalist_id_set_data_full+744>: cmp 0x4(%eax),%edi
 PC (0x00d39e68) ok
 source "0x4(%eax)" (0x00000024) not located in a known VMA region (needed readable region)!
 destination "%edi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: policykit-1-gnome
StacktraceTop:
 g_datalist_id_set_data_full () from /lib/libglib-2.0.so.0
 g_object_unref () from /usr/lib/libgobject-2.0.so.0
 ?? ()
 __libc_start_main () from /lib/libc.so.6
 ?? ()
Title: polkit-gnome-authentication-agent-1 crashed with SIGSEGV in g_datalist_id_set_data_full()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Gary M (garym) wrote :

StacktraceTop:
 g_datalist_id_set_data_full (datalist=0x8a181a0, key_id=52,
 ?? ()

tags: added: apport-failed-retrace
tags: removed: need-i386-retrace
Martin Pitt (pitti) on 2011-01-09
Changed in policykit-1-gnome (Ubuntu):
status: New → Confirmed

debug stacktrace:

Stacktrace:
 #0 0x00195ec8 in g_data_set_internal (datalist=0x869f3b8, key_id=52, data=0x0, destroy_func=0) at /build/buildd/glib2.0-2.27.90/glib/gdataset.c:325
         prev = 0x87f9d40
         list = 0x18
 #1 g_datalist_id_set_data_full (datalist=0x869f3b8, key_id=52, data=0x0, destroy_func=0) at /build/buildd/glib2.0-2.27.90/glib/gdataset.c:598
         __PRETTY_FUNCTION__ = "g_datalist_id_set_data_full"
 #2 0x00137b75 in g_object_unref (_object=0x869f3b0) at /build/buildd/glib2.0-2.27.90/gobject/gobject.c:2711
         object = 0x869f3b0
         old_ref = 0
         __PRETTY_FUNCTION__ = "g_object_unref"
 #3 0x0804fc64 in main (argc=1, argv=0xbfaaa0f4) at main.c:448
         ret = 0
         listener = 0x869f3b0
         error = 0x0

Martin Pitt (pitti) wrote :

Low priority, as this only seems to happen on logout. Seb and I had a quick look at the code, and there's nothing obvious sticking out, so this requires some in-depth debugging. It's not easy to reproduce unfortunately.

summary: polkit-gnome-authentication-agent-1 crashed with SIGSEGV in
- g_datalist_id_set_data_full()
+ g_datalist_id_set_data_full() during logout
Changed in policykit-1-gnome (Ubuntu):
status: Confirmed → Triaged
visibility: private → public
Changed in policykit-1-gnome (Ubuntu):
importance: Undecided → Low
Bouke Bunnik (bosyber) wrote :

Well, since I have now seen about 5-10 different instances of what seems to be this bug over the last week, it seems on my system it is rather reproducible. Is there anything else I can do to help get it fixed? It is rather annoying - at the moment my wife also regularly uses the laptop, so we log in, then out, and the other's session is stopped with the crash.

So, if I can do something to debug this better, I could see how far that goes?

MoLE (moleonthehill) wrote :

Seems to occur shortly after login now. Policykit updates released yesterday appear to have triggered this bug for me.

Paul White (paulw2u) wrote :

Rebooted PC and started terminator. Over 85 updates applied prior to reboot. Sorry, but I left the room and when I returned crash dialog and the option of reporting it was displayed. No other programs running.

Antono Vasiljev (antono) wrote :

Occured right after login.

Ersin Akyuz (ersin2k) wrote :

when I clicked to update manager, this error happened.

JIm (jim-richardson06) wrote :

Update manager was run and asked to restart due to changes, after the restart the bug appeared. it was also coupled with another bug that the OS that stopped apport running which I cannot answer on
Regards Jim

deuce (azinas) wrote :

happened after login, run terminal through the application select menu.

Dale Beaudoin (twocamels) wrote :

comes on right after log on.

Chris Johnston (cjohnston) wrote :

This also happens for me shortly after login.

Ivan Moreno (dhanus17) wrote :

desde q actualice a 11.04 tengo esta falla asi q decide compartirla con ustedes... gracias x la ayuda q puedan prestarme.

Falla del policicykit-1.gnome el cual desactiva las contraseñas o no las encrypta algo asi...

Ivan Moreno (dhanus17) wrote :

desde q actualice a 11.04 tengo esta falla asi q decide compartirla con ustedes... gracias x la ayuda q puedan prestarme.

Solucione el problema de la siguiente manera:

1 desactive el docky
2$ gtf 1280 1024 70

 Esta linea de comando me arrojo algo parecido a lo siguiente:

# 1280×1024 @ 70.00 Hz (GTF) hsync: 63.00 kHz; pclk: 96.77 MHz
Modeline "1280x1024_70.00" 96.77 1152 1224 1344 1536 864 865 868 900 -HSync +Vsync

Luego de Obtener los datos para agregar a los modos de Pantalla procedemos a agregar este modo en el siguiente Archivo (esto es solo un ejemplo cada quien debe poner exactamente los datos que arroje la linea del gtf segun la resolucion que escogieron):

$ sudo gedit /etc/gdm/Init/Default

Luego de estar abierto agregaran las siguientes lineas justo antes de exit 0:

/usr/bin/xrandr --newmode 1280x1024 96.77 1152 1224 1344 1536 864 865 868 900 -HSync +Vsync

/usr/bin/xrandr --addmode DVI-0 1280x1024

/usr/bin/xrandr --output DVI-0 --mode 1280x1024

ya de esta manera tenemos la resolucion deseada de Nuestro Escritorio y no hace falta estar ejecutando las lineas en cada reinicio...

Nota: Cabe destacar que use DVI-0 ya que es el dispositivo DVI el que tengo conectado al monitor, puede que ustedes tengan que colocar VGA-0 o VGA1 o DVI-1, todo depende de cual sea su caso...

Luego de guardar el archivo simplemente con un:

$ sudo reboot
 y al reboot ya todo estaba resuelto...

Jorge Marcano (jorgitomarcano) wrote :

right after login and when I was opening my usb stick.

Vangel Ajanovski (ajanovski) wrote :

Now it happened right after login without opening anything. What's even more strange - I can only see the desktop background and icons on the desktop, nothing else. The bug report opened this browser and I am writing directly.

Restarting unity-window-decorator only shows borders arround windows, no other gui elements

MoLE (moleonthehill) wrote :

continues to occur on login to unity desktop. immediately after login. Same symptoms as reported by Vangel above.

mj1492 (mj1492) wrote :

x86_64 also doesnt work

Bouke Bunnik (bosyber) wrote :

not much news to add; same symptom as mentioned in comment #19; and agreeing with #21.

Happened to me (apport just pushed me here rather than letting me report with files to upload) - shortly after reboot after upgrade today, and immediately after opening a nautilus window on a firewire drive by clicking on its launcher icon. x86_64.

jradwans (jradwans) wrote :

after, when i opened update-manager

Syslog.eu (syslog) wrote :

Not much to add. Occured right after login. No other programs running.

Jorge Marcano (jorgitomarcano) wrote :

It came up just as I started my transmission program for torrent files

PMPope (pmpope) wrote :

It occurs after login & while GDM is loading (on my machine)

Jorge Marcano (jorgitomarcano) wrote :

occurs after login and when i try to open torrent transmission program

Natalia Bidart (nataliabidart) wrote :

Occurred right after login.

Amit Kucheria (amitk) wrote :

Occured right after login

Gary M (garym) on 2011-03-12
tags: added: regression-release
col reilly (lupinehorror) wrote :

opened x in failsafe mode (as that's all i can run after latest update) and error happened.

Jorge Marcano (jorgitomarcano) wrote :

Even before I could login, it crashed

Javi Molina (javich) wrote :

It appeared when logging in to a new session (I deleted all home content, excep .bash* and .profile)

Info-getatech (info-getatech) wrote :

It happened when I started Firefox.

Changed in policykit-1-gnome:
status: New → Confirmed
zhwsjyzk9 (zhwsjyzk9) on 2011-03-18
Changed in policykit-1-gnome:
status: Confirmed → New
Jorge Marcano (jorgitomarcano) wrote :

Happened right after login

Randy Linnell (ranman) wrote :

Doing a restart after partial upgrade, received crash report immediately.

Boris Tosovic (boris-tosovic) wrote :

after upgrade on login, same symtons like other mentined

summary: polkit-gnome-authentication-agent-1 crashed with SIGSEGV in
- g_datalist_id_set_data_full() during logout
+ g_datalist_id_set_data_full() during login
kieran (kieran-charles) wrote :

Not much to add - occurred after login.b

EricDHH (ericdhh) wrote :

No login without it, there is nothing else you have to do. Login and crash.....

Changed in policykit-1-gnome:
status: New → Incomplete
Dolfis (coronado-adolfo) on 2011-04-07
description: updated
Stefan (sbossb) on 2011-04-09
Changed in policykit-1-gnome:
status: Incomplete → Opinion
status: Opinion → Incomplete
Changed in policykit-1-gnome:
status: Incomplete → Opinion
Changed in policykit-1-gnome:
status: Opinion → Confirmed
Changed in policykit-1-gnome (Ubuntu Natty):
milestone: none → ubuntu-11.04
Changed in policykit-1-gnome (Ubuntu Natty):
importance: Low → Medium
exa76 (livetoride76) on 2011-04-14
Changed in policykit-1-gnome:
status: Confirmed → New
Gary M (garym) on 2011-04-15
Changed in policykit-1-gnome:
status: New → Confirmed
71 comments hidden view all 151 comments
beli (imnutsdoc) wrote :

Just downloaded and installed Natty beta 2 yesterday, and got the bug now:

Update
Reboot
Log in
Crash

But it doesn't seem to have caused any problems.

Occurred as 1st run of Mythtv frontend (Beta2)

Jared (jared-vanvolkenburg) wrote :

I had installed some software and the application dashboard wasn't seeming to update, so I logged off and logged in again. It occurred right after log in.

it accured for me, while I was asking the update manager to check for updates, this is the second thing to actually crash at startup, another program crashed, which usually always crashes for me at startup. this program that crashed, I usually dont have any problems with. note also that yesterday i updated the system, and this is the first restart after updates.

Jim Leinweber (jiml-mail) wrote :

had just run "sudo update-grub" (legacy grub1) on a system upgraded from 10.04 to 10.10 to 11.04.

peterzay (peterzay) wrote :

Launched Firefox just after boot. Then ALT+F2 to report a bug: ubuntu-bug clock. Got an error message that package does not exist. Then got an error and was asked if I wanted to report the problem, said yes. Got a window that claimed this bug was already reported, did I wish to view the web page to add more info. Said yes and got this page. Version of 11.04 is beta 16-apr-2011.

Erick Brunzell (lbsolost) wrote :

Perhaps a silly thought, but I've not seen this for quite some time after switching to the Classic w/o effects DE.

I'm embroiled in other things ATM but it may be beneficial to ask those effected to try different DE's, maybe even 'unity-2d'.

Just a thought.

Erasmo (erasmojpo) on 2011-04-17
Changed in policykit-1-gnome:
assignee: nobody → Erasmo (erasmojpo)
simone.aonzo (simone-aonzo) wrote :

Same error at every login after boot.

Sergio Zanchetta (primes2h) wrote :

Installed Natty Beta 2 and updated yesterday.
Today after logging in I got the crash.

Fresh after reboot, tried to launch Chrome. Then this crash occured and no Chrome shows up.

Edit: Actually Chrome DID show up.

FitzLT (anyedge-gmail) wrote :

Rebooted the machine after some updates today. Started Firefox 4 in Beta2 and got the crash.

stoja (stojabreak) wrote :

This crash ocurred when refresh updates from update-manager :(

Mark Cariaga (mzc) wrote :

reproduced the bug same as #123 but not right after a reboot.

After the update on the next boot I opened launchpad site in FF (was going to report another bug) and got this error message.

Patrik Holm (minihdtv) wrote :

Also happening when opening ubuntuone but every thing working

ubunturox (ubunturox-kk) wrote :

happened right after login

Mike (bild85) wrote :

Natty Narwhal beta testing. Ran update manager and rebooted, logged in and noticed my theme was broken. Checked updates (which was too quick,) and rebooted again. Got this error upon running update manager.
Regarding the quickness: Update-manager used to download 13MB of update cache, and now it only downloads 2KB before stating there are no updates available. Either the update system has been redesigned to need less data to update the cache (if so, nice job!) or something is very wrong with it.

Adding myself to the list of sufferers! Upgraded yesterday and when I booted this morning I received the error.

happens after I install update - I usually do that through update manager - reboot (or shutdown then start up) and automatic login into unity - happens within the first minute.

Kate Stewart (kate.stewart) wrote :

Based on the number of folks running into this, am upping its priority to high, and making sure it gets to a team's attention.

Changed in policykit-1-gnome (Ubuntu Natty):
milestone: ubuntu-11.04 → natty-updates
Changed in policykit-1-gnome (Ubuntu Oneiric):
milestone: ubuntu-11.04 → none
milestone: none → oneiric-alpha-1
Changed in policykit-1-gnome (Ubuntu Natty):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Changed in policykit-1-gnome (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Changed in policykit-1-gnome (Ubuntu Natty):
importance: Medium → High
Changed in policykit-1-gnome (Ubuntu Oneiric):
importance: Medium → High

Today after updating the same error.

Martin Pitt (pitti) wrote :

Lowering priority again, see comment 6. Not SRU matter for natty.

Changed in policykit-1-gnome (Ubuntu Natty):
importance: High → Low
milestone: natty-updates → none
status: Triaged → Won't Fix
Changed in policykit-1-gnome (Ubuntu Oneiric):
status: Triaged → Won't Fix
milestone: oneiric-alpha-1 → none
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
Changed in policykit-1-gnome (Ubuntu Natty):
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
Changed in policykit-1-gnome (Ubuntu):
importance: High → Low
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
milestone: oneiric-alpha-1 → none
description: updated
summary: polkit-gnome-authentication-agent-1 crashed with SIGSEGV in
- g_datalist_id_set_data_full() during login
+ g_datalist_id_set_data_full() during logout

This crash occurred as I was opening the thunderbird email application.

ezekiel000 (ezekiel000) wrote :

polkit-gnome-authentication-agent-1 crashes quite often when I shutdown my system.
I've attached my bugbuddy automatically generated crash report.
Running Ubuntu 11.04 amd64.

Alex (alitonjua) wrote :

The system always crashes ever since I have updated from Ubuntu 10.10 to Ubuntu 11.04. The system crashes varies from PolicyKit Gnome component to Squid packages, claws-mail, and screen savers, and freezes video to any form of You Tube file. This system update to Ubuntu 11.04 is very deplorable and terrible in terms of performance issues and reliability. I firmly believed that Ubuntu development team rashes this version 11.04 without testing the entire systems thoroughly.

ADFH (adfh) wrote :

Upgraded from 10.04 through 10.10 to 11.04 - 64 bit install.. Experiencing error popup frequently on login.

knokkels (knokkels) wrote :

Ubuntu 11.04 32 bits
All of a sudden Empathy crashed without warning. It became apparent it got deleted from my system.
I logged out, only to get this message.
Earlier today with an update, there were several marked for deletion on account of them not being needed by the system anymore.
System started getting shoddy when I tried installing E17 windowmanager via easy-e17.sh

Léa GRIS (lea-gris) wrote :

Still this same crash continue randomly and just after login, not just after logout.
Is there somebody with news or working on the issue?

Scenario same as #123. Guess it is more of a nuisance than a major headache, which is why nobody is working on it. Guess we should all just ignore it until someone is bothered enough by the nuisance value to work on it.

Thanks for replying!

On Tue, Sep 27, 2011 at 7:00 PM, Kayode Odusote <email address hidden>wrote:

> Scenario same as #123. Guess it is more of a nuisance than a major
> headache, which is why nobody is working on it. Guess we should all
> just ignore it until someone is bothered enough by the nuisance value to
> work on it.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/697095
>
> Title:
> polkit-gnome-authentication-agent-1 crashed with SIGSEGV in
> g_datalist_id_set_data_full() during logout
>
> Status in PolicyKit GNOME component:
> Confirmed
> Status in “policykit-1-gnome” package in Ubuntu:
> Triaged
> Status in “policykit-1-gnome” source package in Natty:
> Won't Fix
> Status in “policykit-1-gnome” source package in Oneiric:
> Won't Fix
>
> Bug description:
> NOTE: This crash only happens during session logout, at which point it
> is fairly irrelevant. Apport presents the crash at the start of the
> next session, which might falsely suggest that the crash happens at
> session start.
>
> Binary package hint: policykit-1-gnome
>
> Crash occurred shortly after a gnome session login (following updates
> during the previous session), and followed an expected UbuntuOne
> crash.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.04
> Package: policykit-1-gnome 0.99-1ubuntu3
> ProcVersionSignature: Ubuntu 2.6.37-11.25-generic 2.6.37-rc7
> Uname: Linux 2.6.37-11-generic i686
> Architecture: i386
> CrashCounter: 1
> Date: Tue Jan 4 19:28:00 2011
> ExecutablePath:
> /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101202)
> ProcCmdline:
> /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
> ProcEnviron:
> LANGUAGE=en_AU:en
> LANG=en_NZ.UTF-8
> LC_MESSAGES=en_AU.utf8
> SHELL=/bin/bash
> SegvAnalysis:
> Segfault happened at: 0xd39e68 <g_datalist_id_set_data_full+744>: cmp
> 0x4(%eax),%edi
> PC (0x00d39e68) ok
> source "0x4(%eax)" (0x00000024) not located in a known VMA region (needed
> readable region)!
> destination "%edi" ok
> SegvReason: reading NULL VMA
> Signal: 11
> SourcePackage: policykit-1-gnome
> StacktraceTop:
> g_datalist_id_set_data_full () from /lib/libglib-2.0.so.0
> g_object_unref () from /usr/lib/libgobject-2.0.so.0
> ?? ()
> __libc_start_main () from /lib/libc.so.6
> ?? ()
> Title: polkit-gnome-authentication-agent-1 crashed with SIGSEGV in
> g_datalist_id_set_data_full()
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/policykit-1-gnome/+bug/697095/+subscriptions
>

Changed in policykit-1-gnome (Ubuntu):
assignee: nobody → Abhishek kumar singh (abhishekkumarsingh-cse)
status: Triaged → Confirmed
Changed in policykit-1-gnome (Ubuntu):
status: Confirmed → In Progress
Honey I (i-honey1st) wrote :

Thanks for the reply. Is there a way to eliminate this buy?

On Mon, Oct 3, 2011 at 6:42 AM, Abhishek kumar singh <
<email address hidden>> wrote:

> ** Changed in: policykit-1-gnome (Ubuntu)
> Status: Confirmed => In Progress
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/697095
>
> Title:
> polkit-gnome-authentication-agent-1 crashed with SIGSEGV in
> g_datalist_id_set_data_full() during logout
>
> Status in PolicyKit GNOME component:
> Confirmed
> Status in “policykit-1-gnome” package in Ubuntu:
> In Progress
> Status in “policykit-1-gnome” source package in Natty:
> Won't Fix
> Status in “policykit-1-gnome” source package in Oneiric:
> Won't Fix
>
> Bug description:
> NOTE: This crash only happens during session logout, at which point it
> is fairly irrelevant. Apport presents the crash at the start of the
> next session, which might falsely suggest that the crash happens at
> session start.
>
> Binary package hint: policykit-1-gnome
>
> Crash occurred shortly after a gnome session login (following updates
> during the previous session), and followed an expected UbuntuOne
> crash.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.04
> Package: policykit-1-gnome 0.99-1ubuntu3
> ProcVersionSignature: Ubuntu 2.6.37-11.25-generic 2.6.37-rc7
> Uname: Linux 2.6.37-11-generic i686
> Architecture: i386
> CrashCounter: 1
> Date: Tue Jan 4 19:28:00 2011
> ExecutablePath:
> /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101202)
> ProcCmdline:
> /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
> ProcEnviron:
> LANGUAGE=en_AU:en
> LANG=en_NZ.UTF-8
> LC_MESSAGES=en_AU.utf8
> SHELL=/bin/bash
> SegvAnalysis:
> Segfault happened at: 0xd39e68 <g_datalist_id_set_data_full+744>: cmp
> 0x4(%eax),%edi
> PC (0x00d39e68) ok
> source "0x4(%eax)" (0x00000024) not located in a known VMA region (needed
> readable region)!
> destination "%edi" ok
> SegvReason: reading NULL VMA
> Signal: 11
> SourcePackage: policykit-1-gnome
> StacktraceTop:
> g_datalist_id_set_data_full () from /lib/libglib-2.0.so.0
> g_object_unref () from /usr/lib/libgobject-2.0.so.0
> ?? ()
> __libc_start_main () from /lib/libc.so.6
> ?? ()
> Title: polkit-gnome-authentication-agent-1 crashed with SIGSEGV in
> g_datalist_id_set_data_full()
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/policykit-1-gnome/+bug/697095/+subscriptions
>

ALFIN SYAMSUDDIN (alfinny) wrote :
Download full text (3.3 KiB)

When I open nautilus program and closed the session, it always crash and
I stop nautilus program by typing "nautilus --quit" in console. but
it's still not responding when I shutdown my laptop. it happens when i
drag the file in nautilus program into another nautilus window and crash
until now. I don't know how to fix and eliminate this bug

thanks

On 10/04/2011 03:38 AM, Honey I wrote:
> Thanks for the reply. Is there a way to eliminate this buy?
>
>
> On Mon, Oct 3, 2011 at 6:42 AM, Abhishek kumar singh<
> <email address hidden>> wrote:
>
>> ** Changed in: policykit-1-gnome (Ubuntu)
>> Status: Confirmed => In Progress
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/697095
>>
>> Title:
>> polkit-gnome-authentication-agent-1 crashed with SIGSEGV in
>> g_datalist_id_set_data_full() during logout
>>
>> Status in PolicyKit GNOME component:
>> Confirmed
>> Status in “policykit-1-gnome” package in Ubuntu:
>> In Progress
>> Status in “policykit-1-gnome” source package in Natty:
>> Won't Fix
>> Status in “policykit-1-gnome” source package in Oneiric:
>> Won't Fix
>>
>> Bug description:
>> NOTE: This crash only happens during session logout, at which point it
>> is fairly irrelevant. Apport presents the crash at the start of the
>> next session, which might falsely suggest that the crash happens at
>> session start.
>>
>> Binary package hint: policykit-1-gnome
>>
>> Crash occurred shortly after a gnome session login (following updates
>> during the previous session), and followed an expected UbuntuOne
>> crash.
>>
>> ProblemType: Crash
>> DistroRelease: Ubuntu 11.04
>> Package: policykit-1-gnome 0.99-1ubuntu3
>> ProcVersionSignature: Ubuntu 2.6.37-11.25-generic 2.6.37-rc7
>> Uname: Linux 2.6.37-11-generic i686
>> Architecture: i386
>> CrashCounter: 1
>> Date: Tue Jan 4 19:28:00 2011
>> ExecutablePath:
>> /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
>> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101202)
>> ProcCmdline:
>> /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
>> ProcEnviron:
>> LANGUAGE=en_AU:en
>> LANG=en_NZ.UTF-8
>> LC_MESSAGES=en_AU.utf8
>> SHELL=/bin/bash
>> SegvAnalysis:
>> Segfault happened at: 0xd39e68<g_datalist_id_set_data_full+744>: cmp
>> 0x4(%eax),%edi
>> PC (0x00d39e68) ok
>> source "0x4(%eax)" (0x00000024) not located in a known VMA region (needed
>> readable region)!
>> destination "%edi" ok
>> SegvReason: reading NULL VMA
>> Signal: 11
>> SourcePackage: policykit-1-gnome
>> StacktraceTop:
>> g_datalist_id_set_data_full () from /lib/libglib-2.0.so.0
>> g_object_unref () from /usr/lib/libgobject-2.0.so.0
>> ?? ()
>> __libc_start_main () from /lib/libc.so.6
>> ?? ()
>> Title: polkit-gnome-authentication-agent-1 crashed with SIGSEGV in
>> g_datalist_id_set_data_full()
>> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/policykit-1-gnome/+bug/697095/+subscriptions
>>

-- ...

Read more...

Honey I (i-honey1st) wrote :
Download full text (6.0 KiB)

...will try that :)

On Mon, Oct 3, 2011 at 4:06 PM, ALFIN SYAMSUDDIN
<email address hidden>wrote:

> When I open nautilus program and closed the session, it always crash and
> I stop nautilus program by typing "nautilus --quit" in console. but
> it's still not responding when I shutdown my laptop. it happens when i
> drag the file in nautilus program into another nautilus window and crash
> until now. I don't know how to fix and eliminate this bug
>
> thanks
>
> On 10/04/2011 03:38 AM, Honey I wrote:
> > Thanks for the reply. Is there a way to eliminate this buy?
> >
> >
> > On Mon, Oct 3, 2011 at 6:42 AM, Abhishek kumar singh<
> > <email address hidden>> wrote:
> >
> >> ** Changed in: policykit-1-gnome (Ubuntu)
> >> Status: Confirmed => In Progress
> >>
> >> --
> >> You received this bug notification because you are subscribed to the bug
> >> report.
> >> https://bugs.launchpad.net/bugs/697095
> >>
> >> Title:
> >> polkit-gnome-authentication-agent-1 crashed with SIGSEGV in
> >> g_datalist_id_set_data_full() during logout
> >>
> >> Status in PolicyKit GNOME component:
> >> Confirmed
> >> Status in “policykit-1-gnome” package in Ubuntu:
> >> In Progress
> >> Status in “policykit-1-gnome” source package in Natty:
> >> Won't Fix
> >> Status in “policykit-1-gnome” source package in Oneiric:
> >> Won't Fix
> >>
> >> Bug description:
> >> NOTE: This crash only happens during session logout, at which point it
> >> is fairly irrelevant. Apport presents the crash at the start of the
> >> next session, which might falsely suggest that the crash happens at
> >> session start.
> >>
> >> Binary package hint: policykit-1-gnome
> >>
> >> Crash occurred shortly after a gnome session login (following updates
> >> during the previous session), and followed an expected UbuntuOne
> >> crash.
> >>
> >> ProblemType: Crash
> >> DistroRelease: Ubuntu 11.04
> >> Package: policykit-1-gnome 0.99-1ubuntu3
> >> ProcVersionSignature: Ubuntu 2.6.37-11.25-generic 2.6.37-rc7
> >> Uname: Linux 2.6.37-11-generic i686
> >> Architecture: i386
> >> CrashCounter: 1
> >> Date: Tue Jan 4 19:28:00 2011
> >> ExecutablePath:
> >> /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
> >> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386
> (20101202)
> >> ProcCmdline:
> >> /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
> >> ProcEnviron:
> >> LANGUAGE=en_AU:en
> >> LANG=en_NZ.UTF-8
> >> LC_MESSAGES=en_AU.utf8
> >> SHELL=/bin/bash
> >> SegvAnalysis:
> >> Segfault happened at: 0xd39e68<g_datalist_id_set_data_full+744>:
> cmp
> >> 0x4(%eax),%edi
> >> PC (0x00d39e68) ok
> >> source "0x4(%eax)" (0x00000024) not located in a known VMA region
> (needed
> >> readable region)!
> >> destination "%edi" ok
> >> SegvReason: reading NULL VMA
> >> Signal: 11
> >> SourcePackage: policykit-1-gnome
> >> StacktraceTop:
> >> g_datalist_id_set_data_full () from /lib/libglib-2.0.so.0
> >> g_object_unref () from /usr/lib/libgobject-2.0.so.0
> >> ?? ()
> >> __libc_start_main () from /lib/libc.so.6
> >> ?? ()
> >> Title: polkit-gnome-authenticat...

Read more...

Changed in policykit-1-gnome:
status: Confirmed → Fix Released

Has an upstream fix really been released, or was the status change in the PolicyKit GNOME bug task a mistake?

Honey I (i-honey1st) wrote :

Other than the following info I received from another Ubuntu-er, I don't
know if it was a mistake:

 *Bug #697095 status changed in PolicyKit GNOME:

   Confirmed => Fix Released

*
On Wed, Oct 26, 2011 at 11:42 AM, Eliah Kagan
<email address hidden>wrote:

> Has an upstream fix really been released, or was the status change in
> the PolicyKit GNOME bug task a mistake?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/697095
>
> Title:
> polkit-gnome-authentication-agent-1 crashed with SIGSEGV in
> g_datalist_id_set_data_full() during logout
>
> Status in PolicyKit GNOME component:
> Fix Released
> Status in “policykit-1-gnome” package in Ubuntu:
> In Progress
> Status in “policykit-1-gnome” source package in Natty:
> Won't Fix
> Status in “policykit-1-gnome” source package in Oneiric:
> Won't Fix
>
> Bug description:
> NOTE: This crash only happens during session logout, at which point it
> is fairly irrelevant. Apport presents the crash at the start of the
> next session, which might falsely suggest that the crash happens at
> session start.
>
> Binary package hint: policykit-1-gnome
>
> Crash occurred shortly after a gnome session login (following updates
> during the previous session), and followed an expected UbuntuOne
> crash.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.04
> Package: policykit-1-gnome 0.99-1ubuntu3
> ProcVersionSignature: Ubuntu 2.6.37-11.25-generic 2.6.37-rc7
> Uname: Linux 2.6.37-11-generic i686
> Architecture: i386
> CrashCounter: 1
> Date: Tue Jan 4 19:28:00 2011
> ExecutablePath:
> /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101202)
> ProcCmdline:
> /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
> ProcEnviron:
> LANGUAGE=en_AU:en
> LANG=en_NZ.UTF-8
> LC_MESSAGES=en_AU.utf8
> SHELL=/bin/bash
> SegvAnalysis:
> Segfault happened at: 0xd39e68 <g_datalist_id_set_data_full+744>: cmp
> 0x4(%eax),%edi
> PC (0x00d39e68) ok
> source "0x4(%eax)" (0x00000024) not located in a known VMA region (needed
> readable region)!
> destination "%edi" ok
> SegvReason: reading NULL VMA
> Signal: 11
> SourcePackage: policykit-1-gnome
> StacktraceTop:
> g_datalist_id_set_data_full () from /lib/libglib-2.0.so.0
> g_object_unref () from /usr/lib/libgobject-2.0.so.0
> ?? ()
> __libc_start_main () from /lib/libc.so.6
> ?? ()
> Title: polkit-gnome-authentication-agent-1 crashed with SIGSEGV in
> g_datalist_id_set_data_full()
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/policykit-1-gnome/+bug/697095/+subscriptions
>

Honey I (i-honey1st) wrote :

Thanks for the info. As I am very new at Ubuntu and not familiar with all
the intricacies, how do I get to the "Fix Released"? :)

On Wed, Oct 26, 2011 at 11:08 AM, michelle julien <<email address hidden>
> wrote:

> ** Changed in: policykit-1-gnome
> Status: Confirmed => Fix Released
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/697095
>
> Title:
> polkit-gnome-authentication-agent-1 crashed with SIGSEGV in
> g_datalist_id_set_data_full() during logout
>
> Status in PolicyKit GNOME component:
> Fix Released
> Status in “policykit-1-gnome” package in Ubuntu:
> In Progress
> Status in “policykit-1-gnome” source package in Natty:
> Won't Fix
> Status in “policykit-1-gnome” source package in Oneiric:
> Won't Fix
>
> Bug description:
> NOTE: This crash only happens during session logout, at which point it
> is fairly irrelevant. Apport presents the crash at the start of the
> next session, which might falsely suggest that the crash happens at
> session start.
>
> Binary package hint: policykit-1-gnome
>
> Crash occurred shortly after a gnome session login (following updates
> during the previous session), and followed an expected UbuntuOne
> crash.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.04
> Package: policykit-1-gnome 0.99-1ubuntu3
> ProcVersionSignature: Ubuntu 2.6.37-11.25-generic 2.6.37-rc7
> Uname: Linux 2.6.37-11-generic i686
> Architecture: i386
> CrashCounter: 1
> Date: Tue Jan 4 19:28:00 2011
> ExecutablePath:
> /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101202)
> ProcCmdline:
> /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
> ProcEnviron:
> LANGUAGE=en_AU:en
> LANG=en_NZ.UTF-8
> LC_MESSAGES=en_AU.utf8
> SHELL=/bin/bash
> SegvAnalysis:
> Segfault happened at: 0xd39e68 <g_datalist_id_set_data_full+744>: cmp
> 0x4(%eax),%edi
> PC (0x00d39e68) ok
> source "0x4(%eax)" (0x00000024) not located in a known VMA region (needed
> readable region)!
> destination "%edi" ok
> SegvReason: reading NULL VMA
> Signal: 11
> SourcePackage: policykit-1-gnome
> StacktraceTop:
> g_datalist_id_set_data_full () from /lib/libglib-2.0.so.0
> g_object_unref () from /usr/lib/libgobject-2.0.so.0
> ?? ()
> __libc_start_main () from /lib/libc.so.6
> ?? ()
> Title: polkit-gnome-authentication-agent-1 crashed with SIGSEGV in
> g_datalist_id_set_data_full()
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/policykit-1-gnome/+bug/697095/+subscriptions
>

@Honey I
Unless you are the same person as michelle julien, my question was not directed to you in any way specifically. Rather, you are (or were) subscribed to this bug, so you received a notification that my comment had been posted.

Honey I (i-honey1st) wrote :

Mea culpa here, of course; I'm new at Ubuntu and still learning the
intricacies of it.

On Wed, Oct 26, 2011 at 9:25 PM, Eliah Kagan
<email address hidden>wrote:

> @Honey I
> Unless you are the same person as michelle julien, my question was not
> directed to you in any way specifically. Rather, you are (or were)
> subscribed to this bug, so you received a notification that my comment had
> been posted.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/697095
>
> Title:
> polkit-gnome-authentication-agent-1 crashed with SIGSEGV in
> g_datalist_id_set_data_full() during logout
>
> Status in PolicyKit GNOME component:
> Fix Released
> Status in “policykit-1-gnome” package in Ubuntu:
> In Progress
> Status in “policykit-1-gnome” source package in Natty:
> Won't Fix
> Status in “policykit-1-gnome” source package in Oneiric:
> Won't Fix
>
> Bug description:
> NOTE: This crash only happens during session logout, at which point it
> is fairly irrelevant. Apport presents the crash at the start of the
> next session, which might falsely suggest that the crash happens at
> session start.
>
> Binary package hint: policykit-1-gnome
>
> Crash occurred shortly after a gnome session login (following updates
> during the previous session), and followed an expected UbuntuOne
> crash.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.04
> Package: policykit-1-gnome 0.99-1ubuntu3
> ProcVersionSignature: Ubuntu 2.6.37-11.25-generic 2.6.37-rc7
> Uname: Linux 2.6.37-11-generic i686
> Architecture: i386
> CrashCounter: 1
> Date: Tue Jan 4 19:28:00 2011
> ExecutablePath:
> /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101202)
> ProcCmdline:
> /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
> ProcEnviron:
> LANGUAGE=en_AU:en
> LANG=en_NZ.UTF-8
> LC_MESSAGES=en_AU.utf8
> SHELL=/bin/bash
> SegvAnalysis:
> Segfault happened at: 0xd39e68 <g_datalist_id_set_data_full+744>: cmp
> 0x4(%eax),%edi
> PC (0x00d39e68) ok
> source "0x4(%eax)" (0x00000024) not located in a known VMA region (needed
> readable region)!
> destination "%edi" ok
> SegvReason: reading NULL VMA
> Signal: 11
> SourcePackage: policykit-1-gnome
> StacktraceTop:
> g_datalist_id_set_data_full () from /lib/libglib-2.0.so.0
> g_object_unref () from /usr/lib/libgobject-2.0.so.0
> ?? ()
> __libc_start_main () from /lib/libc.so.6
> ?? ()
> Title: polkit-gnome-authentication-agent-1 crashed with SIGSEGV in
> g_datalist_id_set_data_full()
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/policykit-1-gnome/+bug/697095/+subscriptions
>

Anand Kumria (wildfire) wrote :

#134 indicates that #6 is the reason for marking as wontfix and not open to SRU.

#6 just says that it happens on logout.

Actually, this is a particularly egregious and annoying bug.

It happens on shutdown too.

It means that a laptop will lock-up, and you need to forcibly power it off, and then wait for a fsck when next starting.

The condition for this bug to be triggered is:
 - install updates that require a reboot
 - perform the reboot via the menu
 - wait for machine to lock-up

Displaying first 40 and last 40 comments. View all 151 comments or add a comment.