Remove unnecessary dependency on initramfs-tools

Bug #1716825 reported by Steve Langasek on 2017-09-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
Low
Steve Langasek
Xenial
Low
Steve Langasek
Zesty
Low
Steve Langasek

Bug Description

[SRU Justification]
plymouth declares a dependency on initramfs-tools | dracut. Plymouth does not require that the system use an initramfs, it only hooks into the initramfs if it's present and if plymouth is needed for prompting prior to mounting the root filesystem.

We should drop this dependency, to support building of images with initramfs-tools removed for systems that we know don't require an initramfs.

[Test case]
1. On a default cloud image install, try to run 'sudo apt purge initramfs-tools'.
2. Verify that this tries to remove plymouth.
3. Cancel the removal.
4. Install plymouth from xenial-proposed.
5. Run 'sudo apt purge initramfs-tools' again.
6. Verify that plymouth is not removed.
7. Run 'sudo apt install --reinstall plymouth' and confirm that the package can be installed successfully without initramfs-tools installed.

[Regression Potential]
If a user needs an initramfs in order to mount their root device, and plymouth is the only package on their system which depends on initramfs-tools, it is possible that the user may remove initramfs-tools and render their system unbootable.

This is unlikely because initramfs-tools is still part of the 'minimal' seed and is therefore a dependency of ubuntu-minimal; and it remains a dependency of the generic kernel image.

So long as initramfs-tools is installed, plymouth's initramfs hooks will continue to function as intended when required.

Steve Langasek (vorlon) on 2017-09-13
Changed in plymouth (Ubuntu):
status: New → Fix Committed
assignee: nobody → Steve Langasek (vorlon)
Changed in plymouth (Ubuntu Zesty):
assignee: nobody → Steve Langasek (vorlon)
Changed in plymouth (Ubuntu Xenial):
assignee: nobody → Steve Langasek (vorlon)
status: New → In Progress
Changed in plymouth (Ubuntu Zesty):
status: New → In Progress
Steve Langasek (vorlon) on 2017-09-13
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package plymouth - 0.9.2-3ubuntu17

---------------
plymouth (0.9.2-3ubuntu17) artful; urgency=medium

  * Remove dependency on initramfs-tools | dracut. LP: #1716825.

 -- Steve Langasek <email address hidden> Tue, 12 Sep 2017 22:09:59 -0700

Changed in plymouth (Ubuntu):
status: Fix Committed → Fix Released
Łukasz Zemczak (sil2100) wrote :

For a moment I was thinking if maybe we shouldn't make initramfs-tools | dracut a Suggests instead. But that actually wouldn't change the situation in the end, besides adding a soft relationship between both. So it's all good.

Changed in plymouth (Ubuntu Zesty):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-zesty

Hello Steve, or anyone else affected,

Accepted plymouth into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/plymouth/0.9.2-3ubuntu15.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-zesty to verification-done-zesty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-zesty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in plymouth (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed-xenial
Łukasz Zemczak (sil2100) wrote :

Hello Steve, or anyone else affected,

Accepted plymouth into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/plymouth/0.9.2-3ubuntu13.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Steve Langasek (vorlon) wrote :

Confirmed with plymouth 0.9.2-3ubuntu15.1.

tags: added: verification-done-zesty
removed: verification-needed-zesty
Steve Langasek (vorlon) wrote :

Confirmed with plymouth 0.9.2-3ubuntu13.2 as well.

tags: added: verification-done-xenial
removed: verification-needed verification-needed-xenial
Changed in plymouth (Ubuntu):
importance: Undecided → Low
Changed in plymouth (Ubuntu Xenial):
importance: Undecided → Low
Changed in plymouth (Ubuntu Zesty):
importance: Undecided → Low
tags: added: packaging
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package plymouth - 0.9.2-3ubuntu13.2

---------------
plymouth (0.9.2-3ubuntu13.2) xenial; urgency=medium

  * Remove dependency on initramfs-tools | dracut. LP: #1716825.

 -- Steve Langasek <email address hidden> Tue, 12 Sep 2017 22:25:47 -0700

Changed in plymouth (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for plymouth has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package plymouth - 0.9.2-3ubuntu15.1

---------------
plymouth (0.9.2-3ubuntu15.1) zesty; urgency=medium

  * Remove dependency on initramfs-tools | dracut. LP: #1716825.

 -- Steve Langasek <email address hidden> Tue, 12 Sep 2017 22:19:01 -0700

Changed in plymouth (Ubuntu Zesty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers