Plymouth does not display the graphical boot splash

Bug #1370707 reported by Martin Wimpress on 2014-09-17
216
This bug affects 49 people
Affects Status Importance Assigned to Milestone
Plymouth
Unknown
Unknown
plymouth (Gentoo Linux)
Unknown
Unknown
plymouth (Ubuntu)
Medium
Unassigned

Bug Description

When booting from Ubuntu 14.10 daily-live image from 17th September 2014 Plymouth does display the graphical boot splash. However, once Ubuntu 14.10 is installed Plymouth does not display the graphical boot splash while the system is booting. Instead just a black screen is present up until Unity Greeter is loaded.

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: plymouth 0.9.0-0ubuntu4
ProcVersionSignature: Ubuntu 3.16.0-14.20-generic 3.16.2
Uname: Linux 3.16.0-14-generic i686
ApportVersion: 2.14.7-0ubuntu2
Architecture: i386
BootLog: Error: [Errno 2] No such file or directory: '/var/log/boot.log'
CurrentDesktop: Unity
Date: Wed Sep 17 21:55:35 2014
DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
InstallationDate: Installed on 2014-09-17 (0 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Alpha i386 (20140917)
MachineType: IBM 2668Q1G
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/vmlinuz-3.16.0-14-generic root=UUID=a9e0ac17-222f-4b0b-861d-a8b24df9c911 ro quiet splash vt.handoff=7
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.16.0-14-generic root=UUID=a9e0ac17-222f-4b0b-861d-a8b24df9c911 ro quiet splash vt.handoff=7
SourcePackage: plymouth
TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/21/2006
dmi.bios.vendor: IBM
dmi.bios.version: 1YET65WW (1.29 )
dmi.board.name: 2668Q1G
dmi.board.vendor: IBM
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: IBM
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnIBM:bvr1YET65WW(1.29):bd08/21/2006:svnIBM:pn2668Q1G:pvrThinkPadT43p:rvnIBM:rn2668Q1G:rvrNotAvailable:cvnIBM:ct10:cvrNotAvailable:
dmi.product.name: 2668Q1G
dmi.product.version: ThinkPad T43p
dmi.sys.vendor: IBM

Martin Wimpress (flexiondotorg) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in plymouth (Ubuntu):
status: New → Confirmed
Ivan Larionov (xeron-oskom) wrote :

I'm experiencing this issue as well (nouveau). Removing of "vt.handoff=7" from cmdline fixes it.

Ivan Larionov (xeron-oskom) wrote :

Also bug 1343841 looks like the same.

theghost (theghost) wrote :

Also have this issue. Need to press a key to enable screen during boot.

Elfy (elfy) wrote :

See the same here in Xubuntu.

removing vt.handoff=7 get 1 line of text, low then high resolution then plymouth

as post #5 - any key leads to plymouth showing

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1370707

tags: added: iso-testing
Changed in plymouth (Ubuntu):
importance: Undecided → Medium
importance: Medium → High
Esa Peuha (esa-peuha) wrote :

I'm seeing this too, and I find it very annoying, because the screen goes blank long enough to make my monitor power down, and it takes over ten seconds to power back up when the video signal is returned.

So, I added "plymouth.debug=file:/var/log/plymouth-debug.log" to the kernel command line, and the result is attached. It seems that for some reason plymouth can't show the graphical splash screen, so it tries the text splash screen instead, but that isn't shown either. What can I do to debug this further?

Esa Peuha (esa-peuha) wrote :
Da Xue (daxue) wrote :

For me, this seems to be a kernel 3.16 bug. I can get 14.04.2 LTS to display the splash by using the 3.13 kernel. Once I boot to the 3.16 kernel, i lose the splash. I made a bug in the kernel meta package.

https://bugs.launchpad.net/ubuntu/+source/linux-meta-lts-utopic/+bug/1425304

Esa Peuha (esa-peuha) wrote :

Just because the kernel does something differently doesn't mean it's a kernel bug. There's clearly a relevant bug in plymouth that I reported to plymouth upstream two months ago ( https://bugs.freedesktop.org/show_bug.cgi?id=87993 ) but forgot to mention here. Since there has been no response to that report, maybe it's time to fix the bug in ubuntu's plymouth package.

hectorsales (hectorvicente30) wrote :

Same here, after upgrade recently from Ubuntu version 14.04.1 to 14.04.2 version( LTSEnablementStack)... if i boot with the kernel series 3.16.x the default ubuntu plymouth theme don't appears .. however if I starter with the kernel series 3.13.x this if it appears and this works fine. I open a thread on ubuntu forum:

http://ubuntuforums.org/showthread.php?t=2271061

Regards

D. Charles Pyle (dcharlespyle) wrote :

Seeing the same in Trusty 14.04 LTS with kernel 3.16. I am now at 3.16.0-34 and still see the same behavior. Every fix I have tried fails to make it work as it did work in as late as 3.14 kernels, and did work in all the 3.13 series. I think that the problem is kernel configuration in the 3.16 kernels. I do not know about 3.15 kernels as none of those I attempted to use would boot my system properly at all.

I have yet to build my own 3.16 kernels to try to track this down but I have noticed that one of the differences between the 3.13 and 3.14 series kernels, and the 3.16 series kernels, is that CONFIG_DRM_RADEON_UMS is commented out in 3.16 kernels, but not in either 3.13 or 3.14 series kernels from Ubuntu (at least not the ones I used, and I have not been building too many of my own kernels this LTS release, as that kind of defeats the purpose of an LTS release).

I am using a Radeon HD 5750 card with dual, Dell S2440L monitors.

Any further information needed, let me know. I am going to attempt to use apport to send up my configuration, and so forth, in a couple minutes. Last time I tried it failed in another bug.

D. Charles Pyle (dcharlespyle) wrote :

Tried and apport-collect failed again. Just let me know if any other information is necessary and I will do what I can to provide it to help track this down.

D. Charles Pyle (dcharlespyle) wrote :

Per comment #3 I can confirm that manual deletion of $vt_handoff or vt_handoff=7 from the grub kernel line allows the plymouth splash screen to display on a 3.16 series kernel. Changing vt_handoff=1 to vt_handoff=0 in the /etc/grub.d/10_linux file does not change the behavior or omit this kernel parameter from the grub menu if you are running Ubuntu in a Wubi installation, as the parameter on the kernel line is replaced with $vt_handoff by the /etc/grub.d/10_lupin script.

Whatever is going on there with vt_handoff is affecting plymouth splash screen only when running a 3.16 series kernel. It does not affect 3.13 or 3.14 series kernels. Hope this additional information helps track down this bug. In my configuration, leaving $vt_handoff in the kernel line causes both monitors to shut down with no signal from the video card until it reaches the lightDM/Unity screen while also running on a 3.16 series kernel, so this bug is more severe than just a cosmetic issue.

Joshua (colmenar68) on 2015-04-01
no longer affects: plymouth
pst007x (turone) wrote :

This bug also affects Ubuntu 15.10

Kernel 4.2.0-17-generic

NVIDIA V355.11 (open-source)

Boot screen only shows logo and black background, overlayed with text.

Tried usual fixes, changing screen resolution, etc, but no change

Simon Quigley (tsimonq2) wrote :

Confirmed in Lubuntu Xenial Xerus Alpha 2.

jiaowen520li (jiaowen520li) wrote :

Confirmed in Ubuntu Kylin Xenial Alpha 2.

Changed in plymouth (Ubuntu):
importance: High → Medium
Phill Whiteside (phillw) wrote :

Present in Beta 2

sudodus (nio-wiklund) wrote :

I can confirm that we have this problem in Lubuntu Beta 2 version dated 20160323. It is also affecting 'Encrypted home': the passphrase is not displayed, there is nothing but a blue screen.

But it is not BSOD, because the system is alive underneath ;-)

sudodus (nio-wiklund) wrote :

Sorry, I mean 'Encrypted disk'. The passphrase is not displayed, but you can type it in and finish with the enter key, and after that arrive at the login screen of Lubuntu.

This bug is also present in Ubuntu GNOME 16.04 Beta 2.

Ivan S. (ivan-sushik) wrote :

Same thing on Xubuntu 15.10.

If you are seeing this issue in VirtualBox then it is the intended behaviour. The VirtualBox graphics device was blacklisted from Plymouth more than a year ago.

sudodus (nio-wiklund) wrote :

No it is in real computers, for example my Toshiba laptop

http://www.toshiba.se/laptops/satellite-pro/c850/satellite-pro-c850-19w/

Lubuntu has only a dark blue screen (not the text mode Plymouth text and dots), only a dark blue screen, no text at all. The bug affects i386 and amd64, bios mode and uefi mode.

sudodus (nio-wiklund) wrote :

I should add that the text messages are there, and can be seen if you boot without the boot options 'quiet splash'. I think the splash option makes the difference.

sudodus (nio-wiklund) wrote :

Lubuntu Xenial i386 desktop - live session:

Without the boot option splash, the text 'Please remove the installation medium, then press ENTER'.

Otherwise it is not seen, and the user gets the impression that the computer does not poweroff or reboot. I think that several different problems will be solved, when this bug is squashed,

Søren Weber (soren-jido) wrote :

I have also seen this (as in #26) for Kubuntu 16.04 upgraded from 14.04.4 on HP EliteBook 2560p.
I did not see this on Lenovo X1 Carbon upgraded from Kubuntu 15.10.

David (karonzon) wrote :

I'm experienceing the same bug as mentioned from comments #25 onwards with Lubuntu 16.04 i386. The PC is an eMachines EL1600. This could be related to the kernel. When I was running Lubuntu 14.04 with the 3.13 kernel, Plymouth worked as it should. When I updated the kernel to 3.16 a similar bug with the Plymouth theme was exprienced (basically half the screen being displayed) and that was fixed when I went back to the 3.13 kernel.

i2000s (i2000s) wrote :

Not showing the splash screen after I reinstalled Ubuntu GNOME 16.04.2.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.